Minion Beta! - Help us test our new AddOn updater. Get it now!
Download
(563 Kb)
Download
Updated: 12-11-14 12:45 AM
Pictures
File Info
Compatibility:
Warlords of Draenor Pre-Patch (6.0.3)
Updated:12-11-14 12:45 AM
Created:unknown
Downloads:399,350
Favorites:989
MD5:
6.0.3

Ion  Popular! (More than 5000 hits)

Version: Hydrogen-12
by: Maul, Jrosk, SLOKnightfall

Hydrogen 12
-More fixes for ability cooldowns & procs
-Fix for Fairy Swarm tallent
-Fixes for Draenor Garrison ability button cooldown and range
-Fix for shadow dance triggering a stance bar change
-Nephyrin's Dualspec bar fix
-Misc bug fixes



Hydrogen 11
-Added items to the Ion Menu
-Fixed macro generation and cooldowns for most spells
-Added profile system

Hydrogen-10.3 Beta
-Reverted spell name change and added different work around for hunter call pet macros

Hydrogen-10.2 Beta
-Fixed TOC so bar position are global again. 10.1 accidentally contained a version that had the settings stored per character

Hydrogen-10.1 Beta
-Included SLOKnightfall's WoD updates
-Fixed mount macro's
-Fixed random mount macro
-Changed which spell name is used in the generated macro to fix issue with hunter pets summon macros not being correct.
-Created a list of spells that will ignore subtext in the spells. Mainly for hunter traps that were getting Trap Launcher added to the macro and not working.

Hydrogen-10 Beta
-Updating to Warlords of Draenor Expansion patch

Hydrogen-9 Beta
- Debug spam fix

Hydrogen-8 Beta
- Minor update to fix smaller issues

Hydrogen-7 Beta
- Updated for patch 5.4.1

Hydrogen-6 Beta
- Updated for patch 5.3

Hydrogen-5
- Spell Count bug fix (i.e. Death Knight's Scent of Blood count update)
- Spell Charges fix properly implemented

Hydrogen-4
- Forum version, include most hotfixes appearing on the forum (flyx, Nephyrin, chinoloco,kouik)
- should now display the appropriate tooltip in all cases.
- GetSpellCount replaced by GetSpellCharges (roll charges issues)
- spells with distinct subtypes between specs should be shown as useable in all cases.
- spell cooldowns should update (trash, symbiosis, disconnect/reconnect after a spec change should not show questionmark anymore)
- flyout should show the proper spell

Hydorgen-3

Hydrogen-2 Beta
- Updated for patch 5.1
- Fixed texture issue
- Dual spec toggle should work now
- Fixed extra bar action ID
- Other minor changes
- Sorry folks, that is all :(

Hydrogen-2 Beta
-Now scans profession spells
-Tentatively enabling/disabling of the Blizzard Main Bar should work
-Blizzard ExtraAction button should now only show if the Blizzard Bar is used
-Moved localization to one file

Hydrogen-1 Beta
- beta release for patch 5.0.4
Optional Files (8)
File Name
Version
Size
Author
Date
Type
Hydrogen-7 Beta
43kB
10-17-14 10:17 PM
Addon
Hydrogen-7 Beta
12kB
10-15-14 08:37 AM
Addon
Hydrogen-5 Beta
5kB
10-15-14 08:35 AM
Addon
Hydrogen-5 Beta
5kB
10-15-14 08:34 AM
Addon
40300.1
6kB
11-29-11 09:01 AM
Addon
40300.1
15kB
11-29-11 08:59 AM
Addon
40000.2.0.1
23kB
07-02-11 11:28 PM
Patch
40000.2.0.1
2kB
07-02-11 07:51 PM
Addon


Archived Files (6)
File Name
Version
Size
Author
Date
 Ion
Hydrogen-11
561kB
Maul
11-12-14 02:23 PM
 Ion
Hydrogen-10.3 B
460kB
Maul
10-21-14 12:00 AM
 Ion
Hydrogen-10.2 B
460kB
Maul
10-18-14 10:17 AM
 Ion
Hydrogen-10 Bet
454kB
Maul
10-15-14 08:38 AM
 Ion
Hydrogen-9 Beta
454kB
Maul
04-08-14 05:30 PM
 Ion
Hydrogen-8 Beta
417kB
Maul
03-31-14 08:51 AM


Post A Reply Comment Options
Unread 10-25-14, 10:28 PM  
SLOKnightfall
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 74
Uploads: 2
Re: New Issues Since 6.02

Originally Posted by raysmith
I've encountered two new issues so far since 6.0, neither is major, both are kind of hard to explain but I'll do my best:.
Ive never had what you described for point one happen, but I'll keep an eye out and see what I can find.

In regards to the macros, they are giving me problems. One thing I noticed is that unless you have a bar set as dual spec, then they only can be edited when you are in your primary spec. If you are in your secondary spec, then they often do not want to save. No clue why, one of the many quirks of Ion that I'm finding.

As for why the mount flyout is no longer working, that is because Blizzard redid a lot the mount api calls, so the code for mounts in flyouts use to use no longer work. I have a good idea of what needs to get modified from fixing the standard mount macros, but the flyout code is a lot more complex and its going to take me a while to fully understand it.
SLOKnightfall is offline Report comment to moderator  
Reply With Quote
Unread 10-25-14, 07:01 PM  
raysmith
A Kobold Labourer

Forum posts: 1
File comments: 10
Uploads: 0
New Issues Since 6.02

[EDIT - I worked around #1 by removing every ability from my bars and putting them back on, something may not have transitioned properly at some point, seems to be working fine since I did that]

I've encountered two new issues so far since 6.0, neither is major, both are kind of hard to explain but I'll do my best:

1) When on one of my toons (warlock, if that matters), something odd is happening with dragging things to my bar. This manifests that if I drag something out of my bags and just hold it in place, I ... not even sure how to explain this ... I lose grip on it. It snaps back into place in my bag, I'm no longer dragging it and Ion is no longer in its "something that can be dragged into a button slot is being dragged" mode, it's back to normal. Similarly, if I drag something rare (blue) out of my bag and and click again to destroy it, the window where I have to type "delete" only stays up for a short period of time before disappearing on its own and again, Ion snaps back. I've only noticed this on that one toon out of about 20 so far. Disabling just Ion fixes this issue and that toon isn't running any add-ons that aren't also running on all my other toons, nor is it set up differently in any way that I can think of. My other warlocks don't have the same issue, it's just the one.

2) I've never had much luck making a mount selection flyout but I did have one that ... mostly worked prior to 6.02. Sorta. Sometimes. Now, it doesn't work at all, it does have the flyout arrow indicator but right-clicking has no effect. I never had any luck creating one of these within a button, I had to make an actual macro and drag it down, modifications had to be done in the macro, not on the button. Beyond not working now, any changes I make to the button itself aren't actually saved and it reverts back to some other mount macro I tried out at some point that isn't even currently in use. In order to change that macro text I have to actually go into the LUA and change it there, that does change the text but doesn't actually make it work.

Here's the original macro I had that kind of worked, sometimes:

#showtooltip Obsidian Nightwing()
/cast [nobtn:2] Obsidian Nightwing()
/stopmacro [nobtn:2]
/flyout companionbsidian nightwing,"ashes of a'lar":l:b:t:1:c:s

[that's companion : obsidian up there if it shows as a smilie, just without the space before and after the colon]

Sometimes it worked fine, other times I'd get two ? when I right-clicked, sometimes I'd get the two mounts showing on a right-click but selecting the other one didn't work, it would just summon the one currently selected...

As I said, kind of hard to explain... I'm not even sure #1 is fixable and 2 was never fully functional, although it was more functional than it is now.
Last edited by raysmith : 10-26-14 at 08:08 AM.
raysmith is offline Report comment to moderator  
Reply With Quote
Unread 10-25-14, 03:29 PM  
raysmith
A Kobold Labourer

Forum posts: 1
File comments: 10
Uploads: 0
Re: Re: Re: Re: Isn't playing nice with....

Originally Posted by SLOKnightfall
For a quick fix to the issue of TitanPanel causing the default action bars not hideing try this.
  1. Open the file TitanMoveable.lua in the Titan addon folder
  2. Look for line 257: TitanMovableFrame_CheckThisFrame(MainMenuBar:GetName());
  3. Comment out or delete the line, then save the file and the bars should stop showing up after being set to hidden.

Edit: Looks like I found a fix to the problem and should be in the next version of Ion.
Ah, I checked through the main LUA file and didn't see anything, assumed it would be in there somewhere. I suspect that Titan line is to move the Blizz main menu bar up a bit if the Titan bottom bar is enabled, along the lines of what Titan does to the minimap when the top bar is enabled. I tried commenting that line out and it worked here as well, should be fine for anyone who isn't using the main Blizz bar as well. Thanks!
raysmith is offline Report comment to moderator  
Reply With Quote
Unread 10-25-14, 12:11 PM  
SLOKnightfall
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 74
Uploads: 2
Re: Re: Re: Isn't playing nice with....

Originally Posted by raysmith
Originally Posted by SLOKnightfall
I noticed the same thing the other night. I tracked it to Titan Panel hooking into the Bilzz menu bar, once I commented out that line of their code, the problem stopped. I'm not sure why/what changed to cause the issue in 6.0.
Can you document what you commented out in Titan to fix that? I'm going to see if I can find it myself but I'm not expecting that to accomplish much...
For a quick fix to the issue of TitanPanel causing the default action bars not hideing try this.
  1. Open the file TitanMoveable.lua in the Titan addon folder
  2. Look for line 257: TitanMovableFrame_CheckThisFrame(MainMenuBar:GetName());
  3. Comment out or delete the line, then save the file and the bars should stop showing up after being set to hidden.

Edit: Looks like I found a fix to the problem and should be in the next version of Ion.
Last edited by SLOKnightfall : 10-25-14 at 01:10 PM.
SLOKnightfall is offline Report comment to moderator  
Reply With Quote
Unread 10-25-14, 10:15 AM  
raysmith
A Kobold Labourer

Forum posts: 1
File comments: 10
Uploads: 0
Re: Re: Isn't playing nice with....

Originally Posted by SLOKnightfall
I noticed the same thing the other night. I tracked it to Titan Panel hooking into the Bilzz menu bar, once I commented out that line of their code, the problem stopped. I'm not sure why/what changed to cause the issue in 6.0.
Can you document what you commented out in Titan to fix that? I'm going to see if I can find it myself but I'm not expecting that to accomplish much...
raysmith is offline Report comment to moderator  
Reply With Quote
Unread 10-25-14, 09:55 AM  
Sslith
A Kobold Labourer

Forum posts: 0
File comments: 47
Uploads: 0
Re: Re: Re: Re: Keybinds and bars reset for other toons

I was careless but i had a month old back up for my other toons.

I JUST made a back up of my DK before i logged him in because of my problems with the other toons.

So lucky. I will wait for the next release before taking the chance haha

Thanks


Originally Posted by SLOKnightfall
Originally Posted by Sslith
I see. I changed it all and used back up WTF files.

The thing is i just downloaded the official one and installed it without thinking last night and that's when the issues all started.

I redownloaded the one from git hub (that has all the ion master stuff) installed that and then copied in my WTF files for all the characters i logged into it and it was all fixed up fine.

Has there been a change since 1 PM EST yesterday that would have a different effect if i install it ? I have backed up the WTF again just in case.

Or are you saying that I will have to re do all the addons settings eventually anyway ?

let me know thanks!

Edit - It was 10.3 that I downloaded last night and installed that reset everything
Strange. I just compaired what is here and on Github and the files are the same. There have not been any updates since it was released on the 20th. The only thing I can think of is if you previously had the bad V10.1 and updated to 10.3 . It will probably be a good idea to keep a backup of the ion saved variables, just to be on the safe side.
Sslith is offline Report comment to moderator  
Reply With Quote
Unread 10-24-14, 09:27 PM  
SLOKnightfall
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 74
Uploads: 2
Re: Re: Re: Keybinds and bars reset for other toons

Originally Posted by Sslith
I see. I changed it all and used back up WTF files.

The thing is i just downloaded the official one and installed it without thinking last night and that's when the issues all started.

I redownloaded the one from git hub (that has all the ion master stuff) installed that and then copied in my WTF files for all the characters i logged into it and it was all fixed up fine.

Has there been a change since 1 PM EST yesterday that would have a different effect if i install it ? I have backed up the WTF again just in case.

Or are you saying that I will have to re do all the addons settings eventually anyway ?

let me know thanks!

Edit - It was 10.3 that I downloaded last night and installed that reset everything
Strange. I just compaired what is here and on Github and the files are the same. There have not been any updates since it was released on the 20th. The only thing I can think of is if you previously had the bad V10.1 and updated to 10.3 . It will probably be a good idea to keep a backup of the ion saved variables, just to be on the safe side.
SLOKnightfall is offline Report comment to moderator  
Reply With Quote
Unread 10-24-14, 09:10 PM  
Sslith
A Kobold Labourer

Forum posts: 0
File comments: 47
Uploads: 0
Re: Re: Keybinds and bars reset for other toons

I see. I changed it all and used back up WTF files.

The thing is i just downloaded the official one and installed it without thinking last night and that's when the issues all started.

I redownloaded the one from git hub (that has all the ion master stuff) installed that and then copied in my WTF files for all the characters i logged into it and it was all fixed up fine.

Has there been a change since 1 PM EST yesterday that would have a different effect if i install it ? I have backed up the WTF again just in case.

Or are you saying that I will have to re do all the addons settings eventually anyway ?

let me know thanks!

Edit - It was 10.3 that I downloaded last night and installed that reset everything



Originally Posted by SLOKnightfall
Originally Posted by Sslith
My DK which i have been playing since they released the patch is ok...however i just logged in other toons and almost all of them seem screwed up.. binds missing bars all reset.

Anyway to fix this or what caused it really dont want to go and have to reset it all up

seems like some of it is there but not all of it and binds missing

Nope its on him too OMG this has me so upset OMG. Gonna have to do redo everything I trying to find the backup of my WTF since it overwrote everything

Fixed them with backups of my WTF OMG thank goodness

*** Warning - Don't use the official one up there keep using the last one on the GIThub or you will end up with serious issues of bars and binds resetting etc wait until you hear more from the authors about it ****
The Version on Github is the same as official version. The 10.1 version got pushed with a modified version of the Toc that switched the bar layout from a global save to a per character save, which caused all the problems. The Toc issue was fixed, but unfortunately as the saved variables had already been modified from the Toc change, there was no way for the addon to revert it back.
Last edited by Sslith : 10-24-14 at 09:11 PM.
Sslith is offline Report comment to moderator  
Reply With Quote
Unread 10-24-14, 08:59 PM  
SLOKnightfall
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 74
Uploads: 2
Re: Keybinds and bars reset for other toons

Originally Posted by Sslith
My DK which i have been playing since they released the patch is ok...however i just logged in other toons and almost all of them seem screwed up.. binds missing bars all reset.

Anyway to fix this or what caused it really dont want to go and have to reset it all up

seems like some of it is there but not all of it and binds missing

Nope its on him too OMG this has me so upset OMG. Gonna have to do redo everything I trying to find the backup of my WTF since it overwrote everything

Fixed them with backups of my WTF OMG thank goodness

*** Warning - Don't use the official one up there keep using the last one on the GIThub or you will end up with serious issues of bars and binds resetting etc wait until you hear more from the authors about it ****
The Version on Github is the same as official version. The 10.1 version got pushed with a modified version of the Toc that switched the bar layout from a global save to a per character save, which caused all the problems. The Toc issue was fixed, but unfortunately as the saved variables had already been modified from the Toc change, there was no way for the addon to revert it back.
SLOKnightfall is offline Report comment to moderator  
Reply With Quote
Unread 10-24-14, 02:45 PM  
SLOKnightfall
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 74
Uploads: 2
Re: Isn't playing nice with....

Originally Posted by Pantses
Titan Panel

Before the 6.0.2 patch, I was using Titan Panel along with Ion just fine. But for some reason, it's bugging out. Titan Panel has had 2 updates and the problem is still there. What happens is, the original Blizzard Action Bar shows up, with the two dragons on it. I turn off Titan Panel and it goes away. Now I'm not sure if this is on the Titan Panel end of things or Ion, so I'm making this report to both so that it may get rectified.

Peace out!
I noticed the same thing the other night. I tracked it to Titan Panel hooking into the Bilzz menu bar, once I commented out that line of their code, the problem stopped. I'm not sure why/what changed to cause the issue in 6.0.
SLOKnightfall is offline Report comment to moderator  
Reply With Quote
Unread 10-24-14, 02:32 PM  
Pantses
A Kobold Labourer

Forum posts: 0
File comments: 12
Uploads: 0
Isn't playing nice with....

Titan Panel

Before the 6.0.2 patch, I was using Titan Panel along with Ion just fine. But for some reason, it's bugging out. Titan Panel has had 2 updates and the problem is still there. What happens is, the original Blizzard Action Bar shows up, with the two dragons on it. I turn off Titan Panel and it goes away. Now I'm not sure if this is on the Titan Panel end of things or Ion, so I'm making this report to both so that it may get rectified.

Peace out!
Pantses is offline Report comment to moderator  
Reply With Quote
Unread 10-24-14, 01:05 PM  
Sslith
A Kobold Labourer

Forum posts: 0
File comments: 47
Uploads: 0
Keybinds and bars reset for other toons

My DK which i have been playing since they released the patch is ok...however i just logged in other toons and almost all of them seem screwed up.. binds missing bars all reset.

Anyway to fix this or what caused it really dont want to go and have to reset it all up

seems like some of it is there but not all of it and binds missing

Nope its on him too OMG this has me so upset OMG. Gonna have to do redo everything I trying to find the backup of my WTF since it overwrote everything

Fixed them with backups of my WTF OMG thank goodness

*** Warning - Don't use the official one up there keep using the last one on the GIThub or you will end up with serious issues of bars and binds resetting etc wait until you hear more from the authors about it ****
Last edited by Sslith : 10-24-14 at 01:35 PM.
Sslith is offline Report comment to moderator  
Reply With Quote
Unread 10-24-14, 12:28 PM  
SLOKnightfall
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 74
Uploads: 2
Re: Re: Re: Re: Re: Druid issue

Originally Posted by Gumpster
Update, installed 10.3 cat form works fine, bear form it will not recognize thrash, no matter were i put the ability, i cant manually push the button with my mouse either, no idea why only thrash doesnt work, 10.3 seems to have at least partially fixed the issue.
Glad that cat form is working again. I'd guess that Thrash is one of the many spells that Ion does not auto generate macro text properly. Its one of the things that I had hoped to fix, but had to revert back to work on a bit more. Based on looking at the spell on wowhead it appears that the there might be subtext on the spell that is getting added to the macro which breaks it. Id guess that if you go to the edit mode and look at the macro generated it will be something like /cast Thrash(Feral, Guardian)() or with some extra text after the "Thrash". If there is extra text, you can just delete it so it is just /cast Thrash() and the button should work again. I'll look into it deeper once I get home and have time to log into the game.
SLOKnightfall is offline Report comment to moderator  
Reply With Quote
Unread 10-24-14, 11:32 AM  
Gumpster
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 8
Uploads: 4
Re: Re: Re: Re: Druid issue

Originally Posted by Gumpster
Originally Posted by SLOKnightfall
Originally Posted by Gumpster
Originally Posted by Gumpster
Ion is my go to addon for everything, but i am having issues with my druid, bars arent switching properly in various forms like they were, also several of my keybinds arent working either, even after redoing, please help because bartender sucks ass
Forgot some additional info, first of all I use a razer naga mouse, and my bar is mapped to those buttons, seems like only half of the buttons work when using Ion, while others dont, i ever remapped them, deleted the bar, started over, deleting and creating a brand new bar, and still i have the issue, none of the buttons that are not responding are being used by any other addon and or the default in game bindings
What keys are you binding on the naga? I have one and can try binding them and test. Also what setting do you have the keys set to 123, or num?
I use num keys been using that since day one without a problem it frees up more buttons that way.
For me NUMs 123 work fine, its NUMs 456 that i have the issue with
Update, installed 10.3 cat form works fine, bear form it will not recognize thrash, no matter were i put the ability, i cant manually push the button with my mouse either, no idea why only thrash doesnt work, 10.3 seems to have at least partially fixed the issue.
Gumpster is offline Report comment to moderator  
Reply With Quote
Unread 10-23-14, 10:02 PM  
Song42
A Defias Bandit

Forum posts: 2
File comments: 4
Uploads: 0
Re: Re: Blank Screen for Main Menu

Originally Posted by SLOKnightfall
Originally Posted by Song42
Honestly, I've never gotten the Main Menu since updating to Ion, but I never worried about it simply because I love this bar mod so much! I'm sure I'm missing out on some stuff.

I have turned off every addon I have and still, when I open the Main Menu, I only get a blank, block box. Does anyone know what might be causing this or how I can fix it?
Unfortunately it appears that Maul never implemented the menu. All it ever has been is the black box.
Thank you for the information. I never bothered to ask before, but at least it's "working as intended".
Song42 is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: