Minion Beta! - Help us test our new AddOn updater. Get it now!
Download
(563 Kb)
Download
Updated: 12-11-14 12:45 AM
Pictures
File Info
Compatibility:
Warlords of Draenor Pre-Patch (6.0.3)
Updated:12-11-14 12:45 AM
Created:unknown
Downloads:399,343
Favorites:989
MD5:
6.0.3

Ion  Popular! (More than 5000 hits)

Version: Hydrogen-12
by: Maul, Jrosk, SLOKnightfall

Hydrogen 12
-More fixes for ability cooldowns & procs
-Fix for Fairy Swarm tallent
-Fixes for Draenor Garrison ability button cooldown and range
-Fix for shadow dance triggering a stance bar change
-Nephyrin's Dualspec bar fix
-Misc bug fixes



Hydrogen 11
-Added items to the Ion Menu
-Fixed macro generation and cooldowns for most spells
-Added profile system

Hydrogen-10.3 Beta
-Reverted spell name change and added different work around for hunter call pet macros

Hydrogen-10.2 Beta
-Fixed TOC so bar position are global again. 10.1 accidentally contained a version that had the settings stored per character

Hydrogen-10.1 Beta
-Included SLOKnightfall's WoD updates
-Fixed mount macro's
-Fixed random mount macro
-Changed which spell name is used in the generated macro to fix issue with hunter pets summon macros not being correct.
-Created a list of spells that will ignore subtext in the spells. Mainly for hunter traps that were getting Trap Launcher added to the macro and not working.

Hydrogen-10 Beta
-Updating to Warlords of Draenor Expansion patch

Hydrogen-9 Beta
- Debug spam fix

Hydrogen-8 Beta
- Minor update to fix smaller issues

Hydrogen-7 Beta
- Updated for patch 5.4.1

Hydrogen-6 Beta
- Updated for patch 5.3

Hydrogen-5
- Spell Count bug fix (i.e. Death Knight's Scent of Blood count update)
- Spell Charges fix properly implemented

Hydrogen-4
- Forum version, include most hotfixes appearing on the forum (flyx, Nephyrin, chinoloco,kouik)
- should now display the appropriate tooltip in all cases.
- GetSpellCount replaced by GetSpellCharges (roll charges issues)
- spells with distinct subtypes between specs should be shown as useable in all cases.
- spell cooldowns should update (trash, symbiosis, disconnect/reconnect after a spec change should not show questionmark anymore)
- flyout should show the proper spell

Hydorgen-3

Hydrogen-2 Beta
- Updated for patch 5.1
- Fixed texture issue
- Dual spec toggle should work now
- Fixed extra bar action ID
- Other minor changes
- Sorry folks, that is all :(

Hydrogen-2 Beta
-Now scans profession spells
-Tentatively enabling/disabling of the Blizzard Main Bar should work
-Blizzard ExtraAction button should now only show if the Blizzard Bar is used
-Moved localization to one file

Hydrogen-1 Beta
- beta release for patch 5.0.4
Optional Files (8)
File Name
Version
Size
Author
Date
Type
Hydrogen-7 Beta
43kB
10-17-14 10:17 PM
Addon
Hydrogen-7 Beta
12kB
10-15-14 08:37 AM
Addon
Hydrogen-5 Beta
5kB
10-15-14 08:35 AM
Addon
Hydrogen-5 Beta
5kB
10-15-14 08:34 AM
Addon
40300.1
6kB
11-29-11 09:01 AM
Addon
40300.1
15kB
11-29-11 08:59 AM
Addon
40000.2.0.1
23kB
07-02-11 11:28 PM
Patch
40000.2.0.1
2kB
07-02-11 07:51 PM
Addon


Archived Files (6)
File Name
Version
Size
Author
Date
 Ion
Hydrogen-11
561kB
Maul
11-12-14 02:23 PM
 Ion
Hydrogen-10.3 B
460kB
Maul
10-21-14 12:00 AM
 Ion
Hydrogen-10.2 B
460kB
Maul
10-18-14 10:17 AM
 Ion
Hydrogen-10 Bet
454kB
Maul
10-15-14 08:38 AM
 Ion
Hydrogen-9 Beta
454kB
Maul
04-08-14 05:30 PM
 Ion
Hydrogen-8 Beta
417kB
Maul
03-31-14 08:51 AM


Post A Reply Comment Options
Unread 12-01-11, 12:55 PM  
TyBudd
A Deviate Faerie Dragon

Forum posts: 13
File comments: 82
Uploads: 0
No meaning that no matter what Icon you select, it displays as blank, like a clear button, but after you've selected that icon, if you go into any other button that you've previously selected either of these icons, they will all show that you've selected the same icon.

Its as if changing the icon for one button changes the icon for every button of that nature.

of that nature - any button that you manual have chosen an icon for.



As far as the workaround I got you, that makes sense, the only issue with that is, right here, you have them all listed out visually, a place like wowhead doesn't have that, unless you already know the name of the icon/spell you want to look up in order to get the ID of it
TyBudd is offline Report comment to moderator  
Reply With Quote
Unread 12-01-11, 12:18 PM  
TyBudd
A Deviate Faerie Dragon

Forum posts: 13
File comments: 82
Uploads: 0
Originally Posted by TyBudd
No that doesn't seem to be making a difference at all, the 1/3 type conditional does work though btw, its the same setup I had before 4.3 dropped.

Another issue that might help point to the source of the problem, with a macro I have that is slightly more complex:

#showtooltip
/cast [stance:2,@mouseover,exists][stance:2]Taunt;[mod,stance:1]Shattering Throw;[stance:1][stance:3]Execute
/cancelaura [stance:2] Hand of Protection

When actually in either stance 1 or 3, even though I might be in a situation when Execute isn't usable, its always lit up, as if it is, but if I just do your basic /cast Execute, its stays dim like intended until usable.

Edit:
Also a problem with the icons, u change one macro that was using a chosen icon, it changes all macros that is using a chosen Icon, but doesn't actually display

Yes its only the macros dealing with stances, because another multi ability macro i have works fine:


#showtooltip
/cast [mod]Concussion Blow;Shockwave
TyBudd is offline Report comment to moderator  
Reply With Quote
Unread 12-01-11, 12:17 PM  
anseloth
Coding Archmage
 
anseloth's Avatar
AddOn Author - Click to view AddOns

Forum posts: 50
File comments: 266
Uploads: 3
Re: Macros with stance conditionals

Originally Posted by TyBudd
...Also a problem with the icons, u change one macro that was using a chosen icon, it changes all macros that is using a chosen Icon, but doesn't actually display
wow, guess i posted my reply too fast that time, so that i didn't see the stuff you added in the edit i quoted here.

anyway, i am NOT sure understand what you are saying here, so i'll list what i THINK you mean by each portion, and you can correct me wherever i got it wrong.
  1. by 'a chosen icon' i think you mean an macro icon that is set by going through the list of macro icons in the macro interface, and choosing one out of there.
  2. by the part where you said it 'doesn't actually display', i did you mean that the affected macros get their icon changed to that question mark icon?

lastly, a tip for a semi-workaround (well, i'd say its really a better method, but whatever) that i think you'll like: if you want to use a certain icon for your macro, try the following code at the beginning of the macro:
Code:
#showicon item:*****
just replace the asterisks with the item ID of an item with the icon you want. (NOTE: due to Blizzard's laziness, spells do not work for this yet.) now, to find the item ID of an item, (if you don't have an addon that lists the ID in the item tooltip,) just do the following:
  1. make sure you've set the manually set icon for the macro to the first one (meaning the red question mark on a black background)
  2. find something that has the icon you want, ( doesn't have to be an item at this point, but it can be if you like, ) for this example, i'll use a Well Fed food buff.
  3. find the Wowhead page for the thing with the icon you want.
  4. left click the icon on the Wowhead page.
  5. this should make a popup come up, that shows the name of the icon, and also has links to auto-generated searches that show any items, spells, or achievements that use the icon.
  6. chose the items link, and assuming you aren't crazily unlucky, it will have some items listed.
  7. left click of the items in the search results (in this case, the only item it found was the Wine and Cheese Platter, which will work nicely)
  8. now, in the webpage address, it should say only where i put the 5 asterisks, it should show a number with maybe 3 to 5 (maybe 6, but idk) digits. just copy and paste that number in the place of the 5 asterisks in the code in the code box i linked above.
the result of my example is:
Code:
#showicon item:57729
now, the reason i like this method more, is because finding a specific icon in that list of icons in the macro interface is a PAIN, assuming that the icon you want is in there AT ALL!

also, once you have this method memorized, then it is quick and easy to use. (unless you don't play WoW in windowed mode, or something, then you might have some trouble copying the thing with the icon you want from the game into the Wowhead search.)

P.S.
sorry, but please ignore the link in the quote box, i keep trying to turn to remove the link without changing the text displayed, but wowinterface keeps adding the link back in. go figure.
__________________



anseloth is offline Report comment to moderator  
Reply With Quote
Unread 12-01-11, 12:02 PM  
TyBudd
A Deviate Faerie Dragon

Forum posts: 13
File comments: 82
Uploads: 0
No that doesn't seem to be making a difference at all, the 1/3 type conditional does work though btw, its the same setup I had before 4.3 dropped.

Another issue that might help point to the source of the problem, with a macro I have that is slightly more complex:

#showtooltip
/cast [stance:2,@mouseover,exists][stance:2]Taunt;[mod,stance:1]Shattering Throw;[stance:1][stance:3]Execute
/cancelaura [stance:2] Hand of Protection

When actually in either stance 1 or 3, even though I might be in a situation when Execute isn't usable, its always lit up, as if it is, but if I just do your basic /cast Execute, its stays dim like intended until usable.

Edit:
Also a problem with the icons, u change one macro that was using a chosen icon, it changes all macros that is using a chosen Icon, but doesn't actually display
TyBudd is offline Report comment to moderator  
Reply With Quote
Unread 12-01-11, 11:28 AM  
anseloth
Coding Archmage
 
anseloth's Avatar
AddOn Author - Click to view AddOns

Forum posts: 50
File comments: 266
Uploads: 3
Re: Macros with stance conditionals

Originally Posted by TyBudd
For some reason my multi conditional macros, that have stances in them, aren't showing the effect that the ability is being used, or the cooldown of them, but if I just do a basic /cast command of that ability, it performs fine.

Example:

#showtooltip
/cast [stance:1/3] Slam; [stance:2] Revenge

My focus is when in defensive stance, it isn't showing, all you see is the revenge icon, but no visual response when you press the button, but if the ability is available it does person the task at hand.
i THINK i see your problem, i don't think you can use a '/' in a stance state like that. what you should probably change it to, is as follows:

Code:
#showtooltip
/cast [stance:1][stance:3] Slam; [stance:2] Revenge
that SHOULD work, (i think, but, maybe i am mistaken about the '/' not working in there)
__________________



anseloth is offline Report comment to moderator  
Reply With Quote
Unread 12-01-11, 11:15 AM  
TyBudd
A Deviate Faerie Dragon

Forum posts: 13
File comments: 82
Uploads: 0
Macros with stance conditionals

For some reason my multi conditional macros, that have stances in them, aren't showing the effect that the ability is being used, or the cooldown of them, but if I just do a basic /cast command of that ability, it performs fine.

Example:

#showtooltip
/cast [stance:1/3] Slam; [stance:2] Revenge

My focus is when in defensive stance, it isn't showing, all you see is the revenge icon, but no visual response when you press the button, but if the ability is available it does person the task at hand.


Also a problem with the icons, u change one macro that was using a chosen icon, it changes all macros that is using a chosen Icon, but doesn't actually display
Last edited by TyBudd : 12-01-11 at 11:27 AM.
TyBudd is offline Report comment to moderator  
Reply With Quote
Unread 11-30-11, 06:37 PM  
Flaer
A Murloc Raider

Forum posts: 6
File comments: 30
Uploads: 0
Originally Posted by Meltorefas
Originally Posted by drraf3
I searched on how to fix this and couldn't find anything. Anyway the icons for my macro buttons are missing on the bar. icon does show up in my editor screen. Any ideas? The Icons do show up when the button is set to action.
Same issue here. For me at least though, it only affects macros that are not /cast commands. Adding a /cast command to the start of the macro causes the icon to show up once more. As a workaround add /cast to the start of your macro. No need for a spell or anything, just /cast and then nothing, then a new line and your original macro.


EDIT: /use also works.
I'm having this same issue with any button that I've chosen an icon for. Adding /cast or /use isn't fixing the problem.
Flaer is offline Report comment to moderator  
Reply With Quote
Unread 11-30-11, 04:49 PM  
Shakari
A Kobold Labourer

Forum posts: 1
File comments: 58
Uploads: 0
Seem to be having issues with abilities with macaroon. basically I drag say shield block on to my actio bar and it either does 2 things:

1. Vanish when I put it in the action bar so I have to repeatedly drag it onto the bar.
2. Go on the action bar but has no use or cooldown on activation.

I am finding all my buttons with a CD are like No.2.

Also find the profiles are not working again properly and have had to redo them but when redragging buttons onto the bars for example I want to put devastate to button 1 and revenge to button 2 either problem 1 above accurs or I put devastate in button 1 but when I place revenge devastate vanishes.

any solutions to these problems?

Also any button with a macro has no icon on it ...

Using the latest version which was meant to fix it
Last edited by Shakari : 11-30-11 at 05:18 PM.
Shakari is offline Report comment to moderator  
Reply With Quote
Unread 11-30-11, 04:21 PM  
crazyivan
A Murloc Raider

Forum posts: 8
File comments: 80
Uploads: 0
4.3 Error

I have been getting this error when I enter combat

Date: 2011-11-30 16:10:28
ID: 2
Error occured in: AddOn: Macaroon
Count: 1
Message: Note: AddOn Macaroon attempted to call a protected function (MultiBarBottomLeftButton11:Show()) during combat lockdown.
Debug:
[C]: Show()
..\FrameXML\ActionButton.lua:246: ActionButton_Update()
..\FrameXML\ActionButton.lua:484: ActionButton_OnEvent()
..\FrameXML\ActionButton.lua:105:
..\FrameXML\ActionButton.lua:98
AddOns:
StopTheSpam, v2.00.20000
Swatter, v5.13.5233 (BoldBandicoot)
ACP, v3.3.17
AddonLoader, v2.0
Align, v
AlreadyKnown, v
Altoholic, v4.2.002
AraBrokerSpecSwitcher, vr8
ArcanaExperienceBroker, v40000.3
Archy, v1.8.8
Atlas, v1.21.0
AtlasLootLoader, vv6.05.00
Auctionator, v2.9.9
Auditor2, v4.4.2
Bagnon, v4.3.0
BagnonFacade, v3
BagnonForever, v
BattleHerald, v1.04
BrokerAuditor, v4.4.2
BrokerBagFu, vv1.0.6
BrokerDurabilityInfo, v1.11
BrokerGroup, v
BrokeruClock, v3.3.4
ButtonFacade, v4.2.377
ButtonFacadeAquatic, v3.3.1
ButtonFacadeDek, v3.0.47
ButtonFacadeDek2, v3.0.47
ButtonFacadeElegance, v3.3.0
ButtonFacadeShadow, v1.1
ButtonFacadeSleek, v4.0.0
Carousel, v2.1.1
Chatbubbles, v
Chatter, v1.0
ColorTools, v
ConfirmLootRoll, v
Cromulent, vv1.5.10
CurrencyTracker, v1.4
DataStore, v4.2.002
DataStoreAgenda, v4.2.002
DataStoreAuctions, v4.2.002
DataStoreCharacters, v4.2.002
DataStoreContainers, v4.2.002
DataStoreCrafts, v4.2.002
DataStoreCurrencies, v4.2.002
DataStoreInventory, v4.2.002
DataStoreMails, v4.2.002
DataStorePets, v4.2.002
DataStoreReputations, v4.2.002
DataStoreSpells, v4.2.002
DataStoreStats, v4.2.002
DataStoreTalents, v4.2.002
DBMCore, v
DBMLDB, v
DBMPartyCataclysm, v
EJSmallerMapButtons, v1.0
FerousMedia, v1.6
FireTree, v
ForteCasting, v
ForteCooldown, v
ForteCore, v1.975.7
FortePaladin, v
ForteTalent, v
ForteTimer, v
ForteVehicle, v
Fortress, v1.1.5
GearScore, v4.10.01.00
GetOffMyLawn, v2.4
GrizzlySharedMedia, v1
InFlightLoad, v4.3.001
InsanityTracker, v14 (beta)
InspectFix, v2.8
LFGCallToArmsBroker, v1.0
LibResComm10, vv82
Macaroon, v40300.1
MacaroonBound, v40300.1
MacaroonStatusBars, v40300.1
MacaroonTotemBar, v40000.1
MacaroonXtras, v40300.1.2
Mapster, v1.4.3
Masque, v4.2.377
MasqueDarion, v4.1
MasqueEntropy, v4.2.71
MikScrollingBattleText, v5.6.112
MiniLoot, v1.6b
MinimapButtonFrame, v3.1.6
MinimapButtonFramesDark, v1.0
MinimapButtonFrameSkinPack, v3.0
Molinari, v40200.11-Beta
MoveAnything, v12.2.1
nibChatTabs, v0.44
NiceDamage, v40000
OmniCC, v4.3.0
Outfitter, v5.3.4
PowerAuras, v4.22
Quartz, v3.0.8
QuestHelperLite, v4.0.3.0
RatingBuster, v
Raven, v
RealIDToons, v2.1.7
RSA, v2.835
RSAPaladin, v
SexyMap, v
SharedMediaBlizzard, v1.6
shMem, v
shPerformance, v6.1
Skada, v1.3-8
SkadaCC, v1.0
SkadaDamage, v1.0
SkadaDamageTaken, v1.0
SkadaDeaths, v1.0
SkadaDebuffs, v1.0
SkadaDispels, v1.0
SkadaEnemies, v1.0
SkadaHealAbsorbs, v
SkadaHealing, v1.0
SkadaPower, v1.0
SkadaThreat, v1.0
SkadaWindowButtons, v1.0
Skillet, v
SpamBayes, v40100
Stuf, v4.3.001
StufRange, v
StyleDBM, v4.4
TidyPlates, v6.4.8 (R363)
TidyPlatesThreatPlates, v5.4
TidyPlatesWidgets, v
TipTac, v11.09.29
TipTacItemRef, v11.09.29
TipTacTalents, v11.09.29
tomQuest2, v4.2 beta 1
TravelAgent, v4.3.0-1.0.15
Volumizer, v4.2.0-2.0.2
VuhDo, v2.126
VuhDoOptions, v2.126
WIM, v3.5.8
WIMukui, v
XLoot, v0.91.1
XLoot10, v1.0.15
XLootGroup, v0.62
XLootMaster, v0.82
XLootMonitor, v0.72
xUtils, v4.2.3
BlizRuntimeLib_enUS v4.3.0.40300 <us>
(ck=c9b)
crazyivan is offline Report comment to moderator  
Reply With Quote
Unread 11-30-11, 12:28 PM  
Maul
Ion Engines, Engage!
 
Maul's Avatar
AddOn Author - Click to view AddOns

Forum posts: 401
File comments: 1084
Uploads: 32
Re: Re: Re: Possess bar / buttons did not show during encounter even after setup correctly

Originally Posted by jincuteguy
Originally Posted by Maul
Originally Posted by jincuteguy
Hi guys, I been using Macaroon for a while but I have a problem with Possess bar with buttons. I set up a possess bar and give it 5 buttons. I also make sure and set these buttons to Action ID buttons (i.e. 121 - 126). But when during the encounter the possess bar did not show up at all and the possess abilities that suppose to appear did not show up also. So I don't know what the problem is. Can anyone help? I have the latest version of Macaroon for 4.3. But this problem has been going on for a while when I was using earlier version like 4.2 and older. I just couldn't figure out why.
Do you have a vehicle bar set up as well? Blizzard is not consistent on what they will cause to show as possess or as a vehicle.

I will most likely be making some changes so this is no longer an issue and you can use one bar for both.

Yea, I have a vehicle bar set up with the same possess bar. Is that why it causes that issue? So if i make them two separate bars then it will work?
Yes, that possibly may fix it.
Maul is offline Report comment to moderator  
Reply With Quote
Unread 11-30-11, 12:23 PM  
jincuteguy
A Deviate Faerie Dragon

Forum posts: 11
File comments: 5
Uploads: 0
Re: Re: Possess bar / buttons did not show during encounter even after setup correctly

Originally Posted by Maul
Originally Posted by jincuteguy
Hi guys, I been using Macaroon for a while but I have a problem with Possess bar with buttons. I set up a possess bar and give it 5 buttons. I also make sure and set these buttons to Action ID buttons (i.e. 121 - 126). But when during the encounter the possess bar did not show up at all and the possess abilities that suppose to appear did not show up also. So I don't know what the problem is. Can anyone help? I have the latest version of Macaroon for 4.3. But this problem has been going on for a while when I was using earlier version like 4.2 and older. I just couldn't figure out why.
Do you have a vehicle bar set up as well? Blizzard is not consistent on what they will cause to show as possess or as a vehicle.

I will most likely be making some changes so this is no longer an issue and you can use one bar for both.

Yea, I have a vehicle bar set up with the same possess bar. Is that why it causes that issue? So if i make them two separate bars then it will work?
jincuteguy is offline Report comment to moderator  
Reply With Quote
Unread 11-30-11, 11:22 AM  
Maul
Ion Engines, Engage!
 
Maul's Avatar
AddOn Author - Click to view AddOns

Forum posts: 401
File comments: 1084
Uploads: 32
Also found this - http://www.curse.com/addons/wow/ds-extraactionbutton

It should work with Macaroon without issue.
Maul is offline Report comment to moderator  
Reply With Quote
Unread 11-30-11, 11:10 AM  
Maul
Ion Engines, Engage!
 
Maul's Avatar
AddOn Author - Click to view AddOns

Forum posts: 401
File comments: 1084
Uploads: 32
Re: Possess bar / buttons did not show during encounter even after setup correctly

Originally Posted by jincuteguy
Hi guys, I been using Macaroon for a while but I have a problem with Possess bar with buttons. I set up a possess bar and give it 5 buttons. I also make sure and set these buttons to Action ID buttons (i.e. 121 - 126). But when during the encounter the possess bar did not show up at all and the possess abilities that suppose to appear did not show up also. So I don't know what the problem is. Can anyone help? I have the latest version of Macaroon for 4.3. But this problem has been going on for a while when I was using earlier version like 4.2 and older. I just couldn't figure out why.
Do you have a vehicle bar set up as well? Blizzard is not consistent on what they will cause to show as possess or as a vehicle.

I will most likely be making some changes so this is no longer an issue and you can use one bar for both.
Maul is offline Report comment to moderator  
Reply With Quote
Unread 11-30-11, 11:06 AM  
Maul
Ion Engines, Engage!
 
Maul's Avatar
AddOn Author - Click to view AddOns

Forum posts: 401
File comments: 1084
Uploads: 32
Re: Re: Re: Missing control

Originally Posted by Firebelly
Originally Posted by Maul
Use /framestack to find out the name of the button. This will allow you to do two things -

1) Macro /click <frame name>

2) Tell me what the frame's name is so I can investigate further
Cheers Maul, I'm not near the game at the moment and won't be raiding for several hours, but a quick google has turned up a couple of things:

On BetterPowerBarAlt (http://www.wowace.com/addons/betterpowerbaralt/), there is a discussion talking about the new bar. It is called ExtraActionBar, and the button is called ExtraActionButton1 (and can be macro'd by /click ExtraActionButton1).

I will double check this tonight in raid too, using /framestack.

Thanks!
So, from the looks of it, it appears to be using action ID 121. This should be easily set in Macaroon. However, showing/hiding the button at the appropriate time may not be so easy, so for now you may want to make 1 bar with 1 button set to action ID 121 with no show states and set it off to the side until I can figure out if there is a way to make it show/hide on the event it is needed for.
Maul is offline Report comment to moderator  
Reply With Quote
Unread 11-30-11, 10:45 AM  
jincuteguy
A Deviate Faerie Dragon

Forum posts: 11
File comments: 5
Uploads: 0
Possess bar / buttons did not show during encounter even after setup correctly

Hi guys, I been using Macaroon for a while but I have a problem with Possess bar with buttons. I set up a possess bar and give it 5 buttons. I also make sure and set these buttons to Action ID buttons (i.e. 121 - 126). But when during the encounter the possess bar did not show up at all and the possess abilities that suppose to appear did not show up also. So I don't know what the problem is. Can anyone help? I have the latest version of Macaroon for 4.3. But this problem has been going on for a while when I was using earlier version like 4.2 and older. I just couldn't figure out why.
jincuteguy is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: