Download
(714 Kb)
Download
Updated: 08-31-10 10:44 PM
Pictures
File Info
Updated:08-31-10 10:44 PM
Created:unknown
Downloads:13,008
Favorites:327
MD5:
Tabard-O-Matic  Popular! (More than 5000 hits)
Version: 2.0.12
by: Fritos [More]
Ever wanted to know what your Tabards looked like without having to try them on? This mod will do just that. It replaces the game icons with an more accurate representation of what the Tabard actually looks like. There are no settings, it runs pretty much out of the box.

It currently works with these Inventory Systems:
  • Blizzard Character Frame
  • Blizzard Inspect Frame
  • Blizzard Merchant Frame
  • Blizzard Bags/Bank Frame
  • Baggins
  • Combuctor
  • Baudbag
  • ArkInventory
  • AtlasLoot
  • Bagnon
  • FBagOfHolding
  • cargBags
  • Stuffing

--- Version 2.0.12 ---
  • Added support for Stuffing

--- Version 2.0.11 ---
  • Fixed AtlasLoot issues. Thanks AutolycusWolf!!

Compatibility Requests:
If you'd like me to add compatibilty for other AIOI mods, please leave a comment with the link to the specific mod you'd like. I can't guarantee that it would be possible (depending on the severity of the mods code), but I will try my best.


Click here to lend your support!
--- Version 2.0.10 ---
  • Added Tuller fix for CargBags
  • Added some missing Tabards (mainly new PvP rewarded)

--- Version 2.0.3 ---
  • Added support for Bagnon

--- Version 2.0.2 ---
- Client 3.1 Ready!
- Fixed the localization issue with AtlasLoot
- Added support for Equipment Manager Flyout

--- Version 2.0.1 ---
- Fixed some offline bags not showing the right icon.
- Added support for ArkInventory and AtlasLoot.
- Implemented Ammo's suggestion. Thanks Ammo.
- Added rest of Argent Tournament tabards.
- Fixed some spelling issues.

--- Version 2.0 ---
- Updated alot of the tabards that where missing and added in some of the new 3.1 Tabards from Argent Tournament.
- Added support for Combuctor and Baudbag.
Archived Files (12)
File Name
Version
Size
Author
Date
2.0.11
713kB
Fritos
08-31-10 05:31 PM
2.0.10
716kB
Fritos
07-13-10 09:59 PM
2.0.9
695kB
Fritos
08-20-09 03:57 PM
2.0.9
689kB
Fritos
08-05-09 08:20 PM
2.0.6
689kB
Fritos
07-14-09 05:51 PM
2.0.5
663kB
Fritos
04-07-09 08:51 PM
2.0.4
663kB
Fritos
04-07-09 03:48 PM
2.0.3
660kB
Fritos
04-05-09 09:46 AM
2.0.2
660kB
Fritos
04-01-09 03:39 PM
2.0.1
661kB
Fritos
03-05-09 10:18 PM
2.0
648kB
Fritos
02-28-09 06:38 PM
1
122kB
Fritos
09-07-08 08:16 PM


Post A Reply Comment Options
Old 08-31-10, 10:44 PM  
Fritos
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 4
File comments: 149
Uploads: 2
Re: Stuffing support?

Originally posted by kaltoran
Hello first of all great mod but sadly I am not using it atm as it does not seem to work with the inventory mod called Stuffing :/ I feel a little selfish for asking but would there be any chance of you enabling support for stuffing by any chance? If not thats fine but i could not resist asking keep up the great work regardless
Done and uploaded!
Fritos is offline Report comment to moderator  
Reply With Quote
Old 08-31-10, 10:16 PM  
kaltoran
A Murloc Raider
 
kaltoran's Avatar

Forum posts: 8
File comments: 39
Uploads: 0
Stuffing support?

Hello first of all great mod but sadly I am not using it atm as it does not seem to work with the inventory mod called Stuffing :/ I feel a little selfish for asking but would there be any chance of you enabling support for stuffing by any chance? If not thats fine but i could not resist asking keep up the great work regardless
__________________
kaltoran is offline Report comment to moderator  
Reply With Quote
Old 08-31-10, 05:24 PM  
Fritos
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 4
File comments: 149
Uploads: 2
@AutolycusWolf
Thanks for the indepth detail. Helps alot, and I did reproduce this and it is fixed and will upload an update shortly.
Fritos is offline Report comment to moderator  
Reply With Quote
Old 08-31-10, 10:04 AM  
AutolycusWolf
A Kobold Labourer
 
AutolycusWolf's Avatar

Forum posts: 0
File comments: 58
Uploads: 0
Originally posted by Fritos
This very strange as Tabard-O-Matic does nothing with links at all, it only changes the corresponding textures for the Tabards. I will take a look nonetheless, but very strange indeed!

** EDIT **
I just logged in and everything is showing as it should, the T9 sets are linking properly and Trial of the Champions shows the Heroic loot sets. So not positive what may be causing the issue, I'll keep looking to see if I can reproduce this.
Just to confirm things again I did re-enable Tabard-O-Matic and logged in with my alliance warlock. Yes the T9 set was linking properly and it showed the alliance version of it. When logging my horde warlock though Atlasloot kept linking the alliance version of the T9 set instead of the horde one, so yes the sets do link properly, no doubt about it, but the addon's correct behavior is to link the horde versions of them when logged with a horde toon and the alliance versions when logged with an alliance toon, something that is not the case when Tabard-O-Matic is enabled.

Also (and this is my bad of course) the instance I was referring to wasn't Trial of the Champions (which indeed shows the heroic mode loot tables) but Trial of the Crusade. When looking at the loot tables of the Trial of the Crusade raid there is a button that reads "Show 25 Man Loot" which toggles between 10 Man and 25 Man loot and above that a radio box that when ticked shows the heroic mode loot tables, both of these aren't there when Tabard-O-Matic is enabled.

Screenshots follow:
In this first image you see my alliance warlock (with Tabard-O-Matic enabled) looking at the alliance T9 set labaled Kel'Thuzad's Regalia.

In this second image you see my alliance warlock (with Tabard-O-Matic enabled) looking at the Anub'arak loot table from the Trial of the Crusade raid.

In this third image you see my horde warlock (with Tabard-O-Matic enabled) looking at what should have been the horde T9 set which oddly enough is still lebaled Kel'Thuzad's Regalia (which is the name of the alliance set and when clicked, in the dressing room, it has the alliance look and feel).

Notice the differences now in the following last two images.

In this fourth image you see my horde warlock (with Tabard-O-Matic disabled) looking at the correct horde T9 set labeled Gul'Dan's Regalia.

Last but not least in this fifth image my horde warlock (with Tabard-O-Matic disabled) is looking at the Anub'arak loot table from the Trial of the Crusade raid. Notice the button on the left that reads "Show 25 Man Loot" and the radio box above it that reads "Heroic Mode" both of which were not there with Tabard-O-Matic enabled in the previous picture of the same nature.

A small aside here: it doesn't make any difference whatsoever with regards to the Trial of the Crusade raid if you are logged with an alliance or horde toon. If Tabard-O-Matic is enabled the "Show 25 Man Loot" button and the "Heroic Mode" radio box are missing regardless of the faction of the toon you are logged in with

Hope these images (links are safe and point to photobucket, to those of you that might worry about suspicious links and keyloggers) will shed some light on the issue. Thanks again for taking the time and looking into the matter.

Reason for EDIT: screenshots and their descriptions added.
Last edited by AutolycusWolf : 08-31-10 at 01:47 PM.
AutolycusWolf is offline Report comment to moderator  
Reply With Quote
Old 08-30-10, 11:37 AM  
Fritos
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 4
File comments: 149
Uploads: 2
Originally posted by AutolycusWolf
There is a weird bug with Tabard-O-Matic interfering with the (latest versions of) AtlasLoot Enhnaced causing all links of tier 9 sets to point at the alliance versions of them, regardless of what toon you are logged in with (the addon showed the horde versions if you were logged in with a horde toon and the alliance versions if you were logged in with an alliance toon). Also in the Trial of the Champion loot tables page, Tabard-O-Matic for some weird reason is responsible for the addon not having the option to show the heroic mode loot.

As Hegarol (manager/author of AtlasLoot) suggested disabling Tabard-O-Matic solves the aformentioned issues. And it is really weired for me (well I'm not at all .lua literate but...) as to how Tabard-O-Matic is causing this, since your addon just has to do with tabards and not loot tables in anyway.

Regardless looking into the matter would make a lot of us very very happy as both addons are indeed useful and provide a better overal world of warcraft gameplay experience.

Thanks for your hard work.
This very strange as Tabard-O-Matic does nothing with links at all, it only changes the corresponding textures for the Tabards. I will take a look nonetheless, but very strange indeed!

** EDIT **
I just logged in and everything is showing as it should, the T9 sets are linking properly and Trial of the Champions shows the Heroic loot sets. So not positive what may be causing the issue, I'll keep looking to see if I can reproduce this.
Last edited by Fritos : 08-30-10 at 11:50 AM.
Fritos is offline Report comment to moderator  
Reply With Quote
Old 08-15-10, 12:22 AM  
AutolycusWolf
A Kobold Labourer
 
AutolycusWolf's Avatar

Forum posts: 0
File comments: 58
Uploads: 0
There is a weird bug with Tabard-O-Matic interfering with the (latest versions of) AtlasLoot Enhnaced causing all links of tier 9 sets to point at the alliance versions of them, regardless of what toon you are logged in with (the addon showed the horde versions if you were logged in with a horde toon and the alliance versions if you were logged in with an alliance toon). Also in the Trial of the Champion loot tables page, Tabard-O-Matic for some weird reason is responsible for the addon not having the option to show the heroic mode loot.

As Hegarol (manager/author of AtlasLoot) suggested disabling Tabard-O-Matic solves the aformentioned issues. And it is really weired for me (well I'm not at all .lua literate but...) as to how Tabard-O-Matic is causing this, since your addon just has to do with tabards and not loot tables in anyway.

Regardless looking into the matter would make a lot of us very very happy as both addons are indeed useful and provide a better overal world of warcraft gameplay experience.

Thanks for your hard work.
AutolycusWolf is offline Report comment to moderator  
Reply With Quote
Old 08-06-10, 01:11 AM  
kwn2k
A Murloc Raider
 
kwn2k's Avatar

Forum posts: 8
File comments: 20
Uploads: 0
Request for Support

I would like to request for support for Examiner
kwn2k is offline Report comment to moderator  
Reply With Quote
Old 07-15-10, 11:29 AM  
cag_dk
A Deviate Faerie Dragon
 
cag_dk's Avatar

Forum posts: 14
File comments: 44
Uploads: 0
Request for support

could you make Tabard-O-Matic work with Goldpaw's gBags please?
__________________
King for a Day, Fool for a Lifetime
cag_dk is offline Report comment to moderator  
Reply With Quote
Old 03-25-10, 01:10 PM  
Gsusnme
A Wyrmkin Dreamwalker
AddOn Author - Click to view AddOns

Forum posts: 56
File comments: 198
Uploads: 1
Unfortunately, this has stopped working for me since the last patch (3.3.3), I use ArkInventory so it could very well be it's fault, anyone else?
Gsusnme is offline Report comment to moderator  
Reply With Quote
Old 12-10-09, 09:02 PM  
Sepioth
A Molten Giant
AddOn Author - Click to view AddOns

Forum posts: 894
File comments: 97
Uploads: 5
CODE FIX
Thanks Tuller for this.

For anyone trying to do this go into the Tabard-O-Matic folder. Once in open the AIOI folder.

Open the Combuctor.lua file and just replace all that with the code by Tuller. Fixes all my errors.

Thanks again.
Sepioth is offline Report comment to moderator  
Reply With Quote
Old 12-10-09, 05:05 AM  
Tuller
A Black Drake
 
Tuller's Avatar
AddOn Author - Click to view AddOns

Forum posts: 84
File comments: 1608
Uploads: 36
Combuctor needss a new hook:
Code:
function SetUpCombuctor()
	if not Combuctor.ItemSlot then return end

	Tabard_O_Matic:SecureHook(Combuctor.ItemSlot, "Update", function(self)
		local texture, count, locked, quality, readable, lootable, link = self:GetItemSlotInfo()
		
		if (link) then
			local ItemID = tonumber(link:match("item:(%d+)"))
			local TabardValue = TabardTextures[ItemID]
			
			if TabardValue then
				self:SetTexture([[Interface\Addons\Tabard-o-matic\Tabards\]] .. TabardValue.ItemName)
			end
		end	
	end)
end
Tuller is offline Report comment to moderator  
Reply With Quote
Old 12-01-09, 06:26 AM  
Hentaya
A Deviate Faerie Dragon
AddOn Author - Click to view AddOns

Forum posts: 10
File comments: 19
Uploads: 1
Finally got around to finding your WONDERFUL addon. Works like a charm with OneBag/OneBank. Only problem so far is that [Tabard of the Protector] and [Tabard of the Argent Dawn] have the same representation. Haven't looked at the code yet. (Edit: They have the same representation, because they have the same Targa file. oops.
Last edited by Hentaya : 12-01-09 at 06:31 AM.
Hentaya is offline Report comment to moderator  
Reply With Quote
Old 10-07-09, 04:40 AM  
Daviesh
A Murloc Raider
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 4
File comments: 144
Uploads: 5
Originally posted by Fritos
Thanks for the heads up, I'll fix this soon. But yes, I don't keep up to date with compatibility with other peoples mods when they update/change. I don't have the time and most of these additions where by request! As a majority of them I don't use, the only way I know is by users having issues.
Send me a PM with an email address and I will send you a prototype of some code that will get around most of the compatibility problems (ie: only a really major AtlasLoot change would affect you) and reduce the amount of code considerably.
Daviesh is offline Report comment to moderator  
Reply With Quote
Old 10-06-09, 06:10 PM  
Fritos
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 4
File comments: 149
Uploads: 2
Originally posted by Daviesh
The root of it is that Tabard-o-matic's hook of AtlasLoot does not keep up to date with any change I make to AtlasLoot. A better way of doing it would be to call the original AtlasLoot version of AtlasLoot_ShowItemsFrame, then once all that is done, loop through each item of the loot page that has been created and replace the icon if necessary.
Thanks for the heads up, I'll fix this soon. But yes, I don't keep up to date with compatibility with other peoples mods when they update/change. I don't have the time and most of these additions where by request! As a majority of them I don't use, the only way I know is by users having issues.
Fritos is offline Report comment to moderator  
Reply With Quote
Old 10-06-09, 02:27 PM  
Daviesh
A Murloc Raider
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 4
File comments: 144
Uploads: 5
Originally posted by Vilkku
Tabard-O-Matic messes up AtlasLoot.
The root of it is that Tabard-o-matic's hook of AtlasLoot does not keep up to date with any change I make to AtlasLoot. A better way of doing it would be to call the original AtlasLoot version of AtlasLoot_ShowItemsFrame, then once all that is done, loop through each item of the loot page that has been created and replace the icon if necessary.
Daviesh is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.