Minion Beta! - Help us test our new AddOn updater. Get it now!
Download
(14 Kb)
Download
Updated: 09-28-08 08:18 PM
Updated:09-28-08 08:18 PM
Created:unknown
Downloads:24,020
Favorites:166
MD5:
MBB (MiniMap Button Bag)  Popular! (More than 5000 hits)
Version: v0.60
by: Pericles [More]
A WotLK version of MBB (Minimap Button Bag). An addon that gathers up all your buttons on your minimap and puts them into a single button.

Click the single button and out pops a list of all the buttons its put in the bag as if they were on the minimap, fully usable but tidy.


Note this version has been tidied up and made to work with WotLK from the live version maintained in my name at http://files.wowace.com/MBB/MBB.zip

Note also that the secure headers template code needs work and so the buttons may not function in combat. However if you are needing to configure your UI in combat, you really need to ask yourself if you are paying attention to the combat or not.

Please note that this version is out of date the latest version is now on Curse.com


Download the latest version here
Optional Files (0)


Post A Reply Comment Options
Unread 09-29-08, 06:04 AM  
contramundi
A Chromatic Dragonspawn
 
contramundi's Avatar
AddOn Compiler - Click to view compilations

Forum posts: 178
File comments: 78
Uploads: 2
good work m8 nice to know this addon is still updated.

dunno how to explain this in a decent way though, but i've been using a very old version of MBB due to newer versions always giving me a stack overflow after login, and this would mean i couldn't play the game till i disabled the addon. Dunno if you heard about this error and if so if it has been fixed?

is this version only LK compatible, or does it work with 2.4.x clients as well? if so i'm definately gonna try it out tonite.

Keep up the good work btw, since these are the addons i'm definately be needing once the expansion comes out
Last edited by contramundi : 09-29-08 at 06:04 AM.
contramundi is offline Report comment to moderator  
Reply With Quote
Unread 09-29-08, 09:51 AM  
Pericles
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 33
Uploads: 3
The stack overflow bug was fixed on live at least 6 months ago. Get the version that works on live from http://files.wowace.com/MBB/MBB.zip the version on this site is WotLK only.

It is of course possible the reason you get an issue is you pulled a version with embedded libraries from a site other than wowace.com. Bad idea. Ace embedded libraries save a lot of coding but you must ensure you keep them at the same version. Having multiple copies of the same library all at different versions is a recipe for disaster.
Last edited by Pericles : 09-29-08 at 09:54 AM.
Pericles is offline Report comment to moderator  
Reply With Quote
Unread 09-30-08, 09:19 AM  
Xion87
A Kobold Labourer

Forum posts: 1
File comments: 6
Uploads: 0
good, can y make that boton movailable in the next revision?
Xion87 is offline Report comment to moderator  
Reply With Quote
Unread 09-30-08, 05:49 PM  
Pericles
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 33
Uploads: 3
It should be movable by clicking on the button and dragging it around the minimap. Beta is down at present so I can't test this but it works fine with the live version so I am assuming it still works to drag the button on beta.
Pericles is offline Report comment to moderator  
Reply With Quote
Unread 10-02-08, 07:00 AM  
contramundi
A Chromatic Dragonspawn
 
contramundi's Avatar
AddOn Compiler - Click to view compilations

Forum posts: 178
File comments: 78
Uploads: 2
the being fixed 6 months ago, i don't think that was actually the case, i downloaded the latest version from wowace a month ago or so, and it gave me that stack overflow error, thats the reason i had to switch back to a much older version, which thank god i still had.

gonna try that linked version of yours, and ofcourse this one as soon as the expansion goes live

Greetz,

CM
contramundi is offline Report comment to moderator  
Reply With Quote
Unread 10-03-08, 07:19 AM  
Pericles
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 33
Uploads: 3
Originally posted by contramundi
the being fixed 6 months ago, i don't think that was actually the case, i downloaded the latest version from wowace a month ago or so, and it gave me that stack overflow error, thats the reason i had to switch back to a much older version, which thank god i still had.

gonna try that linked version of yours, and ofcourse this one as soon as the expansion goes live

Greetz,

CM
I can assure you the stack overflow was fixed 6 months ago!, as I've been using the latest version since then. The issue in MBB was fixed, which appeared after a patch, but still appears if you have another addon with an old Ace2 embedded library.

You need to make sure that ALL your embedded Ace Libraries are the same version. Its no use having say addon X with an embedded AceAddon-2.0 (r12345) and addon Y having AceAddon-2.0 (r23456) embedded. As addon Y will perhaps need the new features in the latest version.

When wow loads it will only load one version of AceAddon-2.0 if it loads the old version first addon Y could crash.

Note I am using AceAddon-2.0 as an example only the exact same applies to ALL embedded libraries you MUST ensure that EVERY embedded library is the same version.
Last edited by Pericles : 10-03-08 at 07:21 AM.
Pericles is offline Report comment to moderator  
Reply With Quote
Unread 10-04-08, 11:11 AM  
Pericles
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 33
Uploads: 3
Originally posted by Pericles
It should be movable by clicking on the button and dragging it around the minimap. Beta is down at present so I can't test this but it works fine with the live version so I am assuming it still works to drag the button on beta.
Confirmed the button can be dragged if you don't like its default position. Confirmed on beta build 9028.
Pericles is offline Report comment to moderator  
Reply With Quote
Unread 10-07-08, 01:42 PM  
contramundi
A Chromatic Dragonspawn
 
contramundi's Avatar
AddOn Compiler - Click to view compilations

Forum posts: 178
File comments: 78
Uploads: 2
for now, i just stick to the old working MBB i got in the live realms

however i have to admit that as soon as 3.0 goes live i already have my UI built on the PTR (including this addon) so when patch goes live, i only need to copy my UI folder from there to my default client and i'm fixed

edit: about the remark, totally nevermind, complete noob here at the moment, way too tired of modifying an UI to work with 3.0 and 2.4.x that i looked at the wrong button, it wasn't MBB which was moving, it was bugsack so totally never mind this noob

Greetz,

CM
Last edited by contramundi : 10-08-08 at 11:58 AM.
contramundi is offline Report comment to moderator  
Reply With Quote
Unread 10-16-08, 09:27 PM  
Phoul
A Kobold Labourer

Forum posts: 0
File comments: 14
Uploads: 0
The stack overflow bug was fixed on live at least 6 months ago. Get the version that works on live from http://files.wowace.com/MBB/MBB.zip the version on this site is WotLK only.

It is of course possible the reason you get an issue is you pulled a version with embedded libraries from a site other than wowace.com. Bad idea. Ace embedded libraries save a lot of coding but you must ensure you keep them at the same version. Having multiple copies of the same library all at different versions is a recipe for disaster.
This resolution worked nicely once a minor .toc update was done.

Thank you!

-- P
Last edited by Phoul : 10-16-08 at 09:41 PM.
Phoul is offline Report comment to moderator  
Reply With Quote
Unread 10-21-08, 12:24 AM  
Nefz
A Kobold Labourer

Forum posts: 0
File comments: 13
Uploads: 0
I've recently upgraded MBB to v6.0 and i've been getting stack overflow errors..

I see that some of the users dont seem to have any problems but I dont know whats causing mine..

Addons i'm using:


Error i keep getting:


Its frustrating since I cant collapse the buttons or even absent-mindedly slide the cursor over the buttons, the error pops up

-edit-
this is on live server patch 3.0.2
Last edited by Nefz : 10-21-08 at 12:29 AM.
Nefz is offline Report comment to moderator  
Reply With Quote
Unread 10-22-08, 04:44 AM  
Prismatech
A Deviate Faerie Dragon
 
Prismatech's Avatar

Forum posts: 10
File comments: 44
Uploads: 0
hi nefz
I see that you have not the standalone ace addon in the dir .
At the moment use a ace addon the buildin version but most are this versions older .install tip install ace 2 and 3 from ace as standallone that over write the buildin while standalone have higher prio.
__________________
Prismatech is offline Report comment to moderator  
Reply With Quote
Unread 10-23-08, 03:32 PM  
Zwerg
A Murloc Raider

Forum posts: 4
File comments: 15
Uploads: 0
Hi,

there's problem with another addon:

When i activate the MBB, an addon called Dagassist ( Curse link, wowint link ) is not working. I get this error when clicking on the Dagassist icon:
Interface\FrameXML\RestrictedExecution.lua:758:
Cannot declare closure factories from insecure code
Without MBB the addon works nice!

I don't know which addon causes the problem. I will post this error on the Dagassist page aswell.

Thx for your great work!

Greets
Zwerg is offline Report comment to moderator  
Reply With Quote
Unread 10-27-08, 10:16 AM  
teffsi
A Kobold Labourer

Forum posts: 0
File comments: 1
Uploads: 0
Originally posted by Zwerg
Hi,

there's problem with another addon:

When i activate the MBB, an addon called Dagassist ( Curse link, wowint link ) is not working. I get this error when clicking on the Dagassist icon:

Without MBB the addon works nice!

I don't know which addon causes the problem. I will post this error on the Dagassist page aswell.

Thx for your great work!

Greets
I am having the exact same problem, I have had to disable MBB for now as I really need DagAssist as a mage. Sadly this means my mini map is a mess
teffsi is offline Report comment to moderator  
Reply With Quote
Unread 10-29-08, 01:10 PM  
Nefz
A Kobold Labourer

Forum posts: 0
File comments: 13
Uploads: 0
Originally posted by Prismatech
hi nefz
I see that you have not the standalone ace addon in the dir .
At the moment use a ace addon the buildin version but most are this versions older .install tip install ace 2 and 3 from ace as standallone that over write the buildin while standalone have higher prio.
thanks for the reply Prismatech.
I've already installed ace2 and 3 but the same MBB error still occurs
Nefz is offline Report comment to moderator  
Reply With Quote
Unread 10-30-08, 07:25 PM  
woowoowoo
A Kobold Labourer
AddOn Compiler - Click to view compilations

Forum posts: 0
File comments: 27
Uploads: 1
Love the mod, been getting an error though.

MBB blocked from using LFGQuery()
Count: 4

Call Stack:
[C]: in function `LFGQuery'
Interface\FrameXML\LFGFrame.lua:478: in function `SendLFGQuery'
Interface\FrameXML\LFGFrame.lua:28: in function `LFGParentFrame_OnEvent'
[string "*:OnEvent"]:1: in function <[string "*:OnEvent"]:1>
woowoowoo is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: