Download
(23 Kb)
Download
Updated: 09-20-13 10:27 PM
Pictures
File Info
Compatibility:
Siege of Orgrimmar (5.4)
Escalation (5.3)
Thunder Isle (5.2)
Landfall (5.1)
Mists of Pandaria (5.0.4)
Updated:09-20-13 10:27 PM
Created:unknown
Downloads:122,241
Favorites:508
MD5:
5.4
Cellular  Popular! (More than 5000 hits)
Version: 5.4.001
by: totalpackage [More]
Cellular is an instant messenger mod (for only whispers) based on the functionality of an old version of ForgottenChat.

YouTube Intro



Features:
  • Many appearance options
  • History log
  • A way to copy text
  • Reuse of the default chat editbox
  • Whispers shown in separate windows or a tab-based single window
  • Should work with most spam filter mods
  • ...and other basic IM features


How to Use:
  • "/cellular", check Interface Options->AddOns, or right-click a window for options
  • Left-click a window to toggle the editbox
  • Left-click a tab to activate it
  • Shift-left-click and drag a window to move
  • Shift-left-click and drag bottom-right corner to resize
  • Right-click a tab for show/close/options dropdown
  • Middle-click a tab to close
  • Hold ctrl and close any window/tab to quick remove from history
  • Several convenient buttons (some require shift clicking for confirmation reasons)


Warnings:
  • If you have history enabled and notice that Cellular is using a lot of memory, you should cleanup your history entries using Cellular's history options.
  • If you're experiencing crashing due to memory errors, disable and clear your history.
  • If you cherish your history, you can back up the saved variables file and then delete it. You can view it in any text editor later. The location of the saved variables file is here:
    ...\WTF\Account\<Account Name>\<Server Name>\<Character Name>\SavedVariables\Cellular.lua
5.4.001 09/21/2013 - updated for 5.4 (BN fix attempt)
5.3.001 06/05/2013 - updated for 5.3
5.2.001 03/10/2013 - updated for 5.2
5.1.001 12/08/2012 - updated for 5.1
5.0.003 09/24/2012 - another possible fix for reply
5.0.002 09/18/2012 - possible battle.net fix
5.0.001 09/04/2012:
- updated for 5.0.4
- added option to disable handling of battle.net messages

4.3.001 11/29/2011:
- update for 4.3
- fixed the "Disable EditBox Move" option

4.2.001 06/29/2011 - update for 4.2
4.1.001 04/26/2011 - update for 4.1

4.0.003 12/05/2010:
- handle Real ID whispers better
- probably fix crashes this time
- clean up drop down menus

4.0.002a 11/17/2010 - library update, may fix crashes
4.0.002 10/24/2010 - fix reply binding, nothing else
4.0.001 10/18/2010 - toc to 4.0

3.3.006 06/23/2010:
- battle.net Read ID support for 3.3.5 (whispers only)
- fix reply keybind and stack error

3.3.003 03/14/2010:
- reduced the occurrence of the memory usage warning
- fix Prat sound support

3.3.002a 12/09/2009:
- added option to disable moving the default editbox
- attempt to not move editbox if whisperer's box isn't shown
- no longer handle GM whispers

3.3.001 12/08/2009:
- updated toc for 3.3
- added tabbing support to switch between windows/tabs
- added alert for when history memory gets high
- reformatted timestamps to 12 hour format
- added option to reset positions

3.2.003 09/04/2009:
- added cheap support for ConfigMode
- fix some name coloring issues, again

3.2.002 08/13/2009 - make class coloring work after switching tabs and minimizing

3.2.001 08/04/2009 - toc to 3.2

3.1.004 07/24/2009:
- support for 3.2 class coloring names
- use global strings for some of the buttons

3.1.003 05/22/2009 - give chat windows a name so people can reference them

3.1.002 04/22/2009:
- added checks to make sure other mods don't break Cellular
- removed window appearing before any whispers are exchanged

3.1.001 04/14/2009:
- updated for 3.1
- removed 3.0/3.1 compat
Archived Files (16)
File Name
Version
Size
Author
Date
5.3.001
23kB
totalpackage
06-05-13 09:26 PM
5.2.001
23kB
totalpackage
03-10-13 04:57 PM
5.1.001
23kB
totalpackage
12-08-12 07:29 AM
5.0.003
23kB
totalpackage
09-24-12 08:12 PM
5.0.003
23kB
totalpackage
09-24-12 08:12 PM
4.3.001
22kB
totalpackage
11-29-11 10:42 PM
4.2.001
22kB
totalpackage
06-29-11 08:06 PM
4.1.001
22kB
totalpackage
04-26-11 06:22 PM
4.0.003
22kB
totalpackage
12-04-10 08:44 PM
3.3.006
22kB
totalpackage
06-23-10 02:32 PM
3.3.005
22kB
totalpackage
06-23-10 04:08 AM
3.3.003
21kB
totalpackage
03-14-10 03:38 AM
3.3.002a
21kB
totalpackage
12-09-09 07:10 AM
3.2.003
21kB
totalpackage
09-04-09 04:43 AM
3.1.004
21kB
totalpackage
07-24-09 05:23 AM
3.0.014
21kB
totalpackage
04-06-09 01:03 AM


Post A Reply Comment Options
Old 10-02-12, 01:22 PM  
Rosalyne
A Defias Bandit

Forum posts: 3
File comments: 50
Uploads: 0
I can definitely re-produce at will, it happens everytime I receive a whisper. And it's not just b.net friends, it happens with guildies and random people as well. Additionally, with R bound to chat reply, R never works and when it is bound to re-whisper, it won't work for responding to the first message received, but if I click the person's name and respond, pressing R on subsequent replies works. I'm sort of confusing myself here, so I apologize if I am not very clear.

I am using ElvUI which does modify chat, so it may very well be the issue. The author of that isn't super helpful if you're using an addon that isn't part of ElvUI though, so I'd like to confirm it's an Elv problem before going to him.

I'm not sure which settings are relevant, but I think the only changes I have made from the default settings are to enable "use tabs" and "editbox top anchor". If you need to know about anything else, let me know!

I don't have a ton of friends to test with either. Since you're so kindly willing to troubleshoot with me though, I could message you my battletag if you need assistance testing.

Originally Posted by Karnmak
Originally Posted by Rosalyne
So this didn't fix the issue. Just received a whisper from a b.net friend and R worked to respond to the initial whisper and then stopped working. Went back to having R bound to "re-whisper" and it works.
I'd need more information to help track down the issue. So far I've been unable to reproduce it. Can you reproduce this error at will? What other addons (especially chat related addons) are you using? Does it only impact bnet whispers, or any form of replies? What settings are you using for cellular?

I'm not a very cool person though, so I don't have many friends to test replying to messages.

On another note; is anyone else still having issues? Mine has been working like a charm, but I do not use Prat.

-Karnmak
Rosalyne is offline Report comment to moderator  
Reply With Quote
Old 09-28-12, 04:03 PM  
Karnmak
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 7
Uploads: 1
Originally Posted by Rosalyne
So this didn't fix the issue. Just received a whisper from a b.net friend and R worked to respond to the initial whisper and then stopped working. Went back to having R bound to "re-whisper" and it works.
I'd need more information to help track down the issue. So far I've been unable to reproduce it. Can you reproduce this error at will? What other addons (especially chat related addons) are you using? Does it only impact bnet whispers, or any form of replies? What settings are you using for cellular?

I'm not a very cool person though, so I don't have many friends to test replying to messages.

On another note; is anyone else still having issues? Mine has been working like a charm, but I do not use Prat.

-Karnmak
Karnmak is offline Report comment to moderator  
Reply With Quote
Old 09-24-12, 12:16 PM  
Rosalyne
A Defias Bandit

Forum posts: 3
File comments: 50
Uploads: 0
Originally Posted by Rosalyne
Originally Posted by Karnmak
Originally Posted by Rosalyne
So I was still having the issue with R not working to respond to messages, even with the B.net fix. I went into WoW's keybindings menu and R was bound to "chat reply", I bound R to "re-whisper" instead and it seems to be working as it should now. I have no idea what caused this, because with R being bound to "chat reply", it worked fine with WIM and the default UI (eww) but not Cellular. But anyway, so far so good!
Hey there, I'm going to guess you have "Disable Editbox Move" checked under Options>Behavior, right? If that's the case, this issue is due to what looks to be recent changes between handling whispers and bnet responses. In this particular case, line 330 of core.lua is hard-coded to reply via whisper, which does not work with bnet now. If you are not fluent in LUA, I'd recommend waiting until the author can fix the issue and release an update. That being said...
Nope. Disable Editbox Move is not enabled for me. However, I made the lua changes you noted and will switch my keybinds back to how they should be and see if that fixes the problem. Thank you so much for providing assistance!
So this didn't fix the issue. Just received a whisper from a b.net friend and R worked to respond to the initial whisper and then stopped working. Went back to having R bound to "re-whisper" and it works.
Rosalyne is offline Report comment to moderator  
Reply With Quote
Old 09-23-12, 10:10 PM  
totalpackage
A Fallenroot Satyr
 
totalpackage's Avatar
AddOn Author - Click to view AddOns

Forum posts: 21
File comments: 870
Uploads: 2
Another bug appeared. I'll bust my butt to get it updated before MoP.
totalpackage is offline Report comment to moderator  
Reply With Quote
Old 09-22-12, 11:48 AM  
totalpackage
A Fallenroot Satyr
 
totalpackage's Avatar
AddOn Author - Click to view AddOns

Forum posts: 21
File comments: 870
Uploads: 2
Thanks for troubleshooting that issue. I will apply it and upload a release tomorrow night.
totalpackage is offline Report comment to moderator  
Reply With Quote
Old 09-22-12, 11:28 AM  
Rosalyne
A Defias Bandit

Forum posts: 3
File comments: 50
Uploads: 0
Originally Posted by Karnmak
Originally Posted by Rosalyne
So I was still having the issue with R not working to respond to messages, even with the B.net fix. I went into WoW's keybindings menu and R was bound to "chat reply", I bound R to "re-whisper" instead and it seems to be working as it should now. I have no idea what caused this, because with R being bound to "chat reply", it worked fine with WIM and the default UI (eww) but not Cellular. But anyway, so far so good!
Hey there, I'm going to guess you have "Disable Editbox Move" checked under Options>Behavior, right? If that's the case, this issue is due to what looks to be recent changes between handling whispers and bnet responses. In this particular case, line 330 of core.lua is hard-coded to reply via whisper, which does not work with bnet now. If you are not fluent in LUA, I'd recommend waiting until the author can fix the issue and release an update. That being said...
Nope. Disable Editbox Move is not enabled for me. However, I made the lua changes you noted and will switch my keybinds back to how they should be and see if that fixes the problem. Thank you so much for providing assistance!
Rosalyne is offline Report comment to moderator  
Reply With Quote
Old 09-21-12, 07:44 AM  
Aisenfaire
A Murloc Raider

Forum posts: 4
File comments: 275
Uploads: 0
Originally Posted by Karnmak
Line 330 should look like something like this right now:
Code:
editBox:SetAttribute("chatType", "WHISPER");

What looks to be the proper fix for this issue is to replace the block of code on lines 330 to 335 with the following:
Code:
local lastTell, lastTellType = ChatEdit_GetLastTellTarget();
if ( lastTell ) then
	editBox:SetAttribute("chatType", lastTellType);
	editBox:SetAttribute("tellTarget", tab.name)
	ChatEdit_UpdateHeader(editBox)
	if editBox ~= ChatEdit_GetActiveWindow() then
		ChatFrame_OpenChat("")
	end
end
Hello, thank you for your fix! I am trying it out right now and it appears to be working! Will report back if anything unexpected happens later on.
Aisenfaire is offline Report comment to moderator  
Reply With Quote
Old 09-20-12, 06:36 PM  
Karnmak
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 7
Uploads: 1
Re: Re: Re: Re: editbox errors

Originally Posted by AmiYuy
Since it seems nothing other than date update has happened, I'm assuming nothing has changed in Cellular and it's very low priority for Prat's author (and apparently Cellular's too), but it is extremely frustrating for those who love using both. This was the most frustrating experience I've ever had with an addon author basically telling us too bad for people using both and doing nothing about it.

There is a workaround, but you lose part of Prat's functionality to make it work and if you've moved your editbox, it'll be going back to the default location. Even if you're not using Prat you still can't use the "Disable Editbox Move" checkbox as once it's checked the trouble variable is created. If you go to the next page of comments and find the one made by me on 01-05-2011, 05:45 AM there's a full explanation, but here's the summary:

- "Disable EditBox Move" module of Cellular is breaking responding to tells.
- If the "noattach" variable is deleted from the Cellular.lua Saved Variables, it will work fine.
- Unless you have the "Editbox" module of Prat enabled as well, however the error seems to lie in Cellular.

To make it work without Prat:
1) Don't ever touch the "Disable EditBox Move" option
2) Delete the "noattach" variable from the Cellular.lua

So to make it work with Prat:
1) Disable "Disable EditBox Move" if it is enabled
2) Delete the "noattach" variable from the Cellular.lua
3) Disable the "Editbox" module from Prat.
I don't use Prat so I really can't test this issue, but I'd like for you guys to try the code I posted in my post below. If it still persists, let me know, and I will install Prat.

Basically, as I stated, the reason people are unable to respond to tells when using "Disable Editbox Move" and Cellular, is because it hooks the ChatFrame_ReplyTell(), but hard-codes the chatType to WHISPER, instead of checking whether it should be WHISPER or BN_WHISPER.

-Karnmak
Last edited by Karnmak : 09-20-12 at 07:32 PM.
Karnmak is offline Report comment to moderator  
Reply With Quote
Old 09-20-12, 05:04 PM  
Karnmak
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 7
Uploads: 1
Originally Posted by Rosalyne
So I was still having the issue with R not working to respond to messages, even with the B.net fix. I went into WoW's keybindings menu and R was bound to "chat reply", I bound R to "re-whisper" instead and it seems to be working as it should now. I have no idea what caused this, because with R being bound to "chat reply", it worked fine with WIM and the default UI (eww) but not Cellular. But anyway, so far so good!
Hey there, I'm going to guess you have "Disable Editbox Move" checked under Options>Behavior, right? If that's the case, this issue is due to what looks to be recent changes between handling whispers and bnet responses. In this particular case, line 330 of core.lua is hard-coded to reply via whisper, which does not work with bnet now. If you are not fluent in LUA, I'd recommend waiting until the author can fix the issue and release an update. That being said...

Line 330 should look like something like this right now:
Code:
editBox:SetAttribute("chatType", "WHISPER");

What looks to be the proper fix for this issue is to replace the block of code on lines 330 to 335 with the following:
Code:
local lastTell, lastTellType = ChatEdit_GetLastTellTarget();
if ( lastTell ) then
	editBox:SetAttribute("chatType", lastTellType);
	editBox:SetAttribute("tellTarget", tab.name)
	ChatEdit_UpdateHeader(editBox)
	if editBox ~= ChatEdit_GetActiveWindow() then
		ChatFrame_OpenChat("")
	end
end
The reason switching to re-whisper probably worked is because Cellular only appears to hook the "ChatFrame_ReplyTell()" function, not "ChatFrame_ReplyTell2()", which impacts re-whispering.

I apologize for the verbose answer, but that's just how I am wired. If you run into further issues, please reply back with more details!

-Karnmak
Last edited by Karnmak : 09-20-12 at 07:35 PM.
Karnmak is offline Report comment to moderator  
Reply With Quote
Old 09-20-12, 12:53 PM  
Rosalyne
A Defias Bandit

Forum posts: 3
File comments: 50
Uploads: 0
So I was still having the issue with R not working to respond to messages, even with the B.net fix. I went into WoW's keybindings menu and R was bound to "chat reply", I bound R to "re-whisper" instead and it seems to be working as it should now. I have no idea what caused this, because with R being bound to "chat reply", it worked fine with WIM and the default UI (eww) but not Cellular. But anyway, so far so good!
Rosalyne is offline Report comment to moderator  
Reply With Quote
Old 09-20-12, 05:09 AM  
thw24
A Kobold Labourer

Forum posts: 0
File comments: 6
Uploads: 0
I'm quite sure it's been mentioned before:

Delete all your cellular.lua files, both in your char and account folder (WTF)!

After that all the errors and problems were gone.

For me it's the best chat addon out there, THANKS totalpackage!
Last edited by thw24 : 09-20-12 at 10:17 AM.
thw24 is offline Report comment to moderator  
Reply With Quote
Old 09-19-12, 05:38 PM  
altelulex
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 8
Uploads: 1
For me it works perfectly. About 40 Addons running and no conflict and i can response and whisper to all of my friends (and enemies of course) .... BIG thanks to all who helped fix it ... there is no better addon to whisper.

mfg altelulex
altelulex is offline Report comment to moderator  
Reply With Quote
Old 09-19-12, 12:46 PM  
Linayo
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 6
File comments: 54
Uploads: 2
hey there, was wondering will you try to work for a fix with the editbox/prat? mentioned 2-3 pages earlier with some work around but can't be a perma solution imo
Linayo is offline Report comment to moderator  
Reply With Quote
Old 09-18-12, 11:20 PM  
DrCox
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
Re: BNet/RealID ~fix~

Karnmak you sir are a champion! i hate wow without cellular! this made my whole damn night, thx again to the creator of the addon
DrCox is offline Report comment to moderator  
Reply With Quote
Old 09-18-12, 09:07 PM  
totalpackage
A Fallenroot Satyr
 
totalpackage's Avatar
AddOn Author - Click to view AddOns

Forum posts: 21
File comments: 870
Uploads: 2
Re: BNet/RealID ~fix~

Originally Posted by Karnmak
Originally Posted by tallulahkat
Just wondering if there will be an update for the real id bug issue we are all seeing
If you're referring to the error, "no player named <realid friend>", or whatever, I think I have the answer to your problems if you don't mind editing the file yourself.

Open core.lua in the Cellular folder (.\Interface\AddOns\Cellular\core.lua), and line 302 should look something like:
Code:
local sw = _G.SLASH_WHISPER1.." "
Change it so it looks like this:
Code:
local sw = _G.SLASH_SMART_WHISPER1.." "
You can edit the file while WoW is open, then just /reload the UI. If you still have problems afterwards, let me know.

-Karnmak
I'll implement this and release the update today. I cannot test. It would suck if that was the solution, but you'll be awesome for finding it!
totalpackage is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.