Download
(5 Kb)
Download
Updated: 11-14-08 03:42 PM
Pictures
File Info
Updated:11-14-08 03:42 PM
Created:unknown
Downloads:14,954
Favorites:26
MD5:
rBars2  Popular! (More than 5000 hits)
Version: 008
by: zork [More]

Info

rBars2 is outdated. Please use:

rActionBarStyler
008
- vehicle and deathknight fixes

007
- stuff for rothui081027

006
- petbar cannot be casted in combat, but will show after
- changes for rothui081026

005
- pet bar now styled
- shapeshift bar now styled
- fixed bug with rogue shapeshift position

004
- config for bar layout
- config for shapeshift
- fixed bug for self:Alpha

003
- fixed stuff
- config for textures, scale and alpha at the top of the lua-file

002
- more comments and some bugfixes. check googlecode for diffs.

001
- initial release
Optional Files (0)


Post A Reply Comment Options
Unread 10-21-08, 10:03 AM  
AnElk
A Kobold Labourer
 
AnElk's Avatar

Forum posts: 0
File comments: 49
Uploads: 0
Re: Re: squares and spaces...

[i]
5) There are alot mods out there, just use Dominos its awesome and has a GUI. [/b]
I found the rtexture thingy and now the strange look is gone.
It's a pity spacing is not available nor the keybindings visible but I did use Dominos for some time and the problem with that one as well s FuBar and others is that one has to completely redo everything, then when Blizzard makes a patch, like they do fairly often, everything is wiped out unfotunately, even what functions are set in what actionbars. This is why I gave up Dominos, Bongos, FuBar and others. I got tired of the painful process of redoing every single actionbutton on three level 70's and then some alts that also uses maximum numbers of actionbars LOL...

Oh well. I suppose I can make do without the visible key bindings for now but seeing as rBars2 uses blizzards original code, it shouldn't be so hard to make the bindings visible just like the original actionbars?

I use a temporary sollution to the huge gaps/spaces that isn't entirely satisfactory but will suffice for now.
Another matter I was wondering about was the positioning oc the actionbars.
I read the lua file comments and from what I understand, it should be possible to switch places on actionbars as they sit in their own "dock" ?

When I'm not working 10 hours a day, 6 days a week I might piddle around in the lua to see if I can figure out how to move them lower at least. The vertical spacing is more annoying of it and my main concern.

Thank you for the quick reply.

Da voodoo be wid ya mon.
AnElk is offline Report comment to moderator  
Reply With Quote
Unread 10-21-08, 03:08 PM  
zoulnix
A Defias Bandit

Forum posts: 3
File comments: 3
Uploads: 0
<event>ADDON_ACTION_BLOCKED:AddOn 'rBars2' tried to call the protected function 'PetActionButton6:Hide()'.\n<in C code>: in function `Hide'\nInterface\\FrameXML\\PetActionBarFrame.lua:137: in function `PetActionBar_Update':\nInterface\\FrameXML\\PetActionBarFrame.lua:50: in function `PetActionBar_OnEvent':\n<string>:\"*:OnEvent\":1: in function <[string \"*:OnEvent\"]:1>\n\n ---

<event>ADDON_ACTION_BLOCKED:AddOn 'rBars2' tried to call the protected function 'PetActionBarFrame:Show()'.\n<in C code>: in function `Show'\nInterface\\FrameXML\\PetActionBarFrame.lua:188: in function `ShowPetActionBar':\nInterface\\FrameXML\\PetActionBarFrame.lua:40: in function `PetActionBar_OnEvent':\n<string>:\"*:OnEvent\":1: in function <[string \"*:OnEvent\"]:1>\n\n ---
pet bar disappears, got some more errors than this,
i u want the rest of the log i can put up a link to it.
zoulnix is offline Report comment to moderator  
Reply With Quote
Unread 10-21-08, 03:48 PM  
zork
A Pyroguard Emberseer
 
zork's Avatar
AddOn Author - Click to view AddOns

Forum posts: 1343
File comments: 3311
Uploads: 86
Originally posted by Zoulnix
pet bar disappears, got some more errors than this,
i u want the rest of the log i can put up a link to it.
combat and securetemplates make this happen. you have no chance to avoid this.

I fixed it to not do anything while in combat, thus the petbar will return if you get out of combat, but when you cast a pet in combat...bad time thats not doable.
__________________
| Simple is beautiful.
| Roth UI | Roth UI FAQ | GoogleCode | Zork | TDMOG

"I wonder what the non-pathetic people are doing tonight?" - Rajesh Koothrappali (The Big Bang Theory)
Last edited by zork : 10-23-08 at 01:53 PM.
zork is offline Report comment to moderator  
Reply With Quote
Unread 10-25-08, 06:32 PM  
AnElk
A Kobold Labourer
 
AnElk's Avatar

Forum posts: 0
File comments: 49
Uploads: 0
petbar background...

For some odd reason, my hunter has a clean screen with pet up, but warlock does not. On warlock, with the demon up, the petbar background is showing just like it did before installing rTextures. And these two characters are on same account. Oddity or are things actually saved separately between characters?
AnElk is offline Report comment to moderator  
Reply With Quote
Unread 10-27-08, 12:44 AM  
Blindlabel
A Kobold Labourer

Forum posts: 0
File comments: 23
Uploads: 0
Itemrack

If you use Itemrack and bind your sets it will make the keybindings continue to show after reloading. I imagine this is because Itemrack reports the keybinding everytime.


PS: Awesome work once again!
Blindlabel is offline Report comment to moderator  
Reply With Quote
Unread 10-27-08, 01:19 AM  
AnElk
A Kobold Labourer
 
AnElk's Avatar

Forum posts: 0
File comments: 49
Uploads: 0
Re: petbar background...

Originally posted by AnElk
For some odd reason, my hunter has a clean screen with pet up, but warlock does not. On warlock, with the demon up, the petbar background is showing just like it did before installing rTextures. And these two characters are on same account. Oddity or are things actually saved separately between characters?
After some testing and piddling around, it appears that the petbar gets messed up if the settings for "Options - Interface - Actionbars" has the 'lower left' actionbar turned off. I had these set different on my hunter and warlock and as I changed the lower left actionbar to be active on warlock as well, the petbar suddenly showed up where I expected it to and without the ugly background squares to the far left and below to make it worse.
It still has the issue with dissappearing every once in a while, not only while in combat, but also going on and off a mount seems to cause the petbar to simply vanish.

This was found out with the 005 version of rBars2. I'm just now DLing the 006 version to see if it is more stable.


I have not yet found a working version of ItemRack... If you know where to find one, I'd like to know. I really miss that addon. Outfitter is not as good.
Last edited by AnElk : 10-27-08 at 01:22 AM.
AnElk is offline Report comment to moderator  
Reply With Quote
Unread 10-27-08, 02:21 AM  
AnElk
A Kobold Labourer
 
AnElk's Avatar

Forum posts: 0
File comments: 49
Uploads: 0
version 006 ...

... does not work at all...

I get lua error :232: unexpected symbol... every time.

reverting to 005...
AnElk is offline Report comment to moderator  
Reply With Quote
Unread 10-27-08, 02:42 AM  
zork
A Pyroguard Emberseer
 
zork's Avatar
AddOn Author - Click to view AddOns

Forum posts: 1343
File comments: 3311
Uploads: 86
Re: version 006 ...

Originally posted by AnElk
... does not work at all...
I get lua error :232: unexpected symbol... every time.
reverting to 005...
Screenshot please.

Does this still happen when rBars2 is the only active addon (to make sure this error comes from rBars2 only). Its interesting since I tested it with nearly every char without any problems.
__________________
| Simple is beautiful.
| Roth UI | Roth UI FAQ | GoogleCode | Zork | TDMOG

"I wonder what the non-pathetic people are doing tonight?" - Rajesh Koothrappali (The Big Bang Theory)
Last edited by zork : 10-27-08 at 03:09 AM.
zork is offline Report comment to moderator  
Reply With Quote
Unread 10-29-08, 01:18 PM  
AnElk
A Kobold Labourer
 
AnElk's Avatar

Forum posts: 0
File comments: 49
Uploads: 0
007

I have not yet had time to test that. But as I was looking here, I saw version 007 and it seems to be working fine. I don't have much playtime during the week to test stuff but now the petbar at least comes back up after resurrecting a dead pet and mounting, dismounting.
Haven't had a chance to try version 007 on warlock yet but the hunter seems to be OK. Thanks for looking into it.
AnElk is offline Report comment to moderator  
Reply With Quote
Unread 10-29-08, 11:57 PM  
ken kao
A Kobold Labourer

Forum posts: 0
File comments: 32
Uploads: 0
Smile Is there a chinese version?

The nameplates of target and target of target are "level ??" now. ==> It can not show Chinese. Some players ask "Is there a Chinese version now?"
ken kao is offline Report comment to moderator  
Reply With Quote
Unread 10-30-08, 06:22 PM  
AnElk
A Kobold Labourer
 
AnElk's Avatar

Forum posts: 0
File comments: 49
Uploads: 0
rbars.lua error 231.

*** Major edit ***

I was completely wrong about the druid form... In fact, what I had done was change that one single variable that changes the actionbar from a 2x6 style to a 1x12.
No character works with the 1x12 setting any more. I changed it back to 2x6 and rBars2 work again. Something is broken with the code there it seems.

This works...

--button system for bar 1 and bar 2
-- 0 = 1x12 layout
-- 1 = 2x6 layout
local button_system = 1


But when I change it to:

--button system for bar 1 and bar 2
-- 0 = 1x12 layout
-- 1 = 2x6 layout
local button_system = 0


The result becomes the same on all characters:

Interface\addons\rBars2\rBars2.lua:231: unexpected symbol

I would insert a screenshot of it but this website does not allow attachments to posts, only http links and I don't have a website to put it on. lol
Last edited by AnElk : 10-31-08 at 12:42 AM.
AnElk is offline Report comment to moderator  
Reply With Quote
Unread 10-31-08, 02:49 AM  
zork
A Pyroguard Emberseer
 
zork's Avatar
AddOn Author - Click to view AddOns

Forum posts: 1343
File comments: 3311
Uploads: 86
Re: rbars.lua error 231.

Originally posted by AnElk
Interface\addons\rBars2\rBars2.lua:231: unexpected symbol
Thx for reporting, I will look into it.

Edited: Checked it and it worked without any problems. Strange, please deactivate every other mod to make sure its rBars2. I don't get this problem.
__________________
| Simple is beautiful.
| Roth UI | Roth UI FAQ | GoogleCode | Zork | TDMOG

"I wonder what the non-pathetic people are doing tonight?" - Rajesh Koothrappali (The Big Bang Theory)
Last edited by zork : 10-31-08 at 03:15 PM.
zork is offline Report comment to moderator  
Reply With Quote
Unread 11-04-08, 03:43 AM  
Wimpface
A Molten Giant
 
Wimpface's Avatar
AddOn Author - Click to view AddOns

Forum posts: 631
File comments: 263
Uploads: 23
Hi again lol... I followed your lead on the MultiBarBottomRight1 and now i'm a bit curious, does it anchor to ActionButton1?

Code:
    ActionButton1:ClearAllPoints()
    ActionButton1:SetPoint("BOTTOMLEFT",f,"BOTTOMLEFT",0,0);    

    --need to do this since I reanchored the bonusactionbar to f
    BonusActionBarTexture0:Hide()
    BonusActionBarTexture1:Hide()
    
    BonusActionButton1:ClearAllPoints()
    BonusActionButton1:SetPoint("BOTTOMLEFT",f,"BOTTOMLEFT",0,0);
    
    if button_system == 0 then

      MultiBarBottomLeftButton1:ClearAllPoints()  
      MultiBarBottomLeftButton1:SetPoint("BOTTOMLEFT",ActionButton1,"TOPLEFT",0,5);

      MultiBarBottomRightButton1:ClearAllPoints()  
      MultiBarBottomRightButton1:SetPoint("BOTTOMLEFT",MultiBarBottomLeftButton1,"TOPLEFT",0,15);
EDIT: Might tell you that i've tried to edit the code, but with no success... What i tried was:

Code:
MultiBarBottomRightButton1:SetPoint("BOTTOMLEFT",MultiBarBottomLeftButton1,"TOPLEFT",0,5);
Where it's 5 instead of 15... Please shed some light over this!
Last edited by Wimpface : 11-04-08 at 03:50 AM.
Wimpface is offline Report comment to moderator  
Reply With Quote
Unread 11-05-08, 07:26 PM  
simply4
A Kobold Labourer

Forum posts: 0
File comments: 1
Uploads: 0
Hmm, I think the possess bar isn't picking up your gloss textures correctly. The pet bar is, it seems, but not when you're doing an action that is "possessing" (teron ghosts, steam tonk tanks, etc).

I noticed in your code you made some comments on whether you weren't sure if the possess bar was actually a separate thing, so maybe the code to texture it was left out? It's a bit over my head.

I did make some changes to the lua, and there's a small chance I might've messed something up that's causing this, but I don't think so.
simply4 is offline Report comment to moderator  
Reply With Quote
Unread 11-06-08, 12:22 AM  
WaldoJeffers
A Molten Giant
 
WaldoJeffers's Avatar

Forum posts: 564
File comments: 61
Uploads: 0
Hello, would it be hard for a lua rookie (at best) to hide the 2 side bars till mouseover? or to go one better; toggle the 2 side bars to show on/off via a keybinding press?
__________________
I said lady, step inside my Hyundai
Last edited by WaldoJeffers : 11-06-08 at 12:25 AM.
WaldoJeffers is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: