Download
(7 MB)
Download
Updated: 03-18-09 08:19 AM
Addon for:
AlphaMap.
Pictures
File Info
Updated:03-18-09 08:19 AM
Created:01-21-09 08:49 AM
Downloads:2,657
Favorites:20
MD5:
AlphaMap Early Beta
Version: v3.54.30000.B.8
by: Telic [More]
Early Beta with Dungeon Locations moved to a separate plugin AddOn.

"_Utilities" Plugin for display of locations with Flight Masters, MailBoxes, Repair facilities on Zone maps;
And extra info on City maps of Banks / Auction Houses and Anvils/Forges....

"_TravelAgents" Plugin for displaying Flight Masters/Zeppelin Towers/Sea Ports/etc. on Continent maps - click on to see destinations.

Waypoint arrow support for Cartographer/TomTom via Right clicking on world map POIs

Fix to Carbonite support which 'tricks' other AddOns in to thinking TomTom is installed !

Update to MobMap Support + fix(es)
Update to MobMap Support (ad nauseum).
Archived Files (2)
File Name
Version
Size
Author
Date
v3.54.30000.B.7
7MB
Telic
03-08-09 04:39 AM
v3.54.30000.B.6
7MB
Telic
03-07-09 02:21 PM


Post A Reply Comment Options
Unread 01-22-09, 04:32 PM  
Telic
A Defias Bandit
 
Telic's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3
File comments: 431
Uploads: 17
Early feedback welcome ;)

All help reporting errors, or inaccurate coordinates is welcome.

Also, if I have missed out any Flight Masters, or Mail Boxes, etc., then let me know ... preferably also supplying coordinates
Last edited by Telic : 02-20-09 at 12:53 PM.
Telic is offline Report comment to moderator  
Reply With Quote
Unread 02-20-09, 04:41 PM  
Oakayam
Premium Member
 
Oakayam's Avatar
Premium Member

Forum posts: 40
File comments: 136
Uploads: 0
Heya

I use Carbonite Quest while lvling. I get following errors with AlphaMap when both mods are loaded:

When opening AlphaMap:
Code:
[2009/02/20 16:32:42-3392-x1]: AlphaMap-3.54.30000.BETA\AlphaMap.lua:3631: attempt to index field 'profile' (a nil value)
AlphaMap-3.54.30000.BETA\AlphaMap.lua:3602: in function `AlphaMapUnits_Update'
AlphaMap-3.54.30000.BETA\AlphaMap.lua:6561: in function `AM_ScaleSliderChanged'
<string>:"*:OnValueChanged":1: in function <[string "*:OnValueChanged"]:1>
<in C code>: in function `SetValue'
AlphaMap-3.54.30000.BETA\AlphaMap.lua:4840: in function `AM_SetOptionsSliders'
AlphaMap-3.54.30000.BETA\AlphaMap.lua:4799: in function `AM_SetOptions'
AlphaMap-3.54.30000.BETA\AlphaMap.lua:2369: in function `AlphaMapFrame_Update'
AlphaMap-3.54.30000.BETA\AlphaMap.lua:1431: in function `AlphaMapFrame_OnEvent'
<string>:"*:OnEvent":1: in function <[string "*:OnEvent"]:1>
<in C code>: in function `SetMapToCurrentZone'
AlphaMap-3.54.30000.BETA\AlphaMap.lua:7598: in function `AM_Showing'
<string>:"*:OnShow":1: in function <[string "*:OnShow"]:1>
<in C code>: in function `Show'
AlphaMap-3.54.30000.BETA\AlphaMap.lua:3091: in function `ToggleAlphaMap'
<string>:"TOGGLEALPHAMAP":1: in function <[string "TOGGLEALPHAMAP"]:1>

  ---
When clicking on the AlphaMap:
Code:
[2009/02/20 16:32:42-3392-x420]: AlphaMap-3.54.30000.BETA\AlphaMap.lua:3631: attempt to index field 'profile' (a nil value)
AlphaMap-3.54.30000.BETA\AlphaMap.lua:3602: in function `AlphaMapUnits_Update'
<string>:"*:OnUpdate":1: in function <[string "*:OnUpdate"]:1>

  ---
When Alt clicking on ALphaMap ( also alt click doesn't work - I can't interact with the map ):
Code:
[2009/02/20 16:32:57-3392-x5]: AlphaMap-3.54.30000.BETA\AlphaMap.lua:3631: attempt to index field 'profile' (a nil value)
AlphaMap-3.54.30000.BETA\AlphaMap.lua:3602: in function `AlphaMapUnits_Update'
AlphaMap-3.54.30000.BETA\AlphaMap.lua:7830: in function `AlphaMapButton_OnClick'
<string>:"*:OnClick":1: in function <[string "*:OnClick"]:1>

  ---
.

Thanks for all your work.
__________________
Oakayam is offline Report comment to moderator  
Reply With Quote
Unread 02-21-09, 05:46 AM  
Telic
A Defias Bandit
 
Telic's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3
File comments: 431
Uploads: 17
Mmm ?

Do you have TomTom installed also?

If yes, then what version are you using?
Perhaps, I have not kept up to date with the latest version, or your version is an old one?

If you have NOT installed TomTom separately, then it seems odd that CarboniteQuest seems to be using a version of it...
Does the author of TomTom know a version of their AddOn is used in Carbonite?

Seems a bit 'off' that Carbonite charge for their AddOn, and make efforts to obfuscate their code, while using free AddOn code harvested from other authors...
It might explain why they try to hide their own code - but its given me an incentive to decipher it

I guess its possible that they are using a global variable name of 'TomTom' which is entirely of their own design, but its not very polite to clash with an existing separate AddOn.
Or perhaps TomTom code has been 'officially' included in Carbonite, in which case my apologies for casting aspersions

I can release a double check to fix this from the AlphaMap side.
(This is a core AlphaMap issue rather than a Beta issue - the Beta testing here is really just to do with the 'AlphaMap_POI_Utilities' plugin...)
Last edited by Telic : 02-21-09 at 05:50 AM.
Telic is offline Report comment to moderator  
Reply With Quote
Unread 02-21-09, 06:07 AM  
Telic
A Defias Bandit
 
Telic's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3
File comments: 431
Uploads: 17
Carbonite & TomTom

Having read a couple of posts about TomTom on the Carbonite web site it seems that it includes its own TomTom 'emulation' functionality.

This is fine in itself, but I'm not certain its a great idea to use the same global variable names as TomTom, which can just trick other AddOns in to thinking the real version of TomTom is installed but not working....

Why people would be willing to pay a monthly fee for regurgitated software based on 6 month old versions of AddOns that have free up to date versions....s
Last edited by Telic : 02-21-09 at 06:09 AM.
Telic is offline Report comment to moderator  
Reply With Quote
Unread 02-23-09, 09:44 AM  
Telic
A Defias Bandit
 
Telic's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3
File comments: 431
Uploads: 17
WTB Feedback ;)

I can do no testing whatsoever atm - so I'd love to hear about positive feedback if there are no bugs ?

Or let me know about any bug messages you are getting - even if you think it must be so obvious the author should fix it without feedback
Last edited by Telic : 02-23-09 at 09:51 AM.
Telic is offline Report comment to moderator  
Reply With Quote
Unread 03-02-09, 02:52 PM  
naeem151287
A Flamescale Wyrmkin
 
naeem151287's Avatar
AddOn Compiler - Click to view compilations

Forum posts: 144
File comments: 13
Uploads: 1
WTS Feedback ;)

Love the new stuff in AlphaMap. Switched from Cartographer 2 entirely to AlphaMap now because of the new stuff. So far haven't encountered any errors
__________________
My Blog - Feel free to leave comments.
Last edited by naeem151287 : 03-02-09 at 04:21 PM.
naeem151287 is offline Report comment to moderator  
Reply With Quote
Unread 03-02-09, 05:36 PM  
Telic
A Defias Bandit
 
Telic's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3
File comments: 431
Uploads: 17
Re: WTS Feedback ;)

Originally posted by naeem151287
Love the new stuff in AlphaMap. Switched from Cartographer 2 entirely to AlphaMap now because of the new stuff. So far haven't encountered any errors

Thank you for the feedback
(Seriously. You have no idea how hard it is to get anyone to acknowledge a lack of errors )

I guess I'll release this version as a late Beta
(And wait for a larger group of testers to report that the sh*t has hit the fan)
Telic is offline Report comment to moderator  
Reply With Quote
Unread 03-02-09, 06:15 PM  
naeem151287
A Flamescale Wyrmkin
 
naeem151287's Avatar
AddOn Compiler - Click to view compilations

Forum posts: 144
File comments: 13
Uploads: 1
Don't worry I'll keep providing feedback whenever necessary. The new AlphaMap is a must have for me.

One thing I did notice was using MobMap with AlphaMap. When I click on the question mark in MobMap to locate any NPC or quest location, it opens the default map and not AlphaMap. I have AlphaMobMap installed but I am not sure if this is because of an issue with MobMap or AlphaMap.
__________________
My Blog - Feel free to leave comments.
naeem151287 is offline Report comment to moderator  
Reply With Quote
Unread 03-02-09, 06:57 PM  
Telic
A Defias Bandit
 
Telic's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3
File comments: 431
Uploads: 17
Originally posted by naeem151287
Don't worry I'll keep providing feedback whenever necessary. The new AlphaMap is a must have for me.

One thing I did notice was using MobMap with AlphaMap. When I click on the question mark in MobMap to locate any NPC or quest location, it opens the default map and not AlphaMap. I have AlphaMobMap installed but I am not sure if this is because of an issue with MobMap or AlphaMap.

From memory, I can't remember to what extent I wanted to intercept MobMap's WorldMap functionality...

But there have been quite a few changes to MobMap since AlphaMobMap was first released, so I may think about trying to update it... (in the next 'early' Beta - after the release of this Beta)
Last edited by Telic : 03-02-09 at 06:58 PM.
Telic is offline Report comment to moderator  
Reply With Quote
Unread 03-03-09, 04:56 AM  
Telic
A Defias Bandit
 
Telic's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3
File comments: 431
Uploads: 17
Flight Routes ?

Has anyone tested what happens when left clicking on a Flight Master ?

Are the flight paths drawn correctly ?
I have a sneaky suspicion that the lines are being drawn in the wrong place, or may behave strangely if you change the scale of the AlphaMap....

All feedback appreciated
Telic is offline Report comment to moderator  
Reply With Quote
Unread 03-05-09, 03:31 PM  
Telic
A Defias Bandit
 
Telic's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3
File comments: 431
Uploads: 17
Attempted update to MobMap support

Beta.4 should be reasonably stable apart from MobMap support which is definitley in an early-Beta state
Telic is offline Report comment to moderator  
Reply With Quote
Unread 03-05-09, 05:24 PM  
MyrddinEmbais
A Kobold Labourer
 
MyrddinEmbais's Avatar

Forum posts: 0
File comments: 14
Uploads: 0
Re: Attempted update to MobMap support

Got these 2 errors after installing Beta4:

Date: 2009-03-06 00:07:50
ID: -1
Error occured in: Global
Count: 1
Message: ..\AddOns\MobMap\MobMap.lua line 399:
attempt to concatenate local 'zonename' (a nil value)
Debug:
(tail call): ?
[C]: ?
MobMap\MobMap.lua:399:
MobMap\MobMap.lua:384
AlphaMobMap\AlphaMobMap.lua:50: MobMap_ScanTarget()
MobMap\MobMap.lua:1343: MobMapFrame_OnEvent()
[string "*:OnEvent"]:1:
[string "*:OnEvent"]:1
[C]: TurnOrActionStop()
[string "TURNORACTION"]:4:
[string "TURNORACTION"]:1

and

Date: 2009-03-06 00:03:24
ID: -2
Error occured in: Global
Count: 1
Message: ..\AddOns\AlphaMobMap\AlphaMobMap.lua line 112:
attempt to index a nil value
Debug:
(tail call): ?
[C]: ?
AlphaMobMap\AlphaMobMap.lua:112:
AlphaMobMap\AlphaMobMap.lua:110

My client locale is german and the Mobmap Version is 3.17

rgds
Myrddin
MyrddinEmbais is offline Report comment to moderator  
Reply With Quote
Unread 03-06-09, 07:43 AM  
Telic
A Defias Bandit
 
Telic's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3
File comments: 431
Uploads: 17
Re: Re: Attempted update to MobMap support

v3.54.30000.B.5
Last edited by Telic : 03-06-09 at 07:44 AM.
Telic is offline Report comment to moderator  
Reply With Quote
Unread 03-06-09, 05:38 PM  
MyrddinEmbais
A Kobold Labourer
 
MyrddinEmbais's Avatar

Forum posts: 0
File comments: 14
Uploads: 0
Re: Re: Re: Attempted update to MobMap support

Got also an error with Beta 5 and Mobmap

Code:
Date: 2009-03-07 00:31:51
ID: 1
Error occured in: Global
Count: 1
Message: ..\AddOns\AlphaMobMap\AlphaMobMap.lua line 114:
   attempt to index a nil value
Debug:
   (tail call): ?
   [C]: ?
   AlphaMobMap\AlphaMobMap.lua:114:
      AlphaMobMap\AlphaMobMap.lua:112
Thanks for your hard work
MyrddinEmbais is offline Report comment to moderator  
Reply With Quote
Unread 03-06-09, 10:21 PM  
Tenson
A Fallenroot Satyr

Forum posts: 26
File comments: 85
Uploads: 0
I have both Alphamap and Alphamap_beta installed, and when I use Alphamap, the instance modules show up fine (clicked at the addon screen), but if I just choose Alphamap_beta_instance_POI, it doesn't show up when I'm in Naxx.

But it works if I enable Alphamap_beta + Alphamap(original) instances.

Any suggestions?

Thanks for your great work.
Tenson is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: