Minion Beta! - Help us test our new AddOn updater. Get it now!
Download
(87 Kb)
Download
Updated: 01-31-09 04:33 PM
Pictures
File Info
Updated:01-31-09 04:33 PM
Created:01-31-09 04:33 PM
Downloads:1,867
Favorites:1
MD5:

eXtreme Unit Buttons v1.9 Release Candidate 8

Version: 1.9RC8
by: paladindrome [More]

Change Notes for 1.9 rc8:
---------------------------

Bug Fixes from Wowinterface:

Friendly buttons on Hostile and Hostile button on Friendly would show during the Global Cool Down.

I reordered the code back to closer to what is was in Rc6 and
this problem has gone away. The code progression is now different
from what Tay had so we need to test to verify it hasnt
caused other issues.


Strata chages to Frame causeing issues.

Added two constants with RC6 values and update the setting code.

A Use for Debuff (! in extra) was not working.
Changed use debuff code to work

Post A Reply Comment Options
Unread 02-02-09, 10:52 PM  
Cosmic Cleric
A Deviate Faerie Dragon
 
Cosmic Cleric's Avatar
AddOn Author - Click to view AddOns

Forum posts: 15
File comments: 283
Uploads: 10
Originally posted by paladindrome
Should be fixed in 1.9RC8 - I set this up as a test case:

Code:
_NoMagic,use,Heavy Frostweave Bandage,!Magic
and got it to work - if not post back and i will venture to the AH and then Asenvale ;-)


Drome
I'll let you know as soon as I can afford to buy some small venom sacs from the AH!

TY for your efforts, they are appreciated.
Cosmic Cleric is offline Report comment to moderator  
Reply With Quote
Unread 02-02-09, 06:22 PM  
paladindrome
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 140
Uploads: 4
Originally posted by Cosmic Cleric
[BI'm reposting a bug report that I had put in the previous version. Would like to get confirmation from you if this is still a problem with this new version, or if it was something you fixed already please. EDIT: Or its not a bug at all and I have the syntax incorrect!
Code:
_AntiVenom,use,Anti-Venom,!Poison
[/b]

Should be fixed in 1.9RC8 - I set this up as a test case:

Code:
_NoMagic,use,Heavy Frostweave Bandage,!Magic
and got it to work - if not post back and i will venture to the AH and then Asenvale ;-)


Drome
paladindrome is offline Report comment to moderator  
Reply With Quote
Unread 02-02-09, 02:42 AM  
Cosmic Cleric
A Deviate Faerie Dragon
 
Cosmic Cleric's Avatar
AddOn Author - Click to view AddOns

Forum posts: 15
File comments: 283
Uploads: 10
Its good to see you Drome, ty for the new version.

I'm reposting a bug report that I had put in the previous version. Would like to get confirmation from you if this is still a problem with this new version, or if it was something you fixed already please. EDIT: Or its not a bug at all and I have the syntax incorrect!

Thanks.


Hello. Have a customer button setup as such...

Code:
_AntiVenom,use,Anti-Venom,!Poison
When I get hit with a debuff (from a NPC hunter, "Ashenvale Outrunner"), I expect my button to show itself. By default its dimmed.

I get the debuff in combat, the button doesn't change/enable/show. When combat is over, and I still have the debuff (because it hasn't worn off yet), the button still stays disabled/dimmed. It never enables.

If I have the right syntax "!Poision" then I need to report this as a bug, as I would expect this to work. Reported on 1.9 RC7.
Last edited by Cosmic Cleric : 02-02-09 at 02:46 AM.
Cosmic Cleric is offline Report comment to moderator  
Reply With Quote
Unread 01-31-09, 04:35 PM  
paladindrome
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 140
Uploads: 4
1.9RC8

For my target and focus units I have buttons set up for both friendly and hostile mobs.
when my target (or focus) is friendly and I cast a spell, the hostile spells display for a second or two and then disappear.
This is not desirable This did not occur in RC6.
Duplicated this one- verified it worked differently in RC6. It looks like it is showing the button during Global Cool down -
tried a couple of different UI options and did not affect it. I reordered the code back to closetr to what is was in Rc6 and
this problem has gone away. The code progression is now different from what Tay had so we need to test to verify it hasnt
caused other issues.



Any chance we can change what layer the buttons display on BACK to what it used to be?
I keep pushing buttons when I mean to click on a trade or bank window. :/
Done - I actually created a variable that is used to set the strata. An enterprising UI person could add it to the UI
(would have to save it in TOC as well)


XUB wants it to be "aUFpartypetUnitButton#" ('aUF...' vs. 'aUFaUF...', and '...partypet...' vs. '...party...').
So, who fixes this problem? XUB, or ag_UnitFrames?
Try : Selecting agUnit Frames then selecting Custom Frames and type (copy) :

aUFaUFpartyUnitButton#pet

Into the party pet box. This looks like a bug in ag to me - if they think it is the desired behaviour we can change XUB but
I would prefer the ag maintainer to make that statement first.


When I get hit with a debuff (from a NPC hunter, "Ashenvale Outrunner"), I expect my button to show itself. By default its dimmed.
I get the debuff in combat, the button doesn't change/enable/show. When combat is over, and I still have the debuff (because it hasn't
worn off yet), the button still stays disabled/dimmed. It never enables.
If I have the right syntax "!Poision" then I need to report this as a bug, as I would expect this to work. Reported on 1.9 RC7.
I have found the problem - at least it is working for Magic. Give RC8 a try and lets see if it is ok.


Drome
paladindrome is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: