Download
(87 Kb)
Download
Updated: 01-31-09 04:33 PM
Pictures
File Info
Updated:01-31-09 04:33 PM
Created:01-31-09 04:33 PM
Downloads:1,847
Favorites:1
MD5:
eXtreme Unit Buttons v1.9 Release Candidate 8
Version: 1.9RC8
by: paladindrome [More]
Change Notes for 1.9 rc8:
---------------------------

Bug Fixes from Wowinterface:

Friendly buttons on Hostile and Hostile button on Friendly would show during the Global Cool Down.

I reordered the code back to closer to what is was in Rc6 and
this problem has gone away. The code progression is now different
from what Tay had so we need to test to verify it hasnt
caused other issues.


Strata chages to Frame causeing issues.

Added two constants with RC6 values and update the setting code.

A Use for Debuff (! in extra) was not working.
Changed use debuff code to work
Post A Reply Comment Options
Unread 03-20-09, 03:11 AM  
Cosmic Cleric
A Deviate Faerie Dragon
 
Cosmic Cleric's Avatar
AddOn Author - Click to view AddOns

Forum posts: 15
File comments: 283
Uploads: 10
Re: Re: Re: Problems in raids

Originally posted by paladindrome
On the Party vs Raid buttons still being there -

Did you try a xub /p to reset the profile?

I ask because this resets all of the buttons and -should- give you a clean slate? I have a change that does this automatically when party / raid changes - but I don't know if it will solve the problem - i have yet to reproduce it.



Drome
Interesting enough, xub /p doesn't fix the problem. It takes a /console reloadui to fix it. Tried multiple times over multiple days, xub /p doesn't work to clear the unneeded buttons. /shrug
Cosmic Cleric is offline Report comment to moderator  
Reply With Quote
Unread 03-22-09, 08:07 AM  
elvindiva
A Kobold Labourer

Forum posts: 0
File comments: 2
Uploads: 0
Resurrection and raise ally

I have been going through the old version comments looking for the answer to this but I couldn't find it. I know at one time these buttons would show up if a party member dies.

With the V1.9 the button is showing while they are alive and disappearing when they die. The player was next to me so I know it's not the range indicator.

Any ideas?
elvindiva is offline Report comment to moderator  
Reply With Quote
Unread 03-22-09, 09:24 AM  
paladindrome
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 140
Uploads: 4
Re: Resurrection and raise ally

Originally posted by elvindiva
I have been going through the old version comments looking for the answer to this but I couldn't find it. I know at one time these buttons would show up if a party member dies.
I did spend quite a bit of time looking into it - a Dead player has many more states - Besides the normal Distance / Mana requirements you also have the Ghost / Released mechanic (You can only resurrect by clicking on the corpse - not the unit frames). I will peak to see if anythng stands out.

Drome
Last edited by paladindrome : 03-22-09 at 09:24 AM.
paladindrome is offline Report comment to moderator  
Reply With Quote
Unread 03-25-09, 12:45 AM  
Pester
A Cyclonian

Forum posts: 49
File comments: 16
Uploads: 0
I realize that this may seem quite trivial, but how? do you get to enter text into the group box?.. I am only able to enter information into the Profiles box... I am using the latest release and no other add-ons are loaded.
I Make a group with one spell "heal,HolyLight,*" copy it, but there is no way to paste it into the group box, only the profile..

and should the top box already be populated?.. just curious
THanks!
Pester is offline Report comment to moderator  
Reply With Quote
Unread 03-25-09, 03:04 PM  
paladindrome
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 140
Uploads: 4
Originally posted by Pester I realize that this may seem quite trivial, but how do you get to enter text into the group box?
Sadly it is a very good question.

You have to find - just - the right spot. Once you get one line in it it is very easy but the first line can be frustrating. Try clicking where the left most part of a t would be.

and should the top box already be populated?.. just curious
The top box is entirely optional.

The basic config is:

Enter on spell in lower left box: heal,HolyLight,*
Enter one line in lower right box: normal,party,heal

Verify and Save

Configure you unit frames (default is blizzard standard)

enter the command: /xub p normal

Drome
paladindrome is offline Report comment to moderator  
Reply With Quote
Unread 04-06-09, 09:31 AM  
tayedaen
A Deviate Faerie Dragon
AddOn Author - Click to view AddOns

Forum posts: 13
File comments: 192
Uploads: 42
Re: Re: Re: Re: Problems in raids

Originally posted by Cosmic Cleric
Interesting enough, xub /p doesn't fix the problem. It takes a /console reloadui to fix it. Tried multiple times over multiple days, xub /p doesn't work to clear the unneeded buttons. /shrug
Instead of /console reloadui you could use this (because it's faster):
/XUB p <some_not_existing_profile>
/XUB p <your normal profile>

Lets say your normal profile is called 'normal'.
Then in thsi example you could write:
/XUB p c
/XUB p normal

I know this is only a workaround, but I have no time for XUB at the moment.

cu
tay
tayedaen is offline Report comment to moderator  
Reply With Quote
Unread 04-06-09, 10:23 PM  
Cosmic Cleric
A Deviate Faerie Dragon
 
Cosmic Cleric's Avatar
AddOn Author - Click to view AddOns

Forum posts: 15
File comments: 283
Uploads: 10
Question Re: Re: Re: Re: Re: Problems in raids

Originally posted by tayedaen
Instead of /console reloadui you could use this (because it's faster):
/XUB p <some_not_existing_profile>
/XUB p <your normal profile>

Lets say your normal profile is called 'normal'.
Then in thsi example you could write:
/XUB p c
/XUB p normal

I know this is only a workaround, but I have no time for XUB at the moment.

cu
tay
Would I have to actually create the 'c' profile to get this trick to work? Will XUB work if I supply a profile name that doesn't exist?
Cosmic Cleric is offline Report comment to moderator  
Reply With Quote
Unread 04-09-09, 10:35 AM  
tayedaen
A Deviate Faerie Dragon
AddOn Author - Click to view AddOns

Forum posts: 13
File comments: 192
Uploads: 42
Re: Re: Re: Re: Re: Re: Problems in raids

Originally posted by Cosmic Cleric
Would I have to actually create the 'c' profile to get this trick to work? Will XUB work if I supply a profile name that doesn't exist?
As I wrote, the profile 'c' does not need to exist.
tayedaen is offline Report comment to moderator  
Reply With Quote
Unread 04-09-09, 11:11 PM  
Cosmic Cleric
A Deviate Faerie Dragon
 
Cosmic Cleric's Avatar
AddOn Author - Click to view AddOns

Forum posts: 15
File comments: 283
Uploads: 10
Re: Re: Re: Re: Re: Re: Re: Problems in raids

Originally posted by Cosmic Cleric
Would I have to actually create the 'c' profile to get this trick to work? Will XUB work if I supply a profile name that doesn't exist?
Originally posted by tayedaen
As I wrote, the profile 'c' does not need to exist.
Apologies, didn't notice the "/XUB p <some_not_existing_profile>" statement earlier in your same post.
Last edited by Cosmic Cleric : 04-09-09 at 11:12 PM.
Cosmic Cleric is offline Report comment to moderator  
Reply With Quote
Unread 04-09-09, 11:11 PM  
Cosmic Cleric
A Deviate Faerie Dragon
 
Cosmic Cleric's Avatar
AddOn Author - Click to view AddOns

Forum posts: 15
File comments: 283
Uploads: 10
Exclamation Bug Report while in a Raid

Got a "We are here because aUnit is NOK or aFrameNo~=1" message.

I have a screenpic to show the problem, but basically it was the following info...

We are here because aUnit is NOK or aFrameNo~=1.
XUB-Error: aUnit is NOK or aFrameNo~=1.
aFrame: (RaidPullout5Button4)
aUnit: (raid22)
aDestinationUnit: (raid22)
aSpellName: (Dispell Magic)
aRank: ()
aThreshold: (0)
aExtra: (Magic)
aToolTip: (
Starts blinking when unit has these debuffs: Magic)
aExcludeUnits: ()
aWidth: (25)

This happened while in a 25 man Vault run, and I was inside the zone and people were zoning in.

I actually had two disconnects while inside Vault too so whatever XUB is freaking out about is bad enough to potentially destabilize the client.

Using ag_UnitFrames as my UI (ag_UnitFrames-r685.zip).

I was in the last raid position in the last group, and the error happened with my character. This may be significant, as in the past, I've been in the same instance and have not had disconnects and/or XUB errors. Maybe its an array index out of bounds problem?

Here are the screenpics showing my UI at the time of the error...

http://img2.imageshack.us/img2/7712/...0809201653.jpg
http://img2.imageshack.us/img2/9869/...0809201700.jpg
http://img2.imageshack.us/img2/6076/...0809201706.jpg

FYI, please note in the screenpics the the bars to the right of each character is higher up than it should be. Whenever someone enters/leaves the raid, this happens, and I have to type a "xub /p" to get them to line up to the right of the right character name. Not sure if this is related to the problem or a completely different problem, but as I said, a "xub /p" fixes that problem right away.
Last edited by Cosmic Cleric : 04-09-09 at 11:15 PM.
Cosmic Cleric is offline Report comment to moderator  
Reply With Quote
Unread 04-14-09, 06:17 PM  
paladindrome
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 140
Uploads: 4
Re: Bug Report while in a Raid

Originally posted by Cosmic Cleric
Got a "We are here because aUnit is NOK or aFrameNo~=1" message.

aUnit: (raid22)

...

FYI, please note in the screenpics the the bars to the right of each character is higher up than it should be.
And some of the buttons double up. This is with RC8?

I assume the prob is aFrameNo~=1 as aUnit looks liek it is raid22.

Sigh . . .

Drome
paladindrome is offline Report comment to moderator  
Reply With Quote
Unread 04-14-09, 08:27 PM  
Cosmic Cleric
A Deviate Faerie Dragon
 
Cosmic Cleric's Avatar
AddOn Author - Click to view AddOns

Forum posts: 15
File comments: 283
Uploads: 10
Re: Re: Bug Report while in a Raid

Originally posted by paladindrome
And some of the buttons double up. This is with RC8?

I assume the prob is aFrameNo~=1 as aUnit looks liek it is raid22.

Sigh . . .

Drome
Yes, this is with the latest downloadable versio, RC8.

Sorry to add to the woes. For what its worth, XUB doesn't seem to be in a healthy condition when used in a raid.
Last edited by Cosmic Cleric : 04-15-09 at 07:58 PM.
Cosmic Cleric is offline Report comment to moderator  
Reply With Quote
Unread 04-16-09, 04:23 PM  
paladindrome
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 140
Uploads: 4
Re: Re: Re: Bug Report while in a Raid

Originally posted by Cosmic Cleric
Yes, this is with the latest downloadable versio, RC8.

Sorry to add to the woes. For what its worth, XUB doesn't seem to be in a healthy condition when used in a raid.

Were members being moved around groups when the issue happened?

It seems to have the most issues with the changing of party/raid members. The basic approach is - Hey there is a change let me reset everything. I would like to get a relase out for 3.1 and look at a rewrite of the button creation to minimize the work that is done while in raid.

I looked at the changes between RC7 and RC8 and I didnt see anything that should impact the button creation. The specifc error of aFrameNo ~= 1 (not equal) is actually quite confusing - the code specifcally looks to see if there are multiple frames (aFrameNo = 2 in your screenshot). I am not sure how this would occur.

A head knocker for sure.

Drome
paladindrome is offline Report comment to moderator  
Reply With Quote
Unread 04-17-09, 12:27 PM  
Cosmic Cleric
A Deviate Faerie Dragon
 
Cosmic Cleric's Avatar
AddOn Author - Click to view AddOns

Forum posts: 15
File comments: 283
Uploads: 10
Re: Re: Re: Re: Bug Report while in a Raid

Originally posted by paladindrome
Were members being moved around groups when the issue happened?

It seems to have the most issues with the changing of party/raid members. The basic approach is - Hey there is a change let me reset everything. I would like to get a relase out for 3.1 and look at a rewrite of the button creation to minimize the work that is done while in raid.

I looked at the changes between RC7 and RC8 and I didnt see anything that should impact the button creation. The specifc error of aFrameNo ~= 1 (not equal) is actually quite confusing - the code specifcally looks to see if there are multiple frames (aFrameNo = 2 in your screenshot). I am not sure how this would occur.

A head knocker for sure.

Drome
I was inside the instance already with many members, and other members were zoning in. I can't say if members were being moved around, as I was not the leader, and things were kind of hectic (as usual when a PUG is getting its act together).

I can definately say though that people were zoning in at the time.
Cosmic Cleric is offline Report comment to moderator  
Reply With Quote
Unread 04-18-09, 07:12 AM  
paladindrome
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 140
Uploads: 4
Re: Re: Re: Re: Re: Bug Report while in a Raid

Originally posted by Cosmic Cleric
I was inside the instance already with many members, and other members were zoning in. I can't say if members were being moved around, as I was not the leader, and things were kind of hectic (as usual when a PUG is getting its act together).

I can definately say though that people were zoning in at the time.
Zoning shouldn't cause XUB any issues - we have already created the buttuns and the normal update cycle will show or not show them. Adding users and moving people around does cause us a cascade of work. This is what I would like to work on for the next release.

For this problem I have gotten one step closer - Blizzard Raid frames are different from all of the other raid frames in that XUB will associate multiple frames per unit:

Code:
if ( XUB_RaidTable[testFrameUnit] ~= nil ) then
          XUB_RaidTable[testFrameUnit] = XUB_RaidTable[testFrameUnit] .. "/" .. testName;
else
This is what caused the aFrameNo: (2) error message in the screen shot. I do not know why this would be activated - the only conjecture I have is that a user was moved during the middle of our update and this caused us to see that player as having two unit frames.

When we get into the button creation process we check to see if there are more then 1 frame and if so we post the error (Why associate multiples in the first place then?). The joys of working on old code with three different authors. I think the most straightforward approach is to comment out the way the Blizzard frames are coded so they act the same as the add on raid frames and get this version out as a beta/alpha.

I am on vacation starting tomorrow so I will put it out today - but wont be able to help for a bit.


Drome
paladindrome is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: