Download
(167 Kb)
Download
Updated: 11-08-10 02:33 PM
Updated:11-08-10 02:33 PM
Created:02-14-09 11:22 PM
Downloads:41,010
Favorites:227
MD5:
SBF 3.2 Beta  Popular! (More than 5000 hits)
Version: 3.2.3
by: Satrina, father0fnine
SBF has a maintainer!
I have to say, I am amazed by the number of people who just kept plugging along. It makes me feel bad that I do not have the time to keep working on this myself - you guys are all awesome! The good news is that a new maintainer has been found. Meet father0fnine, who is taking over SBF. I'm sure you'll all show him as much love as you showed me all these years
3.2.3
+ When clicking off buffs, the one you meant to dismiss should be dismissed
+ ButtonFacade backgrounds and gloss should be hidden/shown correctly now
- Names still do not show in interactive frames
- Sorting for interactive frames is not yet implemented

3.2.2
Fix two errors on load/zone

3.2.1
Mostly cosmetic fixes
Spell tab should be happy now
Archived Files (4)
File Name
Version
Size
Author
Date
3.2.2
167kB
Satrina
11-07-10 10:54 AM
3.2.1
167kB
Satrina
11-06-10 06:31 AM
3.2.0
166kB
Satrina
11-01-10 01:35 PM
Released!
168kB
Satrina
03-29-09 08:23 PM


Post A Reply Comment Options
Old 11-07-10, 09:08 AM  
Satrina
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 47
File comments: 639
Uploads: 24
I'll make sure to get gloss and backgrounds turned off.

Will get those errors fixed up

Visibility will never work with interactive frames (as noted on the project description page) unless Blizzard allows us to show/hide secure frames in combat.

As noted on the first page, names don't work (though the wtf message should have been removed for release, haha)

Thanks all!
Satrina is offline Report comment to moderator  
Reply With Quote
Old 11-06-10, 09:29 PM  
Necrophgst
A Deviate Faerie Dragon
 
Necrophgst's Avatar

Forum posts: 17
File comments: 35
Uploads: 0
Originally posted by Photekk
This build is working much better but still some bugs.

The ButtonFacade is working again but for some reason is now showing the effects on every aura grid spot you have set up - ie it's showing the gloss and backdrop effects for icons that are not there. I turned off gloss and backdrop to temporarily solve this.

::snip::
I have the same Button Facade issue as above. Only occures if I turn on background and/or gloss. Have resolved the problem as described above.
__________________
The beat goes, Boom Badda Bing
Necrophgst is offline Report comment to moderator  
Reply With Quote
Old 11-06-10, 04:37 PM  
Photekk
A Kobold Labourer

Forum posts: 0
File comments: 22
Uploads: 0
This build is working much better but still some bugs.

The ButtonFacade is working again but for some reason is now showing the effects on every aura grid spot you have set up - ie it's showing the gloss and backdrop effects for icons that are not there. I turned off gloss and backdrop to temporarily solve this.

Also I can no longer use the disappear on mouse-over function with the Interactive window turned on - I'm sure you know this and it's a Blizz side issue but hopefully there will be a work around for that too.
Photekk is offline Report comment to moderator  
Reply With Quote
Old 11-06-10, 12:27 PM  
galen2
A Kobold Labourer

Forum posts: 0
File comments: 18
Uploads: 0
I get this lua error first time i change zone (enter bg)

Error occured in: Global
Count: 112
Message: ..\AddOns\SatrinaBuffFrame\SBFUtil.lua line 15:
attempt to index local 'v' (a boolean value)
Debug:
(tail call): ?
SatrinaBuffFrame\SBFUtil.lua:15: ValueIn()
SatrinaBuffFrame\SBFBuff.lua:161:
SatrinaBuffFrame\SBFBuff.lua:155
SatrinaBuffFrame\SBFBuff.lua:307: IterateAuras()
SatrinaBuffFrame\SBFBuff.lua:200: UpdateUnitAuras()
...terface\AddOns\SatrinaBuffFrame\SatrinaBuffFrame.lua:438: Update()
...terface\AddOns\SatrinaBuffFrame\SatrinaBuffFrame.lua:432: ForceGet()
...terface\AddOns\SatrinaBuffFrame\SatrinaBuffFrame.lua:412: ?()
...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:147:
...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:147
[string "safecall Dispatcher[2]"]:4:
[string "safecall Dispatcher[2]"]:4
[C]: ?
[string "safecall Dispatcher[2]"]:13: ?()
...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:92: Fire()
Ace3\AceEvent-3.0\AceEvent-3.0.lua:120:
Ace3\AceEvent-3.0\AceEvent-3.0.lua:119

SBF 3.2.1
Last edited by galen2 : 11-06-10 at 12:28 PM.
galen2 is offline Report comment to moderator  
Reply With Quote
Old 11-06-10, 09:07 AM  
Kazragore
A Deviate Faerie Dragon

Forum posts: 14
File comments: 121
Uploads: 0
Buffnames doesn't work on the bars, getting only "wtf" in the chat.
Kazragore is offline Report comment to moderator  
Reply With Quote
Old 11-06-10, 07:53 AM  
chwolfgang
A Defias Bandit

Forum posts: 2
File comments: 71
Uploads: 0
Thank you for your continued work on this mod. With this current version, I get this error on load:

Message: Interface\AddOns\SatrinaBuffFrame\SBFSavedVar.lua:225: attempt to index global 'f' (a nil value)
Time: 11/06/10 06:51:27
Count: 1
Stack: (tail call): ?
Interface\AddOns\SatrinaBuffFrame\SBFSavedVar.lua:225: in function `ValidateFrameVars'
Interface\AddOns\SatrinaBuffFrame\SBFSavedVar.lua:61: in function `DoSavedVars'
Interface\AddOns\SatrinaBuffFrame\SBFSavedVar.lua:391: in function `ProfileChanged'
...terface\AddOns\SatrinaBuffFrame\SatrinaBuffFrame.lua:194: in function <...terface\AddOns\SatrinaBuffFrame\SatrinaBuffFrame.lua:178>
(tail call): ?
[C]: ?
[string "safecall Dispatcher[1]"]:9: in function <[string "safecall Dispatcher[1]"]:5>
(tail call): ?
Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-3.0.lua:543: in function `EnableAddon'
Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-3.0.lua:635: in function <Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-3.0.lua:621>
[C]: in function `LoadAddOn'
Interface\FrameXML\UIParent.lua:242: in function `UIParentLoadAddOn'
Interface\FrameXML\UIParent.lua:316: in function `TimeManager_LoadUI'
Interface\FrameXML\UIParent.lua:517: in function <Interface\FrameXML\UIParent.lua:492>

Locals: Sometimes debuglocals() returns nothing, it's one of those times... (FYI: This last sentence (only) is a HotFix from Decursive to prevent a C stack overflow in the new Blizzard error handler and thus giving you the opportunity to send this debug report to the author of the problematic add-on so he/she can fix it)
chwolfgang is offline Report comment to moderator  
Reply With Quote
Old 11-06-10, 06:31 AM  
Satrina
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 47
File comments: 639
Uploads: 24
3.2.1 has some small fixes, but does not fix the dismissing incorrect buff problem described below. Hopefully tomorow i can sort taht out
Satrina is offline Report comment to moderator  
Reply With Quote
Old 11-06-10, 04:43 AM  
Magdalen
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
Originally posted by Satrina
Are you putting filters on the frame before setting it to interactive? If so, don't.
I made new profile without filters and now click off working fine.
Thanks <3
Magdalen is offline Report comment to moderator  
Reply With Quote
Old 11-05-10, 10:31 PM  
Oxboy666
A Kobold Labourer

Forum posts: 0
File comments: 1
Uploads: 0
Filtering with non-interactive?

Satrina, what's the best way now to filter out icons when non-interactive? I used to be able to go to the Spells tab, click on the spell, and check the show/don't show boxes to the right. Now those boxes are greyed out. Help?
Oxboy666 is offline Report comment to moderator  
Reply With Quote
Old 11-05-10, 07:05 PM  
Satrina
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 47
File comments: 639
Uploads: 24
Interesting. I can reproduce this, but have no idea why it's happening. Will keep working at it

What happens is this: cast a buff on yourself, then another. Now recast the first one. The order of the two buffs will change order (they should not) and clicking the icon for one will dismiss the other. Puzzling.
Last edited by Satrina : 11-05-10 at 07:17 PM.
Satrina is offline Report comment to moderator  
Reply With Quote
Old 11-05-10, 12:00 PM  
biggoofyus
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 79
Uploads: 1
Originally posted by Satrina
Are you putting filters on the frame before setting it to interactive? If so, don't.
Fresh install of SBF 3.2 Beta (delete saved variables and also deleted SBF and SBF Options out of Addons folder before putting this version in) and without going into the options panel it still does the random buff bug when right clicking a specific buff off.
biggoofyus is offline Report comment to moderator  
Reply With Quote
Old 11-05-10, 10:28 AM  
Kosma
A Kobold Labourer

Forum posts: 0
File comments: 4
Uploads: 0
Nope, no filters existed for the frame. I'll play around with it more now that another person experienced the same thing
Kosma is offline Report comment to moderator  
Reply With Quote
Old 11-04-10, 09:01 PM  
Satrina
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 47
File comments: 639
Uploads: 24
Are you putting filters on the frame before setting it to interactive? If so, don't.
Satrina is offline Report comment to moderator  
Reply With Quote
Old 11-04-10, 07:51 PM  
biggoofyus
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 79
Uploads: 1
Originally posted by Kosma
Hmm, sometimes when I click off a buff, instead of the one I clicked, an entirely separate buff disappears... Although sometimes it works as intended. Sorry I can't be more specific at the moment

It's happened a couple times on the last boss of UP though. Boss stuns the party during the fight, I bubble to get out of the stun, then can't click off bubble (Divine Shield buff to be precise). But again, in other situations, clicking off worked fine.
Same here, tried to click off "Pirate Costume" and a random buff would come off instead. Also if I tried to click off my "Well Fed" Buff then a random buff comes off instead. It's a very weird bug.
biggoofyus is offline Report comment to moderator  
Reply With Quote
Old 11-04-10, 05:09 PM  
Kosma
A Kobold Labourer

Forum posts: 0
File comments: 4
Uploads: 0
Hmm, sometimes when I click off a buff, instead of the one I clicked, an entirely separate buff disappears... Although sometimes it works as intended. Sorry I can't be more specific at the moment

It's happened a couple times on the last boss of UP though. Boss stuns the party during the fight, I bubble to get out of the stun, then can't click off bubble (Divine Shield buff to be precise). But again, in other situations, clicking off worked fine.
Last edited by Kosma : 11-04-10 at 05:09 PM.
Kosma is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: