Download
(16 Kb)
Download
Updated: 01-31-10 12:14 PM
Pictures
File Info
Updated:01-31-10 12:14 PM
Created:04-21-09 01:35 PM
Downloads:21,553
Favorites:141
MD5:
TellMeWhen (Fan Update)  Popular! (More than 5000 hits)
Version: 1.2.1
by: Ooze [More]
TELLMEWHEN IS NO LONGER BEING UPDATED ON THIS PAGE, PLEASE REFER TO THE ORIGINAL ADDON PAGEFOR FUTURE UPDATES.
Version 1.2.1 (Fan Update)
- Bugfixes

Version 1.2.0 (Fan Update)
- Added options for targetoffocus and targetofpet
- Added "/tmw options" as a shortcut to options menu

(Major thanks to Oodyboo for the following changes)
- Changed how spec settings are saved
- Editbox for "Choose spell/buff/item" retains previous entered value
- Supports 8 bars instead of the old 4
- Added primary/secondary spec toggles for each bar
- Disabled bars and icons don't process everything

Version 1.1.6 (Fan Update)
- Fixed a bug where pets caused an endless stream of errormessages when dismissed/killed
- Fixed a bug where Buff/Debuff set to "Show when Absent" was acting as it was set to "Always Visible"

Version 1.1.5 (Fan Update)
- Buffs/Debuffs set to Always Visible now indicates if they are missing
- Icontextures should update correctly now

Version 1.1.4 (Fan Update)
- Dualspec Support Added

Version 1.1.3 (Fan Update)
- Rewrote Buffcheck to use UNIT_AURA instead of COMBAT_LOG_EVENT_UNFILTERED.
- Removed a bunch of variables that was created, but not used.

Version 1.1.1 (Fan Update)
- 3.1 Support (Calls to UnitAura Updated)
- Added support for showing multiple Buffs/Debuffs on a single icon, seperated them with ;
- Added support for spellIDs and itemIDs
- Added option "always" to BuffShowWhen & CooldownShowWhen

Version 1.1
- Added cooldown and buff/debuff timers. Compatible with OmniCC.

Version 1.0.1
- Updated for WoW 3.0

Version 1.0
- Hello world!
Archived Files (6)
File Name
Version
Size
Author
Date
1.2.0
16kB
Ooze
10-18-09 05:09 AM
1.1.6
14kB
Ooze
09-20-09 12:52 PM
1.1.5
14kB
Ooze
08-07-09 06:19 PM
1.1.4
14kB
Ooze
06-07-09 07:47 AM
1.1.3
16kB
Ooze
05-21-09 09:30 AM
1.1.1
14kB
Ooze
04-21-09 01:35 PM


Post A Reply Comment Options
Old 12-20-09, 08:16 AM  
Noemore
A Kobold Labourer

Forum posts: 0
File comments: 1
Uploads: 0
AddOns\TellMeWhen\TellMeWhen.lua line 567:
Usage: TellMeWhen_Group1_Icon1:SetAlpha(alpha 0 to 1)

I get this error constantly.
Noemore is offline Report comment to moderator  
Reply With Quote
Old 12-20-09, 07:37 AM  
Enkidu
A Kobold Labourer

Forum posts: 0
File comments: 55
Uploads: 0
Trinkets

Multiple trinkets that share the same name (ToC25 trinkets) seem to default to the timer of the none heroic one, regardless of putting in the item ID for the heroic one.

Also, maybe I missed it but is it possible to watch a trinket slot instead of specified trinkets?
Enkidu is offline Report comment to moderator  
Reply With Quote
Old 12-19-09, 12:57 PM  
Cybeloras
A Murloc Raider
 
Cybeloras's Avatar
AddOn Author - Click to view AddOns

Forum posts: 6
File comments: 251
Uploads: 7
Timers

Debuff timers do not work for me
Cybeloras is offline Report comment to moderator  
Reply With Quote
Old 12-16-09, 09:35 PM  
Tinuviel
A Defias Bandit
 
Tinuviel's Avatar

Forum posts: 3
File comments: 214
Uploads: 0
Originally posted by Tinuviel
Got a bug that seems to only happen to my druid (at least, its the only character I have that tends to change spec after zoning into an instance).

Whenever I swap specs in an instance, the position of the icons resets. For reference, I'm swapping from my offspec to my mainspec. It only seems to occur in an instance. I have reset the mod by removing the files several times, yet it persists.
Adding, it didn't matter this time if I was in an instance or not. Switching specs in town or right before zoning into an instance also does it. Doesn't matter if it is main spec or offspec, and it ONLY happens to my druid.
Tinuviel is offline Report comment to moderator  
Reply With Quote
Old 12-16-09, 01:46 AM  
ffcloud2000
A Fallenroot Satyr

Forum posts: 22
File comments: 111
Uploads: 0
Would it be possible to add Totem Support? Like magma totem etc?
__________________
ffcloud2000 is offline Report comment to moderator  
Reply With Quote
Old 12-14-09, 12:43 PM  
Tinuviel
A Defias Bandit
 
Tinuviel's Avatar

Forum posts: 3
File comments: 214
Uploads: 0
Got a bug that seems to only happen to my druid (at least, its the only character I have that tends to change spec after zoning into an instance).

Whenever I swap specs in an instance, the position of the icons resets. For reference, I'm swapping from my offspec to my mainspec. It only seems to occur in an instance. I have reset the mod by removing the files several times, yet it persists.
Tinuviel is offline Report comment to moderator  
Reply With Quote
Old 12-07-09, 08:32 PM  
orbenn
A Kobold Labourer
 
orbenn's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 12
Uploads: 0
I have the same crash on login bug described below. It seems to occur when any icon is disabled.


I didn't take the time to really understand the rest of this addon's code, but
I wrapped line 567 in an if statement so it only runs against enabled icons.

if ( icon.absentAlpha) then
icon:SetAlpha(icon.absentAlpha);
end

Not sure what other effects that would have, but it's prevented the crash on startup. 30 seconds of test fighting hasn't revealed any obvious bugs.
Last edited by orbenn : 01-13-10 at 02:57 PM.
orbenn is offline Report comment to moderator  
Reply With Quote
Old 12-07-09, 07:42 PM  
bikikitty
A Kobold Labourer

Forum posts: 0
File comments: 38
Uploads: 0
Re: Sacred Shield & Spell ID's

Originally posted by Masktchi
I have not been able to get the Sacred Shield proc buff to show separately from the initial buff. It will not display unless the original buff is removed. However, even when the icon changes, it still acts in the same, treating both as the same buff. I tried spell IDs, both show up as the initial sacred shield buff. /facepalm Any comments?

Additionally, I've noticed the reactive ability function (Hammer of Wrath) works inconsistently. Might need something like EventAlert if you want it work 100%.
I would agree with that---inconsistently! I act as a warrior and when i used tellmewhen to monitor the bloodthirst(cool down) and shield slam(reactive ability),sometimes even i can see the skill icon light on on my action bar, but tellmewhen just didn't show up the appropriate icon. I mean sometimes not every-time, but it is not quite dependable.
Last edited by bikikitty : 12-07-09 at 07:44 PM.
bikikitty is offline Report comment to moderator  
Reply With Quote
Old 12-06-09, 01:34 PM  
Masktchi
A Kobold Labourer

Forum posts: 0
File comments: 1
Uploads: 0
Sacred Shield & Spell ID's

I have not been able to get the Sacred Shield proc buff to show separately from the initial buff. It will not display unless the original buff is removed. However, even when the icon changes, it still acts in the same, treating both as the same buff. I tried spell IDs, both show up as the initial sacred shield buff. /facepalm Any comments?

Additionally, I've noticed the reactive ability function (Hammer of Wrath) works inconsistently. Might need something like EventAlert if you want it work 100%.
Last edited by Masktchi : 12-06-09 at 02:08 PM.
Masktchi is offline Report comment to moderator  
Reply With Quote
Old 12-06-09, 09:06 AM  
Ooze
A Kobold Labourer
 
Ooze's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 43
Uploads: 1
Small update for you folks here

Been trying to add ButtonFacade support as has been requested alot, and it is being a total pain in the backside.

As for the bugfix i will pop that up when i get some more spare time... Got somewhere i gotta be in like an hour and gotta get going.
Ooze is offline Report comment to moderator  
Reply With Quote
Old 12-05-09, 06:15 PM  
oody
A Kobold Labourer

Forum posts: 0
File comments: 18
Uploads: 0
Originally posted by blitzseed
hey any update on how the rewrite is going?
i haven't started, was going to wait for Ooze's next version with the changes he was incorporating so I could work off that. i don't have the time for it right now anyway, and the addon is still very functional.
oody is offline Report comment to moderator  
Reply With Quote
Old 12-05-09, 05:28 PM  
oody
A Kobold Labourer

Forum posts: 0
File comments: 18
Uploads: 0
Re: problem with Hammer of Wrath

Originally posted by thoon

I'm using this great addon for some days and i found one problem.
I putted Hammer of Wrath into TMW bar to watch it when can i use it.
Hammer of Wrath can be used only when target has <= 20 % health.
TMW with this skill works randomly.
I don't think the addon was ever designed to support this type of check, it's surprising it works "randomly".

It would have to register extra events to watch target health changes as well, which would make the addon lag more. honestly probably not worth it for just hammer and warrior execute.
oody is offline Report comment to moderator  
Reply With Quote
Old 12-04-09, 02:39 PM  
blitzseed
A Kobold Labourer

Forum posts: 0
File comments: 70
Uploads: 0
hey any update on how the rewrite is going?
blitzseed is offline Report comment to moderator  
Reply With Quote
Old 12-02-09, 02:16 AM  
thoon
A Kobold Labourer

Forum posts: 0
File comments: 1
Uploads: 0
problem with Hammer of Wrath

Hi

I'm using this great addon for some days and i found one problem.
I putted Hammer of Wrath into TMW bar to watch it when can i use it.
Hammer of Wrath can be used only when target has <= 20 % health.
TMW with this skill works randomly. Sometimes when mob has < 20 % it will show icon exactly when it should be shown but sometimes not.
For example. Fighting with mob, mob have 25 % - icon not visible (correct), hit, mob has 18 %, icon still not visible but on normal bar i can see that i can use Hammer of Wrath. Next hits and sometimes TMW icon will work but sometimes not. It looks like addon doesn't react fast enough for changes in target health.
I'm using it also for The Art of War and for this skill it works perfect in 100 % of play time.
I had the same problem in original 1.1.2 version.

Anyone saw such a situation ? or maybe some1 has solution for it ?
thoon is offline Report comment to moderator  
Reply With Quote
Old 12-01-09, 07:02 PM  
apsy
A Kobold Labourer

Forum posts: 0
File comments: 2
Uploads: 0
OMG ! Thx Oody, i was using version 1.1.2 oO"
(How is that possible ? It doesn't exists in the changelog...)
MY error was solved in the 1.1.6 version it seems :
- "Fixed a bug where pets caused an endless stream of errormessages when dismissed/killed"

I've updated my addon to the 1.2 version and all now is ok ! Thanks again and sorry. Next time i'll look to the latest version first ^^
apsy is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: