Download
(16 MB)
Download
Updated: 08-24-14 08:12 AM
Pictures
File Info
Compatibility:
Siege of Orgrimmar (5.4)
Escalation (5.3)
Thunder Isle (5.2)
Landfall (5.1)
Mists of Pandaria (5.0.4)
Updated:08-24-14 08:12 AM
Created:07-23-09 05:44 AM
Downloads:27,601
Favorites:42
MD5:
Categories:Generic Compilations, Suites, DPS Compilations, Healer Compilations, Tank Compilations
5.4
Shining UI  Popular! (More than 5000 hits)
Version: 8.5
by: FaulTier [More]


Important: Read the TXT-FiILE in the archive!





Features:

- different layouts for groups and raids
- mouseover micromenu on top of the screen
- player, pet, target, target of target and focus frames
- Menu with help- and infofunctions and ability to switch the layout and toogle the sidebar!
- 2x 6-button-bars at the left/right of the 2 actionbars
- onClick bar-panels in the sidebar; Storage for professions and mounts/pets
- Stancebar (Druid, Dk, Pala, Warri, Hunter!) under Player/Target-Frames!
- ComoPoints, HolyPower, ShadowsOrb etc are supported
- runesbar for deathknights in center
- broker at bottom
- Cooldowns and DoTs/HoTs - fitting to hostility of the target and layout
- function to minimize the minimap (click on the zone-text to show/hide)
- 1px-borders
- informative and clean BattleText
- skinned and moved Buttons for LFD, PVP/BG, AtlasLoot and Tracking!
- and some more!

MiniMapMinimizing! And theInterfaceQuickMenu!
It's shown in German, but only for "deDE" clients, everyone else will have english tooltips!


Known Bugs/Errors/Problems/ToDo-List!:
- Grid throws an incredibly vast amount of errors, mostly about secured functions.
Everything else is mentioned in the FAQ.txt-file in the .rar-file.
How to Install...:
Code:
... in English:
1. Download "Shining v7.8.rar" and extract it to your Desktop
2. Go to your WoW-folder, delete/rename the excisting "WTF"- and "Interface"-folders
3. Copy the extracted folders into your WoW-folder.
4. Open WoW\WTF\account, rename "YOURACCOUNT" to your account-name in CAPS.
5. Open this folder and rename the "YourRealm", beginning with a capital letter. (Each for every realm, use copy'n'paste)
6. Open the realmfolder and and rename the "Your Character"-folder to your  characternames beginning with a capital letter, use again copy'n'paste to multiple the folder.
7. Start WoW, log in, make sure that "load outdated addons" (or what it is called in english) is checked.
8. Log in with your character and type into the chat "/reflux switch ShiningUI" and there it is!
9. Enjoy.
-------------------------------------------------------------------
...in Deutsch:
1. Runterladen, entpacken.
2. WTF & Interface im WoW-Stammordner löschen/umbenennen
3. Die entpackten Ordner reinkopieren
4. Im Ordner "\WTF\account\" "YOURACCOUNT" in gleicher schreibweise umbennen. (Für mehrere Accounts einfach copy'n'paste)
5. In dem Account Ordner "YourRealm" ebenfalls im gleichen Muster umbennen, auch hier hilft copy'n'paste für mehrere Server.
6. In dem RealmOrdner: Siehe 5, nur mit Charakternamen.
7. WoW starten, einloggen, schauen ob alle Addons aktiviert und auch veraltete Addons geladen werden.
8. In den Chat "/reflux switch ShiningUI" eingeben.
9. Spaß haben :D

Used addons:

Bagnon - Bartender4 - BetterInBox - BigWigs - Chinchilla - ErrorFilter - Grid - Grid Unit Menu - kgpanels - KuiNamePlates - Masque - Masque: Shining - Mike's Srolling BattleText - nibPointDisplay - nibEclipse - OmniCC - oUF - oUF_Fauli - Prat - Raven - Reflux - saftExperienceBar - SimplePowerBar - Skada - StatLineDataText - teksloot - TipTac - WIM - WIM_ukui - Yurys RuneDisplay
>>> Atlasloot, Healbot, AuctionMaster etc. are needed to be downloaded seperately!
v8.5
*all addons are up-to-date
*added options to hide following frames/elements:
***chat
***skada
***all-in-one (chat, skada, sidebar, minimap)
*added lfr/pvp-icon support with minimap minimized
*added changing grid position when chat is hidden
*cleaned up some graphical mess
*reworked some functions, mostly stuff to hide/show frames

---------------------------------------------

v8.3
*all addons are up-to-date
*slightly changed menu-/Interface-graphics
*complete overhaul of kgpanels-scripting/frames (the whole UI stuff in short)
*better behavour for extrabars when engaging combat/vehicles
*quest/av tracker will hide on combat-begin and show up again after
---------------------------------------------

v8.2
*all addons are up-to-date
*very minor fixes.
---------------------------------------------

v8.1
-ErrorMonster
+ErrorFilter
*fixed functions in kgPanels and NugEnergy
*minor stuff as alignment etc
---------------------------------------------

v8
*rewrite of oUF_Fauli
*fixed functions
*minor stuff
---------------------------------------------

v7.8
back again!
all AddOns are up-to-date, even Grid and so on, with edited codes to fit and work well in my compilation again.

---------------------------------------------

v7.7
*fixed nibPointDisplay - Chi and more are now trackablee again
*shamans and monks now work properly with this interface
WORTH downloading if you have only version 7.5

---------------------------------------------
v7.6
*added a help-section in the menu
*included some graphics I'd forgotten - e.g. the tracking-graphic at the minimap... shame on me.
added some bi-lingual tooltips.
WORTH downloading if you have only version 7.5

---------------------------------------------
v7.5
*slightly changed graphics
*added the function to minimize the minimap (click on the zone-text to show/hide.)
*now dual-language supporting, based on your client. (Only German (for deDE) and English (the rest) atm.)

---------------------------------------------

v7.2
*added new dropdown entries - you can leave your groups in instances now!
*fixed some layer issues
*updated and modified Grid.
- BetterInBox
+ Postal


---------------------------------------------

v7.1
*fixed script-issues due to new WoW-API
*updated all update-able addons - do not update Grid!
*almost MoP-Ready!

---------------------------------------------

v7
*fixed an problem with WIM3, that caused the UI to go mad after login/loadingscreens
*updated all update-able addons - do not update Grid!

---------------------------------------------

v6 r9
*kgPanels: fixed WIM3MinimapButton-Position
*kgPanels: SideBarButtons fixed
*bartender4: corrected various bar spaces and sizes
*SLDataText updated

---------------------------------------------

v6 r5
*kgPanels: fixed changing panel-adress to cause errors
*kgPanels: deleted nibEclipse background as it can't be adressed properly
*bartender4: corrected various bar spaces and sizes
*kgPanels: renamed panel to avoid local errors
*raven: redefined filters and fixed buff-spacing on HealLayout

---------------------------------------------

v6
- PitBull
+ oUF
+ debut for oUF_Fauli
+ Bagnon
+ SimplePowerBar
+ GridUnitMenu
+ Masque_Shining
* 2 new bar-panels on SideBar
* new style
* new buff displays/filtering
* many stuff - stuff i don't remember.
---------------------------------------------

v5.3
*byebye DeadlyBossMods
*hey there nibPowerDisplay. nibEclipse, BigWigs
*fixed layout-changing malfunction
*deleted Trash.
---------------------------------------------

v5.2
*fixed some
*added/edited the bordes - are more stylish now!
*SexyGrid works again!
---------------------------------------------

v5.1
*just updated the whole stuff
*Buttonfacade is now called "Masque"
*SexyGrid doesn't work anymore.

---------------------------------------------
v5
*refined kgpanels
**new style
**working and skinned BossMods
*slightly better perfomance
*trying to add multi-screen-solution compability
*new group-layouts
*erased specific raid-size-frames
*SBF has been abondoned - hey there Raven!
*DXE/KLE aren't worthy - back again to DBM!
*arkinventory has been removed, but config is saved!
***some stuff I don't know anymore.
Post A Reply Comment Options
Unread 11-08-13, 05:23 AM  
FaulTier
A Theradrim Guardian
 
FaulTier's Avatar
AddOn Author - Click to view AddOns

Forum posts: 60
File comments: 175
Uploads: 5
Originally Posted by babaan
Naja ausser das dein UI hier und da etwas komisch aussieht nichts

Ich mein, es is dennoch spielbar auch wenn sich z.b. die 2 Leisten rechts nicht aufklappen lassen. Und unten die Infos über fps, Post etc. haben halt auch keinen Rahmen aber das sind alles Dinge, die spielerisch keinen Einfluss haben.
Da Menu dürfte auch nicht funktionieren... PRoblem ist halt, jeder Rahmen, auch von Grid, ist mit !BeautyCase gemacht.

Ich schau nachher mal, wasd en Fehler genau verursacht.
__________________
FaulTier is offline Report comment to moderator  
Reply With Quote
Unread 11-08-13, 05:03 AM  
babaan
A Kobold Labourer

Forum posts: 0
File comments: 4
Uploads: 0
Naja ausser das dein UI hier und da etwas komisch aussieht nichts

Ich mein, es is dennoch spielbar auch wenn sich z.b. die 2 Leisten rechts nicht aufklappen lassen. Und unten die Infos über fps, Post etc. haben halt auch keinen Rahmen aber das sind alles Dinge, die spielerisch keinen Einfluss haben.
babaan is offline Report comment to moderator  
Reply With Quote
Unread 11-08-13, 04:35 AM  
FaulTier
A Theradrim Guardian
 
FaulTier's Avatar
AddOn Author - Click to view AddOns

Forum posts: 60
File comments: 175
Uploads: 5
Originally Posted by babaan
Hab grad selber mal alle Addons nach und nach deaktiviert. Das Problem scheint wohl das Addon "!Beautycase" zusein. Wenn ich dies deaktiviere, kann ich WeakAuras normal benutzen und es stimmt auch alles.
Ist es jedoch wieder aktiviert, sind viele Symbole die ich bei WeakAuras erstellt habe mit einem Fragezeichen versehen, ausserdem lassen sich die Option von WeakAuras nicht mehr öffnen.

Okay, das ist komisch.
Eigentlich müsste mit deaktivieren von !Beautyframes das ganze AddOn aufgeschmissen sein - fällt bei dir etwas auf?
__________________
FaulTier is offline Report comment to moderator  
Reply With Quote
Unread 11-08-13, 02:45 AM  
babaan
A Kobold Labourer

Forum posts: 0
File comments: 4
Uploads: 0
Hab grad selber mal alle Addons nach und nach deaktiviert. Das Problem scheint wohl das Addon "!Beautycase" zusein. Wenn ich dies deaktiviere, kann ich WeakAuras normal benutzen und es stimmt auch alles.
Ist es jedoch wieder aktiviert, sind viele Symbole die ich bei WeakAuras erstellt habe mit einem Fragezeichen versehen, ausserdem lassen sich die Option von WeakAuras nicht mehr öffnen.
babaan is offline Report comment to moderator  
Reply With Quote
Unread 11-07-13, 11:25 AM  
FaulTier
A Theradrim Guardian
 
FaulTier's Avatar
AddOn Author - Click to view AddOns

Forum posts: 60
File comments: 175
Uploads: 5
Originally Posted by babaan
Moin Faultier,

ich hab da nen Problem und weiss nich wie ich es lösen kann. Ich würde gerne Weak Auras benutzen. Jedoch macht mir das arge Probleme.

Das fängt damit an das ich oftmals die Einstellungen nicht sehen kann, genauso lassen sich viele Sachen garnicht richtig einstellen. Wenn ich jedoch alle Addons deaktiviere und mit der Standart UI spiele, funktioniert es einwandfrei. Es muss also an nem Addon liegen welches du benutzt oder eine Einstellung.

Es wäre sehr nett wenn du dir das ma anschauen könntest. Wenn ich dir noch irgendwie helfen kann, dann sag es nur. Ich mag sehr sehr ungern auf dein UI verzichten wegen einem Addon was ich schon sehr sehr gerne benutzen wollen würde.
Moin!

Ich kann nachher mal Weakauras installieren - habs noch nie verwendet - und schauen, was er mir so sagt.

Grüße
__________________
FaulTier is offline Report comment to moderator  
Reply With Quote
Unread 11-07-13, 10:27 AM  
babaan
A Kobold Labourer

Forum posts: 0
File comments: 4
Uploads: 0
Moin Faultier,

ich hab da nen Problem und weiss nich wie ich es lösen kann. Ich würde gerne Weak Auras benutzen. Jedoch macht mir das arge Probleme.

Das fängt damit an das ich oftmals die Einstellungen nicht sehen kann, genauso lassen sich viele Sachen garnicht richtig einstellen. Wenn ich jedoch alle Addons deaktiviere und mit der Standart UI spiele, funktioniert es einwandfrei. Es muss also an nem Addon liegen welches du benutzt oder eine Einstellung.

Es wäre sehr nett wenn du dir das ma anschauen könntest. Wenn ich dir noch irgendwie helfen kann, dann sag es nur. Ich mag sehr sehr ungern auf dein UI verzichten wegen einem Addon was ich schon sehr sehr gerne benutzen wollen würde.
babaan is offline Report comment to moderator  
Reply With Quote
Unread 11-01-13, 12:58 PM  
FaulTier
A Theradrim Guardian
 
FaulTier's Avatar
AddOn Author - Click to view AddOns

Forum posts: 60
File comments: 175
Uploads: 5
Originally Posted by Jenjo
Originally Posted by FaulTier
Originally Posted by Jenjo
Danke für die schnelle Antwort!

<string>:"DpsMid_OnLoad":27: in function "y"
kgPanels\kgPanels-1.17.lua:1115: in function "SetupScript"
kgPanels\kgPanels-1.17.lua:808: in function "InitScripts"
kgPanels\kgPanels-1.17.lua:794: in function "PlaceFrame"
kgPanels\kgPanels-1.17.lua:701: in function "ApplyLayout"
kgPanels\kgPanels-1.17.lua:500: in function <kgPanels\kgPanels.lua:496>
(tail call): ?
<in C code>

Ich habe es sowohl einmal mit den Bugs, als auch ohne versucht. Dies ist was für kgPanels dabei rumkommt, für TipTac gibt es allerdings keine Fehlermeldung.
Gehe dann mit deiner vermeintlichen Vermutung konform, dass das am meiner 1920x1080 Auflösung liegt.

edit// Ich habe BigWigs ausgetauscht und dafür DBM reingenommen, allerdings passiert das gleiche Problem auch mit BigWigs und ohne DBM.

MfG Jenjo

Moin!
Also, an deiner Auflösung kann es es nicht liegen - ich spiele und code ebenfalls unter 1920x1080

Die Fehlermeldung per se klingt logisch, auch wenn ich sie einfach mal gar nicht nachvollziehen kann - ich schau es mir gleich aber an

Die Funktion, die den TipTac-Tooltip verschiebt, kommt nach der mit dem Fehler (irgendwann danach), ergo wird die gar nciht richtug aufgerufen, ich schau gleich rein.

So, ich habe einmal fix reingeschaut - und verstehe nicht, wo dieses "y" herkommen soll.
Mach bitte einmal Folgendes:
Gib im Spiel "/kgpanels config" ein. Im neuen Fenster gehe auf "Aktive PAnels" und wähle dann mit Doppelklick "DpsMid" aus, erweitere dann "Scripte" und wähle "OnLoad" aus.
Jetzt sollte im rechten Teil des Fensters ein paar Zeilen Code sein.
Wenn dieser Code nicht 1:1 wie das hier aussieht, bitte den hier kopieren, im Spiel den Code löschen und einfügen und auf "Annehmen" klicken. Danach einfach einen /reload.

Code:
local _, class = UnitClass("player");
if class == "WARRIOR" then
        CreateBorder(self, 10, 0.78, 0.6, 0.43, -2, -2, -2, -2, -2, -2, -2, -2)
     elseif class == "MONK" then
        CreateBorder(self, 10, 0.33, 0.54, 0.52, -2, -2, -2, -2, -2, -2, -2, -2)     
     elseif class == "PRIEST" then
        CreateBorder(self, 10, 1, 0.98, 1, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "MAGE" then
        CreateBorder(self, 10, 0.41, 0.79, 0.94, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "DRUID" then
        CreateBorder(self, 10, 1, 0.48, 0.04, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "PALADIN" then
        CreateBorder(self, 10, 0.96, 0.54, 0.73, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "HUNTER" then
        CreateBorder(self, 10, 0.67, 0.82, 0.45, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "ROGUE" then
        CreateBorder(self, 10, 1, 0.95, 0.41, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "SHAMAN" then
        CreateBorder(self, 10, 0.00, 0.43, 0.87, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "WARLOCK" then
        CreateBorder(self, 10, 0.58, 0.50, 0.79, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "DEATHKNIGHT" then
        CreateBorder(self, 10, 0.77, 0.12, 0.23, -2, -2, -2, -2, -2, -2, -2, -2)
    end

if SkadaBarWindowDamage then
SkadaBarWindowDamage:ClearAllPoints()
SkadaBarWindowDamage:SetPoint("BOTTOMRIGHT", UIParent, "BOTTOMRIGHT", -14, 109)
SkadaBarWindowAggro:ClearAllPoints()
SkadaBarWindowAggro:SetPoint("BOTTOMRIGHT", UIParent, "BOTTOMRIGHT", -14, 38)
else end
Der zweite Teil des Codes (SkadaBar) war nicht im Skript. Ich habe den jetzt ergänzt, aber keines der beiden Probleme wurde dadurch wirklich behoben. Die Rahmen fehlen wie zuvor auch bei jedem zweiten reload / bei jedem Einloggen wieder und die Anker von TipTac ist auch noch immer über dem Chat. Noch immer tritt das beides nicht zusammen auf. Wenn die Rahmen fehlen, ist TipTac an der richtigen Stelle, sind die Rahmen vorhanden (durch den reload), ist TipTac wieder über dem Chat.

MfG Jenjo
Ich lade nachher mal ein stabiles Update hier hoch. Wenn es da auch auftritt, wissenw ir immerhin das es an deinen AddOns liegt :P
__________________
FaulTier is offline Report comment to moderator  
Reply With Quote
Unread 11-01-13, 12:44 PM  
Jenjo
A Kobold Labourer

Forum posts: 0
File comments: 4
Uploads: 0
Originally Posted by FaulTier
Originally Posted by Jenjo
Danke für die schnelle Antwort!

<string>:"DpsMid_OnLoad":27: in function "y"
kgPanels\kgPanels-1.17.lua:1115: in function "SetupScript"
kgPanels\kgPanels-1.17.lua:808: in function "InitScripts"
kgPanels\kgPanels-1.17.lua:794: in function "PlaceFrame"
kgPanels\kgPanels-1.17.lua:701: in function "ApplyLayout"
kgPanels\kgPanels-1.17.lua:500: in function <kgPanels\kgPanels.lua:496>
(tail call): ?
<in C code>

Ich habe es sowohl einmal mit den Bugs, als auch ohne versucht. Dies ist was für kgPanels dabei rumkommt, für TipTac gibt es allerdings keine Fehlermeldung.
Gehe dann mit deiner vermeintlichen Vermutung konform, dass das am meiner 1920x1080 Auflösung liegt.

edit// Ich habe BigWigs ausgetauscht und dafür DBM reingenommen, allerdings passiert das gleiche Problem auch mit BigWigs und ohne DBM.

MfG Jenjo

Moin!
Also, an deiner Auflösung kann es es nicht liegen - ich spiele und code ebenfalls unter 1920x1080

Die Fehlermeldung per se klingt logisch, auch wenn ich sie einfach mal gar nicht nachvollziehen kann - ich schau es mir gleich aber an

Die Funktion, die den TipTac-Tooltip verschiebt, kommt nach der mit dem Fehler (irgendwann danach), ergo wird die gar nciht richtug aufgerufen, ich schau gleich rein.

So, ich habe einmal fix reingeschaut - und verstehe nicht, wo dieses "y" herkommen soll.
Mach bitte einmal Folgendes:
Gib im Spiel "/kgpanels config" ein. Im neuen Fenster gehe auf "Aktive PAnels" und wähle dann mit Doppelklick "DpsMid" aus, erweitere dann "Scripte" und wähle "OnLoad" aus.
Jetzt sollte im rechten Teil des Fensters ein paar Zeilen Code sein.
Wenn dieser Code nicht 1:1 wie das hier aussieht, bitte den hier kopieren, im Spiel den Code löschen und einfügen und auf "Annehmen" klicken. Danach einfach einen /reload.

Code:
local _, class = UnitClass("player");
if class == "WARRIOR" then
        CreateBorder(self, 10, 0.78, 0.6, 0.43, -2, -2, -2, -2, -2, -2, -2, -2)
     elseif class == "MONK" then
        CreateBorder(self, 10, 0.33, 0.54, 0.52, -2, -2, -2, -2, -2, -2, -2, -2)     
     elseif class == "PRIEST" then
        CreateBorder(self, 10, 1, 0.98, 1, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "MAGE" then
        CreateBorder(self, 10, 0.41, 0.79, 0.94, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "DRUID" then
        CreateBorder(self, 10, 1, 0.48, 0.04, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "PALADIN" then
        CreateBorder(self, 10, 0.96, 0.54, 0.73, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "HUNTER" then
        CreateBorder(self, 10, 0.67, 0.82, 0.45, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "ROGUE" then
        CreateBorder(self, 10, 1, 0.95, 0.41, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "SHAMAN" then
        CreateBorder(self, 10, 0.00, 0.43, 0.87, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "WARLOCK" then
        CreateBorder(self, 10, 0.58, 0.50, 0.79, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "DEATHKNIGHT" then
        CreateBorder(self, 10, 0.77, 0.12, 0.23, -2, -2, -2, -2, -2, -2, -2, -2)
    end

if SkadaBarWindowDamage then
SkadaBarWindowDamage:ClearAllPoints()
SkadaBarWindowDamage:SetPoint("BOTTOMRIGHT", UIParent, "BOTTOMRIGHT", -14, 109)
SkadaBarWindowAggro:ClearAllPoints()
SkadaBarWindowAggro:SetPoint("BOTTOMRIGHT", UIParent, "BOTTOMRIGHT", -14, 38)
else end
Der zweite Teil des Codes (SkadaBar) war nicht im Skript. Ich habe den jetzt ergänzt, aber keines der beiden Probleme wurde dadurch wirklich behoben. Die Rahmen fehlen wie zuvor auch bei jedem zweiten reload / bei jedem Einloggen wieder und die Anker von TipTac ist auch noch immer über dem Chat. Noch immer tritt das beides nicht zusammen auf. Wenn die Rahmen fehlen, ist TipTac an der richtigen Stelle, sind die Rahmen vorhanden (durch den reload), ist TipTac wieder über dem Chat.

MfG Jenjo
Jenjo is offline Report comment to moderator  
Reply With Quote
Unread 11-01-13, 08:27 AM  
FaulTier
A Theradrim Guardian
 
FaulTier's Avatar
AddOn Author - Click to view AddOns

Forum posts: 60
File comments: 175
Uploads: 5
Originally Posted by Jenjo
Danke für die schnelle Antwort!

<string>:"DpsMid_OnLoad":27: in function "y"
kgPanels\kgPanels-1.17.lua:1115: in function "SetupScript"
kgPanels\kgPanels-1.17.lua:808: in function "InitScripts"
kgPanels\kgPanels-1.17.lua:794: in function "PlaceFrame"
kgPanels\kgPanels-1.17.lua:701: in function "ApplyLayout"
kgPanels\kgPanels-1.17.lua:500: in function <kgPanels\kgPanels.lua:496>
(tail call): ?
<in C code>

Ich habe es sowohl einmal mit den Bugs, als auch ohne versucht. Dies ist was für kgPanels dabei rumkommt, für TipTac gibt es allerdings keine Fehlermeldung.
Gehe dann mit deiner vermeintlichen Vermutung konform, dass das am meiner 1920x1080 Auflösung liegt.

edit// Ich habe BigWigs ausgetauscht und dafür DBM reingenommen, allerdings passiert das gleiche Problem auch mit BigWigs und ohne DBM.

MfG Jenjo

Moin!
Also, an deiner Auflösung kann es es nicht liegen - ich spiele und code ebenfalls unter 1920x1080

Die Fehlermeldung per se klingt logisch, auch wenn ich sie einfach mal gar nicht nachvollziehen kann - ich schau es mir gleich aber an

Die Funktion, die den TipTac-Tooltip verschiebt, kommt nach der mit dem Fehler (irgendwann danach), ergo wird die gar nciht richtug aufgerufen, ich schau gleich rein.

So, ich habe einmal fix reingeschaut - und verstehe nicht, wo dieses "y" herkommen soll.
Mach bitte einmal Folgendes:
Gib im Spiel "/kgpanels config" ein. Im neuen Fenster gehe auf "Aktive PAnels" und wähle dann mit Doppelklick "DpsMid" aus, erweitere dann "Scripte" und wähle "OnLoad" aus.
Jetzt sollte im rechten Teil des Fensters ein paar Zeilen Code sein.
Wenn dieser Code nicht 1:1 wie das hier aussieht, bitte den hier kopieren, im Spiel den Code löschen und einfügen und auf "Annehmen" klicken. Danach einfach einen /reload.

Code:
local _, class = UnitClass("player");
if class == "WARRIOR" then
        CreateBorder(self, 10, 0.78, 0.6, 0.43, -2, -2, -2, -2, -2, -2, -2, -2)
     elseif class == "MONK" then
        CreateBorder(self, 10, 0.33, 0.54, 0.52, -2, -2, -2, -2, -2, -2, -2, -2)     
     elseif class == "PRIEST" then
        CreateBorder(self, 10, 1, 0.98, 1, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "MAGE" then
        CreateBorder(self, 10, 0.41, 0.79, 0.94, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "DRUID" then
        CreateBorder(self, 10, 1, 0.48, 0.04, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "PALADIN" then
        CreateBorder(self, 10, 0.96, 0.54, 0.73, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "HUNTER" then
        CreateBorder(self, 10, 0.67, 0.82, 0.45, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "ROGUE" then
        CreateBorder(self, 10, 1, 0.95, 0.41, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "SHAMAN" then
        CreateBorder(self, 10, 0.00, 0.43, 0.87, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "WARLOCK" then
        CreateBorder(self, 10, 0.58, 0.50, 0.79, -2, -2, -2, -2, -2, -2, -2, -2)
    elseif class == "DEATHKNIGHT" then
        CreateBorder(self, 10, 0.77, 0.12, 0.23, -2, -2, -2, -2, -2, -2, -2, -2)
    end

if SkadaBarWindowDamage then
SkadaBarWindowDamage:ClearAllPoints()
SkadaBarWindowDamage:SetPoint("BOTTOMRIGHT", UIParent, "BOTTOMRIGHT", -14, 109)
SkadaBarWindowAggro:ClearAllPoints()
SkadaBarWindowAggro:SetPoint("BOTTOMRIGHT", UIParent, "BOTTOMRIGHT", -14, 38)
else end
__________________
Last edited by FaulTier : 11-01-13 at 08:38 AM.
FaulTier is offline Report comment to moderator  
Reply With Quote
Unread 10-31-13, 12:16 PM  
Jenjo
A Kobold Labourer

Forum posts: 0
File comments: 4
Uploads: 0
Originally Posted by Jenjo
Originally Posted by FaulTier
Originally Posted by Jenjo
Hi, zuerstmal Danke für das klasse UI!

Ich habe leider 2 kleine Probleme damit, ich hab zwar die 300 Comments einmal überflogen, aber das schien noch nicht als Problem aufgetreten zu sein.

Zuerstmal landet der Tooltip von TipTac jedesmal wenn ich mich neu einlogge unten links über dem Chat und ich muss jedes mal wieder in die Options gehen und Tooltip an die richtige Stelle ziehen. Hast du dafür eine Idee?

Das zweite Problem, dass ich habe, sind die Rahmen um Chat, untere Spellleisten und Skada (ich gehe mal von kgPanels aus). Auch diese verschwinden bei jedem einloggen und ab und zu auch einfach während des Spiels (sind nur durch /reload) zurück zuholen. Wenn ich aber /reload nutze, ist der Tooltip von Tiptac wieder über dem Chat. Kann das mit weiteren nicht wirklich klassenspezifischen Addons (z.b Decursive oder TellMeWhen) zusammen hängen?

Bei Bedarf lade ich auch gerne ein Screen hoch, falls die Beschreibung zu schwammig war.

MfG Jenjo

Moin und danke für das Lob

Dein Problem ist klar beschrieben und verständlich. Das andere AddOns das verursachen ist durchaus denkbar, vll. sogar die einzige Möglichkeit, außer du hast einige meiner eingebauten AddOns deaktiviert, da kgPanels ich meine bis auf 2,3 Ausnahmen jedes AddOn einbindet und wenn ein AddOn deaktiviert ist, wirft es das gesamte kgPanelsScript durcheinander, weshalb ab einem bestimmen Punkt viele Funktionen falsch sind.
Am besten machst du einmal folgendes:
Gib "/bugsack" ein und lösche alle vorhanden Fehler über den Button des Interfaces. Sobald dann wieder nach dem Einloggen der Fehler mit den Rändern auftritt, gibst du "/buggrabber" ein - danach kommt eine Nachricht mit einer Zahlenangabe von 1-XX. Dann nacheinander "/Bugrabber ZAHL" (Also 1 bis X durchgehen) - leider können sehr viele dort sein - Buggrabber nimmt es recht genau und sammelt auch Fehler, die keine sind. Sobald allerdings etwas mit kgpanels auftaucht den Chat kopieren (Obenrechts im Chatfenster sollte ein Kopiersymbol sein) und hier posten

Das gleiche gilt für TipTac, auch wenn es dort noch ein Problem geben könnte. Mit welcher Auflösung spielst du?

Grüße
Danke für die schnelle Antwort!

<string>:"DpsMid_OnLoad":27: in function "y"
kgPanels\kgPanels-1.17.lua:1115: in function "SetupScript"
kgPanels\kgPanels-1.17.lua:808: in function "InitScripts"
kgPanels\kgPanels-1.17.lua:794: in function "PlaceFrame"
kgPanels\kgPanels-1.17.lua:701: in function "ApplyLayout"
kgPanels\kgPanels-1.17.lua:500: in function <kgPanels\kgPanels.lua:496>
(tail call): ?
<in C code>

Ich habe es sowohl einmal mit den Bugs, als auch ohne versucht. Dies ist was für kgPanels dabei rumkommt, für TipTac gibt es allerdings keine Fehlermeldung.
Gehe dann mit deiner vermeintlichen Vermutung konform, dass das am meiner 1920x1080 Auflösung liegt.

edit// Ich habe BigWigs ausgetauscht und dafür DBM reingenommen, allerdings passiert das gleiche Problem auch mit BigWigs und ohne DBM.

MfG Jenjo
Jenjo is offline Report comment to moderator  
Reply With Quote
Unread 10-31-13, 12:13 PM  
Jenjo
A Kobold Labourer

Forum posts: 0
File comments: 4
Uploads: 0
Originally Posted by FaulTier
Originally Posted by Jenjo
Hi, zuerstmal Danke für das klasse UI!

Ich habe leider 2 kleine Probleme damit, ich hab zwar die 300 Comments einmal überflogen, aber das schien noch nicht als Problem aufgetreten zu sein.

Zuerstmal landet der Tooltip von TipTac jedesmal wenn ich mich neu einlogge unten links über dem Chat und ich muss jedes mal wieder in die Options gehen und Tooltip an die richtige Stelle ziehen. Hast du dafür eine Idee?

Das zweite Problem, dass ich habe, sind die Rahmen um Chat, untere Spellleisten und Skada (ich gehe mal von kgPanels aus). Auch diese verschwinden bei jedem einloggen und ab und zu auch einfach während des Spiels (sind nur durch /reload) zurück zuholen. Wenn ich aber /reload nutze, ist der Tooltip von Tiptac wieder über dem Chat. Kann das mit weiteren nicht wirklich klassenspezifischen Addons (z.b Decursive oder TellMeWhen) zusammen hängen?

Bei Bedarf lade ich auch gerne ein Screen hoch, falls die Beschreibung zu schwammig war.

MfG Jenjo

Moin und danke für das Lob

Dein Problem ist klar beschrieben und verständlich. Das andere AddOns das verursachen ist durchaus denkbar, vll. sogar die einzige Möglichkeit, außer du hast einige meiner eingebauten AddOns deaktiviert, da kgPanels ich meine bis auf 2,3 Ausnahmen jedes AddOn einbindet und wenn ein AddOn deaktiviert ist, wirft es das gesamte kgPanelsScript durcheinander, weshalb ab einem bestimmen Punkt viele Funktionen falsch sind.
Am besten machst du einmal folgendes:
Gib "/bugsack" ein und lösche alle vorhanden Fehler über den Button des Interfaces. Sobald dann wieder nach dem Einloggen der Fehler mit den Rändern auftritt, gibst du "/buggrabber" ein - danach kommt eine Nachricht mit einer Zahlenangabe von 1-XX. Dann nacheinander "/Bugrabber ZAHL" (Also 1 bis X durchgehen) - leider können sehr viele dort sein - Buggrabber nimmt es recht genau und sammelt auch Fehler, die keine sind. Sobald allerdings etwas mit kgpanels auftaucht den Chat kopieren (Obenrechts im Chatfenster sollte ein Kopiersymbol sein) und hier posten

Das gleiche gilt für TipTac, auch wenn es dort noch ein Problem geben könnte. Mit welcher Auflösung spielst du?

Grüße
Danke für die schnelle Antwort!

<string>:"DpsMid_OnLoad":27: in function "y"
kgPanels\kgPanels-1.17.lua:1115: in function "SetupScript"
kgPanels\kgPanels-1.17.lua:808: in function "InitScripts"
kgPanels\kgPanels-1.17.lua:794: in function "PlaceFrame"
kgPanels\kgPanels-1.17.lua:701: in function "ApplyLayout"
kgPanels\kgPanels-1.17.lua:500: in function <kgPanels\kgPanels.lua:496>
(tail call): ?
<in C code>

Ich habe es sowohl einmal mit den Bugs, als auch ohne versucht. Dies ist was für kgPanels dabei rumkommt, für TipTac gibt es allerdings keine Fehlermeldung.
Gehe dann mit deiner vermeintlichen Vermutung konform, dass das am meiner 1920x1080 Auflösung liegt.

MfG Jenjo
Jenjo is offline Report comment to moderator  
Reply With Quote
Unread 10-31-13, 09:48 AM  
FaulTier
A Theradrim Guardian
 
FaulTier's Avatar
AddOn Author - Click to view AddOns

Forum posts: 60
File comments: 175
Uploads: 5
Originally Posted by Jenjo
Hi, zuerstmal Danke für das klasse UI!

Ich habe leider 2 kleine Probleme damit, ich hab zwar die 300 Comments einmal überflogen, aber das schien noch nicht als Problem aufgetreten zu sein.

Zuerstmal landet der Tooltip von TipTac jedesmal wenn ich mich neu einlogge unten links über dem Chat und ich muss jedes mal wieder in die Options gehen und Tooltip an die richtige Stelle ziehen. Hast du dafür eine Idee?

Das zweite Problem, dass ich habe, sind die Rahmen um Chat, untere Spellleisten und Skada (ich gehe mal von kgPanels aus). Auch diese verschwinden bei jedem einloggen und ab und zu auch einfach während des Spiels (sind nur durch /reload) zurück zuholen. Wenn ich aber /reload nutze, ist der Tooltip von Tiptac wieder über dem Chat. Kann das mit weiteren nicht wirklich klassenspezifischen Addons (z.b Decursive oder TellMeWhen) zusammen hängen?

Bei Bedarf lade ich auch gerne ein Screen hoch, falls die Beschreibung zu schwammig war.

MfG Jenjo

Moin und danke für das Lob

Dein Problem ist klar beschrieben und verständlich. Das andere AddOns das verursachen ist durchaus denkbar, vll. sogar die einzige Möglichkeit, außer du hast einige meiner eingebauten AddOns deaktiviert, da kgPanels ich meine bis auf 2,3 Ausnahmen jedes AddOn einbindet und wenn ein AddOn deaktiviert ist, wirft es das gesamte kgPanelsScript durcheinander, weshalb ab einem bestimmen Punkt viele Funktionen falsch sind.
Am besten machst du einmal folgendes:
Gib "/bugsack" ein und lösche alle vorhanden Fehler über den Button des Interfaces. Sobald dann wieder nach dem Einloggen der Fehler mit den Rändern auftritt, gibst du "/buggrabber" ein - danach kommt eine Nachricht mit einer Zahlenangabe von 1-XX. Dann nacheinander "/Bugrabber ZAHL" (Also 1 bis X durchgehen) - leider können sehr viele dort sein - Buggrabber nimmt es recht genau und sammelt auch Fehler, die keine sind. Sobald allerdings etwas mit kgpanels auftaucht den Chat kopieren (Obenrechts im Chatfenster sollte ein Kopiersymbol sein) und hier posten

Das gleiche gilt für TipTac, auch wenn es dort noch ein Problem geben könnte. Mit welcher Auflösung spielst du?

Grüße
__________________
FaulTier is offline Report comment to moderator  
Reply With Quote
Unread 10-31-13, 05:33 AM  
Jenjo
A Kobold Labourer

Forum posts: 0
File comments: 4
Uploads: 0
Hi, zuerstmal Danke für das klasse UI!

Ich habe leider 2 kleine Probleme damit, ich hab zwar die 300 Comments einmal überflogen, aber das schien noch nicht als Problem aufgetreten zu sein.

Zuerstmal landet der Tooltip von TipTac jedesmal wenn ich mich neu einlogge unten links über dem Chat und ich muss jedes mal wieder in die Options gehen und Tooltip an die richtige Stelle ziehen. Hast du dafür eine Idee?

Das zweite Problem, dass ich habe, sind die Rahmen um Chat, untere Spellleisten und Skada (ich gehe mal von kgPanels aus). Auch diese verschwinden bei jedem einloggen und ab und zu auch einfach während des Spiels (sind nur durch /reload) zurück zuholen. Wenn ich aber /reload nutze, ist der Tooltip von Tiptac wieder über dem Chat. Kann das mit weiteren nicht wirklich klassenspezifischen Addons (z.b Decursive oder TellMeWhen) zusammen hängen?

Bei Bedarf lade ich auch gerne ein Screen hoch, falls die Beschreibung zu schwammig war.

MfG Jenjo
Last edited by Jenjo : 10-31-13 at 05:46 AM.
Jenjo is offline Report comment to moderator  
Reply With Quote
Unread 10-11-13, 11:32 AM  
Dothin
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
Re: Re: Re: Re: Rolling?

Originally Posted by FaulTier
Originally Posted by Dothin
Originally Posted by FaulTier
Originally Posted by Dothin
Hi, and thanks for a great UI.
Although the great work, i have a slight problem with it. I can't seem to roll when asked in instances.
I don't know if i miss something or if it's wrong with the UI.
Hope that you can help me!
Thanks.
Most likely, your screen resolution is under 1920x1080, I guess?
Even if it's not, please close all instances of WoW, open your WoW-Folder, navigate to \WTF\Account\"YOUR ACCOUNTNAME"\SavedVariables\ and delete the two files named teksLoot.lua and teksLoot.lua.bak.
After, log in, and type "/teksloot" in the chatframe - a grey bar should appear which you can drag'n'drop to your desired position for the rollbar(s). Right clock on it when you're finished

Greetings
'


Thanks again, it resolved my problem.
I wonder how i could cut down on the addons to optimate my running, cuz my computer arent that good. I still want to keep the UI but there's lots of addons that takes a lot of memory. How would you do?
The problem is - most AddOns are embedded with kgpanels in a way, so removing them would break the entire UI as kgpanels would fail functioning.

However - what is much memory for you? My AddOn don't use more then 23mb, even after a 9hour gaming session, UI overall (with blizz functions) is around 36mb.

Well, i don't really know the amount of memory. But my experience tells me that my computer would run the game better with lesser AddOns. However, your earlier reply tells that a cutoff would cause problem. I really fancy the UI, although i might look for a lighter one.

Thanks, All regards.
Dothin is offline Report comment to moderator  
Reply With Quote
Unread 10-11-13, 11:25 AM  
FaulTier
A Theradrim Guardian
 
FaulTier's Avatar
AddOn Author - Click to view AddOns

Forum posts: 60
File comments: 175
Uploads: 5
Re: Re: Re: Rolling?

Originally Posted by Dothin
Originally Posted by FaulTier
Originally Posted by Dothin
Hi, and thanks for a great UI.
Although the great work, i have a slight problem with it. I can't seem to roll when asked in instances.
I don't know if i miss something or if it's wrong with the UI.
Hope that you can help me!
Thanks.
Most likely, your screen resolution is under 1920x1080, I guess?
Even if it's not, please close all instances of WoW, open your WoW-Folder, navigate to \WTF\Account\"YOUR ACCOUNTNAME"\SavedVariables\ and delete the two files named teksLoot.lua and teksLoot.lua.bak.
After, log in, and type "/teksloot" in the chatframe - a grey bar should appear which you can drag'n'drop to your desired position for the rollbar(s). Right clock on it when you're finished

Greetings
'


Thanks again, it resolved my problem.
I wonder how i could cut down on the addons to optimate my running, cuz my computer arent that good. I still want to keep the UI but there's lots of addons that takes a lot of memory. How would you do?
The problem is - most AddOns are embedded with kgpanels in a way, so removing them would break the entire UI as kgpanels would fail functioning.

However - what is much memory for you? My AddOn don't use more then 23mb, even after a 9hour gaming session, UI overall (with blizz functions) is around 36mb.
__________________
FaulTier is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.