Download
(171 Kb)
Download
Updated: 01-30-14 07:07 PM
Pictures
File Info
Compatibility:
Siege of Orgrimmar (5.4)
Updated:01-30-14 07:07 PM
Created:07-30-09 02:23 PM
Downloads:7,577
Favorites:98
MD5:
5.4
Reputation Bars  Popular! (More than 5000 hits)
Version: v1.2.4
by: PontusM, mjumnito
DESCRIPTION

Reputation Bars is a modular addon that lets you watch one or more faction standings, i.e. the amount of reputation you have with them. It can be used to track specific factions or automatically track the ones you gain rep with. It is especially useful for those with custom UIs that no longer have the default Blizzard rep bar available.

You can use this while leveling to see your reputation bar or simply as a way to show you how much you have left for various factions as you grind your way to exalted...

FEATURES
* WatchBar module replaces the default Blizzard reputation watch bar.
* WatchBar tracks the currently active faction (similar to Blizzards built in bar).
* WatchBar can automatically switch the active faction to the one you gain reputation with.
* AutoBars module that automatically tracks recently gained reputation.
* StaticBars module to track specific factions that you specify.
* Automatically fadeout bars when no reputation has been gained for a while to avoid cluttering your UI.
* All bars can be customized in order to fit most UI configurations (supports SharedMedia for a larger variety of fonts and bar textures).
* Simply disable any modules you don't need through the configuration UI.

I recommend that you also install the SharedMedia addon for a larger variety of fonts and bar textures.

CONFIGURATION

Configuration is done using the Blizzard addon configuration interface. You can right click on the title bar to open it, or use the slash command /rptb.

CONTRIBUTE

Please visit http://wow.curseforge.com/addons/rep.../localization/ if you want to help out with translations.
v1.2.4
-hopefully fixed bug where unguilded toons was causing rep not to populate correctly

v1.2.3
-Fixed rep display if a toon is unguilded *thanks trent2*

v1.2.2
-fixed display display issue where rep earned was not showing correctly

v1.2.1.1a
Found another bug and fixed it

v1.2.1.1
fixed known bug in last version

v1.2.1
-Mjumnito added as Co-Author
-fixed calls to work with current live version 5.2
Known bug:
When selecting a rep such as Gina Mudclaw an error is produced. Working on fix for this

v1.2.0
-Updated for MoP

v1.1.18
-Upgraded to latest libbars

v1.1.17
-Updated for 4.3
-Added command line support

v1.1.16
-Fixed broken locale files

v1.1.15
-Improved guild reputation detection to work for any locale (thanks Dridzt!)
-Added some translations for traditional and simplified Chinese

v1.1.14
-Guild reputation fixed (thanks cmtitan!)

v1.1.13
-Updated toc

v1.1.12
-Solved a bug regarding guild reputation not being shown at login

v1.1.11
-Now support guild reputation as well (thanks to cmtitan!)

v1.1.10
-Added the ability to hide all bars from the config UI.
-Fixed a sorting bug in StaticBars.
-Fixed a bug when factions have been collapsed in the Blizzard UI.

v1.1.9
-Updated for 4.0.1

v1.1.8
-Updated toc for 3.3

v1.1.7
-AutoBars now show the accumulated rep gained during the session.

v1.1.6
-Fixed another missing lib dependency (doh!)

v1.1.5
-Fixed a lot of missing Ace dependencies
-Corrected a bug in AutoBars causing the bar animations to go all poopy
-Fixed an issue with the WatchBar being displayed in front of the Blizzard default graphics

v1.1.4
-StaticBars will now sort the bars alphabetically

v1.1.3
-StaticBars now show up correctly at login

v1.1.2
-Updated toc

v1.1.1
-Bars can now grow upwards

v1.1.0.54
-Added StaticBars module

v1.0.0.52
-Changed how rep is sent to the sub modules
-AutoBars can now ignore splash rep
-Ability to reset position of bars

v1.0.0.51
-WatchBar now replaces built in rep bar by default
-AutoBar bugs fixed
-Rearranged settings for better usability
-Fixed WatchBar mouse over text behavior
Optional Files (1)
File Name
Version
Size
Author
Date
Type
1.2.0.1
171kB
12-08-12 10:38 AM
Patch


Archived Files (17)
File Name
Version
Size
Author
Date
v1.2.3
163kB
PontusM
11-03-13 02:34 PM
v1.2.2
170kB
PontusM
05-12-13 01:58 PM
v1.2.1.2
171kB
PontusM
05-12-13 10:17 AM
v1.2.1.1a
171kB
PontusM
05-10-13 01:31 PM
v1.2.1.1
171kB
PontusM
05-10-13 01:19 PM
v1.2.1
171kB
PontusM
05-10-13 11:23 AM
v1.2.0
171kB
PontusM
11-03-12 08:03 AM
v1.1.18
171kB
PontusM
12-04-11 06:51 AM
v1.1.17
171kB
PontusM
12-04-11 04:23 AM
v1.1.16
170kB
PontusM
07-10-11 12:29 AM
v1.1.15
170kB
PontusM
07-09-11 11:19 AM
v1.1.14
168kB
PontusM
07-09-11 03:51 AM
v1.1.13
167kB
PontusM
05-01-11 09:24 AM
v1.1.12
167kB
PontusM
03-05-11 06:39 AM
v1.1.11
167kB
PontusM
02-20-11 03:09 AM
v1.1.10
163kB
PontusM
11-10-10 02:17 PM
v1.1.9
162kB
PontusM
10-16-10 09:49 AM


Post A Reply Comment Options
Unread 11-10-13, 04:22 PM  
darniil
A Defias Bandit

Forum posts: 2
File comments: 5
Uploads: 0
Re: Re: Re: no factions

Originally Posted by trent2
Are you running the version that we just updated? If so, did the problem begin at that point or has the update made no difference? I'll do some testing, but let me know.
Looks like I'm running version 1.2.3, released 3 November 2013.

I'm not entirely sure when it started, but I just noticed it very recently (within the past week), so it's possible that it started with this version.
darniil is offline Report comment to moderator  
Reply With Quote
Unread 11-10-13, 10:53 AM  
trent2
A Kobold Labourer
 
trent2's Avatar

Forum posts: 0
File comments: 14
Uploads: 0
Re: Re: no factions

Originally Posted by darniil
I'm encountering something similar to this. Similar, but not identical.
Are you running the version that we just updated? If so, did the problem begin at that point or has the update made no difference? I'll do some testing, but let me know.
trent2 is offline Report comment to moderator  
Reply With Quote
Unread 11-09-13, 03:05 PM  
darniil
A Defias Bandit

Forum posts: 2
File comments: 5
Uploads: 0
Re: no factions

Originally Posted by trent2
shows no factions to choose from under Static Bars.
I'm encountering something similar to this. Similar, but not identical.

For starters, all of my characters are guilded. Secondly, I'm seeing some factions in Static Bars, but not all of them. Thirdly, different characters see different factions available. My rogue, for example, sees all of the individual Tillers, as well as the major factions for MoP, but nothing from any previous expansion (except for the Syndicate). My priest sees none of the individual Tillers, does see the various Steamwheedle Cartel factions, Darkmoon Faire, the Brawlers Guild, and a few others. My paladin only sees the major MoP factions, no individual Tillers, and nothing from any earlier expansion.

And this is with no other addons but Reputation Bars running.

To add to the peculiarity, when I first logged on my priest this morning, I only had four or five different factions showing up in Static Bars. I went through a wing of SoO, and by the time I was done, I had the above-mentioned factions show back up.

At this point, I'm not sure what the problem is. If anyone has any ideas how to figure out whether or not the problem lies with Reputation Bars, I'd be willing to help test those ideas.
darniil is offline Report comment to moderator  
Reply With Quote
Unread 11-03-13, 02:41 PM  
mjumnito
A Flamescale Wyrmkin
 
mjumnito's Avatar
AddOn Author - Click to view AddOns

Forum posts: 106
File comments: 13
Uploads: 1
Re: no factions

Originally Posted by trent2
Well, I've finally been able to devote some time to this problem and I'm happy to report that I've been able to solve the problem.

Please change line 117 from

if not name or name == lastName then break end

to

if not name or name == "Inactive" then break end

The issue stems from the toon not being guilded. If you guild the toon, the issue disappears in the current code. Make the change above and it doesn't matter if the toon is guilded or not.

Updated, thanks for finding it. Been a little busy IRL. Also gave credit where credit was due
mjumnito is offline Report comment to moderator  
Reply With Quote
Unread 11-03-13, 10:59 AM  
trent2
A Kobold Labourer
 
trent2's Avatar

Forum posts: 0
File comments: 14
Uploads: 0
no factions

Well, I've finally been able to devote some time to this problem and I'm happy to report that I've been able to solve the problem.

Please change line 117 from

if not name or name == lastName then break end

to

if not name or name == "Inactive" then break end

The issue stems from the toon not being guilded. If you guild the toon, the issue disappears in the current code. Make the change above and it doesn't matter if the toon is guilded or not.

Last edited by trent2 : 11-03-13 at 11:37 AM.
trent2 is offline Report comment to moderator  
Reply With Quote
Unread 10-05-13, 04:10 AM  
trent2
A Kobold Labourer
 
trent2's Avatar

Forum posts: 0
File comments: 14
Uploads: 0
Re: Re: no factions

Originally Posted by mjumnito
Originally Posted by trent2
I've noticed the same issue on another character, an 85 undead rogue named Trikkin. He also shows no factions.
after looking up your toons via the web site. it says they are inactive or cant retrive the profile for either. I think its safe to say that its a blizz problem (code wise), sorry I couldnt find a way around it
http://us.battle.net/wow/en/characte...Jessyck/simple

http://us.battle.net/wow/en/characte...Trikkin/simple

Odd, I can access both just fine via the BattleNet/Blizzard website. Also, RepCalc works fine with both toons. It's not a Blizzard issue.
Last edited by trent2 : 10-05-13 at 04:11 AM.
trent2 is offline Report comment to moderator  
Reply With Quote
Unread 09-30-13, 11:16 AM  
mjumnito
A Flamescale Wyrmkin
 
mjumnito's Avatar
AddOn Author - Click to view AddOns

Forum posts: 106
File comments: 13
Uploads: 1
Re: no factions

Originally Posted by trent2
I've noticed the same issue on another character, an 85 undead rogue named Trikkin. He also shows no factions.
after looking up your toons via the web site. it says they are inactive or cant retrive the profile for either. I think its safe to say that its a blizz problem (code wise), sorry I couldnt find a way around it
mjumnito is offline Report comment to moderator  
Reply With Quote
Unread 09-21-13, 01:18 AM  
trent2
A Kobold Labourer
 
trent2's Avatar

Forum posts: 0
File comments: 14
Uploads: 0
no factions

I've noticed the same issue on another character, an 85 undead rogue named Trikkin. He also shows no factions.
trent2 is offline Report comment to moderator  
Reply With Quote
Unread 09-02-13, 01:43 AM  
trent2
A Kobold Labourer
 
trent2's Avatar

Forum posts: 0
File comments: 14
Uploads: 0
Originally Posted by mjumnito
Very odd indeed. I had heard of a single toon not pulling the required info from the servers before, but i thought they sorted that all out a while back. just out of curiosity does it do the same thing with other rep addons? RepCalcReputationBars for example is close in style to this addon although a little differently. If you don't mind trying it out, could you see if it works for the loner toon (Jessyck). If it does ill dig though the code and see how distnz managed to get around the problem
RepCalc works flawlessly, but looks like crap next to ReputationBars. No errors. RepCalc works for all toons including Jessyck.
Last edited by trent2 : 09-14-13 at 05:21 AM.
trent2 is offline Report comment to moderator  
Reply With Quote
Unread 08-23-13, 01:51 PM  
mjumnito
A Flamescale Wyrmkin
 
mjumnito's Avatar
AddOn Author - Click to view AddOns

Forum posts: 106
File comments: 13
Uploads: 1
Very odd indeed. I had heard of a single toon not pulling the required info from the servers before, but i thought they sorted that all out a while back. just out of curiosity does it do the same thing with other rep addons? RepCalcReputationBars for example is close in style to this addon although a little differently. If you dont mind trying it out, could you see if it works for the loner toon (Jessyck). If it does ill dig though the code and see how distnz managed to get around the problem
Last edited by mjumnito : 08-23-13 at 01:54 PM.
mjumnito is offline Report comment to moderator  
Reply With Quote
Unread 08-23-13, 06:20 AM  
trent2
A Kobold Labourer
 
trent2's Avatar

Forum posts: 0
File comments: 14
Uploads: 0
After deleting the ReputationBars addon entirely and downloading 1.22 from this site, this is the error I got from BugSack.

1x Libs\6AceGUI-3.0-33\widgets\AceGUIWidget-Button.lua:66: CreateFrame(): Couldn"t find inherited node "UIPanelButtonTemplate2"
<in C code>
Libs\6AceGUI-3.0-33\widgets\AceGUIWidget-Button.lua:66: in function "?"
Libs\AceGUI-3.0\AceGUI-3.0-33.lua:136: in function <Libs\AceGUI-3.0\AceGUI-3.0.lua:125>
Libs\AceGUI-3.0\AceGUI-3.0-33.lua:174: in function "Create"
AceConfigDialog-3.0\AceConfigDialog-3.0-54.lua:1116: in function <AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1054>
AceConfigDialog-3.0\AceConfigDialog-3.0-54.lua:1581: in function "FeedGroup"
AceConfigDialog-3.0\AceConfigDialog-3.0-54.lua:1506: in function <AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1486>
(tail call): ?
<in C code>
<string>:"safecall Dispatcher[3]":9: in function <string>:"safecall Dispatcher[3]":5
(tail call): ?

Libs\AceGUI-3.0\AceGUI-3.0-33.lua:314: in function "Fire"
Libs\AceGUI-3.0\AceGUI-3.0-33.lua:314: in function "Fire"
widgets\AceGUIContainer-BlizOptionsGroup.lua:20: in function <widgets\AceGUIContainer-BlizOptionsGroup.lua:19>
<in C code>
FrameXML\InterfaceOptionsFrame.lua:28: in function "InterfaceOptionsList_DisplayPanel"
FrameXML\InterfaceOptionsFrame.lua:46: in function "InterfaceOptionsListButton_OnClick"
<string>:"*:OnClick":2: in function <string>:"*:OnClick":1

Locals:
nil

My next step is to install WOW on a different machine that's never had wow. Install only this addon along with BugSack and see what happens.

EDIT:
I installed a fresh OS on my laptop, updated it etc. Installed wow. installed BugSack and ReputationBars and signed onto my account. I get the same error listed above on all toons, however all toons have reputations listed and update/work fine except Jessyck. So it appears the error we're getting has no relation to the problem I'm having.
Last edited by trent2 : 08-23-13 at 07:34 AM.
trent2 is offline Report comment to moderator  
Reply With Quote
Unread 08-23-13, 04:10 AM  
trent2
A Kobold Labourer
 
trent2's Avatar

Forum posts: 0
File comments: 14
Uploads: 0
I'll do that, but why are my other toons fine?

Originally Posted by mjumnito
I need you to try something for me. Delete the addon folder for "Reputation Bars" and redownload the one here on the site. From the looks of it some of the libs may have gotten updated. see if that corrects the problem
trent2 is offline Report comment to moderator  
Reply With Quote
Unread 08-17-13, 10:51 AM  
mjumnito
A Flamescale Wyrmkin
 
mjumnito's Avatar
AddOn Author - Click to view AddOns

Forum posts: 106
File comments: 13
Uploads: 1
I need you to try something for me. Delete the addon folder for "Reputation Bars" and redownload the one here on the site. From the looks of it some of the libs may have gotten updated. see if that corrects the problem
mjumnito is offline Report comment to moderator  
Reply With Quote
Unread 08-16-13, 04:45 AM  
trent2
A Kobold Labourer
 
trent2's Avatar

Forum posts: 0
File comments: 14
Uploads: 0
no factions.. continued

Disabling all the other addons seems to have done the trick. I installed bugsack to capture this...


1x Libs\6AceGUI-3.0-33\widgets\AceGUIWidget-Button.lua:66: CreateFrame(): Couldn"t find inherited node "UIPanelButtonTemplate2"
<in C code>
Libs\6AceGUI-3.0-33\widgets\AceGUIWidget-Button.lua:66: in function "?"
Libs\AceGUI-3.0\AceGUI-3.0-33.lua:136: in function <Libs\AceGUI-3.0\AceGUI-3.0.lua:125>
Libs\AceGUI-3.0\AceGUI-3.0-33.lua:174: in function "Create"
AceConfigDialog-3.0\AceConfigDialog-3.0-54.lua:1116: in function <AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1054>
AceConfigDialog-3.0\AceConfigDialog-3.0-54.lua:1581: in function "FeedGroup"
AceConfigDialog-3.0\AceConfigDialog-3.0-54.lua:1506: in function <AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1486>
(tail call): ?
<in C code>
<string>:"safecall Dispatcher[3]":9: in function <string>:"safecall Dispatcher[3]":5
(tail call): ?
Libs\AceGUI-3.0\AceGUI-3.0-33.lua:314: in function "Fire"
Libs\AceGUI-3.0\AceGUI-3.0-33.lua:314: in function "Fire"
widgets\AceGUIContainer-BlizOptionsGroup.lua:20: in function <widgets\AceGUIContainer-BlizOptionsGroup.lua:19>
<in C code>
FrameXML\InterfaceOptionsFrame.lua:28: in function "InterfaceOptionsList_DisplayPanel"
FrameXML\InterfaceOptionsFrame.lua:46: in function "InterfaceOptionsListButton_OnClick"
<string>:"*:OnClick":2: in function <string>:"*:OnClick":1

Locals:
nil


Hope that can point you in the right direction
trent2 is offline Report comment to moderator  
Reply With Quote
Unread 08-14-13, 09:48 PM  
trent2
A Kobold Labourer
 
trent2's Avatar

Forum posts: 0
File comments: 14
Uploads: 0
I turned swatter off and loaded up the toon. No errors, just no factions. After work today, I'm going to disable all addons except Reputation Bars and see if that makes any difference. She's not running anything that all the other toons aren't, but it's worth poking a stick at. I'll let you know.
trent2 is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: