Download
(2 Kb)
Download
Updated: 04-10-10 01:13 PM
Pictures
File Info
Updated:04-10-10 01:13 PM
Created:08-07-09 08:37 PM
Downloads:21,941
Favorites:136
MD5:
aTotemBar  Popular! (More than 5000 hits)
Version: 1.0a
by: Arimis [More]
aTotemBar is a simple totem addon that allows you to move, hide, and scale Blizzard's Default Totem Bar.

Its compatible with most other bar mods:
For Bartender4, Disable the Totem Bar
For Dominos, Disable the Dominos_Totem addon
For rActionBarStyler, no changes needed.

Commands:
/atbar lock
- This toggles the bar position lock. When the frame is black the bar is dragable.

/atbar hide
- This toggles the visibility of the bar

/atbar scale x.x
- Sets the scale of the bar, replace x.x with numbers (ie: 0.9)

**OmniCC or a similar addon is required to add numbers to the timers.
Version 1.0a:
Button Spacing: Adjust in the .LUA

Version 1.0:
Changed the Shaman and Level checks to use the same mechanics that Blizzard has built-in. (Hopefully no more random Nil errors)
Rewrote all the timers to be more efficient. It will also clear the timers when your totems are destroyed from out ranging them.
Default Value should now be set properly upon first run.
Corrected Right-Click to destroy totems.
Timers can now be disabled by setting "aTotemBarTimers = false" in the .lua
Blizzards Timers can now be disabled by setting "BlizzardTimers = false" in the .lua
*Both timers are enabled by default.
**If you're updating, you can safely delete embeds.xml from this addon's folder.

Version 0.8:
TOC Bumped for 3.3
Timers added (Consider this a Beta feature for the time being) *Option to disable coming shortly

Version 0.7:
Shaman Check revised again. Checking for Shaman and Level 30 or greater instead of checking for the default bars existence.

Version 0.6:
Shaman Check Take 2 - Removed the OnLoad() in favor of a check elsewhere (based on Tukz Feedback)

Version 0.5:
Now disables if you're not a Shaman or if you don't have the new Totem Bar yet. - Thanks Tukz
Fixed a small typo.

Version 0.4:
Reworked the frame code to use a completely custom frame instead of attempting to control the default. This should take care of the occasionally position loss.
User Request - Added a command to set the scale.

Version 0.2:
Removed the disable based on class code for the time being.
Tweaked the startup function a little bit.
Optional Files (0)


Archived Files (8)
File Name
Version
Size
Author
Date
1.0
2kB
Arimis
04-09-10 09:07 AM
0.8b
3kB
Arimis
02-20-10 03:24 PM
0.7
2kB
Arimis
08-13-09 05:54 AM
0.6
2kB
Arimis
08-10-09 10:47 AM
0.5
2kB
Arimis
08-10-09 07:01 AM
0.4
2kB
Arimis
08-08-09 07:52 PM
0.3
2kB
Arimis
08-08-09 06:15 AM
0.1
2kB
Arimis
08-07-09 08:37 PM


Post A Reply Comment Options
Unread 04-13-10, 06:04 PM  
cudgel
Premium Member

Forum posts: 8
File comments: 5
Uploads: 0
ButtonFacade Support?

Does this AddOn support ButtonFacade? If not, could it?
cudgel is offline Report comment to moderator  
Reply With Quote
Unread 04-12-10, 12:22 PM  
seebs
Premium Member
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 155
File comments: 185
Uploads: 5
Originally posted by Arimis
Very interesting issue. The buttons should be childs of the slots, which is why I didn't think it needed to be there.

Using a bar mod of any kind, so I can test it as close to exact as possible?
I'm using Macaroon! -- didn't think to check whether that affected it, but I bet it does, as I think it hides the default Blizzard totem bar. D'oh! Shoulda thought of that. I might have another look at it there.

And you're right, the buttons should be parented to the slots. My bad.
seebs is offline Report comment to moderator  
Reply With Quote
Unread 04-12-10, 10:05 AM  
nin
A Cobalt Mageweaver
AddOn Author - Click to view AddOns

Forum posts: 210
File comments: 77
Uploads: 1
Originally posted by Arimis
Default position and no timers sounds like you're getting an error (that you may not be seeing) and it's going to the games default. I'll try to reproduce.
yeh im aware, was just thinking if someone tried to reposition it and being too hasty with the /reloadui before locking it again..
nin is offline Report comment to moderator  
Reply With Quote
Unread 04-12-10, 04:42 AM  
Arimis
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 50
Uploads: 1
Originally posted by seebs
Ah-hah! Missing setparents for the action buttons.

Here's my loop to initialize all four slot buttons and all 12 action buttons:

Code:
local prev_button = MultiCastSummonSpellButton
for i=1, 4 do
        local b = _G["MultiCastSlotButton"..i]
        b:SetParent(aTotemBar)
        b:ClearAllPoints()
        b:SetPoint("LEFT", prev_button, "RIGHT", spacing, 0)
        for j=0, 2 do
                local idx = (j * 4) + i
                local b2 = _G["MultiCastActionButton"..idx]
                b2:SetParent(aTotemBar)
                b2:ClearAllPoints()
                b2:SetPoint("CENTER", b, "CENTER", 0, 0)
        end
        prev_button = b
end
Note that I still haven't got arrows working, but now at least I can see the totems.

ETA: Oh, this is weird. Relogged and it only showed the third and forth totems. No idea why. I've gone back to the February version for now.
Very interesting issue. The buttons should be childs of the slots, which is why I didn't think it needed to be there.

Using a bar mod of any kind, so I can test it as close to exact as possible?
Arimis is offline Report comment to moderator  
Reply With Quote
Unread 04-11-10, 06:31 PM  
seebs
Premium Member
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 155
File comments: 185
Uploads: 5
Ah-hah! Missing setparents for the action buttons.

Here's my loop to initialize all four slot buttons and all 12 action buttons:

Code:
local prev_button = MultiCastSummonSpellButton
for i=1, 4 do
        local b = _G["MultiCastSlotButton"..i]
        b:SetParent(aTotemBar)
        b:ClearAllPoints()
        b:SetPoint("LEFT", prev_button, "RIGHT", spacing, 0)
        for j=0, 2 do
                local idx = (j * 4) + i
                local b2 = _G["MultiCastActionButton"..idx]
                b2:SetParent(aTotemBar)
                b2:ClearAllPoints()
                b2:SetPoint("CENTER", b, "CENTER", 0, 0)
        end
        prev_button = b
end
Note that I still haven't got arrows working, but now at least I can see the totems.

ETA: Oh, this is weird. Relogged and it only showed the third and forth totems. No idea why. I've gone back to the February version for now.
Last edited by seebs : 04-11-10 at 09:22 PM.
seebs is offline Report comment to moderator  
Reply With Quote
Unread 04-11-10, 06:16 PM  
seebs
Premium Member
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 155
File comments: 185
Uploads: 5
First thing figured out: You are missing a SetParent(aTotemBar) for MultiCastRecallSpellButton. Adding that makes me get all six buttons (the totem-set-picker and the four totems).

BTW, this is probably nothing, but... The totem-set-picker button is a border width or so higher than the others.
seebs is offline Report comment to moderator  
Reply With Quote
Unread 04-11-10, 05:46 PM  
seebs
Premium Member
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 155
File comments: 185
Uploads: 5
Yup, the April 10th download. I get a (working) button for Call of the Elements, and next to it are green, red, teal, and purple totem icons with no specific totems in them. There is no totemic recall button. The five buttons I do have get arrows above them on mouseover, but clicking the arrows does nothing. If I back out to an older version (from more than a week ago, don't remember how far back), it all works.

/atbar hide toggles this bar, and /atbar lock lets me move it around.

Removing the savedvariables file moves it to the middle of the screen but changes nothing else (which is what I'd expect).

I have a spare half-hour, I'ma debug this a bit.
seebs is offline Report comment to moderator  
Reply With Quote
Unread 04-11-10, 08:52 AM  
Darxon
A Warpwood Thunder Caller
AddOn Compiler - Click to view compilations

Forum posts: 91
File comments: 65
Uploads: 2
i forgot to say, this is best totem addon there is

edit: im usuing; nMainbar if that matters, usuing the previous version of atotembar (1.0) fixes the errors
__________________
Wafflez - Shattered Hand EU
Last edited by Darxon : 04-11-10 at 09:26 AM.
Darxon is offline Report comment to moderator  
Reply With Quote
Unread 04-11-10, 08:43 AM  
Arimis
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 50
Uploads: 1
Originally posted by Darxon
got the same issue, the bar resets every time i /rl or logout.

and i domt have any timers
Default position and no timers sounds like you're getting an error (that you may not be seeing) and it's going to the games default. I'll try to reproduce.
Arimis is offline Report comment to moderator  
Reply With Quote
Unread 04-11-10, 08:41 AM  
Arimis
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 50
Uploads: 1
Originally posted by nin
when this happens are you doing /atbarlock after you got the bars where you wanted?

for me it resets sometimes if i don't use that command again after moving them.
You should use lock to allow movement and also to stop movement. I'll change it so you don't have to lock afterwards, but you will have to lock to keep from accidentally dragging it away.
Arimis is offline Report comment to moderator  
Reply With Quote
Unread 04-11-10, 06:41 AM  
Darxon
A Warpwood Thunder Caller
AddOn Compiler - Click to view compilations

Forum posts: 91
File comments: 65
Uploads: 2
got the same issue, the bar resets every time i /rl or logout.

and i domt have any timers
__________________
Wafflez - Shattered Hand EU
Darxon is offline Report comment to moderator  
Reply With Quote
Unread 04-11-10, 04:22 AM  
Ardhkor
A Kobold Labourer

Forum posts: 0
File comments: 17
Uploads: 0
of course I use the cvar /atbar lock
Ardhkor is offline Report comment to moderator  
Reply With Quote
Unread 04-11-10, 04:06 AM  
nin
A Cobalt Mageweaver
AddOn Author - Click to view AddOns

Forum posts: 210
File comments: 77
Uploads: 1
Originally posted by Ardhkor
With the new version 1.0a, the arrows works perfectly and all functionalities works.
But the bar position reset after all /reload, deconnection and exit.
when this happens are you doing /atbarlock after you got the bars where you wanted?

for me it resets sometimes if i don't use that command again after moving them.
nin is offline Report comment to moderator  
Reply With Quote
Unread 04-11-10, 02:50 AM  
seebs
Premium Member
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 155
File comments: 185
Uploads: 5
Originally posted by Arimis
Is that with today's update as well?
I thought it was, but it's possible that I got confused. I'll retry.
seebs is offline Report comment to moderator  
Reply With Quote
Unread 04-11-10, 01:38 AM  
Ardhkor
A Kobold Labourer

Forum posts: 0
File comments: 17
Uploads: 0
With the new version 1.0a, the arrows works perfectly and all functionalities works.
But the bar position reset after all /reload, deconnection and exit.
Ardhkor is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: