Minion Beta! - Help us test our new AddOn updater. Get it now!
Download
(5 Kb)
Download
Updated: 12-11-09 10:34 AM
Pictures
File Info
Updated:12-11-09 10:34 AM
Created:10-28-09 11:07 AM
Downloads:7,205
Favorites:34
MD5:

femtoBuff  Popular! (More than 5000 hits)

Version: r7
by: Soeters [More]

I've stopped playing WoW, so this addon won't be updated again, at least not by me.
If someone feels like updating it, just PM me.


Overview

What I wanted to have is a simple buff mover,where I could move buffs, debuffs and weapons enchants easily without needing a GUI.
So, I created this addon that basicly has just the needed things.

The addon now has a little config file at the top of core.lua

Features

  • Move buffs, debuffs and temporary enchants independently
  • Stylize a little bit the buffs (more options will soon come)
  • ButtonFacade support
  • rActionButtonStyler support, assuming you use the normal path (/media/gloss for the main texture) Not working with debuffs
  • No GUI
  • A little memory usage (~= 20 kB)

How to move the buttons ?

It's easy, just type /fb or /femtobuff and anchors will appear. Then Alt-Drag the anchors and buttons should move.

r7
Fixed a debuff anchor problem

r6
Pretty hackish way to fix temporary enchants bugs

r5
Debuffs will no longer cause the game crash
Debuffs styling disabled with rABS (not working)

r4
TOC update
Consolidated buff option handled

r3
New handling system for rABS and BF
Should be more CPU-friendly (test needed although)

r2
rActionButtonStyler support
Stylize the default buff frame
Optional Files (0)


Archived Files (2)
File Name
Version
Size
Author
Date
r6
5kB
Soeters
12-10-09 02:46 PM
r5
5kB
Soeters
12-09-09 09:57 AM


Post A Reply Comment Options
Unread 12-12-09, 08:01 AM  
braudrist
A Kobold Labourer

Forum posts: 0
File comments: 7
Uploads: 0
How come my icon are so dark? Even with brightness at 100%, they still look dark
braudrist is offline Report comment to moderator  
Reply With Quote
Unread 12-12-09, 06:13 AM  
Soeters
A Warpwood Thunder Caller
 
Soeters's Avatar
AddOn Author - Click to view AddOns

Forum posts: 97
File comments: 206
Uploads: 21
The skinning, i.e. duration, timers, scale and so on, will be more precise with the next version.
At this time I don't know when this version will be released
__________________
Soeters is offline Report comment to moderator  
Reply With Quote
Unread 12-11-09, 08:05 PM  
Cowberty
A Murloc Raider

Forum posts: 8
File comments: 40
Uploads: 0
for the scaling of buffs, adding this line of code should work for you:

Code:
BuffFrame:SetScale(1)
just change the 1 to somthing like 0.5 that. Don't know if it's the best way to do this, but it works. :P
Cowberty is offline Report comment to moderator  
Reply With Quote
Unread 12-11-09, 05:31 PM  
Pixol
A Deviate Faerie Dragon
AddOn Author - Click to view AddOns

Forum posts: 13
File comments: 62
Uploads: 8
"Basic config with ButtonFacade"

After applying the texture... My timers look nothing like what it looks like in the pictures. The timer blocks the top one fourth of my buff icon. The fonts ugly and big. The lua doesn't look straight forward for editing timer fonts and such. That doesn't seem like a basic config

Edit:
Nevermind I found out where the timers were, named durations.
dur:SetFont("Fonts\\FRIZQT__.ttf",fBSettings.DurationSize,"THINOUTLINE")
dur:SetPoint("BOTTOM",button,0,-5)
dur:SetDrawLayer"OVERLAY"
lbf.lua
and size adjustments at the top of core.lua
Last edited by Pixol : 12-11-09 at 06:21 PM.
Pixol is offline Report comment to moderator  
Reply With Quote
Unread 12-11-09, 10:37 AM  
Soeters
A Warpwood Thunder Caller
 
Soeters's Avatar
AddOn Author - Click to view AddOns

Forum posts: 97
File comments: 206
Uploads: 21
Originally posted by Arethea
Is there some option to make the debuff move down when you get a lot of buff rows? like i have it set up the buffs covers the debuffs so i had to move the debuff anchor down even more. No biggie just wondering if there is a way for the debuffs to move down by them selves.

Also, is there any way to scale the buffs/debuffs/weapon enchant? i looked through the lua really quickly but im a total newb when it comes to lua so couldnt find any option for it.
For the covering I'll look for this but I don't think that'll be added.

For the scale that can be easily done, surely in r8 when the skinning will be more complete.

PS: I finally resolved all the bugs caused by the 3.3 so everything should (yeah I can't do better than that) work
__________________
Soeters is offline Report comment to moderator  
Reply With Quote
Unread 12-11-09, 10:22 AM  
Arethea
A Kobold Labourer

Forum posts: 0
File comments: 18
Uploads: 0
Is there some option to make the debuff move down when you get a lot of buff rows? like i have it set up the buffs covers the debuffs so i had to move the debuff anchor down even more. No biggie just wondering if there is a way for the debuffs to move down by them selves.

Also, is there any way to scale the buffs/debuffs/weapon enchant? i looked through the lua really quickly but im a total newb when it comes to lua so couldnt find any option for it.
Arethea is offline Report comment to moderator  
Reply With Quote
Unread 12-11-09, 08:33 AM  
Soeters
A Warpwood Thunder Caller
 
Soeters's Avatar
AddOn Author - Click to view AddOns

Forum posts: 97
File comments: 206
Uploads: 21
Originally posted by Arethea
The weapon enchant is working as intended for me now. Everything is just perfect and just like i want it. Thank you very much for fixing it
Even though I fixed it, I have some problems with the debuff anchor which are pretty hard to fix
__________________
Soeters is offline Report comment to moderator  
Reply With Quote
Unread 12-11-09, 06:21 AM  
Arethea
A Kobold Labourer

Forum posts: 0
File comments: 18
Uploads: 0
The weapon enchant is working as intended for me now. Everything is just perfect and just like i want it. Thank you very much for fixing it
Arethea is offline Report comment to moderator  
Reply With Quote
Unread 12-11-09, 01:30 AM  
Soeters
A Warpwood Thunder Caller
 
Soeters's Avatar
AddOn Author - Click to view AddOns

Forum posts: 97
File comments: 206
Uploads: 21
The problem, known but I can do nothing against it, is that you only Alt-Clicked the anchor, and have not dragged it, so you have empty data for the debuff anchor like shown in the saved vars, and you get the error you also posted.

For the temp. enchants I'm working on it but that's long, and difficult

Edit: After some investigation I got absolutely no problem with the temp. enchants
__________________
Last edited by Soeters : 12-11-09 at 05:56 AM.
Soeters is offline Report comment to moderator  
Reply With Quote
Unread 12-10-09, 06:27 PM  
karmamuscle
Premium Member
 
karmamuscle's Avatar
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 196
File comments: 164
Uploads: 1
Ok, just got the error below on my priest, not that I assume my class has anything to do with it.

Using r6.

Code:
Message: ..\AddOns\femtoBuff\core.lua line 54:
   attempt to perform arithmetic on field '?' (a nil value)
Debug:
   [C]: ?
   femtoBuff\core.lua:54: CreateDebuffAnchor()
   femtoBuff\core.lua:96: InitMove()
   femtoBuff\core.lua:116: ?()
   femtoBuff\core.lua:10:
      femtoBuff\core.lua:10
I do a /fb, move the anchors to the desired positions, do /fb to lock them.
After /reload, the above error pops up.

The saved variable looks like this.
Code:
femtoBuff_Options = {
	["Debuff"] = {
	},
	["Temp"] = {
		"TOPRIGHT", -- [1]
		"UIParent", -- [2]
		"TOPRIGHT", -- [3]
		-8.074861049097182, -- [4]
		-162.938399441796, -- [5]
	},
	["Buff"] = {
		"TOPRIGHT", -- [1]
		"UIParent", -- [2]
		"TOPRIGHT", -- [3]
		-146.9757804539832, -- [4]
		-22.35814110079247, -- [5]
	},
}
If I input the relevant data in the saved var. file and don't use the /command, everything works fine on the priest.
http://peecee.dk/uploads/122009/WoWS...109_015354.jpg

Still no go on the shaman. No errors, but the buff frame moves. And can't use /command or it breaks.
http://peecee.dk/uploads/122009/WoWS...109_015334.jpg

edit: On the shaman I can fix it by removing weapon enchant, then the buffs jump back to the right spot. Then I can reapply the enchant and the buffs stay where they are.
Last edited by karmamuscle : 12-10-09 at 07:02 PM.
karmamuscle is offline Report comment to moderator  
Reply With Quote
Unread 12-10-09, 01:56 PM  
Soeters
A Warpwood Thunder Caller
 
Soeters's Avatar
AddOn Author - Click to view AddOns

Forum posts: 97
File comments: 206
Uploads: 21
Oh, that sounds weird

Well, I haven't tried the temp enchants with my shaman so I'm gonna do it, and see what could be the problems with a fresh install.

On another side, it seems that the bugs are really random

Edit: everything should be fixed in r6
__________________
Last edited by Soeters : 12-10-09 at 02:43 PM.
Soeters is offline Report comment to moderator  
Reply With Quote
Unread 12-10-09, 01:50 PM  
Arethea
A Kobold Labourer

Forum posts: 0
File comments: 18
Uploads: 0
I just have a tiny problem. The buffs/debuffs works fine until i use flametongue on my weapon. All the buffs jumps to the weapon buff anchor and if i remove my weapon buff the buffs jump back to its original anchor. I solved it by moving the weapon buff anchor over the buff anchor. Its nothing major but would be nice to get a fix for it. Awesome addon by the way, really like it
Arethea is offline Report comment to moderator  
Reply With Quote
Unread 12-10-09, 01:08 PM  
karmamuscle
Premium Member
 
karmamuscle's Avatar
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 196
File comments: 164
Uploads: 1
On a fresh install of this addon I had these problems.

The temp. enchant frame has no anchor.
The buff anchor is located at the top of the world frame and is not movable.

http://peecee.dk/uploads/122009/WoWS...009_195343.jpg
(you can see the buff anchor beneath the panel.)
(I did move the panel before trying to move it.)

After a /reload the buff frame has disappeared.
http://peecee.dk/uploads/122009/WoWS...009_195808.jpg

Logged out and disabled all addons except femtoBuff.

Now I can move everything, but something is still wrong.
The buffs are anchored to the temp. enchant frame and will move when moving the temp. enchant anchor.

The buff anchor is still at the top of the world frame.
http://peecee.dk/uploads/122009/WoWS...009_200224.jpg

After a relog to enable all addons again, I was able to move buffs using the temp. enchant anchor and got everything where I want.

http://peecee.dk/uploads/122009/WoWS...009_201018.jpg
Buff anchor is still at the top of the world frame.

Kickass buff addon, love it

Update: Just logged another character. Buff frame is gone.
Last edited by karmamuscle : 12-10-09 at 01:33 PM.
karmamuscle is offline Report comment to moderator  
Reply With Quote
Unread 12-10-09, 12:18 PM  
darkenscale
A Defias Bandit
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 27
Uploads: 8
Originally posted by Soeters
Actually, the variables are saved on mouse up but I think that if you alt click, without dragging, the var become nil, and I have no idea to fix it
Maybe throw in default position settings (or save position settings in a holding variable) and when the addon is loaded check the position for a nil value and reset to defaults (or last known position settings) if nil is found.
darkenscale is offline Report comment to moderator  
Reply With Quote
Unread 12-10-09, 12:16 AM  
Soeters
A Warpwood Thunder Caller
 
Soeters's Avatar
AddOn Author - Click to view AddOns

Forum posts: 97
File comments: 206
Uploads: 21
Originally posted by darkenscale
I got to do some more testing at home with your tip to clear the saved variables and found this to be the problem:

If femtoBuff is unlocked when a ui reload is done the save variables become corrupted and the mod produces the errors I posted before. If the saved variable file is deleted the mod can be used normally again.


Perhaps saving the position variables on mouse up would fix this.

I tend to tinker with my ui excessively and perform ui reloads often. If I'm in the middle of tinkering with multiple mods I sometimes forget which mods are locked or unlocked, hence my issue.
Actually, the variables are saved on mouse up but I think that if you alt click, without dragging, the var become nil, and I have no idea to fix it
__________________
Soeters is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.