Minion Beta! - Help us test our new AddOn updater. Get it now!
Download
(3 Kb)
Download
Updated: 02-17-10 06:35 PM
Pictures
File Info
Updated:02-17-10 06:35 PM
Created:02-17-10 11:49 AM
Downloads:82,665
Favorites:76
MD5:

Combat Log Fix  Popular! (More than 5000 hits)

Version: r20100217
by: Shadowed [More]

Fixes the combat log break bugs that have existed since 2.4. Credit goes to Imbad on ArenaJunkies for finding this. It works by clearing your combat log essentially, but it does it a little bit more automatically:

Slash commands: /logfix

On zone type change (pvp -> none, raid -> none, etc) it will clear the combat log
If no combat log events are found for 2 seconds after you cast a spell, it'll clear the log. It will also report how many combat log messages you had when it broke, if you can report these numbers in comments that would be great, might help narrow the bug down.

The above are enabled by default, you can disable them with /logfix.

Author: Shadowed <shadowed.wow@gmail.com>
Date: Wed Feb 17 16:34:43 2010 -0800
- Changed logic, now based off of when the spell with a cost (mana/health/rage/etc) is cast and checks if any combat log messages fired within the last 1 second
- Fixed events not being unregistered
- Reduced timeout to 2 seconds
- Initial commit (/logfix), auto fixes the combat log by clearing it
Optional Files (0)


Archived Files (1)
File Name
Version
Size
Author
Date
rsomething
2kB
Shadowed
02-17-10 11:49 AM


Post A Reply Comment Options
Unread 03-06-10, 01:28 PM  
keLston
A Deviate Faerie Dragon

Forum posts: 11
File comments: 174
Uploads: 0
Yeah I am totally baffled. I can't get it to work on my warrior either. Does it just not register melee classes?

(or if it does, it doesn't give me the message that says how much it cleared)
Last edited by keLston : 03-06-10 at 01:47 PM.
keLston is offline Report comment to moderator  
Reply With Quote
Unread 02-28-10, 08:55 PM  
Bizerk
A Murloc Raider

Forum posts: 6
File comments: 58
Uploads: 0
Log Fixer: 0 filtered/2715 events found.

Just killing stuff for dailies.
Bizerk is offline Report comment to moderator  
Reply With Quote
Unread 02-28-10, 11:33 AM  
TRF_
A Kobold Labourer

Forum posts: 0
File comments: 1
Uploads: 0
Both occured in (the same) wintergrasp when a bunch of vehicles and players came together and it got very lagy:

18:07:20 Log Fixer: 89 filtered/14959 events found. Cleared combat log, as it broke. Please report this!
18:20:27 Log Fixer: 431 filtered/32256 events found. Cleared combat log, as it broke. Please report this!

After nuking on a target dummy in UC for about 5min (without anyone else around; as elemental shaman):

Log Fixer: 136 filtered/8644 events found. Cleared combat log, as it broke. Please report this!
Last edited by TRF_ : 02-28-10 at 01:50 PM.
TRF_ is offline Report comment to moderator  
Reply With Quote
Unread 02-28-10, 08:01 AM  
Ancyfex
A Kobold Labourer

Forum posts: 0
File comments: 11
Uploads: 0
Log Fixer: 1736 filtered/6075 events found. Cleared combat log, as it broke.
Ancyfex is offline Report comment to moderator  
Reply With Quote
Unread 02-26-10, 11:39 PM  
coani
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 28
Uploads: 2
Originally posted by Shadowed
It's not (likely) due to this bug thought. If you have disconnect issues all the time, it sounds ISP related. If you only get it during 10/25 man raids, then it's probably ISP related still. Knew someone who would get disconnected pretty frequently doing raids until he harassed his ISP to get things upgraded.
The weird thing is that it can happen.. anywhere. solo, 5man, 10man, 25man, idling in dalaran, idling in silvermoon city (alone, nobody else in the zone) or orgrimmar, flying around mining, flying between flightpaths, soloing an instance... and the times it happens to me while my friend is playing at my place, it never happens to him (in fact, he has never had this issue at all while playing at my place), and these specific disconnects are always *instant*.. never lag related. One moment I'm tanking a boss, a sec later I'm staring at the login screen /sighing. For the record, I'm on a 12/1.2mbit connection.. and never had issues with other online games or activities.
But since 3.3 patch, it's gotten a lot worse, on those days where I'm having issues (some days I'm fine, no problems, some days are... horrible).
One evening when I had been going through 10+ disconnects, I ended up nuking the savedvariables/blizzard_combatlog.lua setting, and suddenly stopped having any disconnects... for 4 days. But then it started again.
Of course, that could just be a freak coincidence ;p

I'm just mostly irritated that game doesn't spit out any form of debug log or anything that can provide us with any sort of hint about what the problems are, or where they occur (is it actual network issue, or is something blowing up in the game).
coani is offline Report comment to moderator  
Reply With Quote
Unread 02-26-10, 12:03 PM  
Shadowed
...
WoWInterface Super Moderator
AddOn Author - Click to view AddOns

Forum posts: 387
File comments: 2513
Uploads: 99
The detection for deciding if the combat log broke or not isn't 100%, but it should be accurate in most combat situations (which is what matters).

It's not (likely) due to this bug thought. If you have disconnect issues all the time, it sounds ISP related. If you only get it during 10/25 man raids, then it's probably ISP related still. Knew someone who would get disconnected pretty frequently doing raids until he harassed his ISP to get things upgraded.
Shadowed is offline Report comment to moderator  
Reply With Quote
Unread 02-26-10, 07:19 AM  
coani
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 28
Uploads: 2
Is there any more background information on this bug? I didn't know there was a bug with the combatlog, but I tried running this little addon and I've had a few different spams from it, probably the most amusing one after porting to Moonglade last night & getting 0/0 results fixed.

The reason I'm curious about the bug though is that I'm going greyhaired from trying to figure out a random disconnect problem I'm having with the game for the last *10 months* which most frequently (like 99%) happen in combat or just before combat, seemingly combatlog related...
I have tried just about everything to resolve this, including disabling all addons, nuking most settings, fresh re-install of the game on different hd, 2 network cards from different makers, different router ports, different cable (should be noted a friend of mine often plays at my place & he never has any issues), turning off floating combattext, making a combatlog filter with everything turned off, even trying some other addon which was supposed to turn off the combatlog (didn't work), upgrading & downgrading most system drivers... but still no resolution.
coani is offline Report comment to moderator  
Reply With Quote
Unread 02-24-10, 02:24 PM  
ballagarba
A Fallenroot Satyr
 
ballagarba's Avatar

Forum posts: 22
File comments: 376
Uploads: 0
Log Fixer: 1106 filtered/20269 events found. Cleared combat log, as it broke. Please report this!
ballagarba is offline Report comment to moderator  
Reply With Quote
Unread 02-23-10, 01:41 AM  
keLston
A Deviate Faerie Dragon

Forum posts: 11
File comments: 174
Uploads: 0
Originally posted by Shadowed
Hrm, it might be due to Rogues and Death Knights not triggering the cast events properly. One thing you could try is manually running /script CombatLogClearEntries() and seeing if that does it.

It's a weird fix, if you want to trust the ArenaJunkies poll, it fixes it for about 80% of the people, but not the other 20%.
Thanks, i'll be sure to try it. I'll keep running the addon though and see if it works for any of my other characters to see if maybe it's simply a problem on my end.

I played a warrior for 10 games but since combat log didn't break, I have no idea if it was doing anything.
keLston is offline Report comment to moderator  
Reply With Quote
Unread 02-22-10, 11:43 AM  
ballagarba
A Fallenroot Satyr
 
ballagarba's Avatar

Forum posts: 22
File comments: 376
Uploads: 0
Log Fixer: 1035 filtered/15187 events found. Cleared combat log, as it broke. Please report this!
ballagarba is offline Report comment to moderator  
Reply With Quote
Unread 02-22-10, 11:18 AM  
Shadowed
...
WoWInterface Super Moderator
AddOn Author - Click to view AddOns

Forum posts: 387
File comments: 2513
Uploads: 99
Hrm, it might be due to Rogues and Death Knights not triggering the cast events properly. One thing you could try is manually running /script CombatLogClearEntries() and seeing if that does it.

It's a weird fix, if you want to trust the ArenaJunkies poll, it fixes it for about 80% of the people, but not the other 20%.
Shadowed is offline Report comment to moderator  
Reply With Quote
Unread 02-22-10, 04:07 AM  
keLston
A Deviate Faerie Dragon

Forum posts: 11
File comments: 174
Uploads: 0
Originally posted by Shadowed
What class are you? Also try I think it's /logfix status, make sure auto fixing is on.
I'm having inconsistent results using it for Arenaing on both a rogue and a death knight.

It doesn't seem to have an issue in PvE though I never get the report line saying how many it cleared so i'm not sure if it's working.

/logfix status reports:

[05:07:10] Log Fixer: Showing set options
[05:07:10] Message report is enabled
[05:07:10] Wait on clear is disabled
[05:07:10] Auto clearing is enabled
[05:07:10] Zone clearing is enabled
Last edited by keLston : 02-22-10 at 04:09 AM.
keLston is offline Report comment to moderator  
Reply With Quote
Unread 02-21-10, 07:12 PM  
Shadowed
...
WoWInterface Super Moderator
AddOn Author - Click to view AddOns

Forum posts: 387
File comments: 2513
Uploads: 99
What class are you? Also try I think it's /logfix status, make sure auto fixing is on.
Shadowed is offline Report comment to moderator  
Reply With Quote
Unread 02-21-10, 06:47 PM  
keLston
A Deviate Faerie Dragon

Forum posts: 11
File comments: 174
Uploads: 0
Do I have to do something special to make it work? It doesn't seem to be doing anything at all.

The /logfix command works and I have everything set to enabled but it doesn't seem to clear my combat logs nor does it fix broken ones. And it doesn't give me the line that says how much it cleared.
keLston is offline Report comment to moderator  
Reply With Quote
Unread 02-20-10, 08:11 PM  
Winniver
A Kobold Labourer

Forum posts: 0
File comments: 2
Uploads: 0
Originally posted by Shadowed
Are you sure? It really shouldn't be a partial fix, pretty much an all or nothing.
I'm not sure if its the combat log itself or MSBT but MSBT is definitely not reporting interupts/dispels after the combat log breaks and fixes.
Winniver is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.