Download
(7 MB)
Download
Updated: 07-24-14 06:39 AM
Pictures
File Info
Compatibility:
Siege of Orgrimmar (5.4)
Updated:07-24-14 06:39 AM
Created:05-31-10 01:50 PM
Downloads:72,021
Favorites:234
MD5:
Categories:Generic Compilations, Suites, Graphical Compilations, Class Compilations
5.4
Supervillain UI  Updated Today!  Popular! (More than 5000 hits)
Version: 4.074
by: Munglunch [More]

┏━━━━━━━━━━━━┓
Full UI Replacement. Inspired by comic books
CLICK HERE TO SEE THE VIDEO!
┗━━━━━━━━━━━━┛



┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈
IMPORTANT: If you already have a copy of SVUI installed
then you MUST delete any SVUI folders from your "AddOns"
directory BEFORE installing a new one.

┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈
To install: Open the downloaded zip file and drop all
containing folders into your install directory
(ie.. "C:/Program Files/World of Warcraft/").
Be sure that the 2 addons are enabled from your character select screen.

TO CONFIGURE: Type /sv or /svui for easy game configs!
You can access quick config options by clicking the "Henchman" icon
on the bottom right of the screen (second from the right).

┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈
v4.074
-- Fixed bad timers causing MANY issues including long loading times and many lag spikes
v4.073
-- More code slimmed down
-- Fixed docks/rep and various other bugs
v4.072
-- Yet another update to tooltips. Now the new border colors will change for item tooltips to reflect quality color.
-- Classbars now have their own mover frame, simply go into the config under Unitframes->Player->Classbar and check the "Detach from frame" box.
-- Un-docked chat windows will now have a skinned background to improve visibility.
-- Fixed a bad string in the installer file
-- Removed the "Ace3" style from StyleOMatic. Rather than attempt to skin ALL ace config windows (which is NOT resource friendly), I decided to directly modify the lib itself. The config libraries will be replaced in the near future for a much lighter alternative.
-- Removed the config option to change classbar width, this was added as an option but never implemented. Changed the option for classbar height to now be "Size" which is essentially what it has always been.
-- Condensed some code to help further reduce loading times, the following were changed: Docks, Actionbars, Minimap, Unitframes.
v4.066
-- Tooltips adjusted and slightly modified again (pretty colors on units now and the border skins only show on unit tips)
-- Fixed style issues with config menu
-- Added styling support for AuctionLite
-- New textures to replace default blizz tabs
-- FIXED AURA FILTERS FOR TARGET FRAMES!!!!! (I just discovered what has been killing these for God knows how long)
-- Stat panels along the bottom will now attempt to fit/size themselves between dock windows. This SHOULD help those who are using lower resolution monitors.
v4.0652
-- Patched tooltips (...again)
-- Fixed bag search bug
v4.065
-- NEW: backgrounds for stats
-- NEW: skin for encounter journal
-- tooltips adjusted, mount buttons fixed.
-- major changes to styleomatic and config
v4.0641
-- fixed german locale issue with SVUI_Config
-- added better localization support to dock toolbar
v4.064
-- added new option to installer page 1. "Keep My Settings". No more having to overwrite with defaults whenever SVUI makes a big version change!
-- Some new secret animations... see if you can spot them! (Mwahaha)
-- fixed friendship bar issues
-- fixed styleomatic system bug
-- fixed archy progressbar mover loading
-- adjusted some PVPUI skins that were loading incorrectly
-- archaeology laborer events are more fine tuned
v4.063
-- tooltip visual update and fixed classbar options
v4.062
-- fixed bad initialization of filters for new installs
-- fixed totem options, pvp window skinning and a stranded frame in the middle of the screen.
-- top and bottom screen borders will now respect the color choice under (General->Media->Colors->Accent Color)
v4.061
-- Fixed aura bars
-- fixed filter saving
-- visual adjustment to aura bars
-- Archaeology progress bar is now movable using "/sv move"
v4.06
-- NEW: added tooltip and nameplate artwork
-- even more upgrades to unitframe code
-- fixed dock fading bug
-- removed several bad lines of code that could have been causing crashes
-- quality checked/adjusted all xml templates
-- Fixed looping bug in tooltips
v4.056
-- fixed aura filters and loot fonts
v4.055
-- Arena prep frames are now functioning
-- Revised code in all unitframes to attempt to squeeze more performance out of them
v4.054
-- Fixed auraheader update violation
v4.053
-- When i fixed the font configs in 4.051 I inadvertently broke some others :( these are fixed
v4.052
-- corrected bad colorpickers in the config menu
v4.051
-- Last 2 remaining font configs (general unit and actionbar) are working as expected
-- action button hotkey text is now properly abbreviated
v4.05
-- Ultra clean!
-- Fixed druid resources issue
-- Fixed party/raid/tank/assist font and coloring settings bug
-- The "Hearth" dock button is a little more special now for Shaman/Monk/Druid/DeathKnight
-- More visual improvements to various small details
-- Copying profiles will now automatically reload the UI in order to ensure they get properly duplicated and ready for use.
-- Resetting a profile will no longer cause the install screen to show again.
-- Fixed some hemorrhaging elements used in PvP (just sayin...)
v4.046
-- Caught Registry error with event handler frames
v4.045
-- Fixed keybind bug
-- Adjusted bad references in unit code
v4.043
-- Added Doonga's fix for 4k monitors and multi-monitor support
-- Made some visual quality improvements to Mentalo, castbars, stat menus, game menu skins, bag type slot coloring and arena frames.
-- Fixed the "Break Stuff" button/feature, was not loading for milling, prospecting or disenchanting.
-- Micro menu bar is movable again, also added new textures to the "Interface/BUTTONS" folder to further hide default blizzard textures.
-- Stance bars can now use custom visibility tags! You are welcome Moondoggy
-- Found and fixed an issue with Pet bar custom visibility
-- Fixed a bad event handler when going into petbattles
v4.042
-- Fixed event handler used by the visibility class
v4.041
-- quick fixes to aura config, mirror timers bars, tooltip guild names and some minor things.
v4.04
-- Fixed aura filters
-- Profile copying/deleting/importing now fully functional
-- Fixed bug in bags when changing sizes
v4.036
-- Fixed profileKey bug in config
v4.035
-- Fixed more mac screen issues
-- Fixed profile saving/loading
v4.034
-- Fixed mac client screen size variable issue
v4.033
-- Fixed profile copy functions
-- Adjusted loothistory window skinning
v4.032
-- Fixed config failure due to version number changes
-- Now using wowinterface.com git repo!
-- Fixed issue with configs for target of target frames
v4.031
-- Adjusted aura filters a bit to compensate for recent changes
-- Fixed all saving
-- Fixed localization issues
-- Fixed config panel issues
-- Update to uniframe package (shaved another 1mb off game memory)
v4.03
-- Completely forgot to include frame positions in the profile saving process, my bad yo!
-- Almost forgot filter changes, this caused an error but is fixed now.
-- Completely repaired and finalized the new internal config system, this will remove all setting based bugs you may have encountered
-- Found and removed issues that were causing memory leaks in both the Stats and Unit packages
-- Fixed autoscaling, raid frame hiding (just re-iterating that fact) and a handful of other issues

IMPORTANT------

-- New profiles (WARNING: old settings WILL be erased due to changes in the core). Unlike previous versions as well as many other UI's available, SVUI will handle profiles on an as-needed basis. What this means is that if you want to be able to use the same profile from one character to the next then you will have to go into the settings "/sv" and then the "profiles" tab on the left. Once you are there you will need to "SAVE" that current characters profile (this will no longer be automatic as that pollutes the global variables file). After you have saved your profile, you can then log onto another character and select the saved profile from the "Copy" dropdown list. I HIGHLY RECOMMEND that once you are satisfied with and profile duplications you have done, you should then select the unneeded saved profile from the "Delete" dropdown to remove it. This does not affect any character that has already received a copy as the used copies are stored in another location.

v4.02
-- Almost all ace3 libs removed
-- Fixed unitframe visibility issues
-- fixed several crashes
-- fixed notification bugs when repairing and etc...

v4.01 (official)
-- Fixed boss/arena frame mover bug
-- Micro bar is now movable
-- Fixed interrupt messages that were not belonging to the player
-- Added configs for announcements
-- Added "absorbs" option for unit health text
-- Fixed "Lets Ride" mount list bug
-- Fixed errors from dock buttons
-- FIXED EVERYTHING!!!!!! EVEN MEMORY CRASH... (o_O)
-- Fixed heirloom item bug causing massive errors
-- Fixed bag bug causing bag and sort failures
-- Fixed target GPS activation
-- Fixed failing pet/party/raid health bars
-- Fixed vanishing raid frames
-- Fixed Laborer issue ignoring settings that prevent from dropping farm tools
v4.01
-- Fixed bugs in alerts, mounts, bags, auras, unitframes and docks
-- Changed target status indicators (they are AWESOME now)
-- Added ability to change castbar colors on a unit-by-unit basis (by request)
-- More changes/fixes were completed and will be documented later
-- Fixed issue with unitframe name and power text positioning
-- Fixed casting color config bug
-- Fixed combat-fade bug
-- Adjusted more blizzard skins
-- Fixed coloring issues on many buttons and frames
v4.0 (preview)
-- Highly optimized textures and their usage, effectively reducing memory usage by no less than 1mb
-- Greatly improved the speed of all core functions, loading times are mush faster now.
-- Overhaul of most frame templates, they are much more visually engaging imo
-- Full re-design of the archaeology "Laborer" mode
-- Mentalo has gotten a face-lift
-- touch-ups on various info frames including the installer window
-- Visual re-design of the GPS widget
-- Visual enhancement of target status indicators ("Dead", "DC'ed", "Tapped" and "Rare")
-- Adjusted default font-sizes for the following: cooldowns, stats (datatext) menus, tooltips, tabs, hotkey labels
-- Added the "Help" option to the micro bar
-- Included a rough copy of Elv's RaidUtility, this is merely a placeholder until the true SVUI version is complete
-- Drastic improvements to the core API
-- NEW dock tool: Hearthstone
-- (no version change) Fixed a chat bug when receiving PM's
-- (no version change) Partially fixed pet bar bug (still vanishes when changing settings, can be fixed by using "/rl")
-- (no version change) Fixed all chat and petbar bugs
Optional Files (2)
File Name
Version
Size
Author
Date
Type
002
3MB
06-29-11 08:29 AM
Patch
19.8
13MB
01-20-11 12:34 PM
Patch


Archived Files (14)
File Name
Version
Size
Author
Date
4.073
7MB
Munglunch
07-23-14 12:39 AM
4.073
7MB
Munglunch
07-23-14 12:36 AM
4.072
7MB
Munglunch
07-22-14 06:30 AM
4.072
7MB
Munglunch
07-22-14 05:58 AM
4.07
7MB
Munglunch
07-21-14 11:27 PM
4.07
7MB
Munglunch
07-21-14 10:49 PM
4.0662
7MB
Munglunch
07-20-14 10:43 PM
4.0662
7MB
Munglunch
07-20-14 08:10 PM
4.066
7MB
Munglunch
07-20-14 06:19 PM
4.0652
7MB
Munglunch
07-20-14 06:10 PM
4.0652
6MB
Munglunch
07-20-14 12:22 AM
4.065
6MB
Munglunch
07-19-14 03:32 PM
4.065
6MB
Munglunch
07-19-14 11:40 AM
4.064
6MB
Munglunch
07-18-14 08:53 AM


Post A Reply Comment Options
Old Today, 01:05 PM  
Doonga
Premium Member
Premium Member

Forum posts: 10
File comments: 74
Uploads: 0
Definitely more stable today! Thanks!

Adding an aura (shift-right click) to the unitframe filter still causes a small lag spike and it doesn't seem to actually filter the icon.

The dropdown for changing someone's rank in the guild looks to overlap with the actual rank of the person.

Doonga is offline Report comment to moderator  
Reply With Quote
Old Today, 11:33 AM  
UltimateZero
A Kobold Labourer

Forum posts: 0
File comments: 11
Uploads: 0
Hooray, thank you! So I was wrong about the layering, but it least it wasn't due to user configuration! =D
Originally Posted by Munglunch
This was another bug caused by bad timers, I have fixed this in 4.074
UltimateZero is offline Report comment to moderator  
Reply With Quote
Old Today, 10:14 AM  
Holistix
A Kobold Labourer

Forum posts: 0
File comments: 16
Uploads: 0
4.074 "tested" and working great. No problems at all so far.

Originally Posted by Holistix
Sorry, but I spoke too soon.

Took a heroic dungeon and three bosses of a raid, but the error came back. The old problem was surfacing much quicker, like 3-5 packs.

Sorry I can't be more help. Always happy to test. This is a great UI, despite the current issues.

Looking forward to 4.074 (soon as it is passed by moderator).

Originally Posted by Munglunch
Thank you very much for testing this. I will compare versions with 4.066~ and see what may need to change.
Holistix is offline Report comment to moderator  
Reply With Quote
Old Today, 08:47 AM  
KoreanMacho
A Kobold Labourer

Forum posts: 0
File comments: 5
Uploads: 0
Where are the cooldowns settings? I need to disable milliseconds and change numbers color.
KoreanMacho is offline Report comment to moderator  
Reply With Quote
Old Today, 07:09 AM  
Holistix
A Kobold Labourer

Forum posts: 0
File comments: 16
Uploads: 0
Sorry, but I spoke too soon.

Took a heroic dungeon and three bosses of a raid, but the error came back. The old problem was surfacing much quicker, like 3-5 packs.

Sorry I can't be more help. Always happy to test. This is a great UI, despite the current issues.

Looking forward to 4.074 (soon as it is passed by moderator).

Originally Posted by Munglunch
Thank you very much for testing this. I will compare versions with 4.066~ and see what may need to change.
Last edited by Holistix : 07-24-14 at 07:11 AM.
Holistix is offline Report comment to moderator  
Reply With Quote
Old Today, 06:44 AM  
Munglunch
A Deviate Faerie Dragon
 
Munglunch's Avatar
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 12
File comments: 987
Uploads: 7
This was another bug caused by bad timers, I have fixed this in 4.074

Originally Posted by UltimateZero
I'm back, found another one! Apparently my henchmen aren't going away.

http://imgur.com/a/3UqPY

After having sold and repaired some gear (henchmen doing all the work, naturally), it seems that they decided to stick around and clog up the UI space. Any area where the henchmen speech bubble sat is no longer clickable. I used a GetFrame macro to double check and see what was getting in the way. The GetFrame returned as "HenchmenSpeechBubble". This particular frame seems to stay there until the UI refreshes somehow.
Munglunch is online now Report comment to moderator  
Reply With Quote
Old Today, 06:41 AM  
Munglunch
A Deviate Faerie Dragon
 
Munglunch's Avatar
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 12
File comments: 987
Uploads: 7
Incoming..

v4.074
-- Fixed bad timers causing MANY issues including long loading times and many lag spikes

I will be doing more testing today with previous versions to see if I need to change anything else. Another update will follow pending my findings
Munglunch is online now Report comment to moderator  
Reply With Quote
Old Today, 06:40 AM  
Munglunch
A Deviate Faerie Dragon
 
Munglunch's Avatar
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 12
File comments: 987
Uploads: 7
Thank you very much for testing this. I will compare versions with 4.066~ and see what may need to change.

Originally Posted by Holistix
Hi.

Sorry, but I missed this question initially.

The buttons that are disabling are just plain mount buttons. Seems weird that they disable, but other buttons (tradeskills etc) on same bar still work.

I do use macro's for combat. Those macro's appear to be hanging up after a while too, but I put it down to lag on Blizz's end. Now I see other people are getting the out of sync elevators, increased load times and stuff that I have been getting too.

My combat macro's are all keybound, yeah. I use an n52te with auto key repeat.

For what it is worth, I wasn't getting lockups or lag at all until a few days ago, so I am going to install a version of the UI from back then and see if the problem still exists.

EDIT: I have now tried version 4.066 (comes up in game as 4.0661) and so far no issues. Will raid and see what happens, but it was fine in a heroic just now.

Edit2: Appears to work fine in raid too. Will post back if there is a problem.

Originally Posted by Munglunch
Are the buttons in question macros or the actual mount's button? Do the buttons have keybindings?

Originally Posted by Holistix
Thanks for fixing other bugs so quick - if only Blizz support was this good!

Not sure if it is related or not, but some of the action bar buttons are not being detected and so cannot be pressed. This only seems to affect mounts. I can mount once, but then cannot use the same button to dismount without a /reload. Buttons on the same bar that are not mounts still work.
Munglunch is online now Report comment to moderator  
Reply With Quote
Old Today, 05:43 AM  
AtomicKiller
A Defias Bandit

Forum posts: 3
File comments: 52
Uploads: 0
I can confirm delay in loading screen after entering dungeon/raids. Mostly i was first inside , but now they even pull first group of thrash before i join.

And maybe you missed it, but i asked, if it's possible to add castbar overlay with power bar.

something like this: http://www.tukui.org/addons/index.php?act=view&id=62
Last edited by AtomicKiller : 07-24-14 at 05:43 AM.
AtomicKiller is offline Report comment to moderator  
Reply With Quote
Old Today, 05:39 AM  
Holistix
A Kobold Labourer

Forum posts: 0
File comments: 16
Uploads: 0
Hi.

Sorry, but I missed this question initially.

The buttons that are disabling are just plain mount buttons. Seems weird that they disable, but other buttons (tradeskills etc) on same bar still work.

I do use macro's for combat. Those macro's appear to be hanging up after a while too, but I put it down to lag on Blizz's end. Now I see other people are getting the out of sync elevators, increased load times and stuff that I have been getting too.

My combat macro's are all keybound, yeah. I use an n52te with auto key repeat.

For what it is worth, I wasn't getting lockups or lag at all until a few days ago, so I am going to install a version of the UI from back then and see if the problem still exists.

Took longer, but still there.

Code:
4x SVUI-4.0661\system\system.lua:418: script ran too long
SVUI-4.0661\system\system.lua:418: in function <SVUI\system\system.lua:415>

Locals:
and

Code:
8x C stack overflow
<in C code>
<in C code>
<in C code>
<in C code>
<in C code>
<in C code>
<in C code>
<in C code>
<in C code>
<in C code>
<in C code>
<in C code>
SecureStateDriver.lua:83: in function <FrameXML\SecureStateDriver.lua:73>
FrameXML\SecureStateDriver.lua:137: in function <FrameXML\SecureStateDriver.lua:119>

Locals:
(*temporary) = <unnamed> {
 0 = <userdata>
 _noupdate = true
 SetBackdropBorderColor = <function> defined =[C]:-1
 _template = "Bar"
 Smooth = false
 _color = "transparent"
 PostUpdate = <function> defined @Interface\AddOns\SVUI\packages\unit\common\power.lua:36
 barType = 0
 text = <unnamed> {
 }
 SetBackdrop = <function> defined =[C]:-1
 SetValue = <function> defined @Interface\AddOns\SVUI\libs\oUF_Plugins\oUF_Smooth\oUF_Smooth.lua:6
 Panel = <unnamed> {
 }
 SetValue_ = <function> defined =[C]:-1
 ForceUpdate = <function> defined @Interface\AddOns\SVUI\libs\oUF\elements\altpowerbar.lua:28
 __owner = SVUI_Boss2 {
 }
 BackdropNeedsUpdate = true
 SetBackdropColor = <function> defined =[C]:-1
 _texture = false
 _gradient = false
}
 = <function> defined =[C]:-1
 = <function> defined @Interface\AddOns\SVUI\packages\unit\SVUnit.lua:657
Originally Posted by Munglunch
Are the buttons in question macros or the actual mount's button? Do the buttons have keybindings?

Originally Posted by Holistix
Thanks for fixing other bugs so quick - if only Blizz support was this good!

Not sure if it is related or not, but some of the action bar buttons are not being detected and so cannot be pressed. This only seems to affect mounts. I can mount once, but then cannot use the same button to dismount without a /reload. Buttons on the same bar that are not mounts still work.
Last edited by Holistix : 07-24-14 at 06:57 AM.
Holistix is offline Report comment to moderator  
Reply With Quote
Old Today, 02:34 AM  
Finadama
A Kobold Labourer
 
Finadama's Avatar

Forum posts: 0
File comments: 4
Uploads: 0
Re: Re: Bag/bank positions?

Originally Posted by Munglunch
Let me see what I can do

Originally Posted by Finadama
Any chance of getting the bag/bank etc unlinked from the bottom docks? I have changed mine so the chat and dock are at the top of the screen, but the downside is the bags appear off the edge of the screen.
Awesome!!!!
__________________


Finadama-Nagrand, Finbel, Fincorann, Findane, Finelidora, Finfionas, Fingarion, Finhydd, Finisola, Finjakeem, Finkellan
Finadama is offline Report comment to moderator  
Reply With Quote
Old Today, 12:06 AM  
UltimateZero
A Kobold Labourer

Forum posts: 0
File comments: 11
Uploads: 0
When I install a new version I delete everything except for my WTF folder before putting in the new version, cache included. Layering errors strike me as something that may have changed during a patch somewhere that's causing a conflict, so I was crossing my fingers and hoping for that. If deleting the settings is really the solution, consider me sadface. I spent over an hour reconfiguring everything this last update ._.

Originally Posted by Daigan
Had this problem myself not long ago. Ended up having to do a complete fresh install of all UI foldrs.

Originally Posted by UltimateZero
I'm back, found another one! Apparently my henchmen aren't going away.

http://imgur.com/a/3UqPY

After having sold and repaired some gear (henchmen doing all the work, naturally), it seems that they decided to stick around and clog up the UI space. Any area where the henchmen speech bubble sat is no longer clickable. I used a GetFrame macro to double check and see what was getting in the way. The GetFrame returned as "HenchmenSpeechBubble". This particular frame seems to stay there until the UI refreshes somehow.
Last edited by UltimateZero : 07-24-14 at 12:09 AM.
UltimateZero is offline Report comment to moderator  
Reply With Quote
Old Today, 11:46 PM  
Daigan
A Kobold Labourer

Forum posts: 0
File comments: 182
Uploads: 0
Had this problem myself not long ago. Ended up having to do a complete fresh install of all UI foldrs.

Originally Posted by UltimateZero
I'm back, found another one! Apparently my henchmen aren't going away.

http://imgur.com/a/3UqPY

After having sold and repaired some gear (henchmen doing all the work, naturally), it seems that they decided to stick around and clog up the UI space. Any area where the henchmen speech bubble sat is no longer clickable. I used a GetFrame macro to double check and see what was getting in the way. The GetFrame returned as "HenchmenSpeechBubble". This particular frame seems to stay there until the UI refreshes somehow.
Daigan is offline Report comment to moderator  
Reply With Quote
Old Yesterday, 09:26 PM  
UltimateZero
A Kobold Labourer

Forum posts: 0
File comments: 11
Uploads: 0
I'm back, found another one! Apparently my henchmen aren't going away.

http://imgur.com/a/3UqPY

After having sold and repaired some gear (henchmen doing all the work, naturally), it seems that they decided to stick around and clog up the UI space. Any area where the henchmen speech bubble sat is no longer clickable. I used a GetFrame macro to double check and see what was getting in the way. The GetFrame returned as "HenchmenSpeechBubble". This particular frame seems to stay there until the UI refreshes somehow.
Last edited by UltimateZero : 07-23-14 at 09:28 PM.
UltimateZero is offline Report comment to moderator  
Reply With Quote
Old Yesterday, 06:42 PM  
royalsego
A Kobold Labourer

Forum posts: 0
File comments: 4
Uploads: 0
Originally Posted by Daigan
Clear all your SVUI folders in the WTF folder. Though you may want to back them up for future use.

Originally Posted by royalsego
I love this addon to death, but I can't use it in tandem with blizzard default raid frames, then I'll just need to go back to my ElvUI until SVui is more polished.

However, I noticed there are many still remnants of SVui despite disabling the addon... such as role icon in the raid frames or overall look of the character selection screen.

Would you kind folks tell me how to remove all of SVui? I'm afraid to just correspond everything in the zip and delete the folders from my WoW directory.
Thank you!
royalsego is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.