Quantcast
Download
(816 Kb)
Download
Updated: 11-05-16 10:50 AM
Pictures
File Info
Compatibility:
Return to Karazhan (7.1.5)
Legion (7.0.3)
Updated:11-05-16 10:50 AM
Created:09-19-10 11:32 AM
Downloads:38,806
Favorites:118
MD5:
Categories:Minimalistic Compilations, Graphical Compilations, Class Compilations, DPS Compilations, Generic Compilations
7.1.5

Rufio UI Classic  Popular! (More than 5000 hits)

Version: 4.5
by: Rufio [More]

Info
just like the standard ui but smaller and darker

Install
unzip in \World of Warcraft\Interface (not addons)

Info
NOT included addons from the image:
Nameplates are KuiNameplates
ClassIcon from FlatPlayerIcons
Buttonskin from Clean Icons - Original

Addonlist
!BugGrabber + BugSack - show me those bugs
Badboy - less chat spam
BonusRollPreview - what could i get for my coin?
BuyEmAll - i like to buy more than one stack at a time
LiteBag - one bag
ls_Toasts - reskins the toasts window /lstoasts -> Interface -> Addons to edit
LynStats - fps/ms info (bottom right)
nBuff - style those buffs
nMainbar - mainbar
nPower - powerbar in the middle of the screen (i would disable this if i was playing a caster)
PhotoRobot - cc/buff timers on portraits
rCombatText - styles the combat text (enable combat text for self in the settings)
rufioMedia - just a bartexture atm
rufioSettings - merged addons and ui scripts

  • Arenaframes - resize & position - disabled atm (use sArena)
  • Bossframes - resized & scaled
  • Castbars - castbar styling
  • Chat - clean chat
  • Classcolors - on units
  • Classicons - on untis
  • CopyUrl - url copy from chat
  • durability - on charscreen by tek
  • Guildtab - i need my guild on "o" !
  • Minimap - clean minimap (the Orderhallbutton is enabled in this version - even thos its ugly...)
  • noError - no red errors in the middle of the screen
  • RaidFrameReSizer - more scaleable raidframes
  • NumQuest - how many quests are in my questlog - X/25
  • Recolor - recolor frames
  • rufioSettings - rescale, reposition, hiding petname, auto repair, slash commands, moveable questtracker etc.
  • Speedyload - better loading times
  • SpellID - Spellids on tooltip by zork
  • Tooltip - tooltip
TargetPercent - adds 100.0% target/focus/boss frames (you should choose "none" for statustext in the default settings if you want to use this)
teksLoot - Lootframe /teksLoot
tullaCC - nicer number on CDs
whoaUnitFrames - restyled standard unitframes

Credits
nothing from the code is by myself so thanks to all the authors (especially roth/Lyn/Tekkub/haste/alza/neal/dawn/monolit/evl/Aprikot)
please tell me if you find any bugs

PS: You'll find a ripoff from my castbars here: b_Castingbar

Moving Frames
right click player/targetframe and click Unlock Frame

and drag them. Rightclick and Lock Frame to lock them in position.

Move Stance/Petbar by holding alt+shift and drag the first button

4.5
7.1x fixes
4.4
7.1 updates
4.3
addon updates
ls_Toasts, PhotoRobot, rCombatText, TargetPercent are new
4.2
bossframes moved
arenaframe edits disabled (got some errors)
4.1
error text removed
old tooltip
stuff
4.0
legion prerelease
fixed stuff, thx 2 sticklord & Kkthnx
Optional Files (1)
File Name
Version
Size
Author
Date
Type
1.8.1
2MB
02-20-12 07:30 AM
Addon


Archived Files (6)
File Name
Version
Size
Author
Date
4.4
810kB
Rufio
10-27-16 09:23 AM
4.3
784kB
Rufio
10-13-16 01:53 AM
4.2
590kB
Rufio
08-21-16 11:37 AM
4.1
578kB
Rufio
08-10-16 02:29 PM
3.1
872kB
Rufio
03-29-15 03:52 PM
3.0.1
861kB
Rufio
01-23-15 11:09 AM


Post A Reply Comment Options
Unread 11-30-13, 08:16 AM  
Rufio
A Murloc Raider
 
Rufio's Avatar
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 243
Uploads: 8
Originally Posted by Spiattalo
Originally Posted by Rufio
Originally Posted by Spiattalo
My player cast bar just doesn't show, enemy's does. Anyone else?

If I delete the code from the .lua file the default bar shows under my character frame, but that's lame. :P
i gues its offscreen, just edit the setpoint
I thought I tried, I solved by deleting all the .lua parts and installing b_castbars. I also noticed all set points are faulty (pet frame to name one) and I wandered if there is any point of still having them. Aren't they just leftovers from you previous versions?
actual all setpoints are accurate and working for me (i want the petframe where it is). I just don't care about other people's resolutions, so they can be messed up if you're playing on a lower resolution.
Last edited by Rufio : 11-30-13 at 08:17 AM.
Report comment to moderator  
Reply With Quote
Unread 11-29-13, 07:46 PM  
Spiattalo
A Kobold Labourer

Forum posts: 0
File comments: 28
Uploads: 0
Originally Posted by Rufio
Originally Posted by Spiattalo
My player cast bar just doesn't show, enemy's does. Anyone else?

If I delete the code from the .lua file the default bar shows under my character frame, but that's lame. :P
i gues its offscreen, just edit the setpoint
I thought I tried, I solved by deleting all the .lua parts and installing b_castbars. I also noticed all set points are faulty (pet frame to name one) and I wandered if there is any point of still having them. Aren't they just leftovers from you previous versions?
Report comment to moderator  
Reply With Quote
Unread 11-29-13, 11:55 AM  
Rufio
A Murloc Raider
 
Rufio's Avatar
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 243
Uploads: 8
Originally Posted by Spiattalo
My player cast bar just doesn't show, enemy's does. Anyone else?

If I delete the code from the .lua file the default bar shows under my character frame, but that's lame. :P
i gues its offscreen, just edit the setpoint
Report comment to moderator  
Reply With Quote
Unread 11-29-13, 06:47 AM  
Spiattalo
A Kobold Labourer

Forum posts: 0
File comments: 28
Uploads: 0
My player cast bar just doesn't show, enemy's does. Anyone else?

If I delete the code from the .lua file the default bar shows under my character frame, but that's lame. :P
Report comment to moderator  
Reply With Quote
Unread 11-19-13, 11:57 AM  
Rufio
A Murloc Raider
 
Rufio's Avatar
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 243
Uploads: 8
Originally Posted by Poxus
I just downloaded this file and installed everything and noticed when i went to check Addons that Bagnon was missing a dependency. I just updated that addon and everything is working.

I'm glad I found this as it has everything I was attempting to patch together myself and in almost the same look...but you pulled it off far better than i can do.
right click target/playerframe

and drag it

alt+shift and drag the first button to move pet/stancebar
Last edited by Rufio : 11-19-13 at 12:06 PM.
Report comment to moderator  
Reply With Quote
Unread 11-18-13, 02:45 AM  
YrDaDy
A Defias Bandit
 
YrDaDy's Avatar

Forum posts: 2
File comments: 62
Uploads: 0
Originally Posted by kindohein
How do I get the same unit frames locations as shown in the screenshots?


Is this part of the install process antiquated? The UI does not contain such a folder.



Edit:
Also, the stance bar is in the middle of the screen. I forgot to add that.
Basically the same question I have is with this reply.

There is no WTF folder so there are no set points.. would be nice to have. And the Stance Bar is in the middle of screen as stated.
Report comment to moderator  
Reply With Quote
Unread 11-17-13, 06:40 PM  
Poxus
A Defias Bandit

Forum posts: 2
File comments: 24
Uploads: 0
I just downloaded this file and installed everything and noticed when i went to check Addons that Bagnon was missing a dependency. I just updated that addon and everything is working.

I'm glad I found this as it has everything I was attempting to patch together myself and in almost the same look...but you pulled it off far better than i can do.
Report comment to moderator  
Reply With Quote
Unread 11-17-13, 09:18 AM  
Rufio
A Murloc Raider
 
Rufio's Avatar
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 243
Uploads: 8
Originally Posted by Namica
hey,

sorry if that question is already answered, but: i don't manage to see my "target of target"... could you please help me? thanks!
it should be fixed in the current whounitframes version, i'll upload it if i find the time

Originally Posted by Uranium
Hello, I noticed under the rufio settings, it said, "Classicons - on untis", but in that folder, there isn't a classicons.lua like the classcolors one.

Is that part no longer part of this comp?
the code is in the unitframes.lua
Report comment to moderator  
Reply With Quote
Unread 11-16-13, 12:33 PM  
Origin_leilei
A Kobold Labourer

Forum posts: 0
File comments: 5
Uploads: 0
HI
Descending Show
AddOns
Link
Report comment to moderator  
Reply With Quote
Unread 11-15-13, 10:59 PM  
Uranium
A Murloc Raider

Forum posts: 4
File comments: 5
Uploads: 0
Missing lua files?

Hello, I noticed under the rufio settings, it said, "Classicons - on untis", but in that folder, there isn't a classicons.lua like the classcolors one.

Is that part no longer part of this comp?
Report comment to moderator  
Reply With Quote
Unread 11-15-13, 03:12 PM  
Namica
A Kobold Labourer
 
Namica's Avatar

Forum posts: 0
File comments: 121
Uploads: 0
hey,

sorry if that question is already answered, but: i don't manage to see my "target of target"... could you please help me? thanks!
Report comment to moderator  
Reply With Quote
Unread 11-15-13, 01:56 PM  
Rufio
A Murloc Raider
 
Rufio's Avatar
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 243
Uploads: 8
Originally Posted by Featic
Originally Posted by Rufio
Originally Posted by Featic
Hi

Really like the UI but for some reason my font doesn't change (I still have blizzards standard fonts). Everything else loads just fine.

Any idea what could cause this?
You need to get it yourself, the font i'm using it's free
Thanks for responding mate, I appreciate it.

I have downloaded the fonts but I'm not getting them to override the original ones. (I should have said this in my previous post). I created a new fonts folder and renamed them ARIALN.ttf, FRIZQT__.ttf, MORPHEUS.ttf and SKURRI.TTF. This used to work before but nothing happens now.

I was just wondering if I need to do something different with this compilation to get the font to work. It could very well be that its got nothing to do with your UI and that the problem is caused by something else.

Cheers
should work, i did it the same...
ofc you need to restart the game (not just /rl) to apply those changes. Have you checkt if the fonts where replaced? Have downloaded the fonts in the correct format?
Last edited by Rufio : 11-15-13 at 01:59 PM.
Report comment to moderator  
Reply With Quote
Unread 11-14-13, 02:28 PM  
Featic
A Kobold Labourer

Forum posts: 0
File comments: 14
Uploads: 0
Originally Posted by Rufio
Originally Posted by Featic
Hi

Really like the UI but for some reason my font doesn't change (I still have blizzards standard fonts). Everything else loads just fine.

Any idea what could cause this?
You need to get it yourself, the font i'm using it's free
Thanks for responding mate, I appreciate it.

I have downloaded the fonts but I'm not getting them to override the original ones. (I should have said this in my previous post). I created a new fonts folder and renamed them ARIALN.ttf, FRIZQT__.ttf, MORPHEUS.ttf and SKURRI.TTF. This used to work before but nothing happens now.

I was just wondering if I need to do something different with this compilation to get the font to work. It could very well be that its got nothing to do with your UI and that the problem is caused by something else.

Cheers
Report comment to moderator  
Reply With Quote
Unread 11-13-13, 01:22 PM  
Rufio
A Murloc Raider
 
Rufio's Avatar
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 243
Uploads: 8
Originally Posted by Featic
Hi

Really like the UI but for some reason my font doesn't change (I still have blizzards standard fonts). Everything else loads just fine.

Any idea what could cause this?
You need to get it yourself, the font i'm using it's free
Report comment to moderator  
Reply With Quote
Unread 11-10-13, 08:39 AM  
Featic
A Kobold Labourer

Forum posts: 0
File comments: 14
Uploads: 0
Hi

Really like the UI but for some reason my font doesn't change (I still have blizzards standard fonts). Everything else loads just fine.

Any idea what could cause this?
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.