Download
(2 MB)
Download
Updated: 10-22-12 06:02 PM
Pictures
File Info
Compatibility:
Escalation (5.3)
Thunder Isle (5.2)
Landfall (5.1)
Mists of Pandaria (5.0.4)
Updated:10-22-12 06:02 PM
Created:10-08-10 04:46 AM
Downloads:112,103
Favorites:172
MD5:
SpartanUI  Popular! (More than 5000 hits)
Version: 3.1.3
by: Azgaurd, Medmerd, Vaebris, Zilver
SpartanUI
Use curse.com to get this addon

The mods here will not give me full control (Azgaurd) over the addon here and i have been the only person working on it in the last year. As a result the addon will no longer be updated here nor will I be paying any attention to the forum here.
3.1.2:
-Added Monk Chi bar

3.1.3:
Fix - Monk class icon not showing in party frames.
Fix - Monk Statue moved to the right of the CHI.
Fix - Party frames now properly update when someone was invited while in combat.
Fix - Party Frame not showing up after leaving battleground.
Fix - Moved the Extra Power bar (Petrification bar in MV) to the left so its aligned with the player frame to account some people having a issue in Shado-pan Monastery where the bar overlaps with the extra action button on the last boss. (Temporary Fix, Long term this will move only if it needs to)
Change - SpartanUI no longer hides blizzard buffs, blizz does not allow addons to turn off buffs without some lengthy work arounds.
Removed - Player buffs are no longer displayed on the player frame.
Fix - Misc bugs.
Post A Reply Comment Options
Old 10-17-10, 06:31 AM  
Scottbot
A Kobold Labourer

Forum posts: 0
File comments: 11
Uploads: 0
@ the threat update, for some reason soon as i attack anything now it goes red, even when im in a dungeon and nothing is attacking me or near it :P


edit; ok this time i was on a boss and pulled aggro, soon as the boss died, i got a LUA error, but accidently closed it without reading properly, but it did mention spartanUI :P if i get error again ill copy it.
Last edited by Scottbot : 10-17-10 at 06:40 AM.
Scottbot is offline Report comment to moderator  
Reply With Quote
Old 10-17-10, 12:05 AM  
yulskie
A Kobold Labourer

Forum posts: 0
File comments: 6
Uploads: 0
Re: Re: How to Resize





if you like me don't want the bar to "hide" you can type: "/sui popup all".

If it's not there, some other AddOn is interfering with it. [/b]

Thanks for the quick reply, managed to sort it out by updating bartender 4
yulskie is offline Report comment to moderator  
Reply With Quote
Old 10-16-10, 11:26 PM  
Shadowfaux1
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
Hi sry if this has been covered....... but the player frame and target / of target frames do not show aggro color (which is VERY important for me as a tank) is there a change i need to make in the threat lua or enable it in some manner .




Thanks in advance

P.S. - the old sui did have this feature and it was working

EDIT : Issue fixed with SUI 2.6.3-RC4.3
Last edited by Shadowfaux1 : 10-17-10 at 01:24 AM.
Shadowfaux1 is offline Report comment to moderator  
Reply With Quote
Old 10-16-10, 09:43 PM  
dominus1
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
Originally posted by Zilver
This is as I have stated before a Bartender4 issue, I will not start coding modifications in Bartender4 since it's an active project and the developer team have been notified of this problem, here is a link to Bartender project on wowace.com
... that being said:
I did already do a fix for Multi-Passager Mounts, where you can click on the Vehicle display and "Leave" the mount.
I might do a temp fix until Bartender4's issue have been resolved, but also you should know about the player menu:

It's a simple right click on the player UnitFrame, then chose "Leave".
ah ok sorry but thankyou for the quick response
dominus1 is offline Report comment to moderator  
Reply With Quote
Old 10-16-10, 08:14 PM  
tybris
A Kobold Labourer

Forum posts: 0
File comments: 2
Uploads: 0
some things you might want to know

I have found just a few lil things that can be fixed easly i hope.1st off is the chat box i can not go into general chat without the typy thing being on top and pick another then i have to make real small so i can barely click on one and its fixed until i got into general chat.i hope you understand that. second is that buffs on a person in a party with a timer flash and it is really annoying. third and final is the calander and world map button overlap a lil. WISH LIST- bigger map button.


and for anyone who is wondering who i fixed the not loading part is turn WoW completly off and turn it back on
tybris is offline Report comment to moderator  
Reply With Quote
Old 10-16-10, 07:44 PM  
Zilver
Premium Member
 
Zilver's Avatar
AddOn Author - Click to view AddOns

Forum posts: 29
File comments: 137
Uploads: 10
Originally posted by dominus1
hi having a problem when on a drake in oculus that no exit vehicle button is showing
Originally posted by Tofu4679
I'm also having the issue in Oculus, I have no exit mount/vehicle button.

EDIT: Looks like I can right click my portrait and choose leave to exit the mount though.
This is as I have stated before a Bartender4 issue, I will not start coding modifications in Bartender4 since it's an active project and the developer team have been notified of this problem, here is a link to Bartender project on wowace.com
... that being said:
I did already do a fix for Multi-Passager Mounts, where you can click on the Vehicle display and "Leave" the mount.
I might do a temp fix until Bartender4's issue have been resolved, but also you should know about the player menu:

It's a simple right click on the player UnitFrame, then chose "Leave".
Zilver is offline Report comment to moderator  
Reply With Quote
Old 10-16-10, 07:21 PM  
Tofu4679
A Kobold Labourer

Forum posts: 0
File comments: 2
Uploads: 0
I'm also having the issue in Oculus, I have no exit mount/vehicle button.

EDIT: Looks like I can right click my portrait and choose leave to exit the mount though.
Last edited by Tofu4679 : 10-16-10 at 07:23 PM.
Tofu4679 is offline Report comment to moderator  
Reply With Quote
Old 10-16-10, 07:12 PM  
dominus1
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
hi having a problem when on a drake in oculus that no exit vehicle button is showing
dominus1 is offline Report comment to moderator  
Reply With Quote
Old 10-16-10, 05:55 PM  
Zilver
Premium Member
 
Zilver's Avatar
AddOn Author - Click to view AddOns

Forum posts: 29
File comments: 137
Uploads: 10
Re: ugh

Originally posted by tybris
http://s902.photobucket.com/albums/a...610_181235.jpg

please go to that and tell me what to do to fix i
t i dl it and thats what happened
I might be wrong, but to me it looks like you have Bartender4 Enabled, but that SpartanUI isn't Enabled ... I see no parts of SpartanUI on your screenshot.
Zilver is offline Report comment to moderator  
Reply With Quote
Old 10-16-10, 05:43 PM  
garona
A Kobold Labourer

Forum posts: 1
File comments: 22
Uploads: 0
Originally posted by Gwartan
I believe the old authors had a slash command for a reset.
try /sui reset
Or that you can do that as well, I forgot after not using SUI for a couple of months . (Didn't think it would be updated for Cata)
garona is offline Report comment to moderator  
Reply With Quote
Old 10-16-10, 05:40 PM  
Gwartan
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
Originally posted by garona
Did you do a clean install? (deleting/backing up your WTF and Interface folders)
Not sure what else might cause that
I believe the old authors had a slash command for a reset.
try /sui reset
Gwartan is offline Report comment to moderator  
Reply With Quote
Old 10-16-10, 05:35 PM  
garona
A Kobold Labourer

Forum posts: 1
File comments: 22
Uploads: 0
Did you do a clean install? (deleting/backing up your WTF and Interface folders)
Not sure what else might cause that
garona is offline Report comment to moderator  
Reply With Quote
Old 10-16-10, 05:28 PM  
tybris
A Kobold Labourer

Forum posts: 0
File comments: 2
Uploads: 0
ugh

http://s902.photobucket.com/albums/a...610_181235.jpg

please go to that and tell me what to do to fix i
t i dl it and thats what happened
tybris is offline Report comment to moderator  
Reply With Quote
Old 10-16-10, 04:40 PM  
Duraldon
A Kobold Labourer

Forum posts: 0
File comments: 7
Uploads: 0
Re: 2.6.3-RC4.3 released

Originally posted by Zilver
Anyway I just uploaded 2.6.3-RC4.3, check Change Log for changes [/b]
Changelog: * Fixed UnitPopupMenus (was missing a few)

Thanks! Works perfectly!
Duraldon is offline Report comment to moderator  
Reply With Quote
Old 10-16-10, 04:10 PM  
Zilver
Premium Member
 
Zilver's Avatar
AddOn Author - Click to view AddOns

Forum posts: 29
File comments: 137
Uploads: 10
2.6.3-RC4.3 released

Originally posted by bsnorlax
when im clicking on the party portraits, sometimes it just doesnt register. nothing will happen, it wont target the person. its like the portraits need to be clicked in specific areas, instead of anywhere on the portrait (like the health bar). is this fixable?
Check if this issue persist in the new coming version (2.6.3-RC4.3)

Originally posted by Eldrac
Sorry if this is flogging a dead horse but I was wondering, is there a way to get this and Adapt to play nice so we have the 3D portraits? I know it is something to do with the Background Strata layers and so on but for the life I don't know where to start...

Great UI though! Love it to bits!
I have no knowledge of Adapt what so ever, but you can go to my Google Code Repository and create an Issue ... remember to leave a Link to that AddOn, then when I got time I'll take a look at it.

Anyway I just uploaded 2.6.3-RC4.3, check Change Log for changes
Last edited by Zilver : 10-16-10 at 04:11 PM.
Zilver is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: