Download
(2 MB)
Download
Updated: 10-22-12 06:02 PM
Pictures
File Info
Compatibility:
Escalation (5.3)
Thunder Isle (5.2)
Landfall (5.1)
Mists of Pandaria (5.0.4)
Updated:10-22-12 06:02 PM
Created:10-08-10 04:46 AM
Downloads:112,758
Favorites:172
MD5:
SpartanUI  Popular! (More than 5000 hits)
Version: 3.1.3
by: Azgaurd, Medmerd, Vaebris, Zilver
SpartanUI
Use curse.com to get this addon

The mods here will not give me full control (Azgaurd) over the addon here and i have been the only person working on it in the last year. As a result the addon will no longer be updated here nor will I be paying any attention to the forum here.
3.1.2:
-Added Monk Chi bar

3.1.3:
Fix - Monk class icon not showing in party frames.
Fix - Monk Statue moved to the right of the CHI.
Fix - Party frames now properly update when someone was invited while in combat.
Fix - Party Frame not showing up after leaving battleground.
Fix - Moved the Extra Power bar (Petrification bar in MV) to the left so its aligned with the player frame to account some people having a issue in Shado-pan Monastery where the bar overlaps with the extra action button on the last boss. (Temporary Fix, Long term this will move only if it needs to)
Change - SpartanUI no longer hides blizzard buffs, blizz does not allow addons to turn off buffs without some lengthy work arounds.
Removed - Player buffs are no longer displayed on the player frame.
Fix - Misc bugs.
Post A Reply Comment Options
Old 11-08-10, 07:26 AM  
Zilver
Premium Member
 
Zilver's Avatar
AddOn Author - Click to view AddOns

Forum posts: 29
File comments: 137
Uploads: 10
[quote]Originally posted by Zomar
[b]
Originally posted by Zilver
Seen, will get back to you when I've had time to do some more testing ...
That said I'll not be home today until very late...

Had any chance to look at the limited scaling for 4320x900 resolution?
I didn't forget about it, but last week was a nightmare vs coding and testing (had my daughter), but this week I should have more time (not my week with my daughter) ... so I'll get back to you asap.

Zilver
Zilver is offline Report comment to moderator  
Reply With Quote
Old 11-08-10, 12:45 PM  
martiny
A Kobold Labourer

Forum posts: 0
File comments: 9
Uploads: 0
Care to answer my question aswell?
martiny is offline Report comment to moderator  
Reply With Quote
Old 11-08-10, 02:09 PM  
Zilver
Premium Member
 
Zilver's Avatar
AddOn Author - Click to view AddOns

Forum posts: 29
File comments: 137
Uploads: 10
I can see that something is wrong with the scaling, but haven't had a chance to look deeply into it yet, but it's high priority ....

That said:
I got a daughter, a job, a life, so at times things will go slow ... this is just how it'll be,
I do this in my "spare time", and I profit in no way from spending all this time on this.
Time spend in the approximately 1 month since I uploaded first time here is more than 130 hours,
this isn't an easy task, I'm trying to understand code someone else wrote ... and modify / fix / rewrite parts of it.


@martiny: Actually you didn't ask a question, you came with a statement, however I do see the underlying question that you didn't ask ...
You left out what resolution you are using, personally I play on a 21 inch screen with a resolution of 1920x1080, and a UI scale of around 0.64 and SpartanUI scale of 0.8,
everything is tiny, but I can have ALL shown and still find room for chat, Recount & Omen on the sides of SpartanUI (FanUpdate) ...
I did see your picture and it does look messed up with the height, but I don't have an solution to offer you at this moment,
maybe if i figure out what is wrong with the scaling your issue will fix it self,
but i simply can't sit here and guess how to solve it, I need to do a lot of testing every time something isn't working like expected to figure it out.

The more relevant information I have the better i can figure out what is going wrong.

Zilver
Last edited by Zilver : 11-08-10 at 02:13 PM.
Zilver is offline Report comment to moderator  
Reply With Quote
Old 11-08-10, 02:25 PM  
martiny
A Kobold Labourer

Forum posts: 0
File comments: 9
Uploads: 0
Allright. My resolution is 1920x1080, SpartanUI scale 0.7. What other information did you need?
martiny is offline Report comment to moderator  
Reply With Quote
Old 11-09-10, 11:48 AM  
Zilver
Premium Member
 
Zilver's Avatar
AddOn Author - Click to view AddOns

Forum posts: 29
File comments: 137
Uploads: 10
A small update have been uploaded into the Google Code repository Rev 63,
it fixes the issue with the Blizzard Art Bar, and updates the Vehicle Bar ...
it's still code in an early testing phase, but if you want you can get it and test it.
(no Release holds this yet, it needs more testing, and i hope to combine it with a few other things)


Originally posted by martiny
Allright. My resolution is 1920x1080, SpartanUI scale 0.7. What other information did you need?
Can't say for sure if I really need more, but the UI scale would also be great,
it can be found in ( "WoW"\WTF\Config.wtf ) just read the file with Notepad or something similar ...
the value of interest is: "uiScale".

Here is how it looks in my file:
Code:
SET uiScale "0.63999998569489"
Zilver
Zilver is offline Report comment to moderator  
Reply With Quote
Old 11-09-10, 04:44 PM  
Lakotas
A Kobold Labourer

Forum posts: 0
File comments: 4
Uploads: 0
Error Message

Hi Zilver,
I just returned to playing Wow and found your Fan Update for SpartanUI. I love this UI and will do what I can to help you get it up and running. I know nothing about code so I can be little more than a crash test dummy.

I made the changes you listed in R61 and R63 (hopefully I did them right).

Upon entering the game I got the following error message and a prompt to reload the ui. Afterward, everything seemed to be in place except for my bags, it only displayed my backpack.

Here is the error message:

Message: ...rface\AddOns\SpartanUI\scripts\Module-ActionBars.lua:116: attempt to index field 'db' (a nil value)
Time: 11/09/10 17:12:00
Count: 1
Stack: ...rface\AddOns\SpartanUI\scripts\Module-ActionBars.lua:116: in function <...rface\AddOns\SpartanUI\scripts\Module-ActionBars.lua:107>
...rface\AddOns\SpartanUI\scripts\Module-ActionBars.lua:542: in function <...rface\AddOns\SpartanUI\scripts\Module-ActionBars.lua:485>
(tail call): ?
[C]: ?
[string "safecall Dispatcher[1]"]:9: in function <[string "safecall Dispatcher[1]"]:5>
(tail call): ?
...AddOns\Bartender4\libs\AceAddon-3.0\AceAddon-3.0.lua:543: in function `EnableAddon'
...AddOns\Bartender4\libs\AceAddon-3.0\AceAddon-3.0.lua:556: in function `EnableAddon'
...AddOns\Bartender4\libs\AceAddon-3.0\AceAddon-3.0.lua:635: in function <...AddOns\Bartender4\libs\AceAddon-3.0\AceAddon-3.0.lua:621>
[C]: in function `LoadAddOn'
Interface\FrameXML\UIParent.lua:242: in function `UIParentLoadAddOn'
Interface\FrameXML\UIParent.lua:316: in function `TimeManager_LoadUI'
Interface\FrameXML\UIParent.lua:517: in function <Interface\FrameXML\UIParent.lua:492>
Locals: <none>
Lakotas is offline Report comment to moderator  
Reply With Quote
Old 11-09-10, 05:15 PM  
Zilver
Premium Member
 
Zilver's Avatar
AddOn Author - Click to view AddOns

Forum posts: 29
File comments: 137
Uploads: 10
Re: Error Message

@Lakotas:
Thanks for willingly testing the code, but you should just use the download file from here,
there is a few kinks (like the need to turn of the Blizzard Art Bar from Bartenders settings) but it's easy to fix.

Also if you want to test the latest changes you really should be using something like Tortoisesvn to update the files,
it's so easy to do a typo when editing code manually, which is what I suspect is what happened ...
also note that the repository doesn't hold Bartender or oUF which both is needed to run SpartanUI,
so getting em from the download here is by far the easy way, in a few days time,
when I've really had time to test for potential issues I'll release the changes in a new release here 8-)

Hope this helps, if not post back and we'll take it from there...
(btw going to bed now, so no more support for tonight)

Zilver
Zilver is offline Report comment to moderator  
Reply With Quote
Old 11-09-10, 08:54 PM  
Coota
A Kobold Labourer

Forum posts: 1
File comments: 3
Uploads: 0
Issue with vehicles, not the eject

Not sure if this is also a bartender thing, but when in a vehicle such as drake in EoE or Occulus, I have to click the actionbar instead pressing the number keys that are usually bound to the actionbar. The vehicle actionbar replaces my normal actionbar as it should, but the keybinds don't stay with it.

I'm using SpartanUI-263-RC5.1

A friend of mine is using the SpartanUI he found on curse with no problems in that area.
Coota is offline Report comment to moderator  
Reply With Quote
Old 11-10-10, 01:02 AM  
Gksaint
A Kobold Labourer
 
Gksaint's Avatar

Forum posts: 0
File comments: 28
Uploads: 0
Re: Issue with vehicles, not the eject

Originally posted by Coota
Not sure if this is also a bartender thing, but when in a vehicle such as drake in EoE or Occulus, I have to click the actionbar instead pressing the number keys that are usually bound to the actionbar. The vehicle actionbar replaces my normal actionbar as it should, but the keybinds don't stay with it.

I'm using SpartanUI-263-RC5.1

A friend of mine is using the SpartanUI he found on curse with no problems in that area.
I looked on Bartendar4's Changelog and this is what i saw...

version 4.4.13
* Fixed right-click self casting on modifier switched bars
* Fixed Vehicle UI button rebinding
* Bartender will now apply the "Blizzard" preset to new profiles
* Fixed hotkey out-of-range mode
* The "NormalTexture" is hidden once again now (the extra border around buttons)

The link below is a Direct Link to thier files on WoWAce.com
http://www.wowace.com/addons/bartender4/files/

I Installed thier most current "ALPHA" version...it fixed a LOT of things i was having with SpartanUI/Bartendar4... Including fixing the button dragging problem i was having even though i had the buttons locked. Hope this helps you guys out!
Gksaint is offline Report comment to moderator  
Reply With Quote
Old 11-10-10, 03:10 AM  
Coota
A Kobold Labourer

Forum posts: 1
File comments: 3
Uploads: 0
Re: Re: Issue with vehicles, not the eject

Originally posted by Gksaint
I looked on Bartendar4's Changelog and this is what i saw...

version 4.4.13
* Fixed right-click self casting on modifier switched bars
* Fixed Vehicle UI button rebinding
* Bartender will now apply the "Blizzard" preset to new profiles
* Fixed hotkey out-of-range mode
* The "NormalTexture" is hidden once again now (the extra border around buttons)

The link below is a Direct Link to thier files on WoWAce.com
http://www.wowace.com/addons/bartender4/files/

I Installed thier most current "ALPHA" version...it fixed a LOT of things i was having with SpartanUI/Bartendar4... Including fixing the button dragging problem i was having even though i had the buttons locked. Hope this helps you guys out!
Also noticed the underlined part shortly after posting previous message. Things were showing up on the actionbar like they were in range but actually out of range.

Thank you VERY much!
Coota is offline Report comment to moderator  
Reply With Quote
Old 11-10-10, 09:23 AM  
Lakotas
A Kobold Labourer

Forum posts: 0
File comments: 4
Uploads: 0
Thumbs up Re: Re: Issue with vehicles, not the eject

Originally posted by Gksaint


I Installed thier most current "ALPHA" version...it fixed a LOT of things i was having with SpartanUI/Bartendar4... Including fixing the button dragging problem i was having even though i had the buttons locked. Hope this helps you guys out!
@ GKsaint Haven't tried the Alpha yet, but I did install their most recent release and it seems to have corrected the bartender errors I was getting. I haven't played much yet so I haven't encountered the other problems. Hopefully with the Alpha (and new release) I can avoid them completely. Thanks.

@Zilver I heeded your suggestion and reverted back to the downloaded version. That seems to have corrected the SUI errors. Hey, it was worth a shot. I'm still missing my bags (except backpack), but I will be using a bag mod so that isn't really an issue for me. Basically just an FYI.
Lakotas is offline Report comment to moderator  
Reply With Quote
Old 11-10-10, 09:45 AM  
thesin
A Kobold Labourer

Forum posts: 0
File comments: 56
Uploads: 0
Re: Re: Issue with vehicles, not the eject

Originally posted by Gksaint
I looked on Bartendar4's Changelog and this is what i saw...

version 4.4.13
* Fixed right-click self casting on modifier switched bars
* Fixed Vehicle UI button rebinding
* Bartender will now apply the "Blizzard" preset to new profiles
* Fixed hotkey out-of-range mode
* The "NormalTexture" is hidden once again now (the extra border around buttons)
Thanks, I have been fighting with the no lock button locked buttons for a while this totally fixed it for me now too, and I like that curses can now maintain bartender4 for me as well, that was the last bug that was making me nuts
thesin is offline Report comment to moderator  
Reply With Quote
Old 11-10-10, 10:24 AM  
Gksaint
A Kobold Labourer
 
Gksaint's Avatar

Forum posts: 0
File comments: 28
Uploads: 0
Re: Re: Re: Issue with vehicles, not the eject

Originally posted by Lakotas
@ GKsaint Haven't tried the Alpha yet, but I did install their most recent release and it seems to have corrected the bartender errors I was getting. I haven't played much yet so I haven't encountered the other problems. Hopefully with the Alpha (and new release) I can avoid them completely. Thanks.

@Zilver I heeded your suggestion and reverted back to the downloaded version. That seems to have corrected the SUI errors. Hey, it was worth a shot. I'm still missing my bags (except backpack), but I will be using a bag mod so that isn't really an issue for me. Basically just an FYI.
Lakotas,
I have an option for you that may actually work. When patch 4.0.1 came out, I had issues with the "Guild" button in the micro bar not showing up where the used-to-be "Social" button was. It frustrated the crap outta me! So what i did was, I followed blizzards steps to refresh my WOW UI back to normal then redownload/installed ALL my addons again. When i did that it was their! Maybe it will work for you? I will list below the steps that i did to refresh my wow ui.

1. Goto your Wow Folder
2. Delete "Everything" in the Cache Folder. (Do NOT delete the Cache folder just the contents inside it.)
3. Delete "Everything" in the WTF Folder. (Do NOT delete the WTF Folder just the contents inside it.)
4. Then your Interface folder you will want to either rename it to something like InterfaceOLD or delete the Interface folder and all the contents inside.
5. Once you are done with those steps, Start WoW and relog back in. You should now have a "fresh" WoW UI. Also the files/folder you had deleted will be replaced with new ones.
6. Now the sucky part, you will have to download/reinstall/rearrange all your addons again. (Make sure to install the most recent SpartanUI (FanUpdate) first...then goto WoWAce.com and download the most recent "ALPHA" version of Bartendar4.)

Like i said...this worked for me. I dont know if it will fix your Bag issue but if your willing to try it, it may work for you.
Gksaint is offline Report comment to moderator  
Reply With Quote
Old 11-10-10, 10:59 AM  
Zilver
Premium Member
 
Zilver's Avatar
AddOn Author - Click to view AddOns

Forum posts: 29
File comments: 137
Uploads: 10
@Lakotas:
About the bag, it's an SpartanUI Bartender Profile issue,
it'll be fixed next release (not fixed in the repository yet, but I did see it when doing a few test's yesterday),
or you can simply go into Bartender and "disable" the OneBag option

it's located inside the Bag options, and I don't remember the exact name of the option, but it should be easy to find,
I'm not at a place where I can go check the name at this moment, but when I get home I'll edit the post with the exact name.

Regarding Bartender, next SpartanUI (FanUpdate) will as always contain latest Bartender rev (from the Bartender repository).
But it's 99.9% safe to just update to latest Bartender version at anytime
(though on rare occasion's it'll result in weird issues due to SpartanUI (FanUpdate) is missing stuff in the Bartender profile,
but should be very easy to fix by going into Bartender and correct the profile options)

And once again: Thanks Gksaint!
Appreciate you taking your time to help answer questions here

Zilver

Edit: fixed a typo .. lol
Last edited by Zilver : 11-10-10 at 11:38 AM.
Zilver is offline Report comment to moderator  
Reply With Quote
Old 11-10-10, 11:21 AM  
Lakotas
A Kobold Labourer

Forum posts: 0
File comments: 4
Uploads: 0
@GKsaint: Thanks for the suggestion. Unfortunately, I have been doing full UI resets every time and that hasn't helped. (This is with only SUI installed). I am a bit of an addon addict and with bagnon ( I know, processor hog, but I like it. ) it isn't really a problem for me. Just wanted to let Zilver know. I am, however, very grateful that Zilver has picked this up and that people like you are willing to take the time to post possible fixes and work arounds. ( is that even a word?)

(Edit 1)
Oh, hey Zilver, you snuck in on me. Thanks for the update. It's nice to know that it isn't something stupid that I'm doing. No rush. I have a work around and as long as the ui is basically functional, I'm a happy camper.

(Edit 2)
(reading comprehension ftw) Just noticed your one bag suggestion. Will give that a shot. Thanks again.

(Edit 3)
Yeppers, that fixed it!! Bags showing. And it seems to be working with my 50k other addons. GJ!!
Last edited by Lakotas : 11-10-10 at 12:22 PM.
Lakotas is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: