Download
(2 MB)
Download
Updated: 10-22-12 06:02 PM
Pictures
File Info
Compatibility:
Escalation (5.3)
Thunder Isle (5.2)
Landfall (5.1)
Mists of Pandaria (5.0.4)
Updated:10-22-12 06:02 PM
Created:10-08-10 04:46 AM
Downloads:112,758
Favorites:172
MD5:
SpartanUI  Popular! (More than 5000 hits)
Version: 3.1.3
by: Azgaurd, Medmerd, Vaebris, Zilver
SpartanUI
Use curse.com to get this addon

The mods here will not give me full control (Azgaurd) over the addon here and i have been the only person working on it in the last year. As a result the addon will no longer be updated here nor will I be paying any attention to the forum here.
3.1.2:
-Added Monk Chi bar

3.1.3:
Fix - Monk class icon not showing in party frames.
Fix - Monk Statue moved to the right of the CHI.
Fix - Party frames now properly update when someone was invited while in combat.
Fix - Party Frame not showing up after leaving battleground.
Fix - Moved the Extra Power bar (Petrification bar in MV) to the left so its aligned with the player frame to account some people having a issue in Shado-pan Monastery where the bar overlaps with the extra action button on the last boss. (Temporary Fix, Long term this will move only if it needs to)
Change - SpartanUI no longer hides blizzard buffs, blizz does not allow addons to turn off buffs without some lengthy work arounds.
Removed - Player buffs are no longer displayed on the player frame.
Fix - Misc bugs.
Post A Reply Comment Options
Old 10-16-10, 05:55 PM  
Zilver
Premium Member
 
Zilver's Avatar
AddOn Author - Click to view AddOns

Forum posts: 29
File comments: 137
Uploads: 10
Re: ugh

Originally posted by tybris
http://s902.photobucket.com/albums/a...610_181235.jpg

please go to that and tell me what to do to fix i
t i dl it and thats what happened
I might be wrong, but to me it looks like you have Bartender4 Enabled, but that SpartanUI isn't Enabled ... I see no parts of SpartanUI on your screenshot.
Zilver is offline Report comment to moderator  
Reply With Quote
Old 10-16-10, 07:12 PM  
dominus1
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
hi having a problem when on a drake in oculus that no exit vehicle button is showing
dominus1 is offline Report comment to moderator  
Reply With Quote
Old 10-16-10, 07:21 PM  
Tofu4679
A Kobold Labourer

Forum posts: 0
File comments: 2
Uploads: 0
I'm also having the issue in Oculus, I have no exit mount/vehicle button.

EDIT: Looks like I can right click my portrait and choose leave to exit the mount though.
Last edited by Tofu4679 : 10-16-10 at 07:23 PM.
Tofu4679 is offline Report comment to moderator  
Reply With Quote
Old 10-16-10, 07:44 PM  
Zilver
Premium Member
 
Zilver's Avatar
AddOn Author - Click to view AddOns

Forum posts: 29
File comments: 137
Uploads: 10
Originally posted by dominus1
hi having a problem when on a drake in oculus that no exit vehicle button is showing
Originally posted by Tofu4679
I'm also having the issue in Oculus, I have no exit mount/vehicle button.

EDIT: Looks like I can right click my portrait and choose leave to exit the mount though.
This is as I have stated before a Bartender4 issue, I will not start coding modifications in Bartender4 since it's an active project and the developer team have been notified of this problem, here is a link to Bartender project on wowace.com
... that being said:
I did already do a fix for Multi-Passager Mounts, where you can click on the Vehicle display and "Leave" the mount.
I might do a temp fix until Bartender4's issue have been resolved, but also you should know about the player menu:

It's a simple right click on the player UnitFrame, then chose "Leave".
Zilver is offline Report comment to moderator  
Reply With Quote
Old 10-16-10, 08:14 PM  
tybris
A Kobold Labourer

Forum posts: 0
File comments: 2
Uploads: 0
some things you might want to know

I have found just a few lil things that can be fixed easly i hope.1st off is the chat box i can not go into general chat without the typy thing being on top and pick another then i have to make real small so i can barely click on one and its fixed until i got into general chat.i hope you understand that. second is that buffs on a person in a party with a timer flash and it is really annoying. third and final is the calander and world map button overlap a lil. WISH LIST- bigger map button.


and for anyone who is wondering who i fixed the not loading part is turn WoW completly off and turn it back on
tybris is offline Report comment to moderator  
Reply With Quote
Old 10-16-10, 09:43 PM  
dominus1
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
Originally posted by Zilver
This is as I have stated before a Bartender4 issue, I will not start coding modifications in Bartender4 since it's an active project and the developer team have been notified of this problem, here is a link to Bartender project on wowace.com
... that being said:
I did already do a fix for Multi-Passager Mounts, where you can click on the Vehicle display and "Leave" the mount.
I might do a temp fix until Bartender4's issue have been resolved, but also you should know about the player menu:

It's a simple right click on the player UnitFrame, then chose "Leave".
ah ok sorry but thankyou for the quick response
dominus1 is offline Report comment to moderator  
Reply With Quote
Old 10-16-10, 11:26 PM  
Shadowfaux1
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
Hi sry if this has been covered....... but the player frame and target / of target frames do not show aggro color (which is VERY important for me as a tank) is there a change i need to make in the threat lua or enable it in some manner .




Thanks in advance

P.S. - the old sui did have this feature and it was working

EDIT : Issue fixed with SUI 2.6.3-RC4.3
Last edited by Shadowfaux1 : 10-17-10 at 01:24 AM.
Shadowfaux1 is offline Report comment to moderator  
Reply With Quote
Old 10-17-10, 12:05 AM  
yulskie
A Kobold Labourer

Forum posts: 0
File comments: 6
Uploads: 0
Re: Re: How to Resize





if you like me don't want the bar to "hide" you can type: "/sui popup all".

If it's not there, some other AddOn is interfering with it. [/b]

Thanks for the quick reply, managed to sort it out by updating bartender 4
yulskie is offline Report comment to moderator  
Reply With Quote
Old 10-17-10, 06:31 AM  
Scottbot
A Kobold Labourer

Forum posts: 0
File comments: 11
Uploads: 0
@ the threat update, for some reason soon as i attack anything now it goes red, even when im in a dungeon and nothing is attacking me or near it :P


edit; ok this time i was on a boss and pulled aggro, soon as the boss died, i got a LUA error, but accidently closed it without reading properly, but it did mention spartanUI :P if i get error again ill copy it.
Last edited by Scottbot : 10-17-10 at 06:40 AM.
Scottbot is offline Report comment to moderator  
Reply With Quote
Old 10-17-10, 06:50 AM  
Zilver
Premium Member
 
Zilver's Avatar
AddOn Author - Click to view AddOns

Forum posts: 29
File comments: 137
Uploads: 10
Re: some things you might want to know

Originally posted by tybris
I have found just a few lil things that can be fixed easly i hope.1st off is the chat box i can not go into general chat without the typy thing being on top and pick another then i have to make real small so i can barely click on one and its fixed until i got into general chat.i hope you understand that. second is that buffs on a person in a party with a timer flash and it is really annoying. third and final is the calander and world map button overlap a lil. WISH LIST- bigger map button.


and for anyone who is wondering who i fixed the not loading part is turn WoW completly off and turn it back on
1: About the Chat box, if i understand you correct you are having issues with the IM Chat Style (This is an Blizzard Option), the 2.6.3-RC4.3 of SpartanUI (which is the newest version at this point in time) is in no way moving the Chat Edit Box.

2: This is an Issue within Blizzards code for showing/hiding UnitFrames based on states (Player solo / Player in party / player in raid), a workaround is being constructed but I got my daughter this week so coding is slow.

3: Please supply an screenshot showing that the Calender & WorldMap minimap buttons are overlapping (they in no way overlap on my screen), also what screen resolution are you using?
Zilver is offline Report comment to moderator  
Reply With Quote
Old 10-17-10, 06:54 AM  
Scottbot
A Kobold Labourer

Forum posts: 0
File comments: 11
Uploads: 0
Originally posted by Scottbot
@ the threat update, for some reason soon as i attack anything now it goes red, even when im in a dungeon and nothing is attacking me or near it :P


edit; ok this time i was on a boss and pulled aggro, soon as the boss died, i got a LUA error, but accidently closed it without reading properly, but it did mention spartanUI :P if i get error again ill copy it.
Message: ...\SpartanUI_PlayerFrames\scripts\Global-Framework.lua:36: Usage: UnitThreatSituation("unit" [, "mob"])
Time: 10/17/10 13:54:00
Count: 2
Stack: [C]: in function `UnitThreatSituation'
...\SpartanUI_PlayerFrames\scripts\Global-Framework.lua:36: in function <...\SpartanUI_PlayerFrames\scripts\Global-Framework.lua:32>
(tail call): ?
(tail call): ?

Locals: (*temporary) = "targettarget"
Scottbot is offline Report comment to moderator  
Reply With Quote
Old 10-17-10, 07:34 AM  
Feoh
A Kobold Labourer

Forum posts: 0
File comments: 4
Uploads: 0
I've always right clicked my toon to dismount so never realized this was a problem, learn something new every day.

I haven't had time to read through everything here so forgive me if I'm re-asking a question.
The husband and I both use this ui and even after updating yesterday (well, replacing to be honest) we still found we had no party frames showing. I have d/l the newest version just this morning but haven't had time to log in yet and try it out so if this was addressed already my apologies and my thanks! I'm not digging the in game frame thing at all.
Feoh is offline Report comment to moderator  
Reply With Quote
Old 10-17-10, 07:58 AM  
Zilver
Premium Member
 
Zilver's Avatar
AddOn Author - Click to view AddOns

Forum posts: 29
File comments: 137
Uploads: 10
Originally posted by Feoh
I've always right clicked my toon to dismount so never realized this was a problem, learn something new every day.

I haven't had time to read through everything here so forgive me if I'm re-asking a question.
The husband and I both use this ui and even after updating yesterday (well, replacing to be honest) we still found we had no party frames showing. I have d/l the newest version just this morning but haven't had time to log in yet and try it out so if this was addressed already my apologies and my thanks! I'm not digging the in game frame thing at all.
If you find that you can't see the Party UnitFrames, try typing "/sui party reset" in chat, if this doesn't help post back.

Originally posted by Scottbot
Message: ...\SpartanUI_PlayerFrames\scripts\Global-Framework.lua:36: Usage: UnitThreatSituation("unit" [, "mob"])
Time: 10/17/10 13:54:00
Count: 2
Stack: [C]: in function `UnitThreatSituation'
...\SpartanUI_PlayerFrames\scripts\Global-Framework.lua:36: in function <...\SpartanUI_PlayerFrames\scripts\Global-Framework.lua:32>
(tail call): ?
(tail call): ?

Locals: (*temporary) = "targettarget"
Thanks for the error message, this makes the debugging a lot easier, I'll be looking into this.
Zilver is offline Report comment to moderator  
Reply With Quote
Old 10-17-10, 08:25 AM  
Dezzieleloup
A Kobold Labourer

Forum posts: 0
File comments: 10
Uploads: 0
I am having an issue when i am a raid leader setting main tanks in the interface so that my healers can see the tanks pulled out for healbot.

Even if i use the new blizz ui and do a roll check it doesn't mark them as tanks in the interface.

When i go to the raid tab and right click a name, i can still promote to assistant etc, but not promote to main tank.

All my other guildies w/o sui seem to be able to do this.
Any thoughts?
Dezzieleloup is offline Report comment to moderator  
Reply With Quote
Old 10-17-10, 08:47 AM  
Zilver
Premium Member
 
Zilver's Avatar
AddOn Author - Click to view AddOns

Forum posts: 29
File comments: 137
Uploads: 10
Originally posted by Dezzieleloup
I am having an issue when i am a raid leader setting main tanks in the interface so that my healers can see the tanks pulled out for healbot.

Even if i use the new blizz ui and do a roll check it doesn't mark them as tanks in the interface.

When i go to the raid tab and right click a name, i can still promote to assistant etc, but not promote to main tank.

All my other guildies w/o sui seem to be able to do this.
Any thoughts?
I't might be that some PopupMenus still need fixing, I'll take a look at it.
Zilver is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: