Download
(3 Kb)
Download
Updated: 11-28-10 10:52 AM
Patch for:
AzCastBar.
Pictures
File Info
Updated:11-28-10 10:52 AM
Created:10-11-10 11:07 AM
Downloads:3,610
Favorites:16
MD5:
acb CastBarImproved
Version: 10.11.28
by: Star_Hobbit [More]
You need to turn off original acb_CastBar

USAGE:
I add new options to castbars:
- "Not interruptible Cast Bar Color".It's grey by default, but you can change the color in standart option menu of AzCastBar (in part Additional)
- "Real Latency". It shows real latency (for player's cast bar) - not Blizzard's. It's right for that cast. It rechecks every cast. You can turn it on or off in standart option menu of AzCastBar (in part Additional)

If there are some bugs, please write about it in comments.
10.11.28:
Fix: Wrong latency on some spells
Fix: Spell target wasn't show
Fix: Toc update

10.11.24:
Fix: Summoning stone and vehicle's casts make real latency wrong

10.10.11:
New: Shows real latency
New: It's a plugin, not patch now

10.02.14:
Fix: Now detecting of not interruptible channeling spells is correct!
Archived Files (2)
File Name
Version
Size
Author
Date
10.11.24
4kB
Star_Hobbit
11-23-10 04:24 PM
10.10.11
3kB
Star_Hobbit
10-11-10 11:07 AM


Post A Reply Comment Options
Old 03-10-11, 06:01 AM  
Star_Hobbit
A Kobold Labourer
 
Star_Hobbit's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 60
Uploads: 6
Originally posted by fostic_popcorn
Heya, I noticed your posts on AzCastBar's post and thought maybe you would want to know this.

I noticed the same thing as you where AzCastBar sometimes doesn't update the interruptible spell color. I can specifically get this to happen when I:

1) Target myself and cast a noninterruptible spell (e.g. Hearthstone, Basic Campfire, a mount)

2) Cancel it mid-cast and target something other than myself (e.g. nothing at all, an NPC, another player).

3) Cast any spell - the spell will be colored uninterruptible instead of normal.

This gets "fixed" if I target myself again and cast a friendly interruptible spell (e.g. Healing Wave). But until then every cast is colored incorrectly.

It also doesn't "break" if I am targetting nothing or targetting another unit while initially performing step 1).

Let me know if this helps or if I should post this on the main addon's page instead.
thanks, i'll check it and tell you, if it's not my plugin priblem (then it'll be main addon problem)
Star_Hobbit is offline Report comment to moderator  
Reply With Quote
Old 03-08-11, 05:24 PM  
fostic_popcorn
A Murloc Raider
 
fostic_popcorn's Avatar
AddOn Author - Click to view AddOns

Forum posts: 5
File comments: 53
Uploads: 2
Heya, I noticed your posts on AzCastBar's post and thought maybe you would want to know this.

I noticed the same thing as you where AzCastBar sometimes doesn't update the interruptible spell color. I can specifically get this to happen when I:

1) Target myself and cast a noninterruptible spell (e.g. Hearthstone, Basic Campfire, a mount)

2) Cancel it mid-cast and target something other than myself (e.g. nothing at all, an NPC, another player).

3) Cast any spell - the spell will be colored uninterruptible instead of normal.

This gets "fixed" if I target myself again and cast a friendly interruptible spell (e.g. Healing Wave). But until then every cast is colored incorrectly.

It also doesn't "break" if I am targetting nothing or targetting another unit while initially performing step 1).

Let me know if this helps or if I should post this on the main addon's page instead.
fostic_popcorn is offline Report comment to moderator  
Reply With Quote
Old 01-26-11, 07:11 AM  
Morwo
A Kobold Labourer
 
Morwo's Avatar
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 94
Uploads: 1
sorry, i has a fail
__________________
dont nerv me bro
Morwo is offline Report comment to moderator  
Reply With Quote
Old 01-26-11, 05:59 AM  
Star_Hobbit
A Kobold Labourer
 
Star_Hobbit's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 60
Uploads: 6
I think, you must write it in comments of main addon azcastbar http://www.wowinterface.com/download...AzCastBar.html
Star_Hobbit is offline Report comment to moderator  
Reply With Quote
Old 01-26-11, 03:19 AM  
Morwo
A Kobold Labourer
 
Morwo's Avatar
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 94
Uploads: 1
Error

Hi i got an error today. None of my ACB castbars are shown anymore.
and in my ACB options, is nothing anymore UI-Screeny

Code:
1x AzCastBarOptions-10.10.14\Options.lua:619: attempt to index field '?' (a nil value)
AzCastBarOptions-10.10.14\Options.lua:433: in function <AzCastBarOptions\Options.lua:420>

Locals:
self = <unnamed> {
 0 = <userdata>
}
button = "LeftButton"
left = 363.01965431909
bottom = 482.9186697932
cfg = <table> {
 optionsBottom = 482.9186697932
 optionsLeft = 363.01965431909
}
p = <unnamed> {
 0 = <userdata>
 edit = AzCastBarOptionsProfilesEdit {}
 btnLoad = <unnamed> {}
 header = <unnamed> {}
 BuildProfileList = <function> @ AzCastBarOptions\Options.lua:563:
 btnDelete = <unnamed> {}
 outline = <unnamed> {}
 close = <unnamed> {}
 btnSave = <unnamed> {}
}
f = AzCastBarOptions {
 outline = <unnamed> {}
 btnClose = <unnamed> {}
 profilesFrame = <unnamed> {}
 scroll = AzCastBarPluginsScroll {}
 btnReset = <unnamed> {}
 BuildCategoryPage = <function> @ AzCastBarOptions\Options.lua:612:
 editMode = <unnamed> {}
 scroll2 = AzCastBarCategoryScroll {}
 categories = <table> {}
 header = <unnamed> {}
 btnProfiles = <unnamed> {}
 vers = <unnamed> {}
 plugins = <table> {}
 outline2 = <unnamed> {}
 0 = <userdata>
}

  ---
__________________
dont nerv me bro
Morwo is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: