Download
(2 Kb)
Download
Updated: 09-07-12 05:57 PM
Pictures
File Info
Compatibility:
Mists of Pandaria (5.0.4)
Updated:09-07-12 05:57 PM
Created:10-27-10 05:48 AM
Downloads:2,687
Favorites:53
MD5:
Blizzard GuildUI Status
Version: 1.7.1
by: Vladinator [More]
Adds the Away/Busy flags to characters in the guild roster. Helps figure out if someone is away or busy before even trying to talk to them!

As a bonus feature you can edit the core.lua file in a text editor and look at the top, you can then force showing the online/offline icons to make the list consistent.
1.7.1:
+ Trying to improve roster updating to show the correct value on the correct column.

1.7:
+ Added compatibility for GuildRosterButtons.

1.6:
+ Updated for MOP, mostly TOC bump.

1.5:
+ Thanks p3lim for pointing out the obvious easier solution. /thumbsup

1.4b:
+ Fixed an error occurring in 4.3.2 because of a change in one of the returned values by the guild roster API.

1.4:
+ Improved performance even further by not creating new variable space in the memory but reusing the old one, cheers.
+ Most likely fixed error reported by Adorawulf, we will find out sooner or later.

1.3:
- Fixed double-space between icon and name.
- Added the option to show icons for online and offline players as well, simply edit core.lua and remove the "--" from the 2nd line in that file. This is the most performance friendly way of doing this, besides the original function of this addon is to provide Away/Busy information in the guild roster so this is a bonus feature.

1.2:
- Made it so it uses text if you have color blind turned on, otherwise it like in 1.1 uses an icon.

1.1:
- Made it show a away/busy icon (from the friend list) in front of the name instead of appending. Also this way it saves space.

1.0:
- Initial release.
Optional Files (0)


Archived Files (7)
File Name
Version
Size
Author
Date
1.7
2kB
Vladinator
09-03-12 01:45 PM
1.6
1kB
Vladinator
08-17-12 07:32 AM
1.5
2kB
Vladinator
02-02-12 10:51 AM
1.4b
2kB
Vladinator
02-01-12 02:44 PM
1.4
2kB
Vladinator
02-01-12 09:16 AM
1.3
2kB
Vladinator
10-28-10 09:27 AM
1.2
2kB
Vladinator
10-27-10 11:50 AM


Post A Reply Comment Options
Unread 09-10-12, 07:26 PM  
Ellementz
A Kobold Labourer
 
Ellementz's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 59
Uploads: 7
Originally Posted by wagg1
well, not sure why its only this addon tho, heres some pic's i took with just your addon on, then with it off

So with only your addon on

http://i.imgur.com/3CM8x.jpg
http://i.imgur.com/9oRWP.jpg
http://i.imgur.com/oFw3Q.jpg

And with just your addon off

http://i.imgur.com/NrpTn.jpg
http://i.imgur.com/1plBP.jpg
http://i.imgur.com/gwzeL.jpg
http://i.imgur.com/hPBmK.jpg
Same thing is happening to me except I am in a horde guild but it says I am in a level 0 alliance guild.
__________________
Ellementz is offline Report comment to moderator  
Reply With Quote
Unread 09-08-12, 01:48 AM  
Spiderkeg
A Deviate Faerie Dragon

Forum posts: 14
File comments: 227
Uploads: 0
Originally Posted by Vladinator
Version 1.7.1 pending. So far on the breaking of events front, no luck.
I'll test this update out and let you know my results.
Last edited by Spiderkeg : 09-08-12 at 01:48 AM.
Spiderkeg is offline Report comment to moderator  
Reply With Quote
Unread 09-07-12, 05:56 PM  
Vlad
A Molten Giant
 
Vlad's Avatar
AddOn Author - Click to view AddOns

Forum posts: 759
File comments: 382
Uploads: 39
Spiderkeg, I've noticed this behavior long ago, even with the default UI. I didn't do anything, hoping it was a temporary bug, but now I've added a way the addon will request an update until the view matches what is selected.

By the way I hope addons that replace the dropdown still set the cvar "guildRosterView" to the correct view, I now use that to determine what view is currently showing. I find it much safer and more accurate. Please DO keep me updated if this helps, Spiderkeg, of if any issues occur.

Version 1.7.1 pending. So far on the breaking of events front, no luck.
__________________
Profile: Curse | Wowhead
Last edited by Vlad : 09-07-12 at 05:58 PM.
Vlad is offline Report comment to moderator  
Reply With Quote
Unread 09-07-12, 05:07 PM  
Spiderkeg
A Deviate Faerie Dragon

Forum posts: 14
File comments: 227
Uploads: 0
I foud another issue, which seems to be directly related to this addon.

When I choose "Guild Status" from the drop down, and then click the "Rank" column, all of the information under Rank changes to the player's name instead. I have found no way to reset this bug without reloading the UI.

Can someone else test and confirm?
Spiderkeg is offline Report comment to moderator  
Reply With Quote
Unread 09-04-12, 11:17 AM  
wagg1
A Kobold Labourer

Forum posts: 0
File comments: 14
Uploads: 0
well, not sure why its only this addon tho, heres some pic's i took with just your addon on, then with it off

So with only your addon on

http://i.imgur.com/3CM8x.jpg
http://i.imgur.com/9oRWP.jpg
http://i.imgur.com/oFw3Q.jpg

And with just your addon off

http://i.imgur.com/NrpTn.jpg
http://i.imgur.com/1plBP.jpg
http://i.imgur.com/gwzeL.jpg
http://i.imgur.com/hPBmK.jpg
wagg1 is offline Report comment to moderator  
Reply With Quote
Unread 09-04-12, 09:54 AM  
Vlad
A Molten Giant
 
Vlad's Avatar
AddOn Author - Click to view AddOns

Forum posts: 759
File comments: 382
Uploads: 39
Very weird, not sure what to do, I suggest we wait and see if some patch in the close future fixes this issue. I say this because there is no code that could cause so much breaking of the default UI, really.
__________________
Profile: Curse | Wowhead
Last edited by Vlad : 09-04-12 at 10:03 AM.
Vlad is offline Report comment to moderator  
Reply With Quote
Unread 09-04-12, 09:40 AM  
wagg1
A Kobold Labourer

Forum posts: 0
File comments: 14
Uploads: 0
Right ok. lets go all in here. I have set it to 3 and will see what it does now.

after just having your addon on still no taint.log but then i turned on only my guild ui(ish) addons and i got the some "taints" but none from your addon, yet the problem of my level 25 guild saying level 0 and no calender events still happened with only your addon on.
http://pastebin.com/XmKpwUiH
wagg1 is offline Report comment to moderator  
Reply With Quote
Unread 09-04-12, 07:49 AM  
Vlad
A Molten Giant
 
Vlad's Avatar
AddOn Author - Click to view AddOns

Forum posts: 759
File comments: 382
Uploads: 39
Originally Posted by wagg1
Hey, just did what u asked and after logging out in the logs folder there is no taints.log so had a quick look in my config.wtf file and at the bottom it says "SET taintLog "1"" so not sure what to think.
also then tryed it with all my addons on, still no taints.log
wagg1, this is very strange, especially when running with all your addons it's bound to have some taint to complain about. You can try setting it to 2 and even 3 (max) and check if it reacts any differently.
__________________
Profile: Curse | Wowhead
Vlad is offline Report comment to moderator  
Reply With Quote
Unread 09-04-12, 06:59 AM  
wagg1
A Kobold Labourer

Forum posts: 0
File comments: 14
Uploads: 0
Hey, just did what u asked and after logging out in the logs folder there is no taints.log so had a quick look in my config.wtf file and at the bottom it says "SET taintLog "1"" so not sure what to think.
also then tryed it with all my addons on, still no taints.log
wagg1 is offline Report comment to moderator  
Reply With Quote
Unread 09-04-12, 06:39 AM  
Vlad
A Molten Giant
 
Vlad's Avatar
AddOn Author - Click to view AddOns

Forum posts: 759
File comments: 382
Uploads: 39
wagg1, if you like, let's try this:
1. login with no addons enabled
2. type "/console taintLog 1"
3. logout and enable this addon
4. login and do what ever you do to bug the UI (opening it I guess :P)
5. logout
6. the log is in wow\logs\tiant.log you can zip or pastey it, how ever you like
7. next time you are in-game simply disable logging of taint by typing "/console taintLog 0"

I am curious if anything is said, because it can't break so much without it being some sort of taint or something. :P
__________________
Profile: Curse | Wowhead
Last edited by Vlad : 09-04-12 at 06:43 AM.
Vlad is offline Report comment to moderator  
Reply With Quote
Unread 09-04-12, 06:01 AM  
wagg1
A Kobold Labourer

Forum posts: 0
File comments: 14
Uploads: 0
it maybe could be. i have seen that my other addons that add icons to stuff sometimes bug out (with out a error message) and just show the info but with out a icon, but what i dont understand is with your addon on alone on a fresh install of wow i cant see any guild info, (ie guild calender invites, guild rewards, guild level, and blocks all other addons to do with the guild window)

as all i am doing is installing your addon in to my interface file for it to break my guild related stuff theres nothing more then that to tell you how its working. i could (not sure if it will help) make a video of how it looks on my side if that could help find a problem
wagg1 is offline Report comment to moderator  
Reply With Quote
Unread 09-04-12, 03:43 AM  
Vlad
A Molten Giant
 
Vlad's Avatar
AddOn Author - Click to view AddOns

Forum posts: 759
File comments: 382
Uploads: 39
It is, it could be a bug of some sort that's not our fault, I've already noticed some other bugs that are in the game core so wouldn't be surprised if this is resolved in some patch in the near future, I hope.
__________________
Profile: Curse | Wowhead
Vlad is offline Report comment to moderator  
Reply With Quote
Unread 09-03-12, 08:12 PM  
Moxie
A Cobalt Mageweaver
 
Moxie's Avatar
AddOn Author - Click to view AddOns

Forum posts: 203
File comments: 122
Uploads: 2
US client here. I wish I had an error to report to you, but it simply just doesn't work with those two enabled together. Really puzzling.
__________________
"Someday we'll look back on this, laugh nervously and quickly change the subject."

"The truth is like sunlight: people used to think it was good for you."
Moxie is offline Report comment to moderator  
Reply With Quote
Unread 09-03-12, 06:11 PM  
Vlad
A Molten Giant
 
Vlad's Avatar
AddOn Author - Click to view AddOns

Forum posts: 759
File comments: 382
Uploads: 39
I have been trying but can't manage to reproduce this issue. For me to be able to go on I almost need a detailed step by step on how to get this error triggered, in order to fix it. I'll keep an ear out.
__________________
Profile: Curse | Wowhead
Vlad is offline Report comment to moderator  
Reply With Quote
Unread 09-03-12, 05:39 PM  
wagg1
A Kobold Labourer

Forum posts: 0
File comments: 14
Uploads: 0
i play on the Eu server silvermoon (as ally) using enGB as i have said after testing the only addon that gave me problems was with your addon
wagg1 is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.