Download
(169 Kb)
Download
Updated: 11-10-10 06:56 AM
Patch for:
YurrCombatLog.
Pictures
File Info
Updated:11-10-10 06:56 AM
Created:11-08-10 03:32 PM
Downloads:1,076
Favorites:3
MD5:
Yurr Combat Log update for patch 4.0.1
Version: 4.0.1.1
by: Dessembrae [More]
This is a update for Yurr Combat Log to work with patch 4.0.1

This is a complete package.

This should add the functionality that was missing (the new gains like Holy Power, Soul Shards and Eclipse) and causing errors.

What I exactly did:
In yurrcombatlog.lua I added the following:

Code:
	[7] = string.lower(SOUL_SHARDS),
	[8] = string.lower(ECLIPSE),
	[9] = string.lower(HOLY_POWER),
This is line 62 to 64 in the updated package.

In Core.lua I added the following:
Code:
	elseif ( powerType == SPELL_POWER_SOUL_SHARDS ) then
		return SOUL_SHARDS;
	elseif ( powerType == SPELL_POWER_ECLIPSE ) then
		return ECLIPSE;
	elseif ( powerType == SPELL_POWER_HOLY_POWER ) then
		return HOLY_POWER;
These are the lines 406 to 411 in the updated package.
Archived Files (1)
File Name
Version
Size
Author
Date
4.0.1
19kB
Dessembrae
11-08-10 03:32 PM


Post A Reply Comment Options
Old 11-15-10, 04:16 PM  
Dessembrae
A Fallenroot Satyr
 
Dessembrae's Avatar
AddOn Author - Click to view AddOns

Forum posts: 29
File comments: 77
Uploads: 11
Obsolete

The original package is updated by Copystring, so this became obsolete.
__________________
Dessembrae knows the sorrows in our souls.
He walks at the side of each mortal,
a vessel of regret on the fires of vengeance.
Dessembrae knows the sorrows,
and would now share them with us all.
Dessembrae is offline Report comment to moderator  
Reply With Quote
Old 11-10-10, 06:54 AM  
Dessembrae
A Fallenroot Satyr
 
Dessembrae's Avatar
AddOn Author - Click to view AddOns

Forum posts: 29
File comments: 77
Uploads: 11
Upload approved

I've probably misread and therefor misunderstood your former comment.
I didn't realize that Core.lua is not part of the main package.

Core.lua is a part of my YurrCombatLog, so I'm not sure where it came from (I am not aware of renaming anything).
Looking trough the code it seems to be a part of Yurr.

I will rar up the whole thing I have.
It might be some leftover from old times, or something else.
Either way I will pack the whole thing up and upload it here.

I didn't do checks on interlinks, simply updated the parts that I figured needed a update to reflect the new "power gains".

Complete package that I have here on my installation is uploaded approved. It has version number 4.0.1.1

The original package is archived (version 4.0.1).
__________________
Dessembrae knows the sorrows in our souls.
He walks at the side of each mortal,
a vessel of regret on the fires of vengeance.
Dessembrae knows the sorrows,
and would now share them with us all.
Last edited by Dessembrae : 11-10-10 at 02:11 PM.
Dessembrae is offline Report comment to moderator  
Reply With Quote
Old 11-09-10, 04:06 PM  
Fairchild7102
A Kobold Labourer

Forum posts: 0
File comments: 12
Uploads: 0
Originally posted by Dessembrae
In yurrcombatlog.lua I added the following:

Code:
	[7] = string.lower(SOUL_SHARDS),
	[8] = string.lower(ECLIPSE),
	[9] = string.lower(HOLY_POWER),
This is line 62 to 64 in the updated package.

In Core.lua I added the following:
Code:
	elseif ( powerType == SPELL_POWER_SOUL_SHARDS ) then
		return SOUL_SHARDS;
	elseif ( powerType == SPELL_POWER_ECLIPSE ) then
		return ECLIPSE;
	elseif ( powerType == SPELL_POWER_HOLY_POWER ) then
		return HOLY_POWER;
These are the lines 406 to 411 in the updated package.

The error you are experiencing seems to be related to the Ace3 libs in bartender as you stated yourself. Maybe try and update them manually in the bartender installation and see what happens (I know a new Ace3 package was released yesterday if I recall correct).
Yeah I don't know how to update the Ace3 libraries for individual addons so I'm not gonna mess with that. Bartender4 though was last updated on 10-27-10 so I thought it would have the updated libraries already. The last release Ace3 library update was also on 10-27-10.

Again, you updated 2 files the yurrcombatlog.lua file which is found in the YurrCombatLog folder. The second file you updated, the core.lua is nowhere to be found in the last updated YurrCombatLog found on here http://www.wowinterface.com/download...CombatLog.html which was 0.72

Did you maybe mean to rename the file as Config.lua which is found in the YurrCombatLogOptions folder? Because again, your Core.lua file doesn't seem to be in the original addon so I don't believe it's doing anything.
Fairchild7102 is offline Report comment to moderator  
Reply With Quote
Old 11-09-10, 10:48 AM  
Dessembrae
A Fallenroot Satyr
 
Dessembrae's Avatar
AddOn Author - Click to view AddOns

Forum posts: 29
File comments: 77
Uploads: 11
In yurrcombatlog.lua I added the following:

Code:
	[7] = string.lower(SOUL_SHARDS),
	[8] = string.lower(ECLIPSE),
	[9] = string.lower(HOLY_POWER),
This is line 62 to 64 in the updated package.

In Core.lua I added the following:
Code:
	elseif ( powerType == SPELL_POWER_SOUL_SHARDS ) then
		return SOUL_SHARDS;
	elseif ( powerType == SPELL_POWER_ECLIPSE ) then
		return ECLIPSE;
	elseif ( powerType == SPELL_POWER_HOLY_POWER ) then
		return HOLY_POWER;
These are the lines 406 to 411 in the updated package.

The error you are experiencing seems to be related to the Ace3 libs in bartender as you stated yourself. Maybe try and update them manually in the bartender installation and see what happens (I know a new Ace3 package was released yesterday if I recall correct).
__________________
Dessembrae knows the sorrows in our souls.
He walks at the side of each mortal,
a vessel of regret on the fires of vengeance.
Dessembrae knows the sorrows,
and would now share them with us all.
Last edited by Dessembrae : 11-09-10 at 11:00 AM.
Dessembrae is offline Report comment to moderator  
Reply With Quote
Old 11-08-10, 06:41 PM  
Fairchild7102
A Kobold Labourer

Forum posts: 0
File comments: 12
Uploads: 0
update still giving errors.

Hey, thanks for trying to fix this addon. I'm getting this error. Also, the Core.lua you included, not sure what it's for since it doesn't overwrite/update any older file with that same exact name in the YurrCombatLog folders. I did a search in the updated YurrCombatLog.lua file, and I didn't find that it linked to your Core.lua file so yeah, confused. From the log, it seems to be some problem with the old library and bartender4 mod. I'll post the log that bugsack is catching:

1x YurrCombatLog-0.72\YurrCombatLog.lua:808: Usage: RawHook([object], method, [handler], [hookSecure]): Attempting to hook a non existing target
AceHook-3.0-5 (Bartender4):211: in function <...e\AddOns\Bartender4\libs\AceHook-3.0\AceHook-3.0.lua:118>
AceHook-3.0-5 (Bartender4):325: in function `RawHook'
YurrCombatLog-0.72\YurrCombatLog.lua:808: in function <YurrCombatLog\YurrCombatLog.lua:805>
(tail call): ?:
<in C code>: ?
<string>:"safecall Dispatcher[1]":9: in function <[string "safecall Dispatcher[1]"]:5>
(tail call): ?:
AceAddon-3.0-10 (Bartender4):543: in function `EnableAddon'
AceAddon-3.0-10 (Bartender4):635: in function <...AddOns\Bartender4\libs\AceAddon-3.0\AceAddon-3.0.lua:621>
<in C code>: in function `LoadAddOn'
Interface\FrameXML\UIParent.lua:242: in function `UIParentLoadAddOn':
Interface\FrameXML\UIParent.lua:316: in function `TimeManager_LoadUI':
Interface\FrameXML\UIParent.lua:517: in function <Interface\FrameXML\UIParent.lua:492>:

---
Fairchild7102 is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: