Download
(329 b)
Download
Updated: 05-14-11 04:38 PM
Pictures
File Info
Updated:05-14-11 04:38 PM
Created:02-09-11 07:33 AM
Downloads:97,727
Favorites:237
MD5:
Archy bugfix - DISCONTINUED  Popular! (More than 5000 hits)
Version: Read description
by: Cidrei [More]
Archy is officially maintained once more by myrroddin. Official releases have resumed. The updated file here is a dummy text file, telling you the exact same thing. You can get the updated original here.


Archy bugfix
- with credit to original posters of the information.
---

This project contained many of the community's fixes as well a few of my own and and puts them all together into a bugfix patch of the most recent version of Archy to tide people over until myrroddin took things in hand.

I have added a donation link, both to this page, and to the download box. These link to daihenka's donation page, the same as if you clicked them on one of the official Archy download pages. You can double-check this here on WoWInterface (you have to download the file for the donation box to pop up), or over at Curse if you don't trust me.

Thanks!

Click here to lend your support!

Fixes
1.7b8 bugfix6
^ - Fixed not being able to use stones. -- Snowhawk
^ - Fixed koKR locale (my fault, had something defined twice).
^ - Fixes to the currency calculations. -- Saur
^ - No longer throws error when encountering unknown digsite (future-proofing). -- Saur
^ - Fix the longstanding GetNumArtifactsByRace() is not a number error. -- Saur
^ - Correct the TexCoords for the progress bars (second time this has been fixed, see bugfix1. Didn't refix after bugfix3. Seems to be Blizzard bug because the fix doesn't seem to actually fix anything). -- Saur
* - Reorder siteData table to match blob ID order. -- Saur
* - Reordered locales to match siteData. -- Saur
* - Updates to the zhTW locale (complete, needs checked. I received conflicting translations). -- kof9x, bluecike
* - Touched up esMX locale (missing 11). -- PatoDaia
* - Updates to the deDE locale (missing 1). -- Noctum28

Special Mentions
* - daihenka, because it's his addon of course.
* - Bluspacecow, for linking the Curse page and making me look over there too.
* - Codex, for the unreleased beta.
1.7b8 bugfix6
^ - Fixed not being able to use stones. -- Snowhawk
^ - Fixed koKR locale (my fault, had something defined twice).
^ - Fixes to the currency calculations. -- Saur
^ - No longer throws error when encountering unknown digsite (future-proofing). -- Saur
^ - Fix the longstanding GetNumArtifactsByRace() is not a number error. -- Saur
^ - Correct the TexCoords for the progress bars (second time this has been fixed, see bugfix1. Didn't refix after bugfix3. Seems to be Blizzard bug because the fix doesn't seem to actually fix anything). -- Saur
* - Reorder siteData table to match blob ID order. -- Saur
* - Reordered locales to match siteData. -- Saur
* - Updates to the zhTW locale (complete, needs checked. I received conflicting translations). -- kof9x, bluecike
* - Touched up esMX locale (missing 11). -- PatoDaia
* - Updates to the deDE locale (missing 1). -- Noctum28

Fixes
1.7b8 bugfix5
* - Updates to the deDE locale (missing 3). -- Drubar, Meralda, codi
* - Updates to the ruRU locale (missing 5). -- Hanomi
* - Updates to the frFR locale (complete). -- T6CT6C6
* - Updates to the koKR locale (complete). -- jprapstyle
* - All locales (excluding zhCN) now have the new dig sites added in English where a locale specific translation has not been provided. These entries are currently commented out, but should make it easier to find and correct for people looking to update their own copies in between "official" updates.

1.7b8 bugfix4
^ - I somehow managed to upload an older version of the addon and not the finished one. Good job, me! Fixes the 3759 error and the missing digsites in the locale. I don't even know how that one got zipped up.
* - Updates to the deDE locale. -- Contiki

1.7b8 bugfix3
* - This version is based on an unreleased beta by daihenka. It includes a new alternative interface and several changes related to it, as well as various bug fixes including the fps drop inside of old instances. -- Codex, daihenka
* - Old data import re-enabled. Fixed by daihenka.
^ - Updated digsite list. It is believed that we now have all the new sites. -- foxtyke, bradc, Shambarimen, mercuria, MasterAries7, bdemore, Darenia

bugfix2
^ - Updated Ace3 libs to r1009 per Bluspacecow's suggestion. Fixes some configuration weirdness. -- Bluspacecow

bugfix1
^ - GetArcheaologyRaceInfo() return order changes. -- Brandho
^ - Fixed fragment counts not updating. Related to the above change.
^ - Fix "to make the bars look pretty again." (They're still a little wonky when they update.) -- LLGames
^ - Added new dig sites, more are out there. (Need to get the blob IDs on these.) -- bdemore, chrixian, Tekz08
^ - Possible fix for GetNumArtifactsByRace() bug? (Haven't encountered myself, so we'll see.)
^ - Fixed prompt on completing artifacts not going away with training a new rank of Archaeology. (Not tested, should work. Will check tomorrow.)
^ - Fix for the nil surveys error on load. (Commented the function out. Imports old data. Assuming it works in future as it should now, it'll keep existing data when fixed.)
Archived Files (1)
File Name
Version
Size
Author
Date
1.7beta8 bugfix
381kB
Cidrei
02-22-11 07:04 AM


Post A Reply Comment Options
Unread 04-28-11, 10:12 PM  
Glowyrm
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
Originally posted by Jeehell
In the options, Undock it...
Extreme thanks, I must have overlooked that tab.

Originally posted by Furydeath
It was working fine last night but now the windows for this mod wont even show up any more.
Happened in an instance when I left it worked though.
Last edited by Glowyrm : 04-28-11 at 11:55 PM.
Glowyrm is offline Report comment to moderator  
Reply With Quote
Unread 04-28-11, 08:35 PM  
Furydeath
A Kobold Labourer

Forum posts: 1
File comments: 3
Uploads: 0
It was working fine last night but now the windows for this mod wont even show up any more.
Furydeath is offline Report comment to moderator  
Reply With Quote
Unread 04-28-11, 06:40 PM  
Jeehell
A Kobold Labourer

Forum posts: 0
File comments: 14
Uploads: 0
Originally posted by Glowyrm
Is there anyway to separate the Survey Button from the dig site list box?

I used to have the button and the colored circle right near my characters feet (before downloading this version), it worked out well for looting relics then hitting survey as quick as possible.
In the options, Undock it...
Jeehell is offline Report comment to moderator  
Reply With Quote
Unread 04-28-11, 12:35 PM  
Mera
Retired of WoW, In ESO :)
 
Mera's Avatar
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 331
File comments: 121
Uploads: 8
Despite a great value, the code of this addon is very unstable, in my opinion, should be completely rewritten
Aber is for me to resize a frame too fast, and also unnecessarily
__________________
If you need to reach me I'm in ESO, @class101 or "Fathis Ules i"
addons: SpamBayes, BrokerCPU
projects: ThunderBayes
Mera[xeh]? - La CroisadeEcarlate (wow)
Mera is offline Report comment to moderator  
Reply With Quote
Unread 04-28-11, 11:17 AM  
oscarucb
A Murloc Raider
 
oscarucb's Avatar
AddOn Author - Click to view AddOns

Forum posts: 4
File comments: 15
Uploads: 1
Nastier but guaranteed effective fix to the annoying "growing digsite frame" bug:

search/replace in Archy.lua for:

digsiteFrame.container:SetHeight(
digsiteFrame:SetHeight(

and change all the arguments to 200:

:SetHeight(200)
oscarucb is offline Report comment to moderator  
Reply With Quote
Unread 04-28-11, 06:04 AM  
Glowyrm
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
Is there anyway to separate the Survey Button from the dig site list box?

I used to have the button and the colored circle right near my characters feet (before downloading this version), it worked out well for looting relics then hitting survey as quick as possible.
Last edited by Glowyrm : 04-28-11 at 06:05 AM.
Glowyrm is offline Report comment to moderator  
Reply With Quote
Unread 04-27-11, 08:44 PM  
myrroddin
Premium Member
 
myrroddin's Avatar
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 373
File comments: 151
Uploads: 8
Originally posted by Gendou
I do use the minimal style, and I'm pretty sure that changing 4374 is what fixed that.
Sadly, I don't know enough about programming to really say for certain.

In any event, changing 4374 to match 4412 seems to fix the minimal style.
Cool. I'll put it in after work.
myrroddin is offline Report comment to moderator  
Reply With Quote
Unread 04-27-11, 12:14 PM  
Gendou
A Deviate Faerie Dragon
 
Gendou's Avatar

Forum posts: 17
File comments: 7
Uploads: 0
By any change do you use the "minimal" style? I use the "graphical" style and it works fine. Just something I read over on curse's comments for Archy.
I do use the minimal style, and I'm pretty sure that changing 4374 is what fixed that.
Sadly, I don't know enough about programming to really say for certain.

In any event, changing 4374 to match 4412 seems to fix the minimal style.
Gendou is offline Report comment to moderator  
Reply With Quote
Unread 04-27-11, 11:31 AM  
Donnaterassi
An Aku'mai Servant

Forum posts: 36
File comments: 7
Uploads: 0
I thought this was a tomtom issue, but maybe not so much.

Hi.
Sorry to add to your troubles when it may not (just) be you, but here's whats going on...
Used ta could: Open archy and crazy arrow would appear directing me towards closest digsite. Clicking on a different digsite would change crazy arrow to the clicked one. After all items surveyed at a given digsite, the next closest survey site appears on the crazy arrow. ETC.


**for clarity's sake: I have the ArchyBugFix version of Archy installed (in case that makes a difference)

Now crazy arrow only points at Stormwind. I have the Walleye quest, But even deleting that quest, changes nothing, the arrow still wants me to go to SW. (I'm in SW, fyi)
Please can you tricksie the arrow into making archy less tedious?

Please

gonna post this on archy too, just in case its their issue


EDIT:

OMG. L2click "Tomtom integration" which became deselected with the patch.

=,)
__________________
Bacon. 'Nuff said.
Last edited by Donnaterassi : 04-27-11 at 11:38 AM.
Donnaterassi is offline Report comment to moderator  
Reply With Quote
Unread 04-27-11, 07:54 AM  
myrroddin
Premium Member
 
myrroddin's Avatar
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 373
File comments: 151
Uploads: 8
Originally posted by Gendou
Myrr:
You credited Masahikotao with the fix in a line comment, but didn't actually make the change to the code in the Bugfix12 that you uploaded.

Edit1: Sadly, making the suggested change to the code at line 4412 didn't seem to resolve the issue for me.
The window still grows with every step I take and every move I make. Almost like it's watching me.

Edit2: Making the change to line 4374 as well as 4412 seemed to resolve the issue for me.
I just checked the copy I downloaded from bugfix12, and Masa's change is on line 4413 because the original code on line 4412 I commented out. With the change to line to line 4374, that bumps the original reference to 4414.

By any change do you use the "minimal" style? I use the "graphical" style and it works fine. Just something I read over on curse's comments for Archy.

Not going to upload the fixed line 4374/5 until I test it. Here is an example of what I mean by original vs changed code:
Code:
line 7777 -- original code -- comment where fix came from
line 7778 new code provided via you guys -- this is a new line
myrroddin is offline Report comment to moderator  
Reply With Quote
Unread 04-26-11, 09:56 PM  
Gendou
A Deviate Faerie Dragon
 
Gendou's Avatar

Forum posts: 17
File comments: 7
Uploads: 0
Originally posted by myrroddin
Thanks! I got that and something else given to me on wowace, and put them in bugfix12 on my curseforge repo
Myrr:
You credited Masahikotao with the fix in a line comment, but didn't actually make the change to the code in the Bugfix12 that you uploaded.

Edit1: Sadly, making the suggested change to the code at line 4412 didn't seem to resolve the issue for me.
The window still grows with every step I take and every move I make. Almost like it's watching me.

Edit2: Making the change to line 4374 as well as 4412 seemed to resolve the issue for me.
Last edited by Gendou : 04-26-11 at 10:09 PM.
Gendou is offline Report comment to moderator  
Reply With Quote
Unread 04-26-11, 07:54 PM  
myrroddin
Premium Member
 
myrroddin's Avatar
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 373
File comments: 151
Uploads: 8
Originally posted by masahikotao
This seems to fix the 4.1 resize bug...

Archy.lua, line 4412

Change this:

digsiteFrame:SetHeight(digsiteFrame.container:GetHeight() + cyOfs + 40)

To this:

digsiteFrame:SetHeight(maxHeight + cyOfs + 40)
Thanks! I got that and something else given to me on wowace, and put them in bugfix12 on my curseforge repo
myrroddin is offline Report comment to moderator  
Reply With Quote
Unread 04-26-11, 04:58 PM  
masahikotao
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 4
Uploads: 2
This seems to fix the 4.1 resize bug...

Archy.lua, line 4412

Change this:

digsiteFrame:SetHeight(digsiteFrame.container:GetHeight() + cyOfs + 40)

To this:

digsiteFrame:SetHeight(maxHeight + cyOfs + 40)
masahikotao is offline Report comment to moderator  
Reply With Quote
Unread 04-26-11, 04:15 PM  
Enigma_TL
A Kobold Labourer

Forum posts: 0
File comments: 23
Uploads: 0
New issue

With 4.1 for some reason the window that lists the sites begins to expand as I walk forward till its off the screen and covering everything. Have to do a reload ui to fix it.
Enigma_TL is offline Report comment to moderator  
Reply With Quote
Unread 04-25-11, 07:04 AM  
myrroddin
Premium Member
 
myrroddin's Avatar
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 373
File comments: 151
Uploads: 8
Originally posted by Auroro1
Also do you know how to sent new data from gathermate or do i have just have to start over with the data.
Assuming you mean GatherMate2, then get GatherMate2_Data from Curse, and in GatherMate2's options (Esc, Interface, AddOns, GatherMate2) go to the import feature and import. It should auto-populate.
myrroddin is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.