Minion Beta! - Help us test our new AddOn updater. Get it now!
Download
(2 Kb)
Download
Updated: 07-13-11 09:43 AM
Pictures
File Info
Updated:07-13-11 09:43 AM
Created:05-25-11 12:07 PM
Downloads:1,619
Favorites:23
MD5:

Ara Broker Reputations Alts

Version: r2
by: Aranarth [More]

This is a little plugin for Ara Broker Reputations (requires r10 or above).

It records and display alternative characters reputation next to the hovered faction.

r2
- Fixed alts factions to correctly save (and display) but I'm afraid you will have to log your alts again.


r1
- Initial release.
Archived Files (1)
File Name
Version
Size
Author
Date
r1
2kB
Aranarth
05-25-11 12:07 PM


Post A Reply Comment Options
Unread 05-25-11, 08:52 PM  
lwoodya
A Kobold Labourer

Forum posts: 0
File comments: 21
Uploads: 0
Hovering...no tooltip

I am hovering but no info shows up. I got ABR v 10 and this today. Also the code in ABR v10 is still not fixed to stop guild rep from always showing instead of the faction you are gaining rep with.
lwoodya is offline Report comment to moderator  
Reply With Quote
Unread 05-26-11, 03:17 AM  
Aranarth
A Deviate Faerie Dragon
 
Aranarth's Avatar
AddOn Author - Click to view AddOns

Forum posts: 14
File comments: 394
Uploads: 7
Re: Hovering...no tooltip

Originally posted by lwoodya
I am hovering but no info shows up. I got ABR v 10 and this today. Also the code in ABR v10 is still not fixed to stop guild rep from always showing instead of the faction you are gaining rep with.
Have you logged at least 2 characters and hovered a faction they have in common ?

The ABR v10 bug will be fixed shortly, thank you for reporting.
Aranarth is offline Report comment to moderator  
Reply With Quote
Unread 05-27-11, 07:24 PM  
twc
A Kobold Labourer

Forum posts: 0
File comments: 51
Uploads: 0
I'm having a similar issue. I'm using r11, and only guild rep seems to show a tooltip and only for one of my alts. No other alts are appearing. I've logged them all in, hovered over all of their reps in my broker popup (using TitanPanel, is that an issue?) and logged them all out (to save variable data).

Edit: Also, when I right click to check the settings for the ABR, and select "Remove an alt" it picks up the names of all of my alts fine, so it's getting that data at least. Just not showing any alt tooltips.
Last edited by twc : 05-27-11 at 07:27 PM.
twc is offline Report comment to moderator  
Reply With Quote
Unread 06-29-11, 01:35 PM  
martinboy
A Kobold Labourer

Forum posts: 0
File comments: 47
Uploads: 0
It doesnt work for me either. I have version 11 of ara broker reputation and have hovered over some shared factions on a few characters, but the alt rep doesnt show at all. I have the option to remove an alt though.
martinboy is offline Report comment to moderator  
Reply With Quote
Unread 06-29-11, 09:16 PM  
Aranarth
A Deviate Faerie Dragon
 
Aranarth's Avatar
AddOn Author - Click to view AddOns

Forum posts: 14
File comments: 394
Uploads: 7
Can you post your config files please ? Either put them on a host site or copy/paste the content in [code] tag.

These files are:
- WTF\Account\ACCOUNT_NAME\SavedVariables\Ara_Broker_Reputations.lua
- WTF\Account\ACCOUNT_NAME\SavedVariables\Ara_Broker_Reputations_Alts.lua

Also, what display addon are you using ? (DockingStation, ChocolateBar, StatBlockCore, ...)

All these informations may help me reproduce your issue.
Aranarth is offline Report comment to moderator  
Reply With Quote
Unread 07-03-11, 04:07 PM  
martinboy
A Kobold Labourer

Forum posts: 0
File comments: 47
Uploads: 0
ara broker reputation lua

AraReputationsDB = {
["scale"] = 1,
["Silvermoon - Frenzypaws"] = {
["collapsedHeaders"] = {
},
},
["showRawInstead"] = false,
["blizzardColors"] = {
{
["b"] = 0.22,
["g"] = 0.3,
["r"] = 0.8,
}, -- [1]
{
["b"] = 0.22,
["g"] = 0.3,
["r"] = 0.8,
}, -- [2]
{
["b"] = 0,
["g"] = 0.27,
["r"] = 0.75,
}, -- [3]
{
["b"] = 0,
["g"] = 0.7,
["r"] = 0.9,
}, -- [4]
{
["b"] = 0.1,
["g"] = 0.6,
["r"] = 0,
}, -- [5]
{
["b"] = 0.1,
["g"] = 0.6,
["r"] = 0,
}, -- [6]
{
["b"] = 0.1,
["g"] = 0.6,
["r"] = 0,
}, -- [7]
{
["b"] = 0.1,
["g"] = 0.6,
["r"] = 0,
}, -- [8]
},
["textValues"] = false,
["Silvermoon - Alexizi"] = {
["collapsedHeaders"] = {
["The Burning Crusade"] = true,
["Other"] = true,
["Wrath of the Lich King"] = true,
["Classic"] = true,
},
},
["blockDisplay"] = "text",
["Hellfire - Holycrappy"] = {
["collapsedHeaders"] = {
},
},
["showRepToGo"] = true,
["useTipTacSkin"] = true,
["textToGo"] = false,
["Silvermoon - Druidehyld"] = {
["collapsedHeaders"] = {
},
},
["Silvermoon - Lillepala"] = {
["collapsedHeaders"] = {
},
},
["textPerc"] = true,
["Silvermoon - Summersby"] = {
["collapsedHeaders"] = {
["Inactive"] = true,
},
},
["asciiBar"] = "dualColors",
["barTexture"] = "Interface\\AddOns\\Forte_Core\\Textures\\Minimalist",
["textStanding"] = true,
["Silvermoon - Sorine"] = {
["collapsedHeaders"] = {
["Inactive"] = true,
},
},
["textSession"] = false,
["showHints"] = false,
["textFaction"] = true,
["Silvermoon - Animalia"] = {
["collapsedHeaders"] = {
["Other"] = true,
["Inactive"] = true,
["Wrath of the Lich King"] = true,
["The Burning Crusade"] = false,
["Classic"] = true,
},
},
["showSeparateValues"] = true,
["asciiColors"] = {
{
["b"] = 0,
["g"] = 0,
["r"] = 0.54,
}, -- [1]
{
["b"] = 0.1,
["g"] = 0.1,
["r"] = 1,
}, -- [2]
{
["b"] = 0,
["g"] = 0.55,
["r"] = 1,
}, -- [3]
{
["b"] = 0.87,
["g"] = 0.87,
["r"] = 0.87,
}, -- [4]
{
["b"] = 0,
["g"] = 1,
["r"] = 1,
}, -- [5]
{
["b"] = 0.1,
["g"] = 0.9,
["r"] = 0.1,
}, -- [6]
{
["b"] = 0.88,
["g"] = 0.41,
["r"] = 0.25,
}, -- [7]
{
["b"] = 0.8,
["g"] = 0.2,
["r"] = 0.6,
}, -- [8]
{
["b"] = 0.6,
["g"] = 0,
["r"] = 0.4,
}, -- [9]
},
["Silvermoon - Calexia"] = {
["collapsedHeaders"] = {
["Other"] = true,
["The Burning Crusade"] = true,
["Wrath of the Lich King"] = true,
["Classic"] = true,
},
},
["Silvermoon - Fighsty"] = {
["collapsedHeaders"] = {
},
},
}
martinboy is offline Report comment to moderator  
Reply With Quote
Unread 07-03-11, 04:07 PM  
martinboy
A Kobold Labourer

Forum posts: 0
File comments: 47
Uploads: 0
ara broker reputation alts lua

AraReputationsAltsDB = {
["Silvermoon"] = {
["Druidehyld"] = {
["class"] = "DRUID",
["factions"] = {
},
["faction"] = "Alliance",
},
["Frenzypaws"] = {
["class"] = "WARRIOR",
["faction"] = "Alliance",
["factions"] = {
},
},
["Summersby"] = {
["class"] = "DEATHKNIGHT",
["factions"] = {
},
["faction"] = "Alliance",
},
["Lillepala"] = {
["class"] = "PALADIN",
["faction"] = "Alliance",
["factions"] = {
},
},
["Alexizi"] = {
["class"] = "WARLOCK",
["factions"] = {
},
["faction"] = "Alliance",
},
["Calexia"] = {
["class"] = "MAGE",
["faction"] = "Alliance",
["factions"] = {
},
},
["Animalia"] = {
["class"] = "HUNTER",
["factions"] = {
["Alliance Vanguard"] = 42999,
},
["faction"] = "Alliance",
},
["Sorine"] = {
["class"] = "PRIEST",
["factions"] = {
},
["faction"] = "Alliance",
},
},
}
martinboy is offline Report comment to moderator  
Reply With Quote
Unread 07-03-11, 04:08 PM  
martinboy
A Kobold Labourer

Forum posts: 0
File comments: 47
Uploads: 0
display addon

I am using Titan Panels.
martinboy is offline Report comment to moderator  
Reply With Quote
Unread 07-05-11, 02:01 PM  
Aranarth
A Deviate Faerie Dragon
 
Aranarth's Avatar
AddOn Author - Click to view AddOns

Forum posts: 14
File comments: 394
Uploads: 7
Re: display addon

Thank you martinboy, I think I found the issue.
The following version should work correctly, but you will have to log alts again before seeing anything.
http://aranarth.pagesperso-orange.fr...ns_Alts-r2.zip
Last edited by Aranarth : 07-05-11 at 02:02 PM.
Aranarth is offline Report comment to moderator  
Reply With Quote
Unread 07-12-11, 08:31 AM  
martinboy
A Kobold Labourer

Forum posts: 0
File comments: 47
Uploads: 0
I am sorry, but it still doesnt work. It only shows alt rep for Alliance Vanguard and no other factions.

This is what alt.lua gave me after I hovered over all factions from 2 characters:

AraReputationsAltsDB = {
["Silvermoon"] = {
["Summersby"] = {
["class"] = "DEATHKNIGHT",
["factions"] = {
["Alliance Vanguard"] = 42999,
},
["faction"] = "Alliance",
},
["Animalia"] = {
["class"] = "HUNTER",
["faction"] = "Alliance",
["factions"] = {
},
},
},
}
Last edited by martinboy : 07-12-11 at 08:33 AM.
martinboy is offline Report comment to moderator  
Reply With Quote
Unread 07-13-11, 09:32 AM  
Aranarth
A Deviate Faerie Dragon
 
Aranarth's Avatar
AddOn Author - Click to view AddOns

Forum posts: 14
File comments: 394
Uploads: 7
@martinboy:

Aww I'm sorry, I overlooked the part with the Alliance Vanguard.
A fixed version will be posted shortly.

Thank you for your help.
Aranarth is offline Report comment to moderator  
Reply With Quote
Unread 07-15-11, 06:47 PM  
martinboy
A Kobold Labourer

Forum posts: 0
File comments: 47
Uploads: 0
Originally posted by Aranarth
@martinboy:

Aww I'm sorry, I overlooked the part with the Alliance Vanguard.
A fixed version will be posted shortly.

Thank you for your help.
Is the r2 version the new updated version? Because the r2 version I have on my pc is downloaded july 12.
martinboy is offline Report comment to moderator  
Reply With Quote
Unread 07-16-11, 03:45 AM  
Aranarth
A Deviate Faerie Dragon
 
Aranarth's Avatar
AddOn Author - Click to view AddOns

Forum posts: 14
File comments: 394
Uploads: 7
@martinboy:

Yes. The older r2 linked below should have been labelled b2 instead. My bad.
Aranarth is offline Report comment to moderator  
Reply With Quote
Unread 07-16-11, 06:17 AM  
martinboy
A Kobold Labourer

Forum posts: 0
File comments: 47
Uploads: 0
Originally posted by Aranarth
@martinboy:

Yes. The older r2 linked below should have been labelled b2 instead. My bad.
Then its still not working. Now it records no factions at all. I have hovered over factions both in blizzards rep tap and your ara broker rep addon. This is what I get from alt.lua in your newest version after hovering over factions on 3 characters. I can mention, that the alt.lua file doesnt get created before I have logged into a second character.

AraReputationsAltsDB = {
["Silvermoon"] = {
["Calexia"] = {
["class"] = "MAGE",
["faction"] = "Alliance",
["factions"] = {
},
},
["Alexizi"] = {
["class"] = "WARLOCK",
["factions"] = {
},
["faction"] = "Alliance",
},
["Animalia"] = {
["class"] = "HUNTER",
["factions"] = {
},
["faction"] = "Alliance",
},
},
}
martinboy is offline Report comment to moderator  
Reply With Quote
Unread 08-14-11, 11:17 AM  
martinboy
A Kobold Labourer

Forum posts: 0
File comments: 47
Uploads: 0
Update: Somehow suddenly some of the rep begins to show up on alts, but with very different result. I have 10 characters all member of the same guild. Moused over the guildrep on all characters but alt rep only shows the rep for 3 of my characters. My death knights rep with different factions doesnt show at all. All in all, this addon seems not to be working as it should.
martinboy is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: