Quantcast
Download
(847 Kb)
Download
Updated: 06-05-18 11:41 PM
Pictures
File Info
Compatibility:
Battle for Azeroth Beta (8.0.1)
Shadows of Argus (7.3.0)
Updated:06-05-18 11:41 PM
Created:06-28-11 01:11 PM
Downloads:43,313
Favorites:159
MD5:
7.3.0

PitBull Unit Frames 4.0  Popular! (More than 5000 hits)

Version: v4.1.11
by: Shefki, nebula

Woof. Arf. Yip.

Issues (New issue)

FAQ

Getting Started:


You can help translate PitBull for your language with the localization tool.

Full History

v4.1.10
  • Added support for Battle for Azeroth.
  • Added Allied races for LuaText functions.

v4.1.6 changes
  • Fixed an error that would prevent frames from showing in config mode.
  • Updated Totems to show for Death Knight Gargoyles and Priest Shadowfiends.

v4.1.5 changes
  • Updated when the Totem bar shows and added some color settings (background/timer text) to the layout settings (There are more color settings under Colors->Totems).
  • Fixed Chi display.

v4.1.4 changes
  • Added showing your prestige rank when flagged for PvP. You can change this back to just your faction icon under Indictors->PvP icon.
  • Updated Soulstones to use the Blizzard art. Hopefully everyone likes the new icons!

v4.1.1 changes
  • Added Masque support for auras. If you use Masque, you can set the skin for the layout under Aura->Display or in Masque under "PitBull4 Aura". Two PitBull skins are provided that will work with hiding/showing the border as set in the settings, or you can disable Masque support completely in the module options (Modules->Aura).
  • Fixed modules not updating on group frames. (Notably VisualHeal)
  • Fixed anchoring to group frames.

v4.1.0 changes
  • Frame anchoring. For example, you can anchor your Target of target frame to your Target frame so that it moves when you move your Target frame. In config mode, frames anchored to another frame will show a gray line connecting them at the anchor points set.
  • Multiple unit frames
  • Want a player cast bar that auto-hides and doesn't squish your other bars together? Create a new unit frame and set the unit to Player, set a layout that only has Cast bar enabled on it, and anchor it to your original player frame.
  • Due to how the indicator offset system works, it makes fine-tuning the position of secondary resource icons awkward. You can now create a duplicate unit frame for positioning your combo points exactly where you want.
  • Frame names now use the unit frame label instead of the unit. For example, PitBull4_Frames_player is now PitBull4_Frames_Player, PitBull4_Frames_targettarget is now "PitBull4_Frames_Target's target". You'll need to update any addons (kgPanels) that anchor to your unit frames. You can check the name of the frame with /framestack.
  • Default frame positions. Starting from scratch no longer dumps all of the frames in the middle of your screen. They will now show in a layout similar to the Blizzard layout.
Post A Reply Comment Options
Unread 09-11-12, 05:10 PM  
Shefki
An Aku'mai Servant
 
Shefki's Avatar
AddOn Author - Click to view AddOns

Forum posts: 31
File comments: 175
Uploads: 9
Originally Posted by MrFireal
I hope you don't change it, though :P The fact that the bars animate as they do is the sole reason why I switched from Stuf to Pitbull4. I think it's cool.
I'll keep that in mind, if I ever do change it I'll provide an option then.
Report comment to moderator  
Reply With Quote
Unread 09-11-12, 04:56 PM  
Shefki
An Aku'mai Servant
 
Shefki's Avatar
AddOn Author - Click to view AddOns

Forum posts: 31
File comments: 175
Uploads: 9
Originally Posted by dietmug
Is there a media folder where I can add fonts?

Thanks
Inside the SharedMedia addon (that you'll need to install separately) there are instructions on how to add media. Look for the file named "INSTRUCTIONS for MyMedia.txt"

You can find the SharedMedia addon here:
http://www.curse.com/addons/wow/sharedmedia
Report comment to moderator  
Reply With Quote
Unread 09-10-12, 06:01 AM  
MrFireal
A Defias Bandit

Forum posts: 3
File comments: 6
Uploads: 0
Originally Posted by Shefki
To be honest it's always bugged me that changing targets animated the bars.
I hope you don't change it, though :P The fact that the bars animate as they do is the sole reason why I switched from Stuf to Pitbull4. I think it's cool.
Last edited by MrFireal : 09-10-12 at 06:02 AM.
Report comment to moderator  
Reply With Quote
Unread 09-08-12, 05:00 PM  
dietmug
A Defias Bandit

Forum posts: 2
File comments: 18
Uploads: 0
Is there a media folder where I can add fonts?

Thanks
Report comment to moderator  
Reply With Quote
Unread 09-07-12, 08:27 AM  
Everlu
A Murloc Raider
 
Everlu's Avatar
AddOn Compiler - Click to view compilations

Forum posts: 4
File comments: 23
Uploads: 2
Re: Re: Re: Re: LuaText issue

Originally Posted by Shefki
Originally Posted by Everlu
Anyway, I gave it a shot, but I'm still experiencing all of the same issues, but I did notice something about its behavior pattern. By testing it on my target frame, I saw that if I already have a target (or unit frame, I'm guessing) present, then the luatext does not appear. However, if I cast Riptide on myself with no target or another unit selected, and then select myself as a target, it shows up (but doesn't go away after the buff expires).
Like I said, you've missed one piece of the config. Check the UNIT_AURA line in the Events dropdown under the Code and Accept box. If you don't choose the event it'll never update except when the frame gets fully updated e.g. changing targets on the target frame.
Oh wow, I can't believe I misunderstood you the first time. Thanks for humoring me. It seems so obvious now! :P I do appreciate it a lot though.
Report comment to moderator  
Reply With Quote
Unread 09-07-12, 12:28 AM  
Shefki
An Aku'mai Servant
 
Shefki's Avatar
AddOn Author - Click to view AddOns

Forum posts: 31
File comments: 175
Uploads: 9
Originally Posted by TGulics
I've noticed that the Dogtag for [Status] is showing Offline at all times?

The minute I removed this from Health: Percent so it is simply [PercentHP:Percent] in the Dogtag text display, and all my "Offline" display troubles went away.

Perhaps a bug?
Probably. You should report it here: http://www.wowace.com/addons/libdogtag-unit-3-0/

I can't promise anything will happen. I'm not maintaining or involved with DogTags. My recommendation would be to migrate to LuaTexts.
Report comment to moderator  
Reply With Quote
Unread 09-07-12, 12:25 AM  
Shefki
An Aku'mai Servant
 
Shefki's Avatar
AddOn Author - Click to view AddOns

Forum posts: 31
File comments: 175
Uploads: 9
Originally Posted by MrFireal
I have disabled the power bar for units that doesn't have a power bar. So if I target a unit with no power bar, and then target a unit that has a power bar, the bar doesn't animate. It simply goes from full to empty after the set duration of the animation ends.
Thanks for the report I'll look into it. To be honest it's always bugged me that changing targets animated the bars.
Report comment to moderator  
Reply With Quote
Unread 09-06-12, 09:50 PM  
TGulics
A Murloc Raider

Forum posts: 4
File comments: 79
Uploads: 0
I've noticed that the Dogtag for [Status] is showing Offline at all times?

The minute I removed this from Health: Percent so it is simply [PercentHP:Percent] in the Dogtag text display, and all my "Offline" display troubles went away.

Perhaps a bug?
Report comment to moderator  
Reply With Quote
Unread 09-06-12, 06:45 PM  
MrFireal
A Defias Bandit

Forum posts: 3
File comments: 6
Uploads: 0
I have disabled the power bar for units that doesn't have a power bar. So if I target a unit with no power bar, and then target a unit that has a power bar, the bar doesn't animate. It simply goes from full to empty after the set duration of the animation ends.
Report comment to moderator  
Reply With Quote
Unread 09-05-12, 09:34 PM  
Shefki
An Aku'mai Servant
 
Shefki's Avatar
AddOn Author - Click to view AddOns

Forum posts: 31
File comments: 175
Uploads: 9
Re: Re: Re: LuaText issue

Originally Posted by Everlu
Anyway, I gave it a shot, but I'm still experiencing all of the same issues, but I did notice something about its behavior pattern. By testing it on my target frame, I saw that if I already have a target (or unit frame, I'm guessing) present, then the luatext does not appear. However, if I cast Riptide on myself with no target or another unit selected, and then select myself as a target, it shows up (but doesn't go away after the buff expires).
Like I said, you've missed one piece of the config. Check the UNIT_AURA line in the Events dropdown under the Code and Accept box. If you don't choose the event it'll never update except when the frame gets fully updated e.g. changing targets on the target frame.
Report comment to moderator  
Reply With Quote
Unread 09-05-12, 07:11 PM  
Everlu
A Murloc Raider
 
Everlu's Avatar
AddOn Compiler - Click to view compilations

Forum posts: 4
File comments: 23
Uploads: 2
Re: Re: LuaText issue

Originally Posted by Shefki
Originally Posted by Everlu
I've been experiencing some odd buggy action with a luatext on my resto shaman. Here is the text in question, designed to display an R on units that have Riptide on them.
Copied and pasted the answer I gave on the official wow forums here:

More than likely you've forgotten to check UNIT_AURA as the event.

This is what I'd use as the code:

Lua Code:
  1. if UnitAura(unit, "Riptide", nil, "HELPFUL") then
  2.   return "+"
  3. end
Hey, I really appreciate your response. I posted here because I thought my thread would get buried. Should have known better!

Anyway, I gave it a shot, but I'm still experiencing all of the same issues, but I did notice something about its behavior pattern. By testing it on my target frame, I saw that if I already have a target (or unit frame, I'm guessing) present, then the luatext does not appear. However, if I cast Riptide on myself with no target or another unit selected, and then select myself as a target, it shows up (but doesn't go away after the buff expires).
Report comment to moderator  
Reply With Quote
Unread 09-05-12, 12:27 AM  
Shefki
An Aku'mai Servant
 
Shefki's Avatar
AddOn Author - Click to view AddOns

Forum posts: 31
File comments: 175
Uploads: 9
Re: LuaText issue

Originally Posted by Everlu
I've been experiencing some odd buggy action with a luatext on my resto shaman. Here is the text in question, designed to display an R on units that have Riptide on them.
Copied and pasted the answer I gave on the official wow forums here:

More than likely you've forgotten to check UNIT_AURA as the event.

This is what I'd use as the code:

Lua Code:
  1. if UnitAura(unit, "Riptide", nil, "HELPFUL") then
  2.   return "+"
  3. end
Last edited by Shefki : 09-05-12 at 12:27 AM.
Report comment to moderator  
Reply With Quote
Unread 09-04-12, 03:18 PM  
Everlu
A Murloc Raider
 
Everlu's Avatar
AddOn Compiler - Click to view compilations

Forum posts: 4
File comments: 23
Uploads: 2
LuaText issue

I've been experiencing some odd buggy action with a luatext on my resto shaman. Here is the text in question, designed to display an R on units that have Riptide on them.

Code:
local name, _, icon, count = UnitBuff(unit, "Riptide", true) 
if name then
  return "%s","R"
end
A few things happen with this text:
  • No R appears on any unit I cast Riptide on.
  • An R randomly shows up on a unit frame I did not cast it on.
  • An R appears when I cast Riptide but does not disappear after the buff expires.
  • An R appears outside of the unit frame (it is the only item set to display on my party frames, so it is not sharing its position on the health bar or unit frame with anything).
  • An R appears randomly on every party frame.

Any idea what's going on? Here's a screenshot of the issue.

Edit:

Forgot to mention that when I replace Riptide with the name of another buff it works fine. I'm boggled on this.
Last edited by Everlu : 09-04-12 at 03:45 PM.
Report comment to moderator  
Reply With Quote
Unread 09-02-12, 01:51 AM  
Overhealz
A Kobold Labourer
 
Overhealz's Avatar

Forum posts: 0
File comments: 21
Uploads: 0
Originally Posted by Shefki
Originally Posted by Overhealz
I tried what you said. But no matter what settings i choose it does not move. Could it be bugged somehow?

Or do i have to update Pitbull in general? Got the latest one from Curse-client atm.
You're almost certainly editing the layout that's not attached to your player frame. Do the following:
/pb
Go to units.
Select Player as the current unit frame.
Note the Layout that is selected for this frame.
Go to Layout editor, select that layout.
Go to Indicators.
Go to Shadow Orbs
Adjust the Location drop down box to your liking.

This guide may be helpful to you:
http://www.wowace.com/addons/pitbull4/pages/guide/

In particular this page:
http://www.wowace.com/addons/pitbull...ing-to-frames/

Thanks alot mate! This worked perfectly. )
Report comment to moderator  
Reply With Quote
Unread 09-01-12, 12:54 AM  
Shefki
An Aku'mai Servant
 
Shefki's Avatar
AddOn Author - Click to view AddOns

Forum posts: 31
File comments: 175
Uploads: 9
Originally Posted by dietmug
Lol I've posted and deleted so many questions after I've tinkered further into this addon. Last question for now though, how do I make the aggro indicator show up as a red border around a unit's frame, instead of just turning their whole health bar red?
Make sure the border module is enabled. Under the layout for the frame you want to behave this way, Other, AGgro, choose Border under Display.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: