Quantcast
Download
(12 MB)
Download
Updated: 09-14-16 12:12 AM
Pictures
File Info
Compatibility:
Legion (7.0.3)
Updated:09-14-16 12:12 AM
Created:09-11-11 11:24 AM
Downloads:86,257
Favorites:150
MD5:
7.0.3

MiirGui Texture Pack [Blue]  Popular! (More than 5000 hits)

Version: 4.0.12
by: Neza [More]



This is the blue texture pack for MiirGui [Core]. It contains only textures and is meant to be used with MiirGui [Core].

There is a optional Icon Pack.



When updating from an older version delete all files created by this texture pack in
your interface folder.


Alternativly, you can read the changelog and just delete the single files which were removed in an update.

Then proceed to paste the content of the zip file into the interface folder.



If you find any missmatching graphics, please use the comment section of this page.



Copyright 2011-2016 Miiru

The contents of this addon, excluding third-party resources, are
copyrighted to its authors with all rights reserved.

## Upcoming Changes ##
modified Collections.blp
modified GroupFinder.BLP (legacy burning crusade raids were missing)

## Changes in 4.0.12 ##

modified UI-VEHICLE-FRAME.blp slightly
Added QuestFrame/WorldQuest.blp

## Changes in 4.0.10 ##

Added Collections/Collections.blp
Added questframe/QuestBackgroundHordeAlliance.blp
Added questframe/QuestBG.blp
Optional Files (1)
File Name
Version
Size
Author
Date
Type
4.0.0
67MB
07-18-16 03:31 AM
Patch


Post A Reply Comment Options
Unread 03-05-13, 09:43 PM  
NeuronRider
A Murloc Raider
 
NeuronRider's Avatar

Forum posts: 7
File comments: 42
Uploads: 0
Re: symbol error

Originally Posted by mikar
hi,

due to the changes to the honor-GUI by blizzard in 5.2, miirGUI is throwing an error when trying to replace the honor icon in the pvp frame.

Code:
2x miirGui-2.1.9\core.lua:178: attempt to index global "PVPFramePortrait" (a nil value)
miirGui-2.1.9\core.lua:178: in function <miirGui\core.lua:16>
I don't have lua errors turned on right now, but try the following:
  • Open miirgui_icons\miirgui_icons.lua (use notepad, or another text editor)
  • Comment out lines 43 through 47. Should look like:
    Code:
    --[[if factionGroup == "Horde" then
    	Icon(PVPUIFrame, "guildh", -8, 9, "Medium")
    elseif  factionGroup == "Alliance" then
    	Icon(PVPUIFrame, "guilda", -8, 9, "Medium")  
    end	]]
  • Add the following code at line 112 (see full OnEvent function at end of reply if you're not sure what it should look like)
    Code:
    elseif event == "ADDON_LOADED" and arg1 == "Blizzard_PVPUI" then	
    	if factionGroup == "Horde" then
    		Icon(PVPUIFrame, "guildh", -8, 9, "Medium")
    	elseif  factionGroup == "Alliance" then
    		Icon(PVPUIFrame, "guilda", -8, 9, "Medium")  
    	end	
    end
  • Save file
  • Reload WoW

The frame name changed in 5.2, and they broke that element out into a separate blizz addon, so you have to hook into the event to watch for the frame creation.

Hopefully fixes your error. I was noticing this from a graphical perspective, where the portrait was showing at all times in the upper-left-ish corner. I presume the two issues are correlated.

Full OnEvent function (lines 95-119)
Code:
function frame:OnEvent(event, arg1)
	if event == "ADDON_LOADED" and arg1 == "Blizzard_TradeSkillUI" then	
		Icon(TradeSkillFrame, "trade", -8, 9, "Medium")	
	elseif event == "ADDON_LOADED" and arg1 == "Blizzard_ItemAlterationUI" then
		Icon(TransmogrifyFrame, "trans", -8, 9, "High")			
	elseif event == "ADDON_LOADED" and arg1 == "Blizzard_ReforgingUI" then			
		Icon(ReforgingFrame, "reforging", -8, 9, "Medium")				
	elseif event == "ADDON_LOADED" and arg1 == "Blizzard_EncounterJournal"  then
		Icon(EncounterJournal, "journal", -8, 9, "Medium")	
	elseif event == "ADDON_LOADED" and arg1 == "Blizzard_PetJournal" then				
		Icon(PetJournalParent, "mounts", -8, 9, "HIGH")
	elseif event == "ADDON_LOADED" and arg1 == "Blizzard_ArchaeologyUI" then		
		Icon(ArchaeologyFrame, "arch", -8, 9, "Medium")
	elseif event == "ADDON_LOADED" and arg1 == "Blizzard_LookingForGuildUI" then
		Icon(LookingForGuildFrame, "lfgu", -8, 9, "Medium")
	elseif event == "ADDON_LOADED" and arg1 == "Blizzard_MacroUI" then
		Icon(MacroFrame, "macro", -8, 9, "Medium")	
	elseif event == "ADDON_LOADED" and arg1 == "Blizzard_PVPUI" then	
		if factionGroup == "Horde" then
			Icon(PVPUIFrame, "guildh", -8, 9, "Medium")
		elseif  factionGroup == "Alliance" then
			Icon(PVPUIFrame, "guilda", -8, 9, "Medium")  
		end	
	end
end
Last edited by NeuronRider : 03-05-13 at 10:01 PM.
Report comment to moderator  
Reply With Quote
Unread 02-28-13, 10:10 PM  
mikar
A Kobold Labourer

Forum posts: 0
File comments: 4
Uploads: 0
symbol error

hi,

due to the changes to the honor-GUI by blizzard in 5.2, miirGUI is throwing an error when trying to replace the honor icon in the pvp frame.

Code:
2x miirGui-2.1.9\core.lua:178: attempt to index global "PVPFramePortrait" (a nil value)
miirGui-2.1.9\core.lua:178: in function <miirGui\core.lua:16>
Last edited by mikar : 02-28-13 at 10:40 PM.
Report comment to moderator  
Reply With Quote
Unread 12-28-12, 11:12 PM  
love4wheeli3z
A Kobold Labourer
 
love4wheeli3z's Avatar

Forum posts: 0
File comments: 7
Uploads: 0
Chat buble

Hello Mir
Got another question.
How do i make the black background of the chat to not show in the chat bubble ?


is it possible to remove or somehow make the opacity to 0% of that black line in the gaps ?

Happy Holidays and Happy new Year!

-W.
Report comment to moderator  
Reply With Quote
Unread 12-13-12, 07:59 AM  
Miiru
A Flamescale Wyrmkin
 
Miiru's Avatar
AddOn Author - Click to view AddOns

Forum posts: 129
File comments: 313
Uploads: 14
Re: Check marks.

Originally Posted by Omgwtfbbqhax
hey there Miir i know i a pain in the ass when it comes down to things but could you tell me how to restore the check marks.

the blue shade color fill is nice but its harder for me to notice then the original check marks in the beginning.
if your able to hook me up i be very grateful ^^
Interface/Buttons/UI-CheckBox-Check
Interface/Buttons/UI-CheckBox-Check-Disabled
Interface/Buttons/UI-CheckBox-Down
Interface/Buttons/UI-CheckBox-Highlight
Interface/Buttons/UI-CheckBox-Up

I guess thats all of em
__________________
◘◘ Author of MiirGui Texture Pack - [Core] [Blue] [Grey] ◘◘
Report comment to moderator  
Reply With Quote
Unread 12-09-12, 10:18 PM  
love4wheeli3z
A Kobold Labourer
 
love4wheeli3z's Avatar

Forum posts: 0
File comments: 7
Uploads: 0
Hey Miiru i replaced the 32 line with a
Code:
for i=1,7 do _G["ChatFrame"..1]:SetFading(40) end
And works now , havent tried the deleting solution since works perfectly.
Thnx for respond

-W.
Report comment to moderator  
Reply With Quote
Unread 12-09-12, 08:23 PM  
Omgwtfbbqhax
A Kobold Labourer

Forum posts: 0
File comments: 9
Uploads: 0
Check marks.

hey there Miir i know i a pain in the ass when it comes down to things but could you tell me how to restore the check marks.

the blue shade color fill is nice but its harder for me to notice then the original check marks in the beginning.
if your able to hook me up i be very grateful ^^
Report comment to moderator  
Reply With Quote
Unread 11-28-12, 06:36 AM  
Miiru
A Flamescale Wyrmkin
 
Miiru's Avatar
AddOn Author - Click to view AddOns

Forum posts: 129
File comments: 313
Uploads: 14
Re: chat fade out

Originally Posted by love4wheeli3z
Hello

I want to ask you if there is a way to make the chat fade out , cos atm is not working and i dont know how to get this sorted.
With no chat addon in and nothing else except this GUI the chat is not fading , prat/and other chat addons are not making it fade either .

Best regards.
Addons/miirgui/core.lua

Delete line 32

for i=1,7 do _G["ChatFrame"..i]:SetFading(0) end
__________________
◘◘ Author of MiirGui Texture Pack - [Core] [Blue] [Grey] ◘◘
Report comment to moderator  
Reply With Quote
Unread 11-27-12, 09:58 AM  
love4wheeli3z
A Kobold Labourer
 
love4wheeli3z's Avatar

Forum posts: 0
File comments: 7
Uploads: 0
chat fade out

Hello

I want to ask you if there is a way to make the chat fade out , cos atm is not working and i dont know how to get this sorted.
With no chat addon in and nothing else except this GUI the chat is not fading , prat/and other chat addons are not making it fade either .

Best regards.
Report comment to moderator  
Reply With Quote
Unread 10-24-12, 11:36 AM  
Greevir
A Cyclonian
 
Greevir's Avatar
AddOn Compiler - Click to view compilations

Forum posts: 44
File comments: 91
Uploads: 1
Was able to remedy the Character Menu Image by fixing a small typo.
Code:
elseif class == "Monk" then
should be
Code:
elseif class == "MONK" then
Report comment to moderator  
Reply With Quote
Unread 10-22-12, 08:58 AM  
Miiru
A Flamescale Wyrmkin
 
Miiru's Avatar
AddOn Author - Click to view AddOns

Forum posts: 129
File comments: 313
Uploads: 14
Do you use any other addons when getting those errors?

edit: and does it appear on all classes or only on certain ones?

edit2:
I think i found the solution:

You can try to copy the class_icons folder from miirgui/gfx to the miirgui_icons folder and try if it works.
__________________
◘◘ Author of MiirGui Texture Pack - [Core] [Blue] [Grey] ◘◘
Last edited by Miiru : 10-22-12 at 09:42 AM.
Report comment to moderator  
Reply With Quote
Unread 10-21-12, 07:23 AM  
Eternal_Lynx
A Fallenroot Satyr
 
Eternal_Lynx's Avatar
AddOn Author - Click to view AddOns

Forum posts: 28
File comments: 18
Uploads: 2
Originally Posted by Rammoth
I didn't take a screenshot yet, but I found a problem.

The character window when you press C, and a few other windows, do not have an image inside of the square at the top left, like it should. I even tested this with a fresh install, not using anything else and it still isn't there. This same problem occurs on the grey version too.

Just thought you should know.
This annoys me too...so I commented
Code:
SpellBookFramePortrait:Hide()
CharacterFramePortrait:Hide()
and the class icon section in Miirgui_icons.lua

I don't know how to fix this, to make it 'better than nothing' is all i can do for now...
Report comment to moderator  
Reply With Quote
Unread 09-26-12, 06:41 AM  
Rammoth
A Cliff Giant
 
Rammoth's Avatar
AddOn Author - Click to view AddOns

Forum posts: 73
File comments: 637
Uploads: 1
I didn't take a screenshot yet, but I found a problem.

The character window when you press C, and a few other windows, do not have an image inside of the square at the top left, like it should. I even tested this with a fresh install, not using anything else and it still isn't there. This same problem occurs on the grey version too.

Just thought you should know.
Last edited by Rammoth : 09-26-12 at 10:29 AM.
Report comment to moderator  
Reply With Quote
Unread 09-26-12, 06:40 AM  
Rammoth
A Cliff Giant
 
Rammoth's Avatar
AddOn Author - Click to view AddOns

Forum posts: 73
File comments: 637
Uploads: 1
Re: Minimap issue

That circle is normal. That's part of the map itself, that's something we can't change.

Originally Posted by Sohkra
Hi , got a weird white circle when im in a digsite , how can i fix it ? thx

Report comment to moderator  
Reply With Quote
Unread 09-13-12, 08:52 AM  
Sohkra
A Kobold Labourer

Forum posts: 0
File comments: 2
Uploads: 0
Minimap issue

Hi , got a weird white circle when im in a digsite , how can i fix it ? thx

Report comment to moderator  
Reply With Quote
Unread 09-11-12, 12:08 PM  
tallulahkat
A Kobold Labourer
 
tallulahkat's Avatar

Forum posts: 1
File comments: 27
Uploads: 0
Originally Posted by Miiru
Originally Posted by tallulahkat
Originally Posted by Miiru
Originally Posted by tallulahkat
I had just downloaded yesterday for the first time, bu i went and re downloaded again today just to make sure all was good with what version i had and it is still doing it.

Do i need to have the original and this one?
#
No, you only need this and be sure to enable the miirgui addon in your addon settings.
yeah both my husband and I only have this and have it enabled and it does it for both of us, but only for the first pick up for the TB dailies
That is weird indeed. I don't have this with a fresh install :/
Nothing breaking and I love this so much so I will still keep it, but with a side note it does not happen on beta only live, so going to delete all my saved variables and see whats going on


ok so i found the culprit its a conflict with quest guru yay glad to know its nothing i can not fix
Last edited by tallulahkat : 09-11-12 at 12:18 PM.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.