Minion Beta! - Help us test our new AddOn updater. Get it now!
Download
(117 Kb)
Download
Updated: 10-20-14 03:09 PM
Pictures
File Info
Compatibility:
Warlords of Draenor Pre-Patch (6.0.2)
Updated:10-20-14 03:09 PM
Created:07-19-12 07:54 AM
Downloads:7,258
Favorites:35
MD5:
6.0.2
oUF Drk Fanupdate  Updated this week!  Popular! (More than 5000 hits)
Version: r18
by: myno [More]
oUF_Drk Fanupdate

This layout needs oUF 1.6 or higher to work. Get it here: http://www.wowinterface.com/downloads/info9994-oUF.html.

If you have questions or encounter any bugs/problems feel free to post them in the comment section.
The latest version of this layout can always be found on my github.

Known Issues
- Combo Points show wrong values when not having a target

Features
- Supported Unitframes:
  • Player
  • Target
  • TargetOfTarget
  • Focus
  • FocusTarget
  • Pet
  • Bossframes
  • Raid
- Castbar on Player, Target, TargetOfTarget, Focus, FocusTarget and Bossframes
- Buff and Debuffs for Player, Target, TargetOfTarget, Focus and Bossframes (customizable)
- Class Bars (Holy Power, Runes, Combo Points, Balance Power Bar, Chi, Shadow Orbs, Warlock Energy)
- Raid Frames with Raid Debuffs and Indicators for certain buffs (mainly for healers)

Config
You are able to do some basic config (position, enabling stuff etc.) in the cfg.lua.

Plugin Support
- oUF_Smooth Update
- oUF_Experience

Credits
- Haste for making oUF.
- Drakull for originally creating this layout.
- A lot of other oUF layout authors like Phanx, Freebaser and zork.
Latest version can always be found on github

r18
-Fixed/Added Resto Druid tags
-Adjusted Eclipse Bar to new system
-Combo Points are now on the player
-Fixed Priest Shadow Orbs

r17
-Fixed castbar channeling spells missing error
-toc bump

r16
-Use Blizzad right click menu
-Siege of Orgrimmar raid debuffs (Paragons, Garrosh and some others missing)
-toc bump

r15
-Fixed Affliction Warlocks now always having 4 Soul Shards
-Fixed castbar error while in a vehicle
-Temporary fix for boss frames
-Tag optimization

r14
-Added Throne of Thunder raid debuffs
-Fixed tooltips on raid frames not showing
-Fixed wrong frame levels for target energy text and portrait background
-Fixed raid mark on focus, targettarget etc.
-Fixed raid frame debuff duration not refreshing (cd spiral from OmniCC)
-code cleanup
-toc bump

r13
-Fixed SPELL_POWER_CHI
-Added combat icon for target frame (thanks Phanx)

r12
-Added 5th boss bar
-Fixed Wind Step spell id

r11
-Added option to disable right click menu on raid frames

r10
-Fixed debuff desaturation if not own debuff on target frame
-Added scaleable frames (see cfg.lua)
-Fixed party not showing when cfg.raidShowSolo is set to false
-Added Spiral CD count to raid frame debuffs (needs OmniCC or tullaCooldownCount)
-Improved AltPowerBar
-Added DeathBarrier DK indicator

r9
-Fixed class bars to work with oUF-1.5.13-316

r8
-Fixed HealPrediction in raid frames
-Fixed dispellable debuffs in raid frames not showing up for non-english localizations
-Added threat indicator in raid frames
-Added role icons on mouseover in raid frames (see config)
-Target cast bar can now be made seperate as well (see config)
-Changed raidDebuffs to work with spellIDs for better differentiation between debuffs with the same name (e.g. Yor'sahj's Deep Corruption was only showing the debuff with no stacks)

r7
-Fixed raidDebuffs for classes that can't dispell
-Added horizontal raid frame orientation (see config)
-Changed Energy Text position

r6
-Improved Warlock and Monk Class Bar
-Fixed Warrior raid frame indicator error

r5
-Removed AuraWatch, added Raid Frame Indicators for buffs etc. (for example Riptide and Earth Shield for Shaman)
-Added Warlock Spec Bars from tukz
-Shuffled around stuff in the Raid Frames, think I'm kind of okay with how they are looking now

r4
-Some more tweaks and fixes mainly for the Raid Frames

r3
-Removed debug code

r2
-Added Raidframes (not finished)
-Added raidDebuff and AuraWatch for Raidframes
-Minor tweaks and changes

r1
-Initial release
Optional Files (0)


Post A Reply Comment Options
Unread 05-19-13, 10:53 AM  
myno
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 87
Uploads: 4
Originally Posted by McBloed
lol, i made this change every update, but forgotten it this time, same thing with group 6,7,8. last update was long ago^^

Edit: Is it possible to add an easyer way to add costombuffs/indicators to the raidframe? Always have to add so much code in two files^^
You could also create your own tags in cfg.lua, then you would only need to edit one file or don't replace the cfg.lua file if there are no changes in it.

Just include the following line in cfg.lua:
Code:
local tags = oUF.Tags
Then just have the tags in in the cfg.lua file as you would have them in the tags.lua file.
Last edited by myno : 05-20-13 at 09:03 AM.
myno is offline Report comment to moderator  
Reply With Quote
Unread 05-19-13, 09:22 AM  
McBloed
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 31
Uploads: 2
Originally Posted by myno
Originally Posted by McBloed
cant see the Lead, Assist and Masterlooter icons at raidframe
That's how it's supposed to be. Delete Line 361 and 374 in lib.lua to get them.
lol, i made this change every update, but forgotten it this time, same thing with group 6,7,8. last update was long ago^^

Edit: Is it possible to add an easyer way to add costombuffs/indicators to the raidframe? Always have to add so much code in two files^^
__________________
www.extinction-dethecus.de
Last edited by McBloed : 05-19-13 at 10:01 AM.
McBloed is offline Report comment to moderator  
Reply With Quote
Unread 05-19-13, 08:50 AM  
myno
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 87
Uploads: 4
Originally Posted by McBloed
cant see the Lead, Assist and Masterlooter icons at raidframe
That's how it's supposed to be. Delete Line 361 and 374 in lib.lua to get them.
myno is offline Report comment to moderator  
Reply With Quote
Unread 05-19-13, 08:18 AM  
McBloed
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 31
Uploads: 2
cant see the Lead, Assist and Masterlooter icons at raidframe
__________________
www.extinction-dethecus.de
Last edited by McBloed : 05-19-13 at 08:26 AM.
McBloed is offline Report comment to moderator  
Reply With Quote
Unread 04-01-13, 08:37 PM  
Helln_HiHeels
A Deviate Faerie Dragon

Forum posts: 11
File comments: 30
Uploads: 0
Re: Re: Re: Re: Mage & castbar lua error

Originally Posted by myno
I just commited some small changes to castbar.lua on github. Hope this did the job.
It did indeed !! Thank you !
Helln_HiHeels is offline Report comment to moderator  
Reply With Quote
Unread 03-27-13, 09:34 PM  
myno
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 87
Uploads: 4
Re: Re: Re: Mage & castbar lua error

I just commited some small changes to castbar.lua on github. Hope this did the job.
myno is offline Report comment to moderator  
Reply With Quote
Unread 03-27-13, 08:09 PM  
Helln_HiHeels
A Deviate Faerie Dragon

Forum posts: 11
File comments: 30
Uploads: 0
Re: Re: Mage & castbar lua error

Originally Posted by myno
Originally Posted by Helln_HiHeels
I have recently been doing some dailies on my rather unforgotten mage and I get this lua error (which I hope has a very easy solution). I also play a shadowpriest but don't see this error message at all. I use the most up-to-date from your Gib site and the only changes I make are from vertical to horizontal for raid/group frames (but that poses no problem on my shadowpriest) and I've use ./omf to move the layout pieces.
Do you remember what you were doing, when the error occured? Did it happen while you were in a vehicle?
I was in Valley of Four Winds (or whatever it's called), plowed my plots and was just starting to plant.. cast to freeze the little vermin guy in place and that's about when the error showed up. Whether I was about to cast a frost bolt or had just completed one I can't be sure but it was pretty much right at that point. So no vehicle but I was in that phased area where our farming plots are.
Helln_HiHeels is offline Report comment to moderator  
Reply With Quote
Unread 03-27-13, 07:13 PM  
myno
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 87
Uploads: 4
Re: Mage & castbar lua error

Originally Posted by Helln_HiHeels
I have recently been doing some dailies on my rather unforgotten mage and I get this lua error (which I hope has a very easy solution). I also play a shadowpriest but don't see this error message at all. I use the most up-to-date from your Gib site and the only changes I make are from vertical to horizontal for raid/group frames (but that poses no problem on my shadowpriest) and I've use ./omf to move the layout pieces.
Do you remember what you were doing, when the error occured? Did it happen while you were in a vehicle?
myno is offline Report comment to moderator  
Reply With Quote
Unread 03-26-13, 09:37 AM  
Helln_HiHeels
A Deviate Faerie Dragon

Forum posts: 11
File comments: 30
Uploads: 0
Mage & castbar lua error

I have recently been doing some dailies on my rather unforgotten mage and I get this lua error (which I hope has a very easy solution). I also play a shadowpriest but don't see this error message at all. I use the most up-to-date from your Gib site and the only changes I make are from vertical to horizontal for raid/group frames (but that poses no problem on my shadowpriest) and I've use ./omf to move the layout pieces.

Date: 2013-03-26 11:15:00
ID: 1
Error occured in: Global
Count: 1
Message: ..\AddOns\oUF_Drk\castbar.lua line 102:
attempt to index local 'sf' (a nil value)
Debug:
[C]: ?
oUF_Drk\castbar.lua:102: PostCastStart()
oUF\elements\castbar.lua:149: ?()
oUF\events.lua:69:
oUF\events.lua:62
Locals:


**note: there was nothing posted to "Locals" and if needed I can provide a list of addons that are used.
Thank you for keeping this great layout alive !!
Helln_HiHeels is offline Report comment to moderator  
Reply With Quote
Unread 03-09-13, 10:01 PM  
Dartrianis
A Kobold Labourer

Forum posts: 0
File comments: 2
Uploads: 0
Fantastic thanks for the fast response, i have tested the new code and it is working perfectly.
Dartrianis is offline Report comment to moderator  
Reply With Quote
Unread 03-09-13, 06:30 AM  
myno
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 87
Uploads: 4
Originally Posted by Dartrianis
I am having 1 small issue with 5.2, Blizz got rid of the glyph of Soul that gave affliction locks a 4th shard and cooked the 4th shard into the spec.
Try the following code (in github) instead of the one you posted :

Code:
		elseif spec == SPEC_WARLOCK_AFFLICTION then
			local maxshards = 4

			for i = 1, maxshards do
				wsb[i]:Show()
				wsb[i]:SetWidth(w / maxshards - spacing)
			end
I don't have a warlock myself, so sadly I can't test it.
myno is offline Report comment to moderator  
Reply With Quote
Unread 03-08-13, 09:44 PM  
Dartrianis
A Kobold Labourer

Forum posts: 0
File comments: 2
Uploads: 0
Hi and thank you for taking this great layout over. i am having 1 small issue with 5.2, Blizz got rid of the glyph of Soul that gave affliction locks a 4th shard and cooked the 4th shard into the spec.

it would seem that the oUF_WarlockSpecBars.lua is still setup to look for the glyph before making the 4th shard show.

Code:
elseif spec == SPEC_WARLOCK_AFFLICTION then
			local maxshards = 3
			
			for i = 1, GetNumGlyphSockets() do
				local glyphID = select(4, GetGlyphSocketInfo(i))
				if glyphID == SPEC_WARLOCK_AFFLICTION_GLYPH_SHARDS then maxshards = 4 end
			end			

			for i = 1, maxshards do
				if i ~= maxshards then
					wsb[i]:Show()
					wsb[i]:SetWidth(w / maxshards - spacing)
					s = s + (w / maxshards)
				else
					wsb[i]:SetWidth(w - s)
				end
			end
			
			if maxshards == 3 then wsb[4]:Hide() else wsb[4]:Show() end
I think i have located the correct place but i have no clue what to change it to so that 4 shards show up for Affliction.

Would you someone know?
Thanks
Last edited by Dartrianis : 03-08-13 at 09:45 PM.
Dartrianis is offline Report comment to moderator  
Reply With Quote
Unread 12-19-12, 06:18 PM  
myno
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 87
Uploads: 4
Originally Posted by Laorne
I really can't say but it was the same with a fresh install. COuld you tell me the changes I need to make to the code for the tooltip to work? I don't want to install a fresh copy and have to redo all the changes.
Delete this in core.lua: https://github.com/xmyno/oUF_Drk/com...73b032b#L1L275 (Line 275-286)
and add these two in lib.lua: https://github.com/xmyno/oUF_Drk/com...3b032b#L2R1436 (Line 1436-1439 and 1447-1449)
myno is offline Report comment to moderator  
Reply With Quote
Unread 12-19-12, 05:07 PM  
Laorne
A Kobold Labourer

Forum posts: 0
File comments: 13
Uploads: 0
Originally Posted by myno
Originally Posted by Laorne
1. Tooltip issue seems to be resolved. However when I change cfg.ShowRoleIcons = false to true the tooltips stop working again. Turning them back off tooltips work again so there seems to be a conflict somewhere and likely why I couldn't get them working in the previous setup since I didn't think to turn that option off. I assume it has something to do with this code??

2. Raid orientation is still the same. Vertical = frames grow up, Horizontal = frames grow left.
I dont' use horizontal but I assume they should grow right not left

Update** I think I have fixed this with the following code changes:

The default was TOP. I changed it to BOTTOM
Tooltip issue is fixed in the new github version of core.lua and lib.lua. However I still can't see any reason why raid frame orientation shouldn't be working for you. Changing TOP to BOTTOM is just creating the next frame on top of the previous frame and then you move it down by 80px. TOP in this case means that the next frame is anchored with it's top to the previous frame, not that it's created above the previous one.
I really can't say but it was the same with a fresh install. COuld you tell me the changes I need to make to the code for the tooltip to work? I don't want to install a fresh copy and have to redo all the changes.
Last edited by Laorne : 12-19-12 at 05:08 PM.
Laorne is offline Report comment to moderator  
Reply With Quote
Unread 12-19-12, 07:59 AM  
myno
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 87
Uploads: 4
Originally Posted by Laorne
1. Tooltip issue seems to be resolved. However when I change cfg.ShowRoleIcons = false to true the tooltips stop working again. Turning them back off tooltips work again so there seems to be a conflict somewhere and likely why I couldn't get them working in the previous setup since I didn't think to turn that option off. I assume it has something to do with this code??

2. Raid orientation is still the same. Vertical = frames grow up, Horizontal = frames grow left.
I dont' use horizontal but I assume they should grow right not left

Update** I think I have fixed this with the following code changes:

The default was TOP. I changed it to BOTTOM
Tooltip issue is fixed in the new github version of core.lua and lib.lua. However I still can't see any reason why raid frame orientation shouldn't be working for you. Changing TOP to BOTTOM is just creating the next frame on top of the previous frame and then you move it down by 80px. TOP in this case means that the next frame is anchored with it's top to the previous frame, not that it's created above the previous one.
myno is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: