Download
(53 Kb)
Download
Updated: 08-23-12 10:28 AM
Compatibility:
Mists of Pandaria (5.0.4)
Updated:08-23-12 10:28 AM
Created:08-21-12 03:58 AM
Downloads:2,527
Favorites:20
MD5:
TipTac MOP FAN UPDATE
Version: 12.06.7
by: Sockz0r [More]
THIS IS A FAN UPDATE

WILL NOT WORK ON LIVE 4.3 SERVERS

All credit goes to the awesome author that is Aezay

See here for the original 4.3 version http://www.wowinterface.com/downloads/info7593-TipTac.html#info

Would love people to test this before 5.0 hits live servers!

Special thanks to Aezay for making the addon and myno for helping me fix more bugs!
12.06.07
- fixed achievement mouse over stuff, for real this time i promise! :D

12.06.06
- dammit myno stop getting there before me! :D many more bug fixes


12.06.05
- fixed talents! thanks to myno
Optional Files (0)


Archived Files (3)
File Name
Version
Size
Author
Date
12.06.6
53kB
Sockz0r
08-22-12 01:35 PM
12.06.5
53kB
Sockz0r
08-21-12 10:05 AM
12.06
52kB
Sockz0r
08-21-12 03:58 AM


Post A Reply Comment Options
Old 08-23-12, 01:27 AM  
Adam77
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 35
Uploads: 4
Ty for this Fun Update!!!

Ty a lot to update the best tooltip addon

I got a new bug for you mouseovering an achievement in a chat window :

Code:
Message: Interface\AddOns\TipTacItemRef\core.lua:394: GetAchievementCrieriaInfo(achievementID, criteriaIndex), criteria not found
Time: 08/23/12 09:26:08
Count: 6
Stack: [C]: in function `GetAchievementCriteriaInfo'
Interface\AddOns\TipTacItemRef\core.lua:394: in function `?'
Interface\AddOns\TipTacItemRef\core.lua:147: in function <Interface\AddOns\TipTacItemRef\core.lua:140>
[C]: in function `SetHyperlink'
Interface\AddOns\TipTac\core.lua:1074: in function <Interface\AddOns\TipTac\core.lua:1070>

Locals: (*temporary) = "1176"
(*temporary) = 2
Adam77 is offline Report comment to moderator  
Reply With Quote
Old 08-22-12, 02:02 PM  
Inshade
A Kobold Labourer

Forum posts: 0
File comments: 6
Uploads: 0
Good job to all the people who are working on
Inshade is offline Report comment to moderator  
Reply With Quote
Old 08-22-12, 01:36 PM  
myno
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 94
Uploads: 4
Originally Posted by Mikari
I made that change and I'm still getting the error if I have icons disabled.
Are you sure that you did not make a mistake? The only thing that is not correct is the Amount stays when disabling the IconTexture&Count while the tooltip is shown, but I do not get any errors.

Could you post the error again maybe?


edit: ok, maybe it was my own fault, wrote Line 318 but it's Line 317. But this should have been obvious
edit2: the version Sockz0r uploaded includes the fix, try with that.
Last edited by myno : 08-22-12 at 01:42 PM.
myno is offline Report comment to moderator  
Reply With Quote
Old 08-22-12, 01:36 PM  
Sockz0r
A Defias Bandit
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 630
Uploads: 5
fixed in the built i have just updated, myno stop getting there before me! <3

keep testing guys! thanks for all the help!
Sockz0r is offline Report comment to moderator  
Reply With Quote
Old 08-22-12, 01:14 PM  
Mikari
A Deviate Faerie Dragon
AddOn Author - Click to view AddOns

Forum posts: 17
File comments: 116
Uploads: 3
Originally Posted by myno
Did not check that, thanks.

Fixed by the following change:

Line 318
Code:
if (cfg.if_showIcon) then
	self:SetIconTextureAndText("Interface\\Icons\\"..currencyTexture, currencyCount);
end
I made that change and I'm still getting the error if I have icons disabled.
Mikari is offline Report comment to moderator  
Reply With Quote
Old 08-22-12, 01:05 PM  
myno
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 94
Uploads: 4
Did not check that, thanks.

Fixed by the following change:

Line 317
Code:
if (cfg.if_showIcon) then
	self:SetIconTextureAndText("Interface\\Icons\\"..currencyTexture, currencyCount);
end
Last edited by myno : 08-22-12 at 01:41 PM.
myno is offline Report comment to moderator  
Reply With Quote
Old 08-22-12, 12:41 PM  
Mikari
A Deviate Faerie Dragon
AddOn Author - Click to view AddOns

Forum posts: 17
File comments: 116
Uploads: 3
Originally Posted by myno


I'm not sure why you're getting that error, I do not have any problem with archaeology fragments.
What about if you disable the icon?
Mikari is offline Report comment to moderator  
Reply With Quote
Old 08-22-12, 12:36 PM  
myno
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 94
Uploads: 4


I'm not sure why you're getting that error, I do not have any problem with archaeology fragments.
myno is offline Report comment to moderator  
Reply With Quote
Old 08-22-12, 10:56 AM  
Mikari
A Deviate Faerie Dragon
AddOn Author - Click to view AddOns

Forum posts: 17
File comments: 116
Uploads: 3
Getting this error using the normal non modded version, don't suppose you could fix it in your version so that it's fine when 5.0.4 goes live next week?

Happens with Archaeology fragments.

Code:
Message: Interface\AddOns\TipTacItemRef\core.lua:317: attempt to call method 'SetIconTextureAndText' (a nil value)
Time: 08/22/12 17:55:33
Count: 9
Stack: Interface\AddOns\TipTacItemRef\core.lua:317: in function `?'
Interface\AddOns\TipTacItemRef\core.lua:147: in function <Interface\AddOns\TipTacItemRef\core.lua:140>
[C]: ?
[C]: in function `SetHyperlink'
Interface\AddOns\HoverTips\ChatFrame.lua:20: in function <Interface\AddOns\HoverTips\ChatFrame.lua:16>

Locals: self = GameTooltip {
 0 = <userdata>
 SetExistingSocketGem = <function> defined =[C]:-1
 SetHyperlink = <function> defined =[C]:-1
 SetTradeSkillItem = <function> defined =[C]:-1
 hasMoney = 1
 comparing = false
 SetSocketGem = <function> defined =[C]:-1
 SetUnitDebuff = <function> defined =[C]:-1
 SetLootItem = <function> defined =[C]:-1
 SetQuestItem = <function> defined =[C]:-1
 SetReforgeItem = <function> defined =[C]:-1
 SetTrainerService = <function> defined =[C]:-1
 numMoneyFrames = 2
 SetInboxItem = <function> defined =[C]:-1
 SetBuybackItem = <function> defined =[C]:-1
 shoppingTooltips = <table> {
 }
 SetHyperlinkCompareItem = <function> defined =[C]:-1
 SetMerchantItem = <function> defined =[C]:-1
 SetQuestLogItem = <function> defined =[C]:-1
 SetBackpackToken = <function> defined =[C]:-1
 SetTradeTargetItem = <function> defined =[C]:-1
 shownStatusBars = 0
 SetTradePlayerItem = <function> defined =[C]:-1
 SetSendMailItem = <function> defined =[C]:-1
 updateTooltip = 0.04999999217689
 SetInventoryItem = <function> defined =[C]:-1
 numStatusBars = 1
 ttCount = <unnamed> {
 }
 SetLootRollItem = <function> defined =[C]:-1
 SetUnitAura = <function> defined =[C]:-1
 SetCurrencyToken = <function> defined =[C]:-1
 SetAuctionSellItem = <function> defined =[C]:-1
 SetBagItem = <function> defined =[C]:-1
 SetGuildBankItem = <function> defined =[C]:-1
 SetUnitBuff = <function> defined =[C]:-1
 ttIcon = <unnamed> {
 }
 SetMerchantCostItem = <function> defined =[C]:-1
 SetAuctionItem = <function> defined =[C]:-1
}
linkToken = "currency"
id = "385"
_ = "Troll Archaeology Fragment"
currencyCount = 38
currencyTexture = "trade_archaeology_troll_artifactfragment"
(*temporary) = nil
(*temporary) = GameTooltip {
 0 = <userdata>
 SetExistingSocketGem = <function> defined =[C]:-1
 SetHyperlink = <function> defined =[C]:-1
 SetTradeSkillItem = <function> defined =[C]:-1
 hasMoney = 1
 comparing = false
 SetSocketGem = <function> defined =[C]:-1
 SetUnitDebuff = <function> defined =[C]:-1
 SetLootItem = <function> defined =[C]:-1
 SetQuestItem = <function> defined =[C]:-1
 SetReforgeItem = <function> defined =[C]:-1
 SetTrainerService = <function> defined =[C]:-1
 numMoneyFrames = 2
 SetInboxItem = <function> defined =[C]:-1
 SetBuybackItem = <function> defined =[C]:-1
 shoppingTooltips = <table> {
 }
 SetHyperlinkCompareItem = <function> defined =[C]:-1
 SetMerchantItem = <function> defined =[C]:-1
 SetQuestLogItem = <function> defined =[C]:-1
 SetBackpackToken = <function> defined =[C]:-1
 SetTradeTargetItem = <function> defined =[C]:-1
 shownStatusBars = 0
 SetTradePlayerItem = <function> defined =[C]:-1
 SetSendMailItem = <function> defined =[C]:-1
 updateTooltip = 0.04999999217689
 SetInventoryItem = <function> defined =[C]:-1
 numStatusBars = 1
 ttCount = <unnamed> {
 }
 SetLootRollItem = <function> defined =[C]:-1
 SetUnitAura = <function> defined =[C]:-1
 SetCurrencyToken = <function> defined =[C]:-1
 SetAuctionSellItem = <function> defined =[C]:-1
 SetBagItem = <function> defined =[C]:-1
 SetGuildBankItem = <function> defined =[C]:-1
 SetUnitBuff = <function> defined =[C]:-1
 ttIcon = <unnamed> {
 }
 SetMerchantCostItem = <function> defined =[C]:-1
 SetAuctionItem = <function> defined =[C]:-1
}
(*temporary) = "Interface\Icons\trade_archaeology_troll_artifactfragment"
(*temporary) = 38
(*temporary) = "attempt to call method 'SetIconTextureAndText' (a nil value)"
cfg = <table> {
 if_showAchievementIdAndCategory = false
 if_itemQualityBorder = false
 if_iconSize = 42
 if_b
Last edited by Mikari : 08-22-12 at 10:57 AM.
Mikari is offline Report comment to moderator  
Reply With Quote
Old 08-21-12, 12:30 PM  
Sockz0r
A Defias Bandit
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 630
Uploads: 5
Originally Posted by myno
Thanks for pointing this error out. Never got it myself because nobody linked an achievement and did not know that this is part of TipTac.

There's an easy way to fix it. No need to bother with the GetAchievementCriteriaByID function. You only need to check if the right side has a criteria listed.

Just insert the following above and below Line 389
Code:
if (criteriaList[i+1]) then
    myDone2 = select(3,GetAchievementCriteriaInfo(id,i + 1));
end



Do you mean the ItemLevel at the bottom of an item tooltip? Because I've got it in my own version. Did not check this own here though :/
And another edit: Maybe it's just not checked under the ItemRef Tab?
awesome thanks

iLevel is still in this build and is working fine (for me at least)
Sockz0r is offline Report comment to moderator  
Reply With Quote
Old 08-21-12, 12:11 PM  
myno
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 94
Uploads: 4
just discovered another bug, dam things always pop up when you least expect it! the tooltip on achievements when you click ones that are linked it gives an error, i managed to fix the error but i cannot get the criteria to change colour to depend on whether the player has complete it as well
Thanks for pointing this error out. Never got it myself because nobody linked an achievement and I did not know that this is part of TipTac.

There's an easy way to fix it. No need to bother with the GetAchievementCriteriaByID function. You only need to check if the right side has a criteria listed.

Just insert the following above and below Line 389
Code:
if (criteriaList[i+1]) then
    myDone2 = select(3,GetAchievementCriteriaInfo(id,i + 1));
end


The iLevel option is removed into this version? Am i right?
Do you mean the ItemLevel at the bottom of an item tooltip? Because I've got it in my own version. Did not check this one here though :/
And another edit: Maybe it's just not checked under the ItemRef Tab?
Last edited by myno : 08-21-12 at 05:17 PM.
myno is offline Report comment to moderator  
Reply With Quote
Old 08-21-12, 11:29 AM  
Sinaris
A Cyclonian
 
Sinaris's Avatar
AddOn Compiler - Click to view compilations

Forum posts: 48
File comments: 119
Uploads: 5
The iLevel option is removed into this version? Am i right?
__________________
LUI v3 - Forum and Homepage Administration
LUI Support Homepage
Sinaris is offline Report comment to moderator  
Reply With Quote
Old 08-21-12, 10:40 AM  
Sockz0r
A Defias Bandit
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 630
Uploads: 5
just discovered another bug, dam things always pop up when you least expect it! the tooltip on achievements when you click ones that are linked it gives an error, i managed to fix the error but i cannot get the criteria to change colour to depend on whether the player has complete it as well

i wont upload another fix today as its mostly working now, but you can fix it yourself by going into the ItemRef core lua, at line 388 and 389, replace with these:

Code:
					myDone1 = select(3,GetAchievementCriteriaInfoByID(id,i));
					myDone2 = select(3,GetAchievementCriteriaInfoByID(id,i + 1));
Sockz0r is offline Report comment to moderator  
Reply With Quote
Old 08-21-12, 10:16 AM  
Aoife59
A Defias Bandit
 
Aoife59's Avatar

Forum posts: 2
File comments: 24
Uploads: 0
Talking Latest build seems to be working as it should

I installed the latest version (with the fix for Talents from myno) and have tried it in Beta. The addon seems to be working as it should!

Aoife59 is offline Report comment to moderator  
Reply With Quote
Old 08-21-12, 10:06 AM  
Sockz0r
A Defias Bandit
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 630
Uploads: 5
thanks myno, added your fix (with due credit) to the update
Sockz0r is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: