Minion Beta! - Help us test our new AddOn updater. Get it now!
Download
(1 MB)
Download
Updated: 07-19-06 08:02 PM
Pictures
File Info
Updated:07-19-06 08:02 PM
Created:unknown
Downloads:17,263
Favorites:83
MD5:
SciTE-WOWInterface  Popular! (More than 5000 hits)
Version: 0.8
by: Cladhaire [More]
This is a re-package of the popular ScITE editor (based on the scintilla editing component). You can find more information about SciTE at http://www.scintilla.org/SciTE.html. Some of the customization is from the package at http://gisdeveloper.tripod.com/scite.html , but those just amount to some configuration files that have been altered. 've adjusted some of the preferences and added the bulk of the WoW API with prototypes and descriptions as pop-up calltips (you can see a few examples in the attached screenshots).

One thing you will want to adjust is the window placement and size. Unfortunately SciTE does not save window positions (it was originally designed for GTK+, where the window manager saves the position). You can do this by opening the global properties file:

Open SciTE
Select the Options Menu
Select "Open Global Options File"

You'll want to edit the following options (0,0 is in the top left of the screen)
  • position.left
  • position.top
  • position.height
  • position.width

CHANGELOG
=================================
* Re-compiled lua, luac and bitlib so they should all work and operate together with no license restrictions
* Added the bitlib functions to the lua calltips
* Re-packaged the entire distribution from scratch to be a bit more efficient and easier to make quick packages
* Updated SciTE to version 1.70 (the latest version)
* Compile action will compile to FileName.luc
* Build action will do a no-output compile testing for errors
* Go action will execute the LUA using the interpreter
Post A Reply Comment Options
Unread 07-20-07, 01:31 PM  
endlessracingz
A Kobold Labourer

Forum posts: 0
File comments: 1
Uploads: 0
Originally posted by Kemayo
Have an updated API (as updated as wowwiki is, anyway):
http://wowacepy.googlecode.com/files/scite_wow_api.zip

And here's a python script that builds an API file from wowwiki's API page:
http://wowacepy.googlecode.com/svn/u...cite_apigen.py
How do I implement that? How do I apply it to the folders and things?

Oringinally posted by KarlThePagan
This is just what I did to fix things up... your mileage may vary

1) get Lua 5.1 here:
http://www.wowinterface.com/downloa...ua5.1.1WoW.html

2) edit your lua.properties and modify the command.go.* line to the following:
command.go.*.lua=bin\lua.exe -l "lib\wow" "$(FileNameExt)"

3) move your SciTE-WOWInterface\lib directory to SciTE-WOWInterface\bin\lib

4) modify wow.lua to not load bitlib unless it's missing:
if not bit then
local lib = package.loadlib("lib\bitlib.dll", "luaopen_bit")
assert(lib)
lib()
lib = nil
end

(optionally just remove the whole bitlib stuff - since bitlib is included with cogwheel's binaries)
How do I go about doing this exactly? I mean once you get 5.1 then what? do I have to move the lau5.1.exe and lauc5.1.exe files somewhere? or rename them? what about the bin2c5.1.exe and the lua5.1.dll?

Help I am pretty clueless about this stuff and I am just learning.

I have programmed in several different languages (C++, VB, java, etc...) but I have never had to setup something like this to do it
endlessracingz is offline Report comment to moderator  
Reply With Quote
Unread 06-13-07, 04:34 PM  
Kemayo
A Cyclonian
AddOn Author - Click to view AddOns

Forum posts: 40
File comments: 128
Uploads: 11
Have an updated API (as updated as wowwiki is, anyway):
http://wowacepy.googlecode.com/files/scite_wow_api.zip

And here's a python script that builds an API file from wowwiki's API page:
http://wowacepy.googlecode.com/svn/u...cite_apigen.py
Kemayo is offline Report comment to moderator  
Reply With Quote
Unread 12-06-06, 03:43 PM  
KarlThePagan
A Defias Bandit
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 7
Uploads: 1
Smile How I got Lua 5.1 working with Scite

This is just what I did to fix things up... your mileage may vary

1) get Lua 5.1 here:
http://www.wowinterface.com/download...a5.1.1WoW.html

2) edit your lua.properties and modify the command.go.* line to the following:
command.go.*.lua=bin\lua.exe -l "lib\wow" "$(FileNameExt)"

3) move your SciTE-WOWInterface\lib directory to SciTE-WOWInterface\bin\lib

4) modify wow.lua to not load bitlib unless it's missing:
if not bit then
local lib = package.loadlib("lib\bitlib.dll", "luaopen_bit")
assert(lib)
lib()
lib = nil
end

(optionally just remove the whole bitlib stuff - since bitlib is included with cogwheel's binaries)
KarlThePagan is offline Report comment to moderator  
Reply With Quote
Unread 11-16-06, 03:06 PM  
Cladhaire
Salad!
 
Cladhaire's Avatar
WoWInterface Super Moderator
AddOn Author - Click to view AddOns

Forum posts: 1933
File comments: 4528
Uploads: 18
Originally posted by kandoko
Thanks for this editor Cladhaire, it my personal favorite for working on my mods, but its only for lua 5.0. I have a few syntax problems on the current 2.0 test realm, and was curious if you will be updating it to lua 5.1?

If not, is it possible for a semi cluelless newb like myself to update the files?
I haven't decided entirely, but you can replace the lua 5.0 binaries using the binaries cogwheel has compiled here on WoWInterface. Just put these files in the bin/ directory. As for the API update.. I don't know I'll be getting to that any time soon, but we'll see if I get time at work.
__________________
"There's only one thing that I know how to do well and I've often been told that you only can do what you know how to do well, and that's be you-- be what you're like-- be like yourself. And so I'm having a wonderful time, but I'd rather be whistling in the dark..."
Cladhaire is offline Report comment to moderator  
Reply With Quote
Unread 11-16-06, 03:03 PM  
kandoko
A Murloc Raider

Forum posts: 4
File comments: 2
Uploads: 0
Originally posted by Cladhaire
Goto Options
Open Global Options File

Search for the line that contains:
autocompleteword.automatic=0

and change the 0 to a 1 =)
Thanks for this editor Cladhaire, it my personal favorite for working on my mods, but its only for lua 5.0. I have a few syntax problems on the current 2.0 test realm, and was curious if you will be updating it to lua 5.1?

If not, is it possible for a semi cluelless newb like myself to update the files?
kandoko is offline Report comment to moderator  
Reply With Quote
Unread 07-20-06, 10:34 AM  
Cladhaire
Salad!
 
Cladhaire's Avatar
WoWInterface Super Moderator
AddOn Author - Click to view AddOns

Forum posts: 1933
File comments: 4528
Uploads: 18
Goto Options
Open Global Options File

Search for the line that contains:
autocompleteword.automatic=0

and change the 0 to a 1 =)
__________________
"There's only one thing that I know how to do well and I've often been told that you only can do what you know how to do well, and that's be you-- be what you're like-- be like yourself. And so I'm having a wonderful time, but I'd rather be whistling in the dark..."
Cladhaire is offline Report comment to moderator  
Reply With Quote
Unread 07-20-06, 10:30 AM  
Cladhaire
Salad!
 
Cladhaire's Avatar
WoWInterface Super Moderator
AddOn Author - Click to view AddOns

Forum posts: 1933
File comments: 4528
Uploads: 18
I'll have to look into it, but I know its possible-- I just tend to find it annoying. Let me look for a bit =)
__________________
"There's only one thing that I know how to do well and I've often been told that you only can do what you know how to do well, and that's be you-- be what you're like-- be like yourself. And so I'm having a wonderful time, but I'd rather be whistling in the dark..."
Cladhaire is offline Report comment to moderator  
Reply With Quote
Unread 07-20-06, 06:28 AM  
Kaelten
Jack's raging bile duct
 
Kaelten's Avatar
Featured Addon Author

Forum posts: 772
File comments: 48
Uploads: 22
Hey clad, good work, any plans to add code completion, or is this a feature beyond this editor?
__________________
WowAce.com & CurseForge.com Adminstrator
Developer of Ace3, OneBag3, and many other addons and libraries
Project lead and Mac developer for the Curse Client

Anyone that needs what they want
And doesn't want what they need
I want nothing to do with
Kaelten is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.