Quantcast
Download
(2 MB)
Download
Updated: 02-27-17 09:44 AM
Pictures
File Info
Compatibility:
Return to Karazhan (7.1.5)
Updated:02-27-17 09:44 AM
Created:unknown
Downloads:2,496,711
Favorites:2,143
MD5:
7.1.5

BigWigs Bossmods  Updated Today!  Popular! (More than 5000 hits)

Version: v46.4
by: funkydude [More]

Please support my work on Patreon!

BigWigs is open source and development is done on GitHub. You can contribute code, localization, and report issues there: https://github.com/BigWigsMods/BigWigs

BigWigs is a boss encounter add-on. It consists of many individual encounter scripts, or boss modules; mini add-ons that are designed to trigger alert messages, timer bars, sounds, and so forth, for one specific raid encounter. These encounter scripts are activated when you target or mouse over a raid boss, or if any other BigWigs user in your raid does. In most cases only one module will be running at any given time.

If you're looking for boss encounter scripts for 5-man dungeons, these are not in Big Wigs, but live in their own add-on; LittleWigs.

BigWigs
v46.4 (2017-02-27)
Full Changelog Previous releases
  • Etraeus: Cancel Grand Conjunction Cast+Proximity on phase change
  • Fallen Avatar: Fix StopBar, disable Dark Winds in Normal
  • Sisters of the Moon: Add Twilight Volley, Announce all Moon Burns
  • The Desolate Host: if statements
  • Desolate Host: fixes + remove spear from normal
  • Nighthold/Etraeus: fix StopBar
  • The Desolate Host: Heroic data update (#205)
  • Maiden of Vigilance: Heroic testing updates (#206)
  • Fallen Avatar: Heroic testing update (#207)
  • update zhTW (#203)
Optional Files (10)
File Name
Version
Size
Author
Date
Type
v7.1.7
330kB
02-25-17 08:15 PM
Addon
v7.1.5.1
6MB
01-25-17 12:14 PM
Addon
v7.1.3
10kB
01-19-17 11:53 AM
Addon
v7.1.1
190kB
01-11-17 11:15 AM
Addon
v7.1.2
186kB
01-11-17 11:07 AM
Addon
v7.1.2
170kB
01-02-17 04:30 PM
Addon
v7.1.2
255kB
11-29-16 08:34 AM
Addon
v7.1.0
146kB
10-25-16 04:57 PM
Addon
v7.1.0
75kB
10-25-16 04:57 PM
Addon
1.1
72kB
10-28-11 11:36 AM
Patch


Post A Reply Comment Options
Unread 04-03-07, 04:10 PM  
Succubusgoul
A Murloc Raider

Forum posts: 6
File comments: 1
Uploads: 0
Error..

I have a debugger with info about the error I am getting everytime I log on or enter/leave a instance..here is the info.

I have included the addons that I use as well incase it might aid in the fix for it.


Code:
Date: 2007-04-03 17:06:50
ID: 51
Error occured in: Global
Count: 1
Message: ...erface\AddOns\BigWigs\Libs\AceLibrary\AceLibrary.lua line 543:
   Tourist-2.0: Bad argument #2 to `IsHostile' (string expected, got boolean)
Debug:
   ...erface\AddOns\BigWigs\Libs\AceLibrary\AceLibrary.lua:29:
      ...erface\AddOns\BigWigs\Libs\AceLibrary\AceLibrary.lua:27
   ...erface\AddOns\BigWigs\Libs\AceLibrary\AceLibrary.lua:543: Register()
   ...ns\FuBar_LocationFu\libs\Tourist-2.0\Tourist-2.0.lua:2497: in main chunk
   [C]: ?
   [C]: pcall()
   FuBar\FuBar.lua:631:
      FuBar\FuBar.lua:627
   FuBar\FuBar.lua:913: LoadPlugin()
   FuBar\FuBar.lua:1026:
      FuBar\FuBar.lua:1017
   [C]: ?
   ...ce\AddOns\BigWigs\Libs\AceEvent-2.0\AceEvent-2.0.lua:427:
      ...ce\AddOns\BigWigs\Libs\AceEvent-2.0\AceEvent-2.0.lua:403

Date: 2007-04-03 17:06:50
ID: 52
Error occured in: Global
Count: 1
Message: ...ns\FuBar_LocationFu\libs\Tourist-2.0\Tourist-2.0.lua line 2493:
   AceConsole-2.0: args.path: "validate" values must all be strings
Debug:
   ...erface\AddOns\BigWigs\Libs\AceLibrary\AceLibrary.lua:29:
      ...erface\AddOns\BigWigs\Libs\AceLibrary\AceLibrary.lua:27
   ...erface\AddOns\BigWigs\Libs\AceLibrary\AceLibrary.lua:557: Register()
   ...ns\FuBar_LocationFu\libs\Tourist-2.0\Tourist-2.0.lua:2497: in main chunk
   [C]: ?
   [C]: pcall()
   FuBar\FuBar.lua:631:
      FuBar\FuBar.lua:627
   FuBar\FuBar.lua:913: LoadPlugin()
   FuBar\FuBar.lua:1026:
      FuBar\FuBar.lua:1017
   [C]: ?
   ...ce\AddOns\BigWigs\Libs\AceEvent-2.0\AceEvent-2.0.lua:427:
      ...ce\AddOns\BigWigs\Libs\AceEvent-2.0\AceEvent-2.0.lua:403
AddOns:
AchatPoison
Atlas, v1.8.6
AtlasAuchindoun, v1.8.6
AtlasBattlegrounds, v1.8.6
AtlasDungeonLocs, v1.8.6
AtlasExtras, v1.8.6
AtlasFlightPaths, v1.8.6
AtlasLoot, vAtlasLoot Enhanced v2.03.00
AtlasOutdoorRaids, v1.8.6
AtlasTempestKeep, v1.8.6
Bartender3, v3.0.22781
BigWigs, v2.0 r30824
ChatMOD, v90
CTCore, v2.0 (CTMod 2.0)
CTMailMod, v1.5 (CTMod 2.0)
CTRABossMods, v1.3 (CTMod 2)
CTRaidAssist, v1.623 (CTMod 2.0)
CTUnitFrames, v1.5 (CTMod 2.0)
DamageMeters, v5.6.0
EnhTooltip, v3.9.0.1342
EquipCompare, v2.9.8b
FishingBuddy, v0.8.9
GFWDisenchantPredictor, v2.0.4
GFWGemologist, v2.0.5
FuBarLocationFu, v2.0
FuBar, v24665
Gatherer, v2.99.0.0498
Informant, v3.9.0.1397
KLHThreatMeter, v19.8
MobHealth, v3.2
MobInfo2, v3.13
myClock, v1.8
CEnemyCastBar
CECBDebuffs
NotesUNeed, v5.56.20003
PerlCombatDisplay
PerlConfig
PerlFocus
PerlParty
PerlPlayer
PerlPlayerPet
PerlTarget
PerlTargetTarget
ReagentData, v2.4.35
ReagentInfo, v2.0.9
Stubby, v1426
Swatter, v3.9.0.1372
TheoryCraft2, vBeta v.0013
Report comment to moderator  
Reply With Quote
Unread 04-03-07, 03:07 PM  
Pietoro
A Kobold Labourer

Forum posts: 0
File comments: 4
Uploads: 0



Not sure what's causing this error. I get it every time I log in/zone.
Last edited by Pietoro : 04-04-07 at 03:20 AM.
Report comment to moderator  
Reply With Quote
Unread 03-28-07, 05:31 PM  
volk
A Kobold Labourer

Forum posts: 0
File comments: 1
Uploads: 0
Originally posted by Movarrin
Error: BigWigs_Other's zone, Onyxia's Lair, has no translation appropriate for console usage.
AddOn: BigWigs
File: LoadOnDemand.lua
Line: 153
Count: 1


Please fix this. Everytime I log on i get this.
Just delete BigWigs_Other folder, since it has been separated into Azeroth and Outand.
Report comment to moderator  
Reply With Quote
Unread 03-14-07, 06:11 PM  
wrd
A Kobold Labourer

Forum posts: 0
File comments: 7
Uploads: 0
Originally posted by Movarrin
Error: BigWigs_Other's zone, Onyxia's Lair, has no translation appropriate for console usage.

(snip)

Please fix this. Everytime I log on i get this.
Same error here on each login.
Report comment to moderator  
Reply With Quote
Unread 03-10-07, 07:32 PM  
Movarrin
Premium Member
Premium Member

Forum posts: 12
File comments: 79
Uploads: 0
Error: BigWigs_Other's zone, Onyxia's Lair, has no translation appropriate for console usage.
AddOn: BigWigs
File: LoadOnDemand.lua
Line: 153
Count: 1


Please fix this. Everytime I log on i get this.
Report comment to moderator  
Reply With Quote
Unread 03-05-07, 09:48 AM  
Ammo
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 17
File comments: 137
Uploads: 26
shift-click the bigwigs button as the tooltip hint says

-Ammo
Report comment to moderator  
Reply With Quote
Unread 03-02-07, 03:32 AM  
mattftw
A Defias Bandit

Forum posts: 2
File comments: 2
Uploads: 0
How do I get to use the Waterfall config? It looks sexy!
Report comment to moderator  
Reply With Quote
Unread 03-01-07, 05:03 AM  
Rabbit
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 5
File comments: 45
Uploads: 21
You're welcome

I've updated the release version here, it contains lots of fixes, and also the new Waterfall configuration dialog, of which I've also added a screenshot.

Enjoy!
Report comment to moderator  
Reply With Quote
Unread 02-20-07, 11:06 PM  
Morgannon
A Kobold Labourer

Forum posts: 0
File comments: 8
Uploads: 0
Originally posted by Morgannon
Code:
[2007/02/20 17:35:41-241-x1]: BigWigs\LoadOnDemand.lua:149: BigWigs_SC's zone, Serpentshrine Cavern, has no translation appropriate for console usage.
AceAddon-2.0-26427 (FuBar):455: in function <...face\AddOns\FuBar\libs\AceAddon-2.0\AceAddon-2.0.lua:432>
<in C code>: ?
AceEvent-2.0-25921 (FuBar):320: in function `TriggerEvent'
AceEvent-2.0-25921 (FuBar):962: in function <...face\AddOns\FuBar\libs\AceEvent-2.0\AceEvent-2.0.lua:955>

  ---
I've been getting this error for the past few days. I update at very least once a day, sometimes more. Anyone else? If I'm reading/understanding it right, it just doesn't know how to localize "Serpentshrine Cavern"? I'm using the standard enUS client.
Fixed in r28616, thanks rabbit!
Report comment to moderator  
Reply With Quote
Unread 02-20-07, 06:56 PM  
Morgannon
A Kobold Labourer

Forum posts: 0
File comments: 8
Uploads: 0
Code:
[2007/02/20 17:35:41-241-x1]: BigWigs\LoadOnDemand.lua:149: BigWigs_SC's zone, Serpentshrine Cavern, has no translation appropriate for console usage.
AceAddon-2.0-26427 (FuBar):455: in function <...face\AddOns\FuBar\libs\AceAddon-2.0\AceAddon-2.0.lua:432>
<in C code>: ?
AceEvent-2.0-25921 (FuBar):320: in function `TriggerEvent'
AceEvent-2.0-25921 (FuBar):962: in function <...face\AddOns\FuBar\libs\AceEvent-2.0\AceEvent-2.0.lua:955>

  ---
I've been getting this error for the past few days. I update at very least once a day, sometimes more. Anyone else? If I'm reading/understanding it right, it just doesn't know how to localize "Serpentshrine Cavern"? I'm using the standard enUS client.
Report comment to moderator  
Reply With Quote
Unread 02-14-07, 11:30 AM  
zanalla
A Kobold Labourer

Forum posts: 0
File comments: 1
Uploads: 0
Issues

I have found an issue with bigwigs that I can't seem to fix. The mod will load for all my toons but one. The one that it willn't load for has the same name as a toon on a different server and it will load for that one. I've tryed deleting the mod from the addons folder and unpacking it there again but no good.
Report comment to moderator  
Reply With Quote
Unread 01-13-07, 05:33 PM  
Meraxes
An Aku'mai Servant

Forum posts: 31
File comments: 28
Uploads: 0
Strange error

Getting a strange error when clicking on the Fubar Text for the first time:
Code:
Error occured in: Global
Count: 1
Message: ..\AddOns\BigWigs_Extras\CustomBar.lua line 11:
   AceLocale(BigWigsCustomBar): Cannot provide the same locale more than once. "enUS" provided twice.
Debug:
   [C]: ?
   [C]: error()
   ...erface\AddOns\AutoBar\libs\AceLibrary\AceLibrary.lua:85: error()
   ...\AddOns\AutoBar\libs\AceLocale-2.2\AceLocale-2.2.lua:172: RegisterTranslations()
   BigWigs_Extras\CustomBar.lua:11: in main chunk
   [C]: LoadAddOn()
   BigWigs\LoadOnDemand.lua:28:
      BigWigs\LoadOnDemand.lua:25
   BigWigs\LoadOnDemand.lua:78:
      BigWigs\LoadOnDemand.lua:75
[C]: ?
   ...ce\AddOns\AutoBar\libs\AceEvent-2.0\AceEvent-2.0.lua:320: TriggerEvent()
   BigWigs\Core.lua:355: AceEvent_FullyInitialized()
   BigWigs\Core.lua:340:
      BigWigs\Core.lua:338
   [C]: pcall()
   ...nterface\AddOns\AutoBar\libs\AceDB-2.0\AceDB-2.0.lua:24:
      ...nterface\AddOns\AutoBar\libs\AceDB-2.0\AceDB-2.0.lua:23
   ...nterface\AddOns\AutoBar\libs\AceDB-2.0\AceDB-2.0.lua:1655: ToggleActive()
   BigWigs\Options.lua:203: OnClick()
   ...Ons\BigWigs\Libs\FuBarPlugin-2.0\FuBarPlugin-2.0.lua:821:
      ...Ons\BigWigs\Libs\FuBarPlugin-2.0\FuBarPlugin-2.0.lua:819
   FuBar\FuBar.lua:1141:
FuBar\FuBar.lua:1139
That's the entire output from "Swatter" (better debug frame mod)

I am using version 2.0 r24913 if that helps (taken from the SVN website)

I'm not sure if the error is with bigwigs or Autobar (also taken from same SVN, r24927)

MIght simply be a matter of conflicting Ace 2.0 libraries but I'm not that good with Lua
Report comment to moderator  
Reply With Quote
Unread 01-11-07, 02:45 AM  
wrd
A Kobold Labourer

Forum posts: 0
File comments: 7
Uploads: 0
C'thun timers off in r24036

Specifically the eyestalk spawns in Phase 2 were way, way off. Didn't have a chance to observe closely enough to figure out if they were simply offset, or counting down the wrong amount of time, but they were at least 10-15 seconds off each spawn. Been about 6 weeks and quite a few versions since we visted C'thun, so I'm not sure if it broke in this version specifically or an earlier one.
Report comment to moderator  
Reply With Quote
Unread 12-22-06, 04:02 PM  
Silent54
A Defias Bandit

Forum posts: 0
File comments: 53
Uploads: 0
I have the current bigwigs. After uploading the current version, I noticed that all the 3rd party mods such as Bigwigs_CThunAssist, Loathebtactical, and thaddius arrows do not show up in the extras area of bigwigs. Any solutions?
Report comment to moderator  
Reply With Quote
Unread 12-18-06, 06:24 PM  
Soeron
A Kobold Labourer

Forum posts: 0
File comments: 2
Uploads: 0
Got some problems with CandyBar and addons that use the library, like RegenFU, oRA etc ...
Somethig like : Fubar_Regen.lua:316 CandyBar-2.0: Bad argument #4 to 'Register' (string expected, got nil)


Edit: Got it working. Updated to the last versions. Seems the library syntax is changed.
Last edited by Soeron : 12-19-06 at 08:09 AM.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: