Minion Beta! - Help us test our new AddOn updater. Get it now!
Download
(174 Kb)
Download
Updated: 05-06-11 01:23 AM
Addon for:
FuBar 3.6.5.
Pictures
File Info
Updated:05-06-11 01:23 AM
Created:unknown
Downloads:17,763
Favorites:106
MD5:
FubBar - SkillsPlusFuLt  Popular! (More than 5000 hits)
Version: 4.1.0
by: Jayhawk [More]
FuBar - SkillsPlusFuLt v4.1.0
Release Date: 2011-05-03

Shows all skills in a tool tip and allows you to quickly select/reselect one of them.
Note: The light version does not have options for Cooldown and other character skill checking.

Acknowledgements
This add-on is based on avngr's FuBar_ProfessionsFu and Kemayo's FuBar_KungFu. Thanks guys!
4.1.0 - updated TOC
4.0.0 - updated for Cataclysm API changes
3.3.0 - updated TOC
3.2.0 - updated TOC
3.0.0 - updatedf for WotLK and added Inscription
2.4.0 - updated TOC
2.3.2 - updated TOC, added frFR (sturmy), koKR (ochocobo) and zhTW (helium) localisations
2.3.1 - updated TOC, fixed alchemy issue with 2.2
2.3.0 - updated TOC
2.2.4 - added Jewelcrafting
2.2.3 - had to rename the files and folder because of SVN
- changed datastructure, you should probably delete your old SavedVariables file
- fixed Purge character
2.2.2 - finally fixed library issues
- set LoadOnDemand to 0 (false) so it will run without FuBar
2.2.1 - fixed sloppy library references
2.2.0 - updated to WoW 2.0
- updated libraries
- using SkillsPlus to Disenchant, Fish or Pick Locks is no longer possible
2.1.2 - added option to purge toons
2.1.1 - fixed bug calling non FuBar 2.0 librabry
2.1.0 - updated to use BabbleLib for partial localisation
2.0.0 - updated to FuBar 2.0
1.1.0 - updated TOC and added support to show last used skill when reloading
1.0.0 - release of Light version
0.2.2 - fixed bug with leatherworking caption showing as fishing
0.2.1 - added FuBar icon support
0.2.0 - added key binding option
Archived Files (1)
File Name
Version
Size
Author
Date
4.0.0
130kB
Jayhawk
01-02-11 06:10 AM


Post A Reply Comment Options
Unread 12-08-06, 01:03 AM  
WavArt
A Deviate Faerie Dragon
 
WavArt's Avatar

Forum posts: 10
File comments: 11
Uploads: 0
errors with light and 2.20 full

Error: AceAddon: AceOO-2.0: Library "AceHook-2.0" does not exist.
AddOn: FuBar_SkillsPlusFu
File: SkillsPlusFu.lua
Line: 1
Count: 1

same error with the non light version.
WavArt is offline Report comment to moderator  
Reply With Quote
Unread 12-08-06, 08:11 AM  
mizunagare
A Kobold Labourer
AddOn Compiler - Click to view compilations

Forum posts: 1
File comments: 6
Uploads: 2
Re: errors with light and 2.20 full

Originally posted by WavArt
Error: AceAddon: AceOO-2.0: Library "AceHook-2.0" does not exist.
AddOn: FuBar_SkillsPlusFu
File: SkillsPlusFu.lua
Line: 1
Count: 1

same error with the non light version.
Got it working, required these changes:

- remove the reference to AceHook in the AceLibrary call at the top of the code (there doesn't appear to be any hooking going on - perhaps an artifact from an earlier version?

- add AceLocale-2.2 to libs

- add BabbleSpell-2.2 to libs

- fix TOC file to properly reference v2.2 of AceLocale and BabbleSpell (there are references, but it's mixed - loading the 2.2 code file from the 2.0 directory)

- fix LUA code to properly ask for the 2.2 instances of AceLocale and BabbleSpell
mizunagare is offline Report comment to moderator  
Reply With Quote
Unread 12-08-06, 08:34 AM  
Balsta
Guest

Join Date: Not Yet
Forum posts: 0
File comments: 0
Uploads: 0
I am getting the same error. I will wait for an official fix.
Report comment to moderator  
Edit/Delete Message Reply With Quote
Unread 12-08-06, 10:50 AM  
Sparr
A Deviate Faerie Dragon

Forum posts: 10
File comments: 12
Uploads: 0
Re: Re: errors with light and 2.20 full

Originally posted by mizunagare
Got it working, required these changes:

- remove the reference to AceHook in the AceLibrary call at the top of the code (there doesn't appear to be any hooking going on - perhaps an artifact from an earlier version?

- add AceLocale-2.2 to libs

- add BabbleSpell-2.2 to libs

- fix TOC file to properly reference v2.2 of AceLocale and BabbleSpell (there are references, but it's mixed - loading the 2.2 code file from the 2.0 directory)

- fix LUA code to properly ask for the 2.2 instances of AceLocale and BabbleSpell
FWIW:

- You can copy AceLocal-2.2 from the libs directory of Ace2
- You can copy BabbleSpell-2.2 from the libs directory of Fubar
Sparr is offline Report comment to moderator  
Reply With Quote
Unread 12-08-06, 01:29 PM  
Zidomo
A Cliff Giant
 
Zidomo's Avatar

Forum posts: 76
File comments: 1047
Uploads: 0
Angry Re: Re: errors with light and 2.20 full

Originally posted by mizunagare
Got it working, required these changes:

- remove the reference to AceHook in the AceLibrary call at the top of the code (there doesn't appear to be any hooking going on - perhaps an artifact from an earlier version?

- add AceLocale-2.2 to libs

- add BabbleSpell-2.2 to libs

- fix TOC file to properly reference v2.2 of AceLocale and BabbleSpell (there are references, but it's mixed - loading the 2.2 code file from the 2.0 directory)

- fix LUA code to properly ask for the 2.2 instances of AceLocale and BabbleSpell
Drycoding FTL, testing FTW, Jayhawk

Thanks for the simple (for some people) fix, mizunagare .
Zidomo is offline Report comment to moderator  
Reply With Quote
Unread 12-08-06, 11:32 PM  
Jayhawk
Premium Member
 
Jayhawk's Avatar
AddOn Author - Click to view AddOns

Forum posts: 105
File comments: 151
Uploads: 6
Unhappy Apologies

Zidomo, let's start with you.
I did test and it worked. The problem is...I was (am?) still somewhat unclear how the Ace 2 library-thing works. Only when I picked up the comments in the bugs section about the AceHook issue, I realised I must have been picking them up from elsewhere.
I'm clueless as to how it managed not to break by the mis references to the Babble stuff, though.

The APIs being virtually unavailable on wowace didn't really help either.

Oh, do define drycoding for me? Please?

mizunagare, thanks for the help.
Something very weird must have happened while I was preparing the zip here, as I was convinced the 2.2 libs were in the zip. I see they aren't and that makes me feel bad.
The AceHook library is indeed an artifact, and I'm almost sure the AceConsole can go to.

My apologies to all of you
I hope to get this updated today.
Jayhawk is offline Report comment to moderator  
Reply With Quote
Unread 12-10-06, 04:25 AM  
Jayhawk
Premium Member
 
Jayhawk's Avatar
AddOn Author - Click to view AddOns

Forum posts: 105
File comments: 151
Uploads: 6
Dependencies

I understood a FuBar addon should be able to run without FuBar, but SkillsPlus doesn't. I guess I'm still missing dependencies, but it's confusing me immensely... I started a thread on this topic here: http://www.wowinterface.com/forums/s...6174#post36174

Any help would be appreciated...
Jayhawk is offline Report comment to moderator  
Reply With Quote
Unread 12-10-06, 11:31 AM  
Noyl
A Kobold Labourer

Forum posts: 0
File comments: 16
Uploads: 4
Still making a reference to BabbleSpell-2.0 in SkillsPlusFu.lua change the reference to BabbleSpell-2.2 to fix (Line 9 I beleive)
Last edited by Noyl : 12-10-06 at 01:15 PM.
Noyl is offline Report comment to moderator  
Reply With Quote
Unread 12-10-06, 02:32 PM  
Jayhawk
Premium Member
 
Jayhawk's Avatar
AddOn Author - Click to view AddOns

Forum posts: 105
File comments: 151
Uploads: 6
Noyl, I should have new versions up my tomorrow. I want to do a little more testing to make absolutely sure I have everything.
Jayhawk is offline Report comment to moderator  
Reply With Quote
Unread 01-10-07, 09:22 PM  
cscscott
A Deviate Faerie Dragon

Forum posts: 12
File comments: 16
Uploads: 0
broken

Some of my FuBar's seem to be broken after yesterdays patch. they all show to be loaded i.e. SkillsFu, DurabilityFu,ItemBonusesFu and KungFu, some even have the icons on the Fubar, but, they have no options and the ones that do can't be changed. SkillsFu shows to be loaded but isn't even listed as an option to load through the Fubar window interface. I need help please.

Addicted to Fubar,
cscscott is offline Report comment to moderator  
Reply With Quote
Unread 01-11-07, 10:15 AM  
Jayhawk
Premium Member
 
Jayhawk's Avatar
AddOn Author - Click to view AddOns

Forum posts: 105
File comments: 151
Uploads: 6
Re: broken

Sorry to hear that. I'm out in the US at this moment, but should be around after the weekend to try and fix it.

[edit]
I did have issues at one stage after the patch, but that was because I was getting errors in other modules. Apart from that things seem to be running okay for me. Did things change for you since you last posted?
Last edited by Jayhawk : 01-16-07 at 12:52 AM.
Jayhawk is offline Report comment to moderator  
Reply With Quote
Unread 07-07-10, 02:07 AM  
ahua
A Kobold Labourer

Forum posts: 0
File comments: 24
Uploads: 0
Error

FuBar_SkillsPlusFuLt-3.3.0 \SkillsPlusFuLt.lua:8: Cannot find a library instance of Crayon-2.0.
FuBar-3.0.90030\libs\AceLibrary\AceLibrary.lua:490: in function `AceLibrary'
FuBar_SkillsPlusFuLt-3.3.0 \SkillsPlusFuLt.lua:8: in main chunk

---

For some reason, SkillsPlusFuLt does not cause error if it is loaded with FishingAce.
ahua is offline Report comment to moderator  
Reply With Quote
Unread 07-09-11, 11:19 AM  
kanezfan
A Murloc Raider

Forum posts: 5
File comments: 8
Uploads: 0
Is there any way to have it show the number from your two main professions, like for this toon i'm leveling up I'd like to always see the skill level of skinning and mining without having to mouse over the icon on fubar. Could be showing like [profession icon/skill level, profession icon/skill level]

Something like that?
kanezfan is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: