Quantcast
Download
(325 Kb)
Download
Updated: 08-11-16 11:56 PM
Pictures
File Info
Compatibility:
Legion Pre-Patch (7.0.3)
Updated:08-11-16 11:56 PM
Created:unknown
Downloads:634,782
Favorites:2,586
MD5:
Categories:Raid Mods, Healers, Unit Mods
7.0.3

Grid  Popular! (More than 5000 hits)

Version: 7.0.3.3
by: Phanx, Trelis

Grid is a compact and highly configurable party/raid unit frame addon.

The compact grid of unit frames lets you select a group member quickly, while keeping a good overview of the whole group. It shows as much information as possible without overloading you. It allows you to customize what information you see, and how you see it. It works in both party and raid groups, and supports pets and vehicles.

Want more features? The Grid core tries to include only features which are generally useful for all classes and roles, but makes it easy to add new features with a simple plugin API for developers. Over 75 third-party plugins are already available!

Type “/grid” for options, or right-click the minimap button, DataBroker launcher, or Grid frame tab.

Need Help?
IMPORTANT: If you did not download Grid from this page, do not post on this page about any problems you encounter with it. Copies of Grid obtained from anywhere other than the official download pages on WoWInterface and Curse, or through the Curse Client or Minion, may be outdated or modified, and are not supported at all.
Found a bug?
Please submit a bug report to let us know about the problem so we can fix it!
Problem with a plugin?
Contact the plugin’s author for help. The Grid team cannot provide support for third-party plugins.
Have a suggestion?
Feel free to tell us about your idea, but please make sure there isn’t already a plugin that adds the feature you’re looking for first!
Questions? Comments?
Post a comment on this page, or post in our WowAce forum thread.
Language Support
Grid is compatible with all World of Warcraft localizations. It is currently translated into English, Deutsch, Español, Français, Italiano, Português, Русский, 한국어, 简体中文, and 繁體中文.

To add or update translations for any language, enter them on the WowAce project page. New and updated translations will be automatically included in the next version of Grid!

HINT: The WowAce interface for adding translations is quite cumbersome. To make the process easier, you can use the Export function on WowAce, copy the exported data into your text editor, fill in your translations, and then paste them back into WowAce using the Import function.
Credits
Grid was originally conceived and written by Maia and Pastamancer in late 2006. Phanx has been the primary developer since late 2009. Jerry wrote the original pet support code. Mikk designed the icon. jlam added some advanced options for auras. Greltok has helped a lot with bugfixing. Finally, lots of people have contributed translations!

Version 7.0.3.3
  • Really fixed the frames sometimes appearing behind the backdrop (ticket #840)

Version 7.0.3.2
  • Updated detection for dispellable debuffs (ticket #841)
  • Fixed the frames sometimes appearing behind the backdrop (ticket #840)
  • Fixed the frames disappearing if an invalid layout was selected (ticket #835)
  • Auras:
    • The default statuses for Grace, Earth Shield, Eternal Flame, Sacred Shield, and Weakened Soul have been removed, since these buffs (and debuff) were removed from the game.
    • New statuses have been added for Atonement, Beacon of Faith, and Clarity of Will.

Version 7.0.3.1
  • Fixed ticket 834 Show offline option broken. Thanks Samuelreus.
  • Fixed ticket 833 Layout none in non-English locale. Thanks Elnarfim.
  • Package with libraries should include new LibResInfo for ticket 828.
  • Mark code for splitGroups as debug in Layouts because the option is marked as debug. Should fix odd behavior for people who had option enabled before the option was disabled.

Version 7.0.3.0-beta
  • Updated for WoW 7.0 (Legion)
  • Added options for offline and wrong zone groups
Optional Files (5)
File Name
Version
Size
Author
Date
Type
7.0.3.0
7kB
07-24-16 08:41 AM
Patch
6.1.0.38
9kB
02-27-15 04:09 AM
Addon
1.6
1kB
10-20-14 02:02 AM
Addon
1.0
2kB
10-24-11 02:42 AM
Addon
1.0.0
2kB
01-01-11 11:25 AM
Addon


Archived Files (16)
File Name
Version
Size
Author
Date
7.0.3.2
324kB
Phanx
08-02-16 02:17 AM
7.0.3.1
327kB
Phanx
07-25-16 08:50 PM
7.0.3.1
327kB
Phanx
07-25-16 02:26 PM
7.0.3.0-beta
328kB
Phanx
07-20-16 10:18 PM
6.2.0.1754-beta
382kB
Phanx
08-05-15 08:49 AM
6.0.3.1710
376kB
Phanx
11-25-14 08:52 PM
6.0.2.1699
378kB
Phanx
10-26-14 11:32 PM
6.0.2.1679-beta
376kB
Phanx
10-17-14 09:24 AM
6.0.2.1674
389kB
Phanx
10-16-14 08:15 AM
5.4.7.1653
378kB
Phanx
05-05-14 12:23 AM
5.4.1.1628
374kB
Phanx
11-30-13 11:45 AM
5.3.0.1621
371kB
Phanx
07-21-13 08:24 PM
5.3.0.1618
371kB
Phanx
07-11-13 04:58 AM
5.3.0.1611
370kB
Phanx
07-10-13 04:28 AM
5.3.0.1606
367kB
Phanx
07-09-13 05:36 AM
5.2.0.1600
367kB
Phanx
05-14-13 10:26 PM


Post A Reply Comment Options
Unread 12-27-06, 10:49 AM  
Argent
A Defias Bandit

Forum posts: 3
File comments: 16
Uploads: 0
hi, still love this mod, but have a minor issue atm - every time i launch into an instance/BG, i get the following error:

Error: table index is nil
File: Interface\FrameXML\SecureTemplates.lua
Line: 816
Count: 1
[string "GridLayoutHeader1:OnShow"]:2: in function <[string "GridLayoutHeader1:OnShow"]:1>
[C]: in function `Show'
Interface\AddOns\Grid\GridLayout.lua:748: in function `CheckVisibility'
Interface\AddOns\Grid\GridLayout.lua:669: in function `UpdateDisplay'
Interface\AddOns\Grid\GridLayout.lua:661: in function `LoadLayout'
Interface\AddOns\Grid\GridLayout.lua:602: in function `ReloadLayout'
Interface\AddOns\Grid\GridLayout.lua:683: in function <Interface\AddOns\Grid\GridLayout.lua:681>
[C]: ?
...\FuBar_OutfitterFu\lib\AceEvent-2.0\AceEvent-2.0.lua:426: in function <...\FuBar_OutfitterFu\lib\AceEvent-2.0\AceEvent-2.0.lua:402>

(i have no idea if the outfitter thing at the end is a second error or just something related)

i'm using r19919 of grid and play on v2.01 US of wow.
Report comment to moderator  
Reply With Quote
Unread 12-28-06, 01:45 AM  
RedLegg
A Deviate Faerie Dragon

Forum posts: 13
File comments: 56
Uploads: 0
Re: Re: Grid error message

Originally posted by Lunet
[Update: Solved problem by deleting WTF. Had to reconfigure everything, of course, but Grid is good enough that it was worth the trouble.]

Great add-on. It makes healing in battlegrounds tolerable, and that's no small feat!

It was working fine for a couple of weeks, but I disabled it on an alt, and now I get the following error message when I try to reenable (with "/grid standby"):

Interface\FrameXML\ChatFrame.lua:3008:AceConsole-2.0: AceConsole-2.0: Option handler "IsActive" not found.

I tried deleting Grid, starting WoW, reinstalling Grid, then restarting WoW . . . same result. Help?
I have the very same problem. I have a error trapping mod and will post the error that pops next time I log on.

Here is the error that is trapped by "Swatter"


Error occured in: Global
Count: 1
Message: ..\FrameXML\ChatFrame.lua line 3008:
AceConsole-2.0: AceConsole-2.0: Option handler |cffffff7f"IsActive"|r not found.
Debug:
[C]: ?
[C]: error()
...rface\AddOns\sct\libs\Ace2\AceLibrary\AceLibrary.lua:84: error()
...dOns\sct\libs\Ace2\AceConsole-2.0\AceConsole-2.0.lua:1564:
...dOns\sct\libs\Ace2\AceConsole-2.0\AceConsole-2.0.lua:1288
...dOns\sct\libs\Ace2\AceConsole-2.0\AceConsole-2.0.lua:2115: value()
..\FrameXML\ChatFrame.lua:3008: ChatEdit_ParseText()
..\FrameXML\ChatFrame.lua:2734:
..\FrameXML\ChatFrame.lua:2733
[C]: ChatEdit_SendText()
..\FrameXML\ChatFrame.lua:2756: ChatEdit_OnEnterPressed()
[string "ChatFrameEditBox:OnEnterPressed"]:2:
[string "ChatFrameEditBox:OnEnterPressed"]:1

I personally don't want to delete my WTF folder to fix this problem. Grid is a great mod, but that is a lot of work on 6 toons.
Last edited by RedLegg : 12-28-06 at 12:57 PM.
Report comment to moderator  
Reply With Quote
Unread 12-29-06, 12:31 AM  
RedLegg
A Deviate Faerie Dragon

Forum posts: 13
File comments: 56
Uploads: 0
Also receiving this error when joining a raid group:

Error occured in: Global
Count: 1
Message: ..\FrameXML\SecureTemplates.lua line 816:
table index is nil
Debug:
[C]: ?
..\FrameXML\SecureTemplates.lua:816: SecureRaidGroupHeader_Update()
[string "GridLayoutHeader1:OnShow"]:2:
[string "GridLayoutHeader1:OnShow"]:1
[C]: Show()
Grid\GridLayout.lua:653: LoadLayout()
Grid\GridLayout.lua:602: ReloadLayout()
Grid\GridLayout.lua:683:
Grid\GridLayout.lua:681
[C]: ?
...AddOns\PallyPower\libs\AceEvent-2.0\AceEvent-2.0.lua:402:
...AddOns\PallyPower\libs\AceEvent-2.0\AceEvent-2.0.lua:378
Report comment to moderator  
Reply With Quote
Unread 12-29-06, 11:47 AM  
Pastamancer
A Deviate Faerie Dragon
AddOn Author - Click to view AddOns

Forum posts: 17
File comments: 54
Uploads: 2
Re: Re: Re: Grid error message

Originally posted by RedLegg
I have the very same problem. I have a error trapping mod and will post the error that pops next time I log on.


Message: ..\FrameXML\ChatFrame.lua line 3008:
AceConsole-2.0: AceConsole-2.0: Option handler |cffffff7f"IsActive"|r not found.
<snip>

I personally don't want to delete my WTF folder to fix this problem. Grid is a great mod, but that is a lot of work on 6 toons.
Can you re-enable Grid if you disable your other addons that use Ace2?
Report comment to moderator  
Reply With Quote
Unread 12-29-06, 06:30 PM  
RedLegg
A Deviate Faerie Dragon

Forum posts: 13
File comments: 56
Uploads: 0
Re: Re: Re: Re: Grid error message

Originally posted by Pastamancer
Can you re-enable Grid if you disable your other addons that use Ace2?
Okay disabling all ACE2 mods but Grid restored functions. However, SCT enabled and when I type grid standby I received this error:

Count: 1
Message: ..\FrameXML\ChatFrame.lua line 3008:
AceConsole-2.0: AceConsole-2.0: Option handler |cffffff7f"IsActive"|r not found.
Debug:
[C]: ?
[C]: error()
...rface\AddOns\sct\libs\Ace2\AceLibrary\AceLibrary.lua:84: error()
...dOns\sct\libs\Ace2\AceConsole-2.0\AceConsole-2.0.lua:1564:
...dOns\sct\libs\Ace2\AceConsole-2.0\AceConsole-2.0.lua:1288
...dOns\sct\libs\Ace2\AceConsole-2.0\AceConsole-2.0.lua:2115: value()
..\FrameXML\ChatFrame.lua:3008: ChatEdit_ParseText()
..\FrameXML\ChatFrame.lua:2734:
..\FrameXML\ChatFrame.lua:2733
[C]: ChatEdit_SendText()
..\FrameXML\ChatFrame.lua:2756: ChatEdit_OnEnterPressed()
[string "ChatFrameEditBox:OnEnterPressed"]:2:
[string "ChatFrameEditBox:OnEnterPressed"]:1

Also when Pally Power is enabled I receive this message:


Count: 1
Message: ..\FrameXML\ChatFrame.lua line 3008:
AceConsole-2.0: AceConsole-2.0: Option handler |cffffff7f"IsActive"|r not found.
Debug:
[C]: ?
[C]: error()
...ace\AddOns\PallyPower\libs\AceLibrary\AceLibrary.lua:84: error()
...ns\PallyPower\libs\AceConsole-2.0\AceConsole-2.0.lua:1564:
...ns\PallyPower\libs\AceConsole-2.0\AceConsole-2.0.lua:1288
...ns\PallyPower\libs\AceConsole-2.0\AceConsole-2.0.lua:2115: value()
..\FrameXML\ChatFrame.lua:3008: ChatEdit_ParseText()
..\FrameXML\ChatFrame.lua:2734:
..\FrameXML\ChatFrame.lua:2733
[C]: ChatEdit_SendText()
..\FrameXML\ChatFrame.lua:2756: ChatEdit_OnEnterPressed()
[string "ChatFrameEditBox:OnEnterPressed"]:2:
[string "ChatFrameEditBox:OnEnterPressed"]:1

Only MrPlow seems to work without trouble.
Report comment to moderator  
Reply With Quote
Unread 01-01-07, 11:46 PM  
Pastamancer
A Deviate Faerie Dragon
AddOn Author - Click to view AddOns

Forum posts: 17
File comments: 54
Uploads: 2
Re: Re: Re: Re: Re: Grid error message

Originally posted by RedLegg
Okay disabling all ACE2 mods but Grid restored functions. However, SCT enabled and when I type grid standby I received this error:

Count: 1
Message: ..\FrameXML\ChatFrame.lua line 3008:
AceConsole-2.0: AceConsole-2.0: Option handler |cffffff7f"IsActive"|r not found.
<snip>

Also when Pally Power is enabled I receive this message:


Count: 1
Message: ..\FrameXML\ChatFrame.lua line 3008:
AceConsole-2.0: AceConsole-2.0: Option handler |cffffff7f"IsActive"|r not found.
<snip>

Only MrPlow seems to work without trouble.
It sounds like a problem with the version of AceConsole that your other Ace2 addons are using. You can either wait for the next Grid release, or see if there's a newer version of any of your other Ace2 addons in order to get an updated version of AceConsole.
Report comment to moderator  
Reply With Quote
Unread 01-02-07, 12:15 PM  
RedLegg
A Deviate Faerie Dragon

Forum posts: 13
File comments: 56
Uploads: 0
Re: Re: Re: Re: Re: Re: Grid error message

Originally posted by Pastamancer
It sounds like a problem with the version of AceConsole that your other Ace2 addons are using. You can either wait for the next Grid release, or see if there's a newer version of any of your other Ace2 addons in order to get an updated version of AceConsole.
This is interesting. When I look at my addons page at the character screen, each mod that uses ACE have "Ace2" after the name. With out exception, all the mods but MrPlow the letters are of a different color than Grid's "Ace2".

Being that Grid is working fine otherwise I think I can wait for the next update of Grid. Thanks again for the great mod.
Report comment to moderator  
Reply With Quote
Unread 01-02-07, 02:00 PM  
Battousai
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
First off - love these raidframes, the best I've ever used for healing by far.

I have an issue though. It seems that quite often a spot in the raidframes becomes 'dead', as in clicking on whoever's in that spot at the time doesn't target them. The spot varies, it's usually near the last group.

As an example this is from an AB from earlier: http://img320.imageshack.us/img320/5...ickablefq0.jpg. Apologies for the poor quality, MSPaint In the image every single person is clickable except the person at the end of the second group (in this case Mot..) I've tried playing around with grid's config a lot to try to fix it, and I've also tried using old versions, and the current beta (from WoWAce) before reverting back to the 19919 build as I had the issue with all of them.

I get no errors or anything when clicking on the target. Just nothing happens, although mousing over the target does display the tooltip. Any ideas?

And as per the requested info thing: I'm using grid r19919 atm. I've tried 18940, and 22790 (from WoWAce) both of which I had the same problem with, and I'm using WoWEU current version (2.0.1 iirc.)
Report comment to moderator  
Reply With Quote
Unread 01-02-07, 10:43 PM  
Pastamancer
A Deviate Faerie Dragon
AddOn Author - Click to view AddOns

Forum posts: 17
File comments: 54
Uploads: 2
Originally posted by Battousai
First off - love these raidframes, the best I've ever used for healing by far.

I have an issue though. It seems that quite often a spot in the raidframes becomes 'dead', as in clicking on whoever's in that spot at the time doesn't target them. The spot varies, it's usually near the last group.

There's an open ticket for this issue http://www.wowace.com/trac/ticket/97

I need a way to reliably reproduce the bug, unfortunately it seems to be random. Reloading the UI usually fixes it, but I'd much rather it not happen in the first place.

The next time this happens to you, turn on debugging for the GridFrame module and then run /script GridFrame:ListRegisteredFrames() and check your combat log (or whatever ChatFrame2 is for you). The output will help me figure out what's causing this problem.
Report comment to moderator  
Reply With Quote
Unread 01-03-07, 02:33 AM  
Pastamancer
A Deviate Faerie Dragon
AddOn Author - Click to view AddOns

Forum posts: 17
File comments: 54
Uploads: 2
Here's a sneak peek at the next release. I'll be testing it for the next week in order to have it ready before the 16th.

Changes:
- Remove center text 2 indicator from the menu if it's disabled.
- Layout now reloads when switching between solo/party/raid/battleground. This should fix raid groups not showing up occasionally.
- Made range module more friendly to addon developers.
- Added UTF-8 support. GridFrame counts characters properly when truncating names now.
- Increased maximum text length to 20.
- Health updates should be more responsive.
- Use the right addon communication channel in battlegrounds.
- Improved group placement, groups shouldn't end up stacked ontop of each other anymore.
- Updated to Roster-2.1 and Banzai-1.1. This will break any Grid addons that depended on Roster-2.0 and Banzai-1.0! It also improves performance, so it's worth it.
Report comment to moderator  
Reply With Quote
Unread 01-03-07, 01:24 PM  
Battousai
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
Originally Posted by Pastamancer
The next time this happens to you, turn on debugging for the GridFrame module and then run /script GridFrame:ListRegisteredFrames() and check your combat log (or whatever ChatFrame2 is for you). The output will help me figure out what's causing this problem.
I will do that next time it happens - something which I realized yesterday though is that it was fine for several AV's and the bug didn't pop up once - however, when I was in AB, and then left halfway through to join AV, the bug popped up straight away. Also, when I tried again last night, I was in a group with a friend before I joined the AV battleground and the bug popped up straight away.

I'll try again when I get home so I can test, it could be a coincidence but it seems as if the bug appears if I'm already in a group then join a battleground without leaving it first (as is the way in battlegrounds, where you're in two raids at once practically, can still talk to people in your party/raid who aren't even in the battleground while communicating with the battleground raid via bg.) Or if you accept to join a second battleground without first leaving the initial battleground you're in.
Report comment to moderator  
Reply With Quote
Unread 01-05-07, 05:54 AM  
Holydruid
A Murloc Raider

Forum posts: 7
File comments: 5
Uploads: 0
Version r23489 get an error:

GridFrame.lua:354 attempt to call method 'utf8sub' (a nil value)

German client.

No frames are shown.
Last edited by Holydruid : 01-05-07 at 05:55 AM.
Report comment to moderator  
Reply With Quote
Unread 01-05-07, 11:53 AM  
Pastamancer
A Deviate Faerie Dragon
AddOn Author - Click to view AddOns

Forum posts: 17
File comments: 54
Uploads: 2
Originally posted by Holydruid
Version r23489 get an error:

GridFrame.lua:354 attempt to call method 'utf8sub' (a nil value)

German client.

No frames are shown.
See above:
If you downloaded Grid from wowace.com/files or the wowace svn, please don't post here. The wowinterface releases are actually tested. Anything from wowace.com is bleeding-edge and may or may not work.
Report comment to moderator  
Reply With Quote
Unread 01-05-07, 04:55 PM  
Holydruid
A Murloc Raider

Forum posts: 7
File comments: 5
Uploads: 0
Ok, I don´t know that. I just wanted to be up-to-date and I was wondering if your version from December was really the newest. So just to understand it in the right way: I only have to download from here and not from wowace.com? What persons update these files at wowace? I thought you did it...Thanks a lot I will test this version.
Report comment to moderator  
Reply With Quote
Unread 01-05-07, 08:17 PM  
Battousai
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
http://img219.imageshack.us/img219/559/clickzj1.jpg

Image with the output of the frame debug thing when the bug is active.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: