Download
(105 Kb)
Download
Updated: 12-06-10 04:15 PM
Pictures
File Info
Updated:12-06-10 04:15 PM
Created:unknown
Downloads:22,126
Favorites:123
MD5:
eXtreme Unit Buttons  Popular! (More than 5000 hits)
Version: v2.0
by: tayedaen [More]
This highly configurable mod allows players to associate buttons to unit frames. It is meant as a replacement to GroupButtons which stopped functioning with the 2.0 patch in December 2006. The mod extends the capabilities of GroupButtons by providing these additional features:
  1. an unlimited number of buttons per unit frame
  2. Buttons which turn on/off depending on the amount of damage a unit has
  3. Buttons which are dimmed if a unit as that buff or a related buff applied.
  4. Buttons which appear when a debuff is applied to a unit.
  5. Buttons which allow you to have any type of "/" slash or macro command on a button
  6. A variety of a modes for different activities in the game. For example, a set of buttons
  7. for soloing, buttons for instances, buttons for raids, buttons for specific bosses (such as Baron Geddon in MC (to all priests to debuff), buttons for PvP, etc.
  8. Assign buttons to unit frames that when clicked cast spells on different units. This feature allows, for example, buffs and heals for the player unit to appear within the target buttons to minimize the amount of mouse movement between buttons.
  9. Works for any kind of non-casting classes; specifically warriors and rogues.

Version 2.0 (Dec 06, 2010) (by tayedaen)

I know that the documentation is a complete mess at the moment, I am already working on it.
But I wanted to have a released version for cataclysm start.

Before upgrading, please read the included 'readme.txt'.

You will loose your config, so read carefully !

Hightlights of the changes since the last official release:

Code:
New: Support for default profiles for spec1 and spec 2
New: Wizards for Group and Profile generation
 Please use them !
New: LDB button (and menu)
New: Default Buttons now always use the Prefix 'SB_'
 This is an abbreviation for StandardButton.
 I recommend to use 'CB_' as prefix for custom buttons.
New: '$' self condition for cast buttons (buff, debuff etc.)
 Example: CB_Renew,buff,Renew,$Renew
 This custom buutton will only chnge to the state BUFFED if the destination unit is buffed with your OWN Renew.
New: '!' inverts conditions for cast buttons (buff, debuff etc.)
New: new debuff condition "Death"
 A button with this condition is only shown if the destination unit is dead.
New: new debuff condition "Purge"
 A button with this condition is only shown if the destination unit has at least one buff to purge.
New: two keywords for exclude-units:
  'hostile'   and    'friendly'
  Example: MyGroupName,SB_Renew,*,hostile
  This button will be hidden on hostile units (= it will only be shown on friendly units)
New: Spell ranks have been removed (multiranking too)
New: Macro buttons support now '[target=unit#]'
 Here unit# will be rpalced at runtime with the unit the button is attached to.
 Example: /target [target=unit#]
Improved: Verification of buttons while configuring the addon

And last but not least: 
!!! Improved: Internals are mostly rewritten from scratch for better performance  !!!

Please refer to 'z_historic_Changelog.txt' for older changes.
Known problems:
XPerl's partypets get no buttons

Known blizzard bugs:
------------------------
'isUsableSpell' is broken, there is nothing I can do to change that.
That means: Some spells are reported 'not usable' if you target a hostile target or NPC (like 'PowerWord: Shield' for example).

Enjoy - Tayedaen
Hightlights of the changes since the last official release:
===========================================================
New: Support for default profiles for spec1 and spec 2
New: Wizards for Group and Profile generation
Please use them !
New: LDB button (and menu)
New: Default Buttons now always use the Prefix 'SB_'
This is an abbreviation for StandardButton.
I recommend to use 'CB_' as prefix for custom buttons.
New: '$' self condition for cast buttons (buff, debuff etc.)
Example: CB_Renew,buff,Renew,$Renew
This custom buutton will only chnge to the state BUFFED if the destination unit is buffed with your OWN Renew.
New: '!' inverts conditions for cast buttons (buff, debuff etc.)
New: new debuff condition "Death"
A button with this condition is only shown if the destination unit is dead.
New: new debuff condition "Purge"
A button with this condition is only shown if the destination unit has at least one buff to purge.
New: two keywords for exclude-units:
'hostile' and 'friendly'
Example: MyGroupName,SB_Renew,*,hostile
This button will be hidden on hostile units (= it will only be shown on friendly units)
New: Spell ranks have been removed (multiranking too)
New: Macro buttons support now '[target=unit#]'
Here unit# will be rpalced at runtime with the unit the button is attached to.
Example: /target [target=unit#]
Improved: Verification of buttons while configuring the addon

And last but not least:
!!! Improved: Internals are mostly rewritten from scratch for better performance !!!

Please refer to 'z_historic_Changelog.txt' for older changes.

Known problems:
XPerl's partypets get no buttons
Optional Files (2)
File Name
Version
Size
Author
Date
Type
2.1beta4
104kB
09-15-12 11:51 AM
Addon
upload1 RC2
105kB
12-01-10 11:42 AM
Addon


Archived Files (1)
File Name
Version
Size
Author
Date
v1.8.2
1MB
tayedaen
07-26-08 03:47 PM


Post A Reply Comment Options
Unread 01-23-11, 02:44 AM  
Cosmic Cleric
A Deviate Faerie Dragon
 
Cosmic Cleric's Avatar
AddOn Author - Click to view AddOns

Forum posts: 15
File comments: 283
Uploads: 10
Exclamation Bug Report v2.0: Standard buttons disappearing

On my hunter, if I call out and then dismiss pets one after another, after the second or third dismiss, the standard buttons disappear from the Pet frame (the custom ones are still there), and then when I call the next pet, the standard buttons do not show up.

A '/xub p' does NOT fix the problem. I have to do a '/console reloadui' to fix the problem.

I also seen player and party buttons disappear after zoning in/out of dungeons and to/from the boat, so I'm guessing there's some zoning event that is not being listened for??
Last edited by Cosmic Cleric : 01-23-11 at 12:07 PM.
Cosmic Cleric is offline Report comment to moderator  
Reply With Quote
Unread 01-23-11, 02:42 AM  
Cosmic Cleric
A Deviate Faerie Dragon
 
Cosmic Cleric's Avatar
AddOn Author - Click to view AddOns

Forum posts: 15
File comments: 283
Uploads: 10
Exclamation Bug Report v2.0: '$' is not working

From the README...

New: '$' self condition for cast buttons (buff, debuff etc.)
Example: CB_Renew,buff,Renew,$Renew
This custom buutton will only chnge to the state BUFFED if the destination unit is buffed with your OWN Renew.

I was in a group with another hunter, and I had various custom Hunter buttons set up...

_AimedShot,buff,Aimed Shot,$Aimed Shot
_BlackArrow,buff,Black Arrow,$Black Arrow
_ExplosiveShot,buff,Explosive Shot,$Explosive Shot
_SerpentSting,buff,Serpent Sting,$Serpent Sting
_WyvernSting,buff,Wyvern Sting,$Wyvern Sting
When the other hunter shot the target I had targeted but had not attacked yet, the buttons would dim/gray, like if I had shot them. In other words, the custom buttons were acting just like regular buttons, and ignoring the '$' part of the custom button defintion.
Cosmic Cleric is offline Report comment to moderator  
Reply With Quote
Unread 01-12-11, 09:16 PM  
VolRath217
A Kobold Labourer

Forum posts: 0
File comments: 8
Uploads: 0
Originally posted by Cosmic Cleric
Have you tried doing a "/console reloadui" when you see these problems?

For me, XUB is working mostly perfectly, except that every once in a while, a bunch of buttons disappear (usually having to do with zoning in/out of a zone), and "/xub p" won't fix it, I have to do a "/console reloadui" (while out of combat of course) to fix it. There's an intermittent disappearing buttons bug with XUB.
The major issue takes place during combat, I can't reloadui. Once combat is over they come back because there was a change. Either the mob died, or I died.
VolRath217 is offline Report comment to moderator  
Reply With Quote
Unread 01-12-11, 12:30 PM  
Cosmic Cleric
A Deviate Faerie Dragon
 
Cosmic Cleric's Avatar
AddOn Author - Click to view AddOns

Forum posts: 15
File comments: 283
Uploads: 10
Have you tried doing a "/console reloadui" when you see these problems?

For me, XUB is working mostly perfectly, except that every once in a while, a bunch of buttons disappear (usually having to do with zoning in/out of a zone), and "/xub p" won't fix it, I have to do a "/console reloadui" (while out of combat of course) to fix it. There's an intermittent disappearing buttons bug with XUB.


Originally posted by VolRath217
No luck, still cuts off after 10.

I'm actually having a lot of trouble lately with all my buttons it seems. For example, on my rogue my stealth,SB_Sap,* used to light up when I targeted something that could be sapped, and wouldn't show up if it was unsappable. Now, it doesn't show up ever unless I do a /xub p and when I do that, all the buttons light up and stay lit up until I do something like kill a mob or mount. (I assume this has something to do with the isUsableSpell bug?) Also any button that I have set up to be x,y,player stays lit up all the time regardless of whether I have a target or not. Plus when changing targets while in combat, for instance on Magmaw when switching from his body to his head, all the buttons disappear except the x,y,player while I'm hitting the head, then they go back to normal when I switch back to the body.

Finally, when I installed the current release and put my beta config in, it had changed my spells from say "stealth,SB_Sap,*" to "stealth,SB_Sap,*," (note the comma at the end) Is that extra comma at the end there for a reason?
Cosmic Cleric is offline Report comment to moderator  
Reply With Quote
Unread 01-12-11, 01:47 AM  
VolRath217
A Kobold Labourer

Forum posts: 0
File comments: 8
Uploads: 0
Originally posted by abinning
Maybe try to escape the '/' like '\/'
It thinks the /10 is another function.
No luck, still cuts off after 10.

I'm actually having a lot of trouble lately with all my buttons it seems. For example, on my rogue my stealth,SB_Sap,* used to light up when I targeted something that could be sapped, and wouldn't show up if it was unsappable. Now, it doesn't show up ever unless I do a /xub p and when I do that, all the buttons light up and stay lit up until I do something like kill a mob or mount. (I assume this has something to do with the isUsableSpell bug?) Also any button that I have set up to be x,y,player stays lit up all the time regardless of whether I have a target or not. Plus when changing targets while in combat, for instance on Magmaw when switching from his body to his head, all the buttons disappear except the x,y,player while I'm hitting the head, then they go back to normal when I switch back to the body.

Finally, when I installed the current release and put my beta config in, it had changed my spells from say "stealth,SB_Sap,*" to "stealth,SB_Sap,*," (note the comma at the end) Is that extra comma at the end there for a reason?
Last edited by VolRath217 : 01-12-11 at 01:52 AM.
VolRath217 is offline Report comment to moderator  
Reply With Quote
Unread 01-07-11, 10:30 AM  
abinning
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 48
Uploads: 1
Maybe try to escape the '/' like '\/'
It thinks the /10 is another function.

Originally posted by VolRath217
Having trouble setting my hunter back up. Previously I had the following macro:

_shoot,macro,131,/castsequence [button:2] Hunter's Mark; reset=target/10, Serpent Sting, Arcane Shot

When I put that in now, as soon as I hit save, it deletes everything after "...target/10,"
abinning is offline Report comment to moderator  
Reply With Quote
Unread 01-07-11, 09:22 AM  
VolRath217
A Kobold Labourer

Forum posts: 0
File comments: 8
Uploads: 0
Having trouble setting my hunter back up. Previously I had the following macro:

_shoot,macro,131,/castsequence [button:2] Hunter's Mark; reset=target/10, Serpent Sting, Arcane Shot

When I put that in now, as soon as I hit save, it deletes everything after "...target/10,"
Last edited by VolRath217 : 01-07-11 at 09:25 AM.
VolRath217 is offline Report comment to moderator  
Reply With Quote
Unread 01-02-11, 09:50 AM  
tayedaen
A Deviate Faerie Dragon
AddOn Author - Click to view AddOns

Forum posts: 13
File comments: 192
Uploads: 42
Re: Button Check

Originally posted by Whist34
Will someone please check my purge button text. I want it to show up only when the enemy target has a buff that can be purged. Currently it shows up but it doesn't seem to purge or maybe it is getting flagged to purge when it shouldn't? Please just let me know if the code line is correct.

Thanks!

CB_Purge,debuff,Purge,Purge
Hi !

Thank you for the report, I've found a bug, and fixed it.
The fix will be included in the next version.

cu
tay

P.S.
If you need a fix immediately, then open 'XUB_CheckConditions.lua', and goto line 39.
There the whole 'if (myButton.Condition[i].name == "purge")' part must be replaced by:
Code:
if (myButton.Condition[i].name == "purge") then
	for i,v in pairs(XUB.AllBuffs2) do
		myButton.is_STATE_INVALID = nil
		return
	end
elseif (myButton.Condition[i].name == "death") and UnitIsDeadOrGhost(myButton.DestinationUnit) then
tayedaen is offline Report comment to moderator  
Reply With Quote
Unread 01-02-11, 09:45 AM  
tayedaen
A Deviate Faerie Dragon
AddOn Author - Click to view AddOns

Forum posts: 13
File comments: 192
Uploads: 42
Originally posted by Whist34
Not sure if this is a bug or not, but the following Custom Button continues to blink and does not fade the button. (This is for a Shaman.)

CB_EarthlivingWeaponBlink,buffblink,Earthliving Weapon,Earthliving Weapon/Flametongue Weapon/Frostbrand Weapon

I also tried:
CB_EarthlivingWeaponBlink,buffblink,Earthliving Weapon,Earthliving Weapon
Hi !

Shaman weapon buffs are working fine here.
Your button is not fading because the buff that your weapon receives has not the same name as the spell.
Your button should be defined like this:
CB_EarthlivingWeaponBlink,buffblink,Earthliving Weapon,Earthliving/Flametongue/Frostbrand

For details look here: http://www.wowhead.com/spell=8024/flametongue-weapon

cu
tay
tayedaen is offline Report comment to moderator  
Reply With Quote
Unread 01-01-11, 09:36 PM  
Cosmic Cleric
A Deviate Faerie Dragon
 
Cosmic Cleric's Avatar
AddOn Author - Click to view AddOns

Forum posts: 15
File comments: 283
Uploads: 10
Re: Button Check

Originally posted by Whist34
Will someone please check my purge button text. I want it to show up only when the enemy target has a buff that can be purged. Currently it shows up but it doesn't seem to purge or maybe it is getting flagged to purge when it shouldn't? Please just let me know if the code line is correct.

Thanks!

CB_Purge,debuff,Purge,Purge
I don't have a Shaman, so I can't check out your button, but it looks ok to me (syntactically at least).

I'd suggest trying to make a non-custom button first, and see if that works. Sometimes, when creating a custom button, the name you 'think' is the right name for the spell/ability is actually different than what Blizzard actually uses.



Originally posted by Whist34
Not sure if this is a bug or not, but the following Custom Button continues to blink and does not fade the button. (This is for a Shaman.)

CB_EarthlivingWeaponBlink,buffblink,Earthliving Weapon,Earthliving Weapon/Flametongue Weapon/Frostbrand Weapon

I also tried:
CB_EarthlivingWeaponBlink,buffblink,Earthliving Weapon,Earthliving Weapon


Still an awesome mod! Thanks!
Again, no Shaman, but I think that weapons type buffs don't show up (via WoW API calls) the same way that other buffs/debuffs do, which may be why XUB is not seeing the buff and fading the button. I know this was true a long time ago, but not sure if that is still the case, or if XUB makes additional WoW API calls to handle Shaman (and other class) weapon buffing. Tay will have to answer this one for sure, one way or another.
Cosmic Cleric is offline Report comment to moderator  
Reply With Quote
Unread 01-01-11, 04:50 PM  
Whist34
A Murloc Raider

Forum posts: 7
File comments: 33
Uploads: 0
Button Check

Will someone please check my purge button text. I want it to show up only when the enemy target has a buff that can be purged. Currently it shows up but it doesn't seem to purge or maybe it is getting flagged to purge when it shouldn't? Please just let me know if the code line is correct.

Thanks!

CB_Purge,debuff,Purge,Purge
Whist34 is offline Report comment to moderator  
Reply With Quote
Unread 12-31-10, 12:14 PM  
Whist34
A Murloc Raider

Forum posts: 7
File comments: 33
Uploads: 0
Not sure if this is a bug or not, but the following Custom Button continues to blink and does not fade the button. (This is for a Shaman.)

CB_EarthlivingWeaponBlink,buffblink,Earthliving Weapon,Earthliving Weapon/Flametongue Weapon/Frostbrand Weapon

I also tried:
CB_EarthlivingWeaponBlink,buffblink,Earthliving Weapon,Earthliving Weapon


Still an awesome mod! Thanks!
Last edited by Whist34 : 12-31-10 at 05:28 PM.
Whist34 is offline Report comment to moderator  
Reply With Quote
Unread 12-29-10, 10:38 AM  
abinning
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 48
Uploads: 1
Custom frames

/script ChatFrame1:AddMessage(GetMouseFocus():GetName())

put it on a hot key, mouseover the raid/party/player frames and hit the key.

Then use that information in the Custom Frames.
If you need more help just ask! =)
abinning is offline Report comment to moderator  
Reply With Quote
Unread 12-28-10, 08:36 PM  
berkz
A Defias Bandit

Forum posts: 2
File comments: 3
Uploads: 0
Tukui

Any chance this addon can work with tukui?

Looks great!
berkz is offline Report comment to moderator  
Reply With Quote
Unread 12-27-10, 05:32 PM  
Cosmic Cleric
A Deviate Faerie Dragon
 
Cosmic Cleric's Avatar
AddOn Author - Click to view AddOns

Forum posts: 15
File comments: 283
Uploads: 10
Exclamation Re: Re: Shadowform not working

FYI, line 413 also has the same bug.

Did not check any of the other .lua files.

Originally posted by tayedaen
Hi !

I have no lua errors here, which is kind of funny, since there IS a bug.
The bug is in line 455 of 'XUB_OnUpdate.lua'.
There is written 'XUBShowDebugMessage' and it should be 'XUB_ShowDebugMessage'. A simple typo, but hard to find

Could you please report if changing this word fixes the error ?

cu
tay
Cosmic Cleric is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: