Minion Beta! - Help us test our new AddOn updater. Get it now!
Download
(48 Kb)
Download
Updated: 12-22-12 08:58 AM
Pictures
File Info
Updated:12-22-12 08:58 AM
Created:unknown
Downloads:88,223
Favorites:196
MD5:

ZMobDB Advanced6  Popular! (More than 5000 hits)

Version: 6.7.4
by: Dant [More]

COUTION: Needs to Disable "Zuxana Model Citizen"

IF YOU GET ERROR. TRY RESETCOMMAND (/ZMOB RESETBOX) BEFORE POST

All Animation 3D Models for UnitFrames and User original view Database
(models only.not include another Unit Informations)

Supported unit :
player,pet,pet target
target,target of target
party,party pet,party target
focus,focus target

All models will use default camera position when you find 1st time.
But you can change camera(zoom,rotation,position) settings.
Zmob will save your original camera setting and Auto-Load next time you find that model.

fullbody,halfbody,shoulder up,fullface as you like.

---- Mouse controls ----
CTRL Key + Left Mouse Button = Rotate and Zoom in on the model.
CTRL Key + Right Mouse Button = Pan the model horizontally or vertically.

ALT Key + Left Mouse Button = increace/decreace model scale.

SHIFT Key + Left Mouse Button = Drag the bounding box around.
SHIFT Key + Right Mouse Button = Resize the bounding box.

CTRL + SHIFT + Left Mouse Button = Auto Portrait ON
CTRL + SHIFT + Right Mouse Button = Auto Portrait OFF
CTRL + SHIFT + ALT + Left Mouse Button = Refresh Model View
Right Mouse Button or ALT Key + Right Mouse Button = Reflesh All Models.

---- Features ----
* Model Database (Common / UnitFrame Specific / PvP Faction Specific)
* Portrait / Auto Portrait Mode
* Clique Supported
* Event Animation
* Random Animation
* Selectable Pannel Style
* Eye Catch Animation
* Raid Target Icon
* UI Compilations Author Support
etc..

Plz Check README.TXT

---- Command ----
/ZMOB delete DataName :delete data from database ("/ZMOB delete Undead_male" etc)
/ZMOB copy DataName1,DataName2 : copy DataName1 setting to DataName2 ("/ZMC copy Undead_male,Troll_female" etc)
/ZMOB config : pop up Config Window
/ZMOB copymenu : pop up Copy Menu
/ZMOB cleardatabase : clear all model data
/ZMOB refresh :Refresh All Models (or mouse right-crick)
/ZMOB testbox op up Animation Test Window
/ZMOB resetbox : reset window position/size when next login



for UI Compilations Authors:

ZMobDB profile has your(author's) character/server name.
so I prepare command when building UI Compilation.
plz check README.txt

6.0
up to stage6

rebuild and unite ZMC and ZMobDB,
this addon not "Plug In". now "Standalone"

* update TOC
* update for 3.0.2 (all options reset but Model Database keeping old data)
* add New Feature "PvP Icon"

6.1 6.1beta2
* add "PvP Position Adjust Control"

6.1beta4,beta7
* Fix Small Bugs
* add Key Bind "Open/Close Animation Test Window"

6.2
* Add New Feature "UI Compilations Author Support"
check README.txt for Detail

6.2beta5,beta8
* Fix Small Bugs
* Change and add "UnitFrame Tooltip" Option

6.2beta9
* Fix Small Bugs

6.2beta10
* Support Vehicle Menu

6.2beta11
* ZMobDB will not change alpha rate while stealth animation OFF
* Database will auto save data when find new model
* Add Option "Notice New Data" (default OFF)
notice when find new model

6.2beta11hotfix
* FixBug: Alpha Rate will not back to default

6.2beta14
* Add command
/ZMOB resetbox : reset window position/size when next login

6.2beta16
* FixBug: cant change model settings while Player Window OFF

6.3alpha1
* Add corde for lag issues

6.3alpha2
* Fix small bugs

6.3alpha3
* Delete "Template" Feature
* model maximum scale has been increased. (ALT+Left Mouse)

6.3alpha4
* Add Mouse Control
CTRL + SHIFT + ALT + Right Mouse Button = Save Model View Compulsory

6.3alpha5
* Fix Small bugs while in Raid group

6.3alpha6
* Stop Bug for 3.0.9
(bug stop only, still have sissues)

6.4alpha1
* update for 3.0.9
* Fix Flame Error,Taint Error

6.4alpha2
* delete Mouse Control CTRL+SHIFT+ALT+RightMouse command
* Fix Mouse Control Error

6.4alpha3
* Fix Profile Issues
* Fix Option Saving Issues
* Animation TestBox re-work
* decrease FPS Issues

6.4alpha4
* Fix "Enable Mouse" Error
* Stop Auto Save when ALT+RightMouse

6.4alpha6
* Fix issues about Raid

6.4beta12
* Fix "Enable Mouse" Option Issue
* Fix Error if change model while UI OFF

6.4beta12 HotFix1
* Fix Error when change target

6.4beta14
* Implubed reflesh count when window pop

6.5beta1
* Update TOC
* BugFix : PartyMember DropDown Menu

6.5.2
* Change Option "Simple Data Mode" Feature

6.6.0
* Add code for patch 4.0.1

6.6.1
* Add code for patch 4.1

6.6.2
* update Animation System script
* re-build Dwarf Male's DEAD animation
* re-build Draenei's DEAD animation

11/05/05
Update Desc

6.6.3
* BugFix : Unitframe "Enable" option

6.7.1
* update TOC
* decreace FPS issue
* find bug: some EventAnimations not work correctly

6.7.2 6.7.3
* update for 5.0.4API Changes

6.7.4
* update TOC
* update Model Scale Range, all models can set more Small
Archived Files (7)
File Name
Version
Size
Author
Date
6.7.3 beta2
48kB
Dant
10-06-12 09:38 PM
6.7.1 alpha
48kB
Dant
10-05-12 09:29 PM
6.6.3
47kB
Dant
09-17-11 04:24 AM
6.6.1 beta2
47kB
Dant
05-03-11 02:26 AM
6.6.1 beta1
47kB
Dant
04-30-11 07:36 AM
6.6.0 beta1
47kB
Dant
10-29-10 05:04 AM
6.4beta18
46kB
Dant
04-04-09 03:12 AM


Post A Reply Comment Options
Unread 11-19-08, 05:53 PM  
Dant
A Murloc Raider
 
Dant's Avatar
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 328
Uploads: 3
6.2beta10

6.2beta10
* Support Vehicle Menu
add Vehicle DropDown Menu
Dant is offline Report comment to moderator  
Reply With Quote
Unread 11-10-08, 09:00 PM  
Dant
A Murloc Raider
 
Dant's Avatar
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 328
Uploads: 3
animation delay

Originally posted by IceShadow
Model animation, it doesn't reset the position. It just makes my character model snap to normal standing animation if he is itching his butt or something.
I see.
I did not measured accurately the delay of each race's animation.
so I set it bit longer.
some models plays "pause (default standing) animation" after motion
Dant is offline Report comment to moderator  
Reply With Quote
Unread 11-10-08, 08:23 PM  
IceShadow
A Deviate Faerie Dragon
 
IceShadow's Avatar

Forum posts: 15
File comments: 93
Uploads: 0
Re: animation setteing

Originally posted by Dant
>Character animation "skips" back to default position on successful cast. Meant to be or bug?
means "CAST animation will skip" or "Model skip to default when you successful cast" ?
Model animation, it doesn't reset the position. It just makes my character model snap to normal standing animation if he is itching his butt or something.
IceShadow is offline Report comment to moderator  
Reply With Quote
Unread 11-10-08, 07:50 PM  
Dant
A Murloc Raider
 
Dant's Avatar
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 328
Uploads: 3
animation setteing

>Character animation "skips" back to default position on successful cast. Meant to be or bug?
means "CAST animation will skip" or "Model skip to default when you successful cast" ?

>Is it possible to change ZMob to work while in combat, to edit the settings?
can change but will hit "Taint Error"
Dant is offline Report comment to moderator  
Reply With Quote
Unread 11-10-08, 06:37 PM  
IceShadow
A Deviate Faerie Dragon
 
IceShadow's Avatar

Forum posts: 15
File comments: 93
Uploads: 0
Report: Character animation "skips" back to default position on successful cast. Meant to be or bug?

Is it possible to change ZMob to work while in combat, to edit the settings?
Last edited by IceShadow : 11-10-08 at 06:44 PM.
IceShadow is offline Report comment to moderator  
Reply With Quote
Unread 11-08-08, 07:45 PM  
Dant
A Murloc Raider
 
Dant's Avatar
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 328
Uploads: 3
6.2beta9

Originally posted by Kystel
5. In a raid and sometime also in a party the TARGET frame will not save change to camera view.

I can change and adjust camera of target "such as a boss" but when i change target and then retarget the boss it goes back to the original setting.
I also do not get the "Update mode setting" message while in a raid.

What is frustraiting is that it will sometimes work ok but not often.
thx info.
6.2beta9 up.
add mouse lock code.plz update

PS:
if you still have same issue.set "Random Animation" "TARGET" OFF
Dant is offline Report comment to moderator  
Reply With Quote
Unread 11-08-08, 02:37 PM  
Kystel
A Defias Bandit

Forum posts: 2
File comments: 9
Uploads: 0
teach me more detail

1) "Hide Party In Raid" Option ON/OFF ?
2) "Hold Windows" Option ON/OFF ?
3) "Specific Database" Option "Party" ON/OFF ?
4) "Random Animation" Option "Party"s Interval/rate?
5) what Unitframe you cant change model setting?


1. On
2. On.
3. On
4. Turned off random animations.
5. In a raid and sometime also in a party the TARGET frame will not save change to camera view.

I can change and adjust camera of target "such as a boss" but when i change target and then retarget the boss it goes back to the original setting.
I also do not get the "Update mode setting" message while in a raid.

What is frustraiting is that it will sometimes work ok but not often.
Kystel is offline Report comment to moderator  
Reply With Quote
Unread 11-07-08, 09:51 PM  
Dant
A Murloc Raider
 
Dant's Avatar
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 328
Uploads: 3
Re: Re: no error

Originally posted by 1defx1
Hey, just looking for some help here. I've got the issue seen below of a square over my character that doesn't seem to have any options attached to it. When I try to move my camera around via dragging with my mouse over the blue square it doesn't move and seems to refresh my bottom portrait.

Reinstalled the mod, deleted the saved variables from the WTF to reset it completely. It disappears the first time I log in and set the mod back up but reappears when I relog.

Any ideas would be much help, thanks in advanced

Here is a shot of it: http://img392.imageshack.us/img392/4984/sighyc7.jpg
checked SS.
all windows turns to Blue and shows "UnitName Text(ex: target,player)" while config window on.
but I cant find that.
I suppose 2way

1)old data:
have to OFF "ZuxanaModelCritizen" addon

2)profile error
try following:
1)create NewCharacter and login
2)open ZMOB config menu and setting.
3) if you have same issue 4-A),no issue 4-B)
4-A)logout and backup and delete saved data
World of Warcraft\WTF\Account\AccountName\SavedVariables\ZMobDB.lua and .bak
World of Warcraft\WTF\Account\AccountName\ServerName\CharacterNmae\SavedVariables\ZMobDB.lua and .bak

4-B)open config menu profiles tab,andcopy new character's profile to main character
Dant is offline Report comment to moderator  
Reply With Quote
Unread 11-07-08, 08:08 PM  
Nihlo
A Murloc Raider

Forum posts: 5
File comments: 125
Uploads: 0
Re: no error

Originally posted by Dant
In use in a usual state, there is no thing that the error occurs.

PS:
* No-Support to Stealed / Edited file
hmm ? didn't steal anything...and edit neither,wouldn't be able to even if I'd like^^ error occured after changing some dead animation and I think a not accurate shoutdown of wow...never mind,it didn't happen again til now...
Nihlo is offline Report comment to moderator  
Reply With Quote
Unread 11-07-08, 07:32 PM  
1defx1
A Kobold Labourer
 
1defx1's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 1
Uploads: 3
Re: no error

Hey, just looking for some help here. I've got the issue seen below of a square over my character that doesn't seem to have any options attached to it. When I try to move my camera around via dragging with my mouse over the blue square it doesn't move and seems to refresh my bottom portrait.

Reinstalled the mod, deleted the saved variables from the WTF to reset it completely. It disappears the first time I log in and set the mod back up but reappears when I relog.

Any ideas would be much help, thanks in advanced

Here is a shot of it: http://img392.imageshack.us/img392/4984/sighyc7.jpg
1defx1 is offline Report comment to moderator  
Reply With Quote
Unread 11-07-08, 06:39 PM  
Dant
A Murloc Raider
 
Dant's Avatar
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 328
Uploads: 3
no error

Originally posted by Nihlo
Message: ..\AddOns\ZMobDB\ZMobDB_Setting.lua line 443:
attempt to index global 'ZMobDB_Animation_stats' (a nil value)
Debug:
[C]: ?
ZMobDB\ZMobDB_Setting.lua:443: ZMobDB_GetStats()
ZMobDB\ZMobDB.lua:1816: ZMobDB_EventAnimation()
ZMobDB\ZMobDB.lua:142: ZMobDB_Avatar_Main_OnEvent()
[string "*:OnEvent"]:1:
[string "*:OnEvent"]:1
In use in a usual state, there is no thing that the error occurs.

PS:
* No-Support to Stealed / Edited file
Dant is offline Report comment to moderator  
Reply With Quote
Unread 11-07-08, 12:51 PM  
Nihlo
A Murloc Raider

Forum posts: 5
File comments: 125
Uploads: 0
Message: ..\AddOns\ZMobDB\ZMobDB_Setting.lua line 443:
attempt to index global 'ZMobDB_Animation_stats' (a nil value)
Debug:
[C]: ?
ZMobDB\ZMobDB_Setting.lua:443: ZMobDB_GetStats()
ZMobDB\ZMobDB.lua:1816: ZMobDB_EventAnimation()
ZMobDB\ZMobDB.lua:142: ZMobDB_Avatar_Main_OnEvent()
[string "*:OnEvent"]:1:
[string "*:OnEvent"]:1
Nihlo is offline Report comment to moderator  
Reply With Quote
Unread 11-07-08, 02:21 AM  
Dant
A Murloc Raider
 
Dant's Avatar
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 328
Uploads: 3
some questions

Originally posted by Kystel
Has any progress been made on fixung this addon for use in parties and raids?
When i enter a raid it becomes impossible to change the camera view as it does not save. Also the camera view for some reason will often change a bit and settings that were fine before are no longer the same.
teach me more detail

1) "Hide Party In Raid" Option ON/OFF ?
2) "Hold Windows" Option ON/OFF ?
3) "Specific Database" Option "Party" ON/OFF ?
4) "Random Animation" Option "Party"s Interval/rate?
5) what Unitframe you cant change model setting?

PS:
party unitframe will change when
* party members changed
* Raid Roster Update(include changeing raid members)
so frequency change will happen while in raid group

PS:
you can use "Amimation Test Window" for setting.

1)open amination test box /zmob testbox
2)target near player
3)set format "Party","normal"
4)push start
5)change model setting in test box
6)can change "Party" Data even if you are not in group

hope it help
Last edited by Dant : 11-07-08 at 02:24 AM.
Dant is offline Report comment to moderator  
Reply With Quote
Unread 11-07-08, 01:25 AM  
Kystel
A Defias Bandit

Forum posts: 2
File comments: 9
Uploads: 0
Has any progress been made on fixung this addon for use in parties and raids?
When i enter a raid it becomes impossible to change the camera view as it does not save. Also the camera view for some reason will often change a bit and settings that were fine before are no longer the same.
Kystel is offline Report comment to moderator  
Reply With Quote
Unread 10-31-08, 03:15 AM  
Dant
A Murloc Raider
 
Dant's Avatar
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 328
Uploads: 3
6.2beta8

6.2beta8
* Fix Profile Bug
* re-work "UI Compilations Author Support"

thx and sorry for waiting.
tested and upload 6.2beta8.
checked flesh-install,backup,restore etc.
no-error found but need re-make backup file
(UI Compilations "Author" only)

for your UI
Dant
Dant is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: