Download
(63 Kb)
Download
Updated: 05-09-12 02:47 PM
Pictures
File Info
Updated:05-09-12 02:47 PM
Created:unknown
Downloads:35,582
Favorites:157
MD5:
Spellcraft  Popular! (More than 5000 hits)
Version: 1.402
by: batrick [More]
News

Spellcraft is back!

Please donate for Spellcraft's Continued Development: Click here to lend your support!


This addon, Spellcraft, does a variety of things for the Mage Class.

All of which you can configure yourself using /spellcraft or /sc.


This addon is entirely modularized. This means that you pick the features that you want, the rest do NOT stay in memory (i.e. the addon is only as big as you want it to be). You can pick the modules you want using /spellcraft when you are logged in. Additionally if you would like, you can permanently remove the modules yourself; they are all in this folder following the naming convention: "Spellcraft.[Module].lua".

Below are some of the features you have availible to you:
  • You can buy reagents (up to a certain number you can set with "/changereagent"), sell your gray items, and repair all your items. Will tell you when you need to purchase more reagents upon entering a city.
  • You can use the slash command: "/bandagem" to messages healers in our group/raid that are targetting you that you are bandaging yourself. It also notifies your party. This can also be done automatically.
  • Automatically Releases you from a BG.
  • Makes a Minimap Button only for mages that, when clicked, will open a frame with all the portals your level permits you to cast, along with your hearthstone.
  • The addon will give you a prompt to remove all your armor when you use invisibility while in a group and leaving combat. It will then provide a prompt to put all your gear back on.
  • You can set up this addon to automatically whisper people that are targetting your sheep, message your party, and message your raid. You can also use the slash command: "/polym [f,t]". If you use this, TURN OFF automatic messaging. For example: "/polym f" where f means your sheep is your focus, or use "/polym t" where t means your sheep is your target. It messages people in your group/raid/battlegroup ONCE that they are targeting your "focus" or "target" and that you are polymorphing their target. Additionally, it has a configurable set probable chance to say polymorph phrases when in a party or raid, depending on your settings. These things you can configure with "/polym config".
  • Tells you who broke your sheep and with what attack/spell.
  • This addon automatically collects garbage (recycles unused memory) of all addons when you die or enter a place of rest. This helps minimize computer lag (not netowrk lag!). Other conditionals for this may be added in the future.

SLASH COMMAND LIST

/spellcraft -- Configure this addon.

/bandagem -- Messages healers in your group that are targeting you, that you are bandaging yourself. Also notifies party.

/polym [config,f,t]-- Messages people in your party/raid/battlegroup that you are polymorphing their target. Messages your party as well, if you are just in a party.

/getnaked -- Takes off all your gear with durability.

/gearoff -- Same as /getnaked.

/gearon -- Puts your gear (that you took off with /getnaked) back on.

/changereagent -- Opens a window to change the maximum number of each of your class' reagent to buy.
http://www.unm.edu/~batrick/spellcraft/files/ChangeLog.txt
Archived Files (6)
File Name
Version
Size
Author
Date
1.401
63kB
batrick
12-19-11 06:03 AM
1.400
125kB
batrick
12-16-11 03:30 PM
1.300
62kB
batrick
11-01-10 01:01 AM
1.202
62kB
batrick
01-07-10 04:51 AM
1.201
182kB
batrick
12-15-09 03:46 AM
1.200
185kB
batrick
12-09-09 10:41 PM


Post A Reply Comment Options
Old 07-20-07, 03:48 AM  
Gaffadin
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
At Level 20 even though I could teleport to the Exodar, Ironforge and Stormwind, the minimap button would not enable itself for me even when turned on.

I took a quick look at the code and changed line 342 of spellcraft.lua to:

"if UnitClass("player") == SC_CLASS_MAGE and SC_Player_Level > 19"

instead of

"if UnitClass("player") == SC_CLASS_MAGE and SC_Player_Level > 20"

and this fixed the problem.
Gaffadin is offline Report comment to moderator  
Reply With Quote
Old 07-21-07, 02:41 AM  
batrick
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 12
Uploads: 2
Originally posted by Gaffadin
At Level 20 even though I could teleport to the Exodar, Ironforge and Stormwind, the minimap button would not enable itself for me even when turned on.

I took a quick look at the code and changed line 342 of spellcraft.lua to:

"if UnitClass("player") == SC_CLASS_MAGE and SC_Player_Level > 19"

instead of

"if UnitClass("player") == SC_CLASS_MAGE and SC_Player_Level > 20"

and this fixed the problem.
What version are you using? You should be using 1.102. That has been fixed for a while.
batrick is offline Report comment to moderator  
Reply With Quote
Old 07-26-07, 12:21 AM  
Gaffadin
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
Originally posted by batrick
What version are you using? You should be using 1.102. That has been fixed for a while.
I was using the latest version.

I just checked the line again and it still says Level 20 instead of 19 in the current downloadable version from this site.
Gaffadin is offline Report comment to moderator  
Reply With Quote
Old 08-02-07, 02:04 PM  
Norek
A Murloc Raider
 
Norek's Avatar

Forum posts: 4
File comments: 70
Uploads: 0
For some reason the DOWNLOAD button at the top, is downloading V1.05 instead of the newest version /shrug

Just thought id let ya know

EDIT: heck even clicking the 1.102 link downloads 1.05 O.O - oh well, got it from curse for now till this gets fixed up =p really neet looking addon! gona save my mage atleast 4 macro slots from the portals alone =D
__________________
Norek - Garithos
Last edited by Norek : 08-02-07 at 02:06 PM.
Norek is offline Report comment to moderator  
Reply With Quote
Old 08-02-07, 04:08 PM  
Norek
A Murloc Raider
 
Norek's Avatar

Forum posts: 4
File comments: 70
Uploads: 0
error

Error: attempt to concatenate local 'reagent' (a nil value)
AddOn: Spellcraft
File: Spellcraft.Merchant.lua
Line: 618
Count: 5

Getting this Error when trying to change the number of regents to buy on my druid alt (70) havent tested if i get this on my mage yet will let you know. This happens when i change the number and try to click Done, then every time i Open the spellcraft menu it gives the error again.
__________________
Norek - Garithos
Norek is offline Report comment to moderator  
Reply With Quote
Old 08-18-07, 10:26 PM  
batrick
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 12
Uploads: 2
Ya I'm aware of that error and should have it fixed for the next release (which I plan to release when wow patch 2.2 is released). I believe the changes you make do go through anyway, just ignore the error for now. Thanks for reporting it.
batrick is offline Report comment to moderator  
Reply With Quote
Old 10-03-07, 08:55 AM  
Amythyst
A Kobold Labourer

Forum posts: 0
File comments: 1
Uploads: 0
Error Message at Log in

First let me say I love this!! But..

I am getting an error when logging in and am unable to use it.

Interface\addons\spellcraft.Init.Lua:51:Attempt to call field 'Set Default Regents' (a nil value)

I downloaded the new version, got the same thing, went back deleted it completely and redownloaded it, and still have the same issue. I am using the most current version.

Any suggestions?

Thanks.
Amythyst is offline Report comment to moderator  
Reply With Quote
Old 10-04-07, 01:56 AM  
batrick
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 12
Uploads: 2
Re: Error Message at Log in

Originally posted by Amythyst
First let me say I love this!! But..

I am getting an error when logging in and am unable to use it.

Interface\addons\spellcraft.Init.Lua:51:Attempt to call field 'Set Default Regents' (a nil value)

I downloaded the new version, got the same thing, went back deleted it completely and redownloaded it, and still have the same issue. I am using the most current version.

Any suggestions?

Thanks.
I doubt I'll figure out what it was, and whatever it is it's an anomaly to me. Download the new version 1.107. If it's not on this site yet use:

http://unm.edu/~batrick/spellcraft

Delete the files:
World of Warcraft\WTF\Account\ACCOUNTNAME\SavedVariables\Spellcraft.lua
World of Warcraft\WTF\Account\ACCOUNTNAME\SavedVariables\Spellcraft.lua.bak

before playing with the new install. This will reset everything.
batrick is offline Report comment to moderator  
Reply With Quote
Old 10-08-07, 08:47 AM  
KhalisSentinels
A Kobold Labourer

Forum posts: 0
File comments: 7
Uploads: 0
Every version past 1.104 hasn't changed my weapons for evocation. I went back to 1.104 and it works again. I also had problems with the auto vendor repair and trash dump on the newer versions not staying active.
KhalisSentinels is offline Report comment to moderator  
Reply With Quote
Old 10-12-07, 11:29 AM  
Fouxglove
A Kobold Labourer

Forum posts: 0
File comments: 1
Uploads: 0
I love this mod but it hasn't worked properly for me since the last patch. The merchant window to sell all greys and buy reagents doesn't load. I downloaded the newest version again today and deleted the saved variables as directed below before installing and it still isn't working. Here is the error code I see when I type /spellcraft

Date: 2007-10-12 13:21:36
ID: 52
Error occured in: Global
Count: 1
Message: ..\AddOns\Spellcraft\Spellcraft.Merchant.lua line 89:
bad argument #1 to 'ipairs' (table expected, got nil)
Debug:
[C]: ?
[C]: ipairs()
Spellcraft\Spellcraft.Merchant.lua:89:
Spellcraft\Spellcraft.Merchant.lua:86
Spellcraft\Spellcraft.Merchant.lua:142:
Spellcraft\Spellcraft.Merchant.lua:121
Spellcraft\Spellcraft.Merchant.lua:663: CreateSettingsFrame()
Spellcraft\Spellcraft.lua:662: MakeMainFrame()
Spellcraft\Spellcraft.lua:389: value()
..\FrameXML\ChatFrame.lua:3017: ChatEdit_ParseText()
..\FrameXML\ChatFrame.lua:2709: ChatEdit_SendText()
..\FrameXML\ChatFrame.lua:2730: ChatEdit_OnEnterPressed()
[string "*:OnEnterPressed"]:1:
[string "*:OnEnterPressed"]:1
Last edited by Fouxglove : 10-12-07 at 11:38 AM.
Fouxglove is offline Report comment to moderator  
Reply With Quote
Old 10-16-07, 04:51 PM  
Tkozy
A Kobold Labourer

Forum posts: 1
File comments: 1
Uploads: 0
Evocation

The Evocation equipper doesn't seem to work for me.
Tkozy is offline Report comment to moderator  
Reply With Quote
Old 10-16-07, 06:35 PM  
batrick
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 12
Uploads: 2
Originally posted by Fouxglove
I love this mod but it hasn't worked properly for me since the last patch. The merchant window to sell all greys and buy reagents doesn't load. I downloaded the newest version again today and deleted the saved variables as directed below before installing and it still isn't working. Here is the error code I see when I type /spellcraft

Date: 2007-10-12 13:21:36
ID: 52
Error occured in: Global
Count: 1
Message: ..\AddOns\Spellcraft\Spellcraft.Merchant.lua line 89:
bad argument #1 to 'ipairs' (table expected, got nil)
Debug:
[C]: ?
[C]: ipairs()
Spellcraft\Spellcraft.Merchant.lua:89:
Spellcraft\Spellcraft.Merchant.lua:86
Spellcraft\Spellcraft.Merchant.lua:142:
Spellcraft\Spellcraft.Merchant.lua:121
Spellcraft\Spellcraft.Merchant.lua:663: CreateSettingsFrame()
Spellcraft\Spellcraft.lua:662: MakeMainFrame()
Spellcraft\Spellcraft.lua:389: value()
..\FrameXML\ChatFrame.lua:3017: ChatEdit_ParseText()
..\FrameXML\ChatFrame.lua:2709: ChatEdit_SendText()
..\FrameXML\ChatFrame.lua:2730: ChatEdit_OnEnterPressed()
[string "*:OnEnterPressed"]:1:
[string "*:OnEnterPressed"]:1
I have this fixed, but is this error occurring on your mage? Are you using an English client?
batrick is offline Report comment to moderator  
Reply With Quote
Old 11-14-07, 11:51 AM  
Yawgmoth21
A Defias Bandit

Forum posts: 3
File comments: 5
Uploads: 0
Spirit weapon equip

Since the 2.3 patch Envoction no longer goes off spirit regen. So you could remove this from this addon making it less memory intensive. Just a helpful thought. If you already thought about this, sweet I can't wait to get the update.
Last edited by Yawgmoth21 : 11-14-07 at 01:07 PM.
Yawgmoth21 is offline Report comment to moderator  
Reply With Quote
Old 11-14-07, 02:28 PM  
batrick
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 12
Uploads: 2
Evocation now works off of Intellect (as increasing your intellect, increases your mana pool which will cause you to have more than 60% mana when you change back to your regular weapons). You can turn off Evocate from the main configuration menu (it will no longer take up any memory when you play).
batrick is offline Report comment to moderator  
Reply With Quote
Old 12-15-07, 08:57 PM  
Brachial
A Kobold Labourer

Forum posts: 0
File comments: 1
Uploads: 0
From what I understand it is suppose to also say who broke your sheep in a raid how do I get that to work?
Brachial is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.