Minion Beta! - Help us test our new AddOn updater. Get it now!
Download
(142 Kb)
Download
Updated: 10-31-10 01:39 PM
Addon for:
PerfectRaid.
Pictures
File Info
Updated:10-31-10 01:39 PM
Created:unknown
Downloads:21,259
Favorites:120
MD5:

PerfectRaid (Inc Heal)  Popular! (More than 5000 hits)

Version: r20101031
by: Shadowed, garnerh42

This is a module for PerfectRaid if you don't have that installed then this won't work for you.

Adds support for LibHealComm-4.0 to PerfectRaid, when someone has an incoming heal to someone in your party or raid it'll show how much as "+<inc>" on the left side of the bar, if multiple people are healing the same person then it'll show the total amount incoming.

Only syncs with people using a mod that has LibHealComm-4.0 enabled.

- Replaced LibHealComm for UNIT_HEAL_PREDICTED support
- done by guest author garnerh42

Author: Shadowed <shadowed.wow@gmail.com>
Date: Sat Jan 30 17:31:37 2010 -0800
- Updated LibHealComm-4.0 to v1.6

Date: Tue Dec 8 09:20:33 2009 -0800
- Updated LibHealComm-4.0 to 1.5.5
- TOC Bump 30300

Date: Wed Dec 2 13:44:23 2009 -0800
- Updated LibHealComm to 1.5.3

Date: Tue Nov 17 12:33:30 2009 -0800
- Updated LibHealComm-4.0 to 1.5.3, LibWrapperHealComm-1.0 to 5.1

Date: Tue Oct 27 01:22:31 2009 -0700
- Updated LibHealComm-4.0 and LibWrapperHealComm-1.0

Date: Thu Oct 8 10:41:28 2009 -0700
- Updated LibHealComm-4.0 and LibWrapperHealComm-1.0

Date: Sun Sep 27 02:20:38 2009 -0700
- Annd reupdated
- Quick change
- CRLF Change
- Updated LHC4 support to work

Date: Tue Sep 15 21:11:12 2009 -0700
- Updated libraries to use LibHealComm-4.0 and LibWrapperHealComm-1.0
- Quick drycode of this using LibHealComm-4.0, I'll test it on Thursday and push it once LHC4 has a stable tag
- Updated version number and file list

Date: Tue Apr 14 03:32:35 2009 +0000
- * Updated LibHealComm-3.0 + TOC

Date: Fri Jan 30 19:40:00 2009 +0000
- * Updated LibHealComm-3.0
- * TOC update

Date: Mon Oct 6 22:03:09 2008 +0000
- * Updated LibHealComm-3.0

Date: Fri Mar 7 23:51:08 2008 +0000
- * Will now create button.raise if it doesn't exist yet on ConfigureButtons() since the latest WoWI version of PR doesn't include it yet but the trunk does
- * Fixed UpdateButtonLayout being called before the heal FontString was created, not sure why only some people get this issue but fixed it

Date: Wed Feb 27 18:38:16 2008 +0000
- * Added RequiredReps: PerfectRaid
- * Cleaned up the positioning code, don't need to rely on a hack anymore
- * Added an option to position the inc heal text at the health deficit, defaults to being positioned on the left side of the bar

Date: Tue Feb 26 22:58:13 2008 +0000
- * Added a config, it's under the "Heal" tab in /perfectraid, but may need to add it in under another tab. You can choose to disable it, show your own heals, and how many seconds in the future to show heals inc for
- * Tried to fix some positioning issues with text, it's still a hack but it works better then before
- * We only call :UpdateHealing from UNIT_HEALTH and UNIT_HEALTH_MAX if UnitExists(name) is valid, meaning we won't update non raid members
- * Added in rounding to the amount, so we don't have 5032.0311341341341234 showing up

Date: Mon Feb 25 21:18:58 2008 +0000
- * Setup svn:externals
- * Initial Import: PerfectRaid_IncHeal/
- * Adds LibHealComm-3.0 support to PR, shows "+<inc> <deff>" on the PR frames
Optional Files (0)


Archived Files (10)
File Name
Version
Size
Author
Date
r20100130
54kB
Shadowed
01-30-10 07:32 PM
r20091208
54kB
Shadowed
12-08-09 11:20 AM
r20091202
50kB
Shadowed
12-02-09 03:45 PM
r20091117
50kB
Shadowed
11-17-09 02:35 PM
r20091027
50kB
Shadowed
10-27-09 02:22 AM
r20091008
48kB
Shadowed
10-08-09 11:43 AM
r20090927
48kB
Shadowed
09-27-09 03:22 AM
r1247
29kB
Shadowed
04-13-09 09:32 PM
r1101
29kB
Shadowed
01-30-09 01:41 PM
r614
156kB
Shadowed
05-15-08 09:24 PM


Post A Reply Comment Options
Unread 08-05-08, 02:54 PM  
forty2j
A Cobalt Mageweaver

Forum posts: 232
File comments: 260
Uploads: 0
I installed this thinking it would show me the heals from my raid members running HealBot. It didn't.. I can only see my own incoming heals. Is there some obvious config I'm missing, or does it not work with HealBot?
forty2j is offline Report comment to moderator  
Reply With Quote
Unread 05-06-08, 12:06 PM  
Shadowed
...
WoWInterface Super Moderator
AddOn Author - Click to view AddOns

Forum posts: 387
File comments: 2512
Uploads: 99
I'll update the LibHealComm-3.0 version since some things have changed since last release, but it's going to have to wait until Wednesday so I can test it out in a raid and make sure it works fine.
Shadowed is offline Report comment to moderator  
Reply With Quote
Unread 05-06-08, 09:59 AM  
Hellno
A Kobold Labourer

Forum posts: 0
File comments: 2
Uploads: 0
Originally posted by Cladhaire
There isn't an Ace3 version of PerfectRaid. That beta just happens to include the Ace3Config libraries that I have considered using as the config GUI, but they certainly aren't being used or required.
My issue must then be related to the specific event in Blk Temple and something with LibHealComm version. For the next raid, I have done the following and will report if it happens again.

* reloaded r181 of PR (beta)
* updated the Ace3 libs that are distributed with PR incHeal and PR (beta), specially the LibHealComm lib, in case that's related to my issue.

If on the next raid it happens again, I will try disabling PR.incHeal and see if that isolates the issue.

I hope this is an encounter specific issue and probably can be fixed easily, cause I really like the incoming heal feedback.
Last edited by Hellno : 05-06-08 at 10:00 AM.
Hellno is offline Report comment to moderator  
Reply With Quote
Unread 05-06-08, 08:14 AM  
Cladhaire
Salad!
 
Cladhaire's Avatar
WoWInterface Super Moderator
AddOn Author - Click to view AddOns

Forum posts: 1934
File comments: 4529
Uploads: 18
There isn't an Ace3 version of PerfectRaid. That beta just happens to include the Ace3Config libraries that I have considered using as the config GUI, but they certainly aren't being used or required.
__________________
"There's only one thing that I know how to do well and I've often been told that you only can do what you know how to do well, and that's be you-- be what you're like-- be like yourself. And so I'm having a wonderful time, but I'd rather be whistling in the dark..."
Cladhaire is offline Report comment to moderator  
Reply With Quote
Unread 05-06-08, 08:10 AM  
Hellno
A Kobold Labourer

Forum posts: 0
File comments: 2
Uploads: 0
Last night on RoS in BT, PR w/ Inc Heal locked up in Phase 1, Essence of Suffering. Basically, the raid frames got 'stuck' and did not update anything. Once this phase was done and we were regen'ing mana from the trash, the frames started working again.

In looking through the forums and changelogs of dependent libraries, I was wondering if PR inc Heal needs to use the updated LibHealComm-3.0 (r 71750 or higher) in order to apply some type of RoS healing fix.

Also, is it possible to support X-embeds, so I can eliminate concerns about old libraries being called. Thanks

Also, I was wondering what version of PerfectRaid should be used, since IncHeal is using Ace3, I would assume that the beta Ace3 PR should be used. If so, it is not clear to the user. Could this be the cause of my issue? because last night I did not have the beta version of PR running.

Anyway, I like the healing feedback of this mod. thanks for the efforts.

Any chance of integrating this with PR (ace3 v) or will it always be an addon? Just trying to streamline the update process and eliminate any incompatibles.

cheers,
Last edited by Hellno : 05-06-08 at 08:11 AM.
Hellno is offline Report comment to moderator  
Reply With Quote
Unread 04-24-08, 06:21 PM  
Cladhaire
Salad!
 
Cladhaire's Avatar
WoWInterface Super Moderator
AddOn Author - Click to view AddOns

Forum posts: 1934
File comments: 4529
Uploads: 18
Originally posted by Rilynn
Just found this mod.. however I was unable to get it to work for me so a question.

I modify Clad's code to change my raid frames a bit, would this cause any issues ?
Will every healer need PR and your mod to show in the raid frames ?

EDIT: also using Clad's new beta PR if that matters and I do not see a new tab in the PR options menu.

Also do not see the mod when loading my character.. should this be loaded as a seperate folder aor added to the PR folder ?
It is a separate addon, and should be loaded and installed as such.
__________________
"There's only one thing that I know how to do well and I've often been told that you only can do what you know how to do well, and that's be you-- be what you're like-- be like yourself. And so I'm having a wonderful time, but I'd rather be whistling in the dark..."
Cladhaire is offline Report comment to moderator  
Reply With Quote
Unread 03-09-08, 11:22 AM  
Shadowed
...
WoWInterface Super Moderator
AddOn Author - Click to view AddOns

Forum posts: 387
File comments: 2512
Uploads: 99
Originally posted by Cyko1
This definitely fixed the problem. I've noticed when I've downloaded your mods before and when using the built-in unzip of windows, it has a problem because the zip files have for each folder has a file as well with the same name in it and the windows unzip just fails. The previous version of this mod didn't have that problem, but then this latest one did again. I've always had the problem with the ss series of stuff. Not sure if you ever saw that.
Good to hear, thanks for testing.

It's because I use a program to upload mods to WoWI, and it's done in Java so it uses the provided zip libraries, your best bet would be to get an unzip program that has better support.

Why it just started happening now, I'm unsure however.
Shadowed is offline Report comment to moderator  
Reply With Quote
Unread 03-09-08, 10:11 AM  
Cyko1
A Murloc Raider

Forum posts: 6
File comments: 7
Uploads: 0
This definitely fixed the problem. I've noticed when I've downloaded your mods before and when using the built-in unzip of windows, it has a problem because the zip files have for each folder has a file as well with the same name in it and the windows unzip just fails. The previous version of this mod didn't have that problem, but then this latest one did again. I've always had the problem with the ss series of stuff. Not sure if you ever saw that.
Cyko1 is offline Report comment to moderator  
Reply With Quote
Unread 03-08-08, 11:38 AM  
Yoshette
A Defias Bandit

Forum posts: 2
File comments: 3
Uploads: 0
Ok. I'm going to try it monday.

In the same time, I've downloaded the last trunk version of perfectraid to try.
Yoshette is offline Report comment to moderator  
Reply With Quote
Unread 03-07-08, 05:51 PM  
Shadowed
...
WoWInterface Super Moderator
AddOn Author - Click to view AddOns

Forum posts: 387
File comments: 2512
Uploads: 99
This should be fixed I fixed about a difference between WoWI PR and SVN PR, try r614
Last edited by Shadowed : 03-07-08 at 05:53 PM.
Shadowed is offline Report comment to moderator  
Reply With Quote
Unread 03-07-08, 03:37 PM  
txamethyst
A Fallenroot Satyr
 
txamethyst's Avatar

Forum posts: 29
File comments: 58
Uploads: 0
with only perfect raid, this module and bug grabber/bug sack running i get this pasted from bug grabber log) immediately on logging in:

{
["message"] = {
"PerfectRaid_IncHeal\\PerfectRaid_IncHeal.lua:41: attempt to index field 'raise' (a nil value)\nPerfectRaid\\PerfectRaid.lua:675: in function `configFunction'\nInterface\\FrameXML\\SecureTemplates.lua:675: in function <Interface\\FrameXML\\SecureTemplates.lua:672>:\n<in C code>: in function `securecall'\nInterface\\FrameXML\\SecureTemplates.lua:682: in function `SetupUnitButtonConfiguration':\nInterface\\FrameXML\\SecureTemplates.lua:760: in function <Interface\\FrameXML\\SecureTemplates.lua:715>:\nInterface\\FrameXML\\SecureTemplates.lua:902: in function `SecureGroupHeader_Update':\n<string>:\"*:OnShow\":1: in function <[string \"*:OnShow\"]:1>\n<in C code>: in function `Show'\nPerfectRaid\\PerfectRaid.lua:342: in function `CreateRaidFrame'\nPerfectRaid\\PerfectRaid.lua:142: in function `UpdateRaidFrames'\nPerfectRaid\\PerfectRaid.lua:116: in function <Interface\\AddOns\\PerfectRaid\\PerfectRaid.lua:97>\n<in C code>: in function `pcall'\nPerfectRaid\\Dongle.lua:246: in function <Interface\\AddOns\\Perfect", -- [1]
"Raid\\Dongle.lua:245>\nPerfectRaid\\Dongle.lua:1313: in function <Interface\\AddOns\\PerfectRaid\\Dongle.lua:1305>\n<in C code>: in function `pcall'\nPerfectRaid\\Dongle.lua:246: in function <Interface\\AddOns\\PerfectRaid\\Dongle.lua:245>\nPerfectRaid\\Dongle.lua:336: in function <Interface\\AddOns\\PerfectRaid\\Dongle.lua:327>\n\n ---", -- [2]
},
["type"] = "error",
["time"] = "2008/03/07 15:33:20",
["session"] = 711,
["counter"] = 1,
}, -- [500]
},

perfect raid alone - no errors
Last edited by txamethyst : 03-07-08 at 03:38 PM.
txamethyst is offline Report comment to moderator  
Reply With Quote
Unread 03-07-08, 01:18 AM  
Shadowed
...
WoWInterface Super Moderator
AddOn Author - Click to view AddOns

Forum posts: 387
File comments: 2512
Uploads: 99
Try r613, the issue should be fixed.
Shadowed is offline Report comment to moderator  
Reply With Quote
Unread 03-06-08, 07:02 PM  
Yoshette
A Defias Bandit

Forum posts: 2
File comments: 3
Uploads: 0
Originally posted by Shadowd
Make sure you have Lua errors enabled through the Interface options, and also can you provide a screenshot of the list in the "Raid Frames" tab.

Another thing is to try disabling all addons besides PerfectRaid + IncHeal module to make sure it's not a conflict.
Here is a screenshot of the error that I have.

I know that I have other addons. But even after disabling everything except Perfectraid and Perfectraid Incheal I got the same error.



My system :

French Client
Normal server
Last version of perfectraid found on wowinterface (so not anything from the trunk)
MacOs system

My errror :
No raid frame. I disable the Perfectraid IncHeal and the frame re appear.
Last edited by Yoshette : 03-06-08 at 07:03 PM.
Yoshette is offline Report comment to moderator  
Reply With Quote
Unread 03-06-08, 02:21 AM  
Shadowed
...
WoWInterface Super Moderator
AddOn Author - Click to view AddOns

Forum posts: 387
File comments: 2512
Uploads: 99
Make sure you have Lua errors enabled through the Interface options, and also can you provide a screenshot of the list in the "Raid Frames" tab.

Another thing is to try disabling all addons besides PerfectRaid + IncHeal module to make sure it's not a conflict.
Last edited by Shadowed : 03-06-08 at 02:23 AM.
Shadowed is offline Report comment to moderator  
Reply With Quote
Unread 03-05-08, 07:42 PM  
Shadowed
...
WoWInterface Super Moderator
AddOn Author - Click to view AddOns

Forum posts: 387
File comments: 2512
Uploads: 99
I'll look into it, but I can't think of a reason as to why that would happen.
Shadowed is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.