Download
(96 Kb)
Download
Updated: 07-26-08 02:51 PM
Pictures
File Info
Updated:07-26-08 02:51 PM
Created:unknown
Downloads:2,800
Favorites:16
MD5:
Beauty
Version: 0.5.2
by: Faryn [More]
Beauty is a small, lightweight addon to manage your video settings.

By default it activates an "extreme" mode with the best possible video options. It doesn't alter all video settings, just the ones that are hidden or limited in the options menu. You can easily switch back to your previous settings and even to a very low-settings preset, in case you need the best possible fps.

If you somehow screw up the default setting, just reconfigure the video options in the Blizzard Menu and reset the default profile of the addon with the slashcommand or the menu button.

Configurable via /Beauty or the Blizzard Addon Menu, it should work with any language client. It is localized for English and German, if you can help me with a translation to other languages, please contact me!

If you have any bug reports or suggestions feel free to leave a comment!
- fixed an error on enUS client
- fixed some typos
Optional Files (0)


Post A Reply Comment Options
Unread 07-27-08, 04:45 PM  
Faryn
A Defias Bandit
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 4
Uploads: 1
Originally posted by Icedawg
Checked for errors and had none, Using English US client


so I deleted the SavedVariables files in WTF directoryand it's now working.

But all I notice now between the default and Extreme settings is some of the vegetation is little brighter.

The draw distance of the vegetation is the same. The draw Distance of hills/mountains are the same etc etc.. (Not sure if your addon does this?)

Can your extreme settings can go higher?
Ok you should try this macro:
/console farclip 777
/console horizonfarclip 6226
/console groundeffectdensity 256
/console groundeffectdist 140
/console smallcull 0
/console skycloudlod 3
/console characterambient 0

these are the things the addon modifies. If you see a difference using this, there's probably something wrong with the addon. If not it's gotta be something with your WoW Installation (or Video Driver? idk tbh)
Faryn is offline Report comment to moderator  
Reply With Quote
Unread 07-27-08, 08:41 AM  
Icedawg
A Kobold Labourer

Forum posts: 1
File comments: 38
Uploads: 0
Checked for errors and had none, Using English US client


so I deleted the SavedVariables files in WTF directoryand it's now working.

But all I notice now between the default and Extreme settings is some of the vegetation is little brighter.

The draw distance of the vegetation is the same. The draw Distance of hills/mountains are the same etc etc.. (Not sure if your addon does this?)

Can your extreme settings can go higher?
Icedawg is offline Report comment to moderator  
Reply With Quote
Unread 07-27-08, 08:18 AM  
Faryn
A Defias Bandit
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 4
Uploads: 1
Originally posted by Icedawg
I was in Nagrand when testing..

I'll check for errors...


BTW do I need to reload ui settings or log back out and in for settings to take?

or is it instant?
It doesn't require a restart or reloadui, should be instant.
Do you get the chat messages like "settings set to extreme" etc and nothing happens, or nothing at all?
What language Client do you use?
Last edited by Faryn : 07-27-08 at 08:18 AM.
Faryn is offline Report comment to moderator  
Reply With Quote
Unread 07-27-08, 07:58 AM  
Icedawg
A Kobold Labourer

Forum posts: 1
File comments: 38
Uploads: 0
I was in Nagrand when testing..

I'll check for errors...


BTW do I need to reload ui settings or log back out and in for settings to take?

or is it instant?
Last edited by Icedawg : 07-27-08 at 08:42 AM.
Icedawg is offline Report comment to moderator  
Reply With Quote
Unread 07-27-08, 05:09 AM  
Faryn
A Defias Bandit
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 4
Uploads: 1
Originally posted by Icedawg
Hmm I ran this on extreme and without the addon and I could not see an differance in the graphics at all, and my frame rate is the same with or without it.

I took screen shots to compair as well and I could not see anything either side by side.

I guess it's not working..

Running a ATI HD4870 videocard..

Any ideas?
Where did you test it?
There are of course some zones where you barely notice any difference. To be sure you should go to a zone with much vegetation on the ground, like Nagrand, Terokkar or Stranglethorn and switch between the "low"-setting and the "extreme"-setting.
If you don't see any changes it's not working and you should enable "Display Lua Errors" and look for any error message.
Faryn is offline Report comment to moderator  
Reply With Quote
Unread 07-26-08, 09:33 PM  
Icedawg
A Kobold Labourer

Forum posts: 1
File comments: 38
Uploads: 0
Hmm I ran this on extreme and without the addon and I could not see an differance in the graphics at all, and my frame rate is the same with or without it.

I took screen shots to compair as well and I could not see anything either side by side.

I guess it's not working..

Running a ATI HD4870 videocard..

Any ideas?
Icedawg is offline Report comment to moderator  
Reply With Quote
Unread 07-26-08, 03:57 PM  
Dreadlorde
A Pyroguard Emberseer
 
Dreadlorde's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2302
File comments: 141
Uploads: 21
I wish I could use these settings. But my computer can't even run tbc.
__________________

Funtoo - Plan 9 - Windows 7
Dreadlorde is offline Report comment to moderator  
Reply With Quote
Unread 07-26-08, 02:52 PM  
Faryn
A Defias Bandit
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 4
Uploads: 1
Originally posted by Ailae
Throws this error:



Just downloaded it now. Seems to function though, so it's not breaking the addon per se. I play with the english client.
Yeah sorry, I focused so much on the German translation (which worked fine) so I forgot to recheck the English one...

It's fixed in the new version!
Faryn is offline Report comment to moderator  
Reply With Quote
Unread 07-26-08, 12:26 PM  
Ailae
A Rage Talon Dragon Guard
 
Ailae's Avatar
AddOn Author - Click to view AddOns

Forum posts: 317
File comments: 75
Uploads: 7
Throws this error:

Interface\AddOns\Beauty\Locale-deDE.lua:5: attempt to index local 'L' (a nil value)
Count: 1

Call Stack:
[C]: ?
Interface\AddOns\Beauty\Locale-deDE.lua:5: in main chunk
Just downloaded it now. Seems to function though, so it's not breaking the addon per se. I play with the english client.
Ailae is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: