Quantcast
Download
(446 Kb)
Download
Updated: 09-10-14 01:50 PM
Pictures
File Info
Compatibility:
Warlords of Draenor Pre-Patch (6.0.2)
Updated:09-10-14 01:50 PM
Created:09-10-14 01:50 PM
Downloads:2,733
Favorites:5
MD5:
Categories:Warlords of Draenor Beta, Beta-version AddOns

ElvUI Kkthnx Beta

Version: 7.0
by: Kkthnx [More]


You need ElvUI 7+ For this.

Post A Reply Comment Options
Unread 09-11-14, 08:36 AM  
miguelxp
A Kobold Labourer

Forum posts: 0
File comments: 33
Uploads: 0
Thank you !!!
Report comment to moderator  
Reply With Quote
Unread 09-11-14, 02:29 AM  
Darkfart
A Kobold Labourer

Forum posts: 0
File comments: 7
Uploads: 0
playable?

Hi Kkthnx

nice to hear from you again

I'm using you fantastic UI from the beginning and still satisfied with it

Is this version for the actual version or just for WoD?

Best Regards

Darkfart


Forget it. I just saw the ElvUI 7 is required
Last edited by Darkfart : 09-11-14 at 02:35 AM.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: