Download
(142 Kb)
Download
Updated: 11-09-13 01:49 AM
Pictures
File Info
Compatibility:
Siege of Orgrimmar (5.4)
Escalation (5.3)
Thunder Isle (5.2)
Mists of Pandaria (5.0.4)
Updated:11-09-13 01:49 AM
Created:12-25-09 07:04 AM
Downloads:3,535
Favorites:22
MD5:
5.4
zz Infoclock
Version: 50400.22
by: Rilgamon [More]
Broker AddOn for time, date, latency and fps with configurable display line.


Addon Loader

The current version supports Addon Loader.
Addon Loader is a load manager, which can speed up the addon loading process.
50400.22 Nov/11/13

- Fixed bug reported by sconley (forgot to remove old GameTooltip autoupdate)

50400.21 Oct/10/13

- Update toc 5.4
- changed tooltip handling

50300.19 May/23/13
- Updated toc 5.3

50200.18 Mar/09/12
- Updated Ace-Libs
- Updated toc 5.2

50001.15 Sep/23/12

- Added expert mode to configure the display line

50001.14 Aug/29/12

- Updated Libs
- toc update

40300.14 Apr/22/12

- (Hopefully) fixed AddonLoader startup (again)

40300.10 Apr/22/12

- Cleaned the libs and using zzLibCommon

40300.4 Jan/14/12

- updated AceLibs
- fixed a race condition when loading is delayed by addonloader

40300.3 Nov/30/11

- fix menuName (table index nil)

40300.3 Nov/30/11

- Updated Ace-Libs
- Updated toc

40200.2 Jul/03/11

- Updated Ace3-Libs
- Created WoWI-SVN

4.5 Apr/27/11

- Updated Ace3-Libs

06/Dec/2010 4.1

- Fixed iconpath

04/Dec/2010 4.0

- Bumped version to 4.0 as an internal sign its includeable in BrokerPack

Jul/02/10 1.5

- Fixed localization july

Apr/12/10 1.4

- Updated zzLib (v24)

Feb/20/10 1.3

- Updated zzLib (v 18)
- Added Addon Loader-Support

Feb/17/10 1.2

- Updated zzLib (v 16)
- Fixed loading order of libs (I hope)

Jan/11/10 1.1

- Updated zzLib (v 10)
- Fixed some wrong functioncalls
Optional Files (0)


Archived Files (21)
File Name
Version
Size
Author
Date
50400.21
142kB
Rilgamon
10-30-13 11:08 AM
50300.19
129kB
Rilgamon
05-23-13 02:19 AM
50200.18
128kB
Rilgamon
03-09-13 03:11 AM
50001.15
128kB
Rilgamon
09-23-12 05:26 AM
50001.14
125kB
Rilgamon
08-29-12 06:34 AM
40300.14
124kB
Rilgamon
04-22-12 12:13 PM
40300.13
124kB
Rilgamon
04-22-12 06:28 AM
40300.10
123kB
Rilgamon
04-21-12 05:58 PM
40300.4
243kB
Rilgamon
01-14-12 08:07 AM
40300.4
242kB
Rilgamon
11-30-11 11:16 AM
40300.3
242kB
Rilgamon
11-30-11 08:23 AM
40200.2
237kB
Rilgamon
07-03-11 01:06 AM
4.5
155kB
Rilgamon
04-27-11 05:05 AM
4.1
180kB
Rilgamon
12-06-10 04:25 AM
4.0
180kB
Rilgamon
12-04-10 10:11 AM
1.5
145kB
Rilgamon
07-01-10 09:51 PM
1.4
144kB
Rilgamon
04-12-10 12:37 PM
1.3
144kB
Rilgamon
02-19-10 05:12 PM
1.2
144kB
Rilgamon
02-16-10 07:33 PM
1.1
144kB
Rilgamon
01-11-10 04:37 PM
1.0
143kB
Rilgamon
12-25-09 07:06 AM


Post A Reply Comment Options
Unread 07-25-14, 07:38 AM  
Rilgamon
Premium Member
 
Rilgamon's Avatar
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 548
File comments: 230
Uploads: 34
Re: Latency String

Originally Posted by AzureDragon
Just started using the addon and found that %local wasn't working correctly for latency. I checked the code and found that line 79 had
Lua Code:
  1. l = l:gsub("%%local", l)
instead of
Lua Code:
  1. l = l:gsub("%%local", h)
After making that change in my copy it looks to be working correctly.
Thank you for reporting Never noticed because latency displayed is so inaccurate I stopped using it long ago
I've fixed the bug in the repo but delay an update until pre-patch because I'm already testing and changing my addons on beta-servers
__________________
The cataclysm broke the world ... and the pandas could not fix it!
Rilgamon is offline Report comment to moderator  
Reply With Quote
Unread 07-22-14, 06:33 PM  
AzureDragon
A Kobold Labourer

Forum posts: 1
File comments: 1
Uploads: 0
Latency String

Just started using the addon and found that %local wasn't working correctly for latency. I checked the code and found that line 79 had
Lua Code:
  1. l = l:gsub("%%local", l)
instead of
Lua Code:
  1. l = l:gsub("%%local", h)
After making that change in my copy it looks to be working correctly.
AzureDragon is offline Report comment to moderator  
Reply With Quote
Unread 04-22-12, 04:58 AM  
Rilgamon
Premium Member
 
Rilgamon's Avatar
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 548
File comments: 230
Uploads: 34
Originally Posted by tordenflesk
40300.10 doesn't load.
Do you get an error ? Here it loads fine. Tested it on chars with old wtf and chars with wtf deleted.
Edit: Damn ... it's the Addonloader support again ... need to remember to check this twice
Edit 2: 40300.13 is pending ... could you check if this works for you ? I'll update the other addons asap if this fixes your probs
__________________
The cataclysm broke the world ... and the pandas could not fix it!
Last edited by Rilgamon : 04-22-12 at 06:29 AM.
Rilgamon is offline Report comment to moderator  
Reply With Quote
Unread 04-22-12, 04:26 AM  
tordenflesk
A Deviate Faerie Dragon

Forum posts: 10
File comments: 154
Uploads: 0
40300.10 doesn't load.
tordenflesk is offline Report comment to moderator  
Reply With Quote
Unread 12-06-10, 06:33 AM  
tordenflesk
A Deviate Faerie Dragon

Forum posts: 10
File comments: 154
Uploads: 0
Originally posted by Rilgamon
I've changed the loading process for 4.1 ... perhaps this fixes your problem, too.
I removed the old version and Its files in WTF. Installed the latest version, and now it's working just fine.
Originally posted by Rilgamon
When you hover the mouse over it, does it show the tooltip with the right values ? [/b]
Yes, it did.
tordenflesk is offline Report comment to moderator  
Reply With Quote
Unread 12-06-10, 04:27 AM  
Rilgamon
Premium Member
 
Rilgamon's Avatar
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 548
File comments: 230
Uploads: 34
Originally posted by tordenflesk
Makes no difference. Even after deleting it's files from the WTF-folder, the boxes in the config do nothing.
I'm looking at the code over and over and cant find the fault.
I've changed the loading process for 4.1 ... perhaps this fixes your problem, too.

When you hover the mouse over it, does it show the tooltip with the right values ?
__________________
The cataclysm broke the world ... and the pandas could not fix it!
Rilgamon is offline Report comment to moderator  
Reply With Quote
Unread 12-05-10, 03:36 PM  
tordenflesk
A Deviate Faerie Dragon

Forum posts: 10
File comments: 154
Uploads: 0
Makes no difference. Even after deleting it's files from the WTF-folder, the boxes in the config do nothing.
Last edited by tordenflesk : 12-05-10 at 03:40 PM.
tordenflesk is offline Report comment to moderator  
Reply With Quote
Unread 12-05-10, 03:02 PM  
Rilgamon
Premium Member
 
Rilgamon's Avatar
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 548
File comments: 230
Uploads: 34
Originally posted by tordenflesk
Started getting this today:

All addons up to date, and no bugs in BugSack.
The new version resetted the settings. When you see the addon-name
instead of the time/fps/latency check them.
__________________
The cataclysm broke the world ... and the pandas could not fix it!
Rilgamon is offline Report comment to moderator  
Reply With Quote
Unread 12-05-10, 01:43 PM  
tordenflesk
A Deviate Faerie Dragon

Forum posts: 10
File comments: 154
Uploads: 0
Started getting this today:

All addons up to date, and no bugs in BugSack.
tordenflesk is offline Report comment to moderator  
Reply With Quote
Unread 10-14-10, 04:26 PM  
Opaque
A Fallenroot Satyr
 
Opaque's Avatar

Forum posts: 23
File comments: 143
Uploads: 0
Talking Thanks!

Great little mod!
__________________
Last edited by Opaque : 10-14-10 at 04:27 PM.
Opaque is offline Report comment to moderator  
Reply With Quote
Unread 06-15-10, 09:40 AM  
Latharus
A Murloc Raider
 
Latharus's Avatar
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 28
Uploads: 3
another great ZZ addon. I used to have three for clock/mem/fps, and now I just need to run one on my bar.

THankx for this one
Latharus is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: