Download
(41 Kb)
Download
Updated: 11-28-10 05:08 PM
Updated:11-28-10 05:08 PM
Created:unknown
Downloads:75,836
Favorites:195
MD5:
ChatScroll  Popular! (More than 5000 hits)
Version: 3.4.40000
by: AnduinLothar, Kharthus
ChatScroll makes chat windows scrollable with the mouse wheel.

Shift-ScrollUp: Scroll To Top
Shift-ScrollDown: Scroll To Bottom

Also adds a keybinding to scroll to top. (scroll to bottom already default)

Also has a Scroll Speed option.

Uses Portfolio for GUI options if you've got it.
Otherwise the following macro will enable button hiding:
/run ChatScroll_SavedVars.EnableScrolling="1"
Or Scroll Speed (change 1 to your speed #):
/run ChatScroll_SavedVars.ScrollSpeed=1

Note: Blizzard added its own chat scroll option with 4.0, but without this addon you wont be able to adjust scroll speed or shift-scroll to top or bottom.
v3.4 (Kharthus)
- Updates for WoW 4.0.1

v3.3
- Added a Scroll Speed slider
(If you're not using Portfolio manually set ChatScroll_SavedVars.ScrollSpeed to a number > 0)
- Portfolio v0.7 included (GUI Options)

v3.2
- Fixed Portfolio not being optional

v3.1
- More aggressive button hiding
- Now uses LibDefaults for variable initialization

v3.0
- Updated for WoW 3.0
- Added Portfolio Options, Removed Khaos Options

v2.2
- Added "Hide Chat Frame Scroll Buttons" Option
- Cleaned up the code

v2.1
- Prepared for Lua 5.1
- Removed Localization usage

v2.0
- No longer uses hidden frames, now uses script element hooks
- No longer supports PopUI or TransUI, I recomend using VisibilityOptions to hide the buttons.
- Added Shift-MouseWheelUp to to to the top of the chat window
- Added Shift-MouseWheelDown to to to the bottom of the chat window
- Added Scroll to Top Binding

v1.1
- Fixed negative framelevel bug in new patch
- Updated the TOC to 1300.

v1.1
- Initial Release
Archived Files (2)
File Name
Version
Size
Author
Date
3.3.30100
41kB
AnduinLothar
04-16-09 07:18 PM
3.3.30000
24kB
AnduinLothar
11-21-08 08:39 PM


Post A Reply Comment Options
Unread 10-30-10, 03:59 PM  
Kharthus
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 227
Uploads: 6
I've got it working in 4.0.1. Just need access to upload the fixes.
Kharthus is offline Report comment to moderator  
Reply With Quote
Unread 07-18-10, 11:01 PM  
Kharthus
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 227
Uploads: 6
I know scrolling is in the default UI now, but the speed settings and jump to top/bottom are really nice. Can you update this?
Kharthus is offline Report comment to moderator  
Reply With Quote
Unread 04-19-09, 04:30 AM  
Quandru
A Kobold Labourer

Forum posts: 0
File comments: 11
Uploads: 0
Nevermind, sorted!
Last edited by Quandru : 04-19-09 at 04:36 AM.
Quandru is offline Report comment to moderator  
Reply With Quote
Unread 02-15-09, 01:26 PM  
cawfee
An Aku'mai Servant
 
cawfee's Avatar
AddOn Author - Click to view AddOns

Forum posts: 30
File comments: 94
Uploads: 1
I currently have the problem that ChatScroll doesn't recognize my value for the amount of lines scrolled anymore; it seems to default to 1 line per turn. Portfolio is at 1.0 and I haven't made any other mod or UI changes since then. No Swatter errors either; any idea what could be causing it?
cawfee is offline Report comment to moderator  
Reply With Quote
Unread 11-28-08, 06:05 PM  
AnduinLothar
Nobody of Importance
 
AnduinLothar's Avatar
AddOn Author - Click to view AddOns

Forum posts: 95
File comments: 208
Uploads: 49
Re: loading error

Originally posted by Kharthus
ChatScrollControlPanelScrollSpeed.text(nil) Error:
Interface\AddOns\ChatScroll\ChatScroll.lue:167: Bad argument #1 to 'format' (string expected, got nil)

I just loaded the new version of Portfolio (0.9) in case that's related.
portfolio bug. grab v0.91
AnduinLothar is offline Report comment to moderator  
Reply With Quote
Unread 11-28-08, 02:10 PM  
Kharthus
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 227
Uploads: 6
loading error

ChatScrollControlPanelScrollSpeed.text(nil) Error:
Interface\AddOns\ChatScroll\ChatScroll.lue:167: Bad argument #1 to 'format' (string expected, got nil)

I just loaded the new version of Portfolio (0.9) in case that's related.
Last edited by Kharthus : 11-28-08 at 02:10 PM.
Kharthus is offline Report comment to moderator  
Reply With Quote
Unread 11-21-08, 10:03 PM  
cawfee
An Aku'mai Servant
 
cawfee's Avatar
AddOn Author - Click to view AddOns

Forum posts: 30
File comments: 94
Uploads: 1
Originally posted by AnduinLothar
I can do better than that...
A wizard, you are. Many thanks for the quick implementation
cawfee is offline Report comment to moderator  
Reply With Quote
Unread 11-21-08, 08:40 PM  
AnduinLothar
Nobody of Importance
 
AnduinLothar's Avatar
AddOn Author - Click to view AddOns

Forum posts: 95
File comments: 208
Uploads: 49
Originally posted by cawfee
Works flawlessly for me! Just an idea: Add a /cs (x) command to determine the amount of lines scrolled with each turn of the wheel, that way the user can set their preferred scrolling speed and amount.

If that's possible, it'd be the cherry on the cake. Thanks for making a great addon!
I can do better than that...
AnduinLothar is offline Report comment to moderator  
Reply With Quote
Unread 11-21-08, 11:40 AM  
cawfee
An Aku'mai Servant
 
cawfee's Avatar
AddOn Author - Click to view AddOns

Forum posts: 30
File comments: 94
Uploads: 1
Works flawlessly for me! Just an idea: Add a /cs (x) command to determine the amount of lines scrolled with each turn of the wheel, that way the user can set their preferred scrolling speed and amount.

If that's possible, it'd be the cherry on the cake. Thanks for making a great addon!
cawfee is offline Report comment to moderator  
Reply With Quote
Unread 10-31-08, 07:35 AM  
KerriK73
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
yes. updated to version 3.2.3 about 10 minutes before i posted here. i sorta think it's some other mod conflicting, because chatscroll works perfectly on my priest but the scroll buttons seem to un-hide on my warrior. i'm running healbot on my priest but not on my warrior, otherwise same mods on both. i'll check more thoroughly today for any lua errors with bugsack/buggrabber.

edit: no bugs showing on bugsack/buggrabber. chatscroll isn't showing on my interface->addons tab anymore either.
Last edited by KerriK73 : 10-31-08 at 10:47 AM.
KerriK73 is offline Report comment to moderator  
Reply With Quote
Unread 10-30-08, 07:16 PM  
AnduinLothar
Nobody of Importance
 
AnduinLothar's Avatar
AddOn Author - Click to view AddOns

Forum posts: 95
File comments: 208
Uploads: 49
Maybe a silly question, but are you using the version released 10 hours before you posted?
AnduinLothar is offline Report comment to moderator  
Reply With Quote
Unread 10-30-08, 12:02 PM  
KerriK73
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
not sure if it's a conflict with another mod, or if i'm just doing something wrong. but every time i open and close my map, the chat scroll buttons don't stay hidden. if i /reloadui they will hide if i click a player name or item in one window (and these may not be hidden, i have those buttons effectively off the screen), but if i click a player name or item in the other window its chat scroll buttons un-hide. this only seems to occur after i open and close the map, and i'm not getting any error message that i can tell. here is a screenshot:

http://s275.photobucket.com/albums/j...008_135302.jpg
KerriK73 is offline Report comment to moderator  
Reply With Quote
Unread 10-30-08, 01:29 AM  
AnduinLothar
Nobody of Importance
 
AnduinLothar's Avatar
AddOn Author - Click to view AddOns

Forum posts: 95
File comments: 208
Uploads: 49
Re: Error

Ah ok, i forgot to pass the silent flag to make it optional, sorry. I'll fix that.
AnduinLothar is offline Report comment to moderator  
Reply With Quote
Unread 10-29-08, 11:38 PM  
Kharthus
A Murloc Raider
AddOn Author - Click to view AddOns

Forum posts: 8
File comments: 227
Uploads: 6
Error

Date: 2008-10-29 22:33:38
ID: 51
Error occured in: Global
Count: 1
Message: ..\AddOns\ChatScroll\ChatScroll.lua line 134:
Cannot find a library instance of "Portfolio".
Debug:
[C]: ?
[C]: error()
!Swatter\Support\LibRevision.lua:47: LibStub()
ChatScroll\ChatScroll.lua:134: in main chunk
Kharthus is offline Report comment to moderator  
Reply With Quote
Unread 10-13-06, 12:01 PM  
elsid
A Kobold Labourer

Forum posts: 0
File comments: 1
Uploads: 0
2 Errors for me!

How to fix them...

ChatScroll.toc => change interface to ## Interface: 20000
or chatscroll wont load!

Bug, that i cant select items in chat so see them, fix in *.xml =>
change the line
this:SetFrameLevel(this:GetParent():GetFrameLevel()-1)
to
this:SetFrameLevel(this:GetParent():GetFrameLevel())

all now working fine!

ty
Last edited by elsid : 10-13-06 at 03:14 PM.
elsid is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: