Download
(337 Kb)
Download
Updated: 11-30-07 04:54 AM
Pictures
File Info
Updated:11-30-07 04:54 AM
Created:unknown
Downloads:2,724
Favorites:13
MD5:
SLCommunity 1.0
Version: r4
by: Taffu [More]
No Longer Supported/Updated
If you are still interested in the SL text-based plugins, please download SLDataText which is the current supported AddOn.
Post A Reply Comment Options
Old 12-15-07, 06:23 PM  
LgEnder
A Kobold Labourer

Forum posts: 0
File comments: 6
Uploads: 0
Bug?
I've noticed that the Guild mouseover seems to update the locations of people correctly, yet the Friends mouseover does not seem to update unless you manually open the Friends tab on the Social window.
LgEnder is offline Report comment to moderator  
Reply With Quote
Old 12-05-07, 01:03 PM  
Taffu
A Flamescale Wyrmkin
AddOn Author - Click to view AddOns

Forum posts: 149
File comments: 418
Uploads: 33
Originally posted by digmouse
me too, zhCN and zhTW
I'll be patching soon with localized class tables to fix the error from non-US clients.
Taffu is offline Report comment to moderator  
Reply With Quote
Old 12-02-07, 01:03 AM  
digmouse
A Fallenroot Satyr
AddOn Author - Click to view AddOns

Forum posts: 26
File comments: 65
Uploads: 2
Originally posted by Taffu
I think I know what the problem is. Are you both on non-US clients? The "Class" tables for the class colors isn't localized.
me too, zhCN and zhTW
digmouse is offline Report comment to moderator  
Reply With Quote
Old 12-01-07, 11:34 AM  
LiaDavinia
A Murloc Raider

Forum posts: 7
File comments: 27
Uploads: 0
Originally posted by Taffu
I think I know what the problem is. Are you both on non-US clients? The "Class" tables for the class colors isn't localized.
yep i play on a EU (German) Client
LiaDavinia is offline Report comment to moderator  
Reply With Quote
Old 12-01-07, 08:54 AM  
Taffu
A Flamescale Wyrmkin
AddOn Author - Click to view AddOns

Forum posts: 149
File comments: 418
Uploads: 33
Originally posted by digmouse
As Divinia, I still got :
SLCommunity\\Core.lua:222: bad argument #2 to 'format' (string expected, got nil)
I think I know what the problem is. Are you both on non-US clients? The "Class" tables for the class colors isn't localized.
Last edited by Taffu : 12-01-07 at 10:27 AM.
Taffu is offline Report comment to moderator  
Reply With Quote
Old 12-01-07, 08:27 AM  
digmouse
A Fallenroot Satyr
AddOn Author - Click to view AddOns

Forum posts: 26
File comments: 65
Uploads: 2
As Divinia, I still got :
SLCommunity\\Core.lua:222: bad argument #2 to 'format' (string expected, got nil)
digmouse is offline Report comment to moderator  
Reply With Quote
Old 12-01-07, 03:29 AM  
LiaDavinia
A Murloc Raider

Forum posts: 7
File comments: 27
Uploads: 0
after installing r4:

PHP Code:
SLCommunity\\Core.lua:222bad argument #2 to 'format' (string expected, got nil) 
LiaDavinia is offline Report comment to moderator  
Reply With Quote
Old 11-28-07, 07:06 AM  
Taffu
A Flamescale Wyrmkin
AddOn Author - Click to view AddOns

Forum posts: 149
File comments: 418
Uploads: 33
Originally posted by digmouse
SLCommunity\\Core.lua:222: bad argument #2 to 'format' (string expected, got nil)

and when I move mouse on to the guild member info text:
SLCommunity\\Core.lua:255: bad argument #7 to 'format' (string expected, got nil)SLCommunity\\Core.lua:255: in function <Interface\\AddOns\\SLCommunity\\Core.lua:233>

any ideas?
Yes, I actually already have this fixed, I just forgot to upload the fix this morning. I accidentally commented out lines that affect the state of mouseover when the count of online members goes to zero from > zero when online. Same thing will happen with friends if someone logs on and then logs off and the count is zero. Oopsy...will upload the fix when I get home from work today
Taffu is offline Report comment to moderator  
Reply With Quote
Old 11-28-07, 06:46 AM  
digmouse
A Fallenroot Satyr
AddOn Author - Click to view AddOns

Forum posts: 26
File comments: 65
Uploads: 2
SLCommunity\\Core.lua:222: bad argument #2 to 'format' (string expected, got nil)

and when I move mouse on to the guild member info text:
SLCommunity\\Core.lua:255: bad argument #7 to 'format' (string expected, got nil)SLCommunity\\Core.lua:255: in function <Interface\\AddOns\\SLCommunity\\Core.lua:233>

any ideas?
digmouse is offline Report comment to moderator  
Reply With Quote
Old 11-23-07, 09:20 PM  
Mons
A Kobold Labourer

Forum posts: 0
File comments: 5
Uploads: 0
I would vote for columnization. Does my vote count? Also, a way to scale the tooltip or its font up...I use a funky font that's really hard to read at small font sizes.

Edit: PS Have I said that I love these mods? Cause I do.
Last edited by Mons : 11-23-07 at 09:23 PM.
Mons is offline Report comment to moderator  
Reply With Quote
Old 11-23-07, 05:15 PM  
cabouter
A Kobold Labourer

Forum posts: 0
File comments: 2
Uploads: 0
Originally posted by Taffu
That'll be a future feature...I may add the use of the Tablet library to columnize & add stuff like that to the info tooltip.
No need for that if you want it columnized.
I editted my version (Like to screw lua ) with class colors and columnized it.
It's a standard wow api feature.

just split your GameTooltip:Addline() into
GameTooltip:AddDoubleLine(textL, textR, rL, gL, bL, rR, gR, bR)
Does the same trick..
cabouter is offline Report comment to moderator  
Reply With Quote
Old 11-23-07, 05:12 PM  
Cymmeron
A Defias Bandit

Forum posts: 2
File comments: 22
Uploads: 0
Oh my, you've just answered my prayers! I've been wanting to get away from Titan and Fubar friend and guild addons forever and you just did that for me.

I am eternally grateful! <3!
Cymmeron is offline Report comment to moderator  
Reply With Quote
Old 11-23-07, 01:55 PM  
Taffu
A Flamescale Wyrmkin
AddOn Author - Click to view AddOns

Forum posts: 149
File comments: 418
Uploads: 33
Originally posted by Yinchie
Would like to suggest class colors and such on the tooltip.
That'll be a future feature...I may add the use of the Tablet library to columnize & add stuff like that to the info tooltip.
Taffu is offline Report comment to moderator  
Reply With Quote
Old 11-23-07, 10:30 AM  
Yinchie
A Murloc Raider

Forum posts: 4
File comments: 50
Uploads: 0
Would like to suggest class colors and such on the tooltip.
Yinchie is offline Report comment to moderator  
Reply With Quote
Old 11-23-07, 08:14 AM  
Taffu
A Flamescale Wyrmkin
AddOn Author - Click to view AddOns

Forum posts: 149
File comments: 418
Uploads: 33
Originally posted by cabouter
i noticed another thing.
When playing with the lock and moving frames I noticed something odd.
Unlock - move a frame - Lock - Mouseover frame - then unlock.

At the last unlock the frame just moves to the right.
I'll see if i can find out why ;-) [/b]
This happens if you actually "click" the modules while unlocked, but don't move it. The reason why is, there are two functions that translate the x & y coords to avoid it bumping around too much after a drag move (a problem originally with SLTimex 2.0 prior to the re-write). The translate function adjusts the x & y coordinates based on a drag, not a click, so it will slightly bump the module(s) if they aren't actually dragged. I'm working on a condition that checks if it's been moved or not to avoid this...but it's a very minor problem for the time being.

The other problems (with bumping) has been fixed, I'm releasing a fix shortly (just finishing up some code cleanup). Thanks
Taffu is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: