Quantcast
 
Results: 77Comments by: frenchie
File: Shieldmonitor12-02-11
Hmm, just remembered there's someth...
Posted By: frenchie
Hmm, just remembered there's something extra in the code... I put a few lines in to warn me when I was queuing in the dungeon finder and already had more than 3500 JP or VP It's a complete hack that I did in 15 minutes and just used Shieldmonitor cos it was easier than writing a complete new addon... it has no options associate...
File: Shieldmonitor12-02-11
Hey, any chance of update for 4.3?...
Posted By: frenchie
Hey, any chance of update for 4.3? It's not working anymore sadly. Seems Blizz made another stealth log change to the combatlog API. Pretty minor, I'm uploading a new version shortly. Have also removed the right-click menu, since it's still causing taint. Please use /sm options if you need to get to the options screen or want...
File: Shieldmonitor07-15-11
As far as I can tell the taint is a...
Posted By: frenchie
As far as I can tell the taint is a result of a bug Blizz have introduced into UIDropDownMenu that Shieldmonitor uses. Apparently lots of addons are having problems at the moment. As a workaround I may just disable the dropdown menu for now, since it doen't provide anything you can't do via Interface -> Options, it's just a conven...
File: Shieldmonitor12-18-10
Originally posted by twistdshade...
Posted By: frenchie
Originally posted by twistdshade Sure would be nice if this would monitor Blood Shield for dk tanks. Mine absorbs about 15k each time I hit with death strike. It would greatly improve my dmg mitigation if I could monitor the absorption effect. It might be possible to add it, it depends whether or not Blizz have implemented t...
File: Shieldmonitor11-23-10
Originally posted by CNchenyuan T...
Posted By: frenchie
Originally posted by CNchenyuan Thank you for your reply. I have added 1 line in SHIELDMONITOR_SPELLS and 1line in TIPREAD, but the problem is not solved. I guess the key of the problem could be the "line" or "pattern" in TIPREAD. Since you said all spells use line 4, I think the pattern that I add is wrong. Is there any ways to l...
File: Shieldmonitor11-22-10
Originally posted by oalex I figu...
Posted By: frenchie
Originally posted by oalex I figured out where to change the texture, background and border to what I like to use (for my UI). I made a media folder and then put the textures there. In the XML I changed where relevant to: Interface\AddOns\shieldmonitor\media\texture However I could not figure out where to change the fonts....
File: Shieldmonitor11-22-10
Originally posted by CNchenyuan H...
Posted By: frenchie
Originally posted by CNchenyuan Hi, frenchie, thank you for your addon, it's awsome. I am a player come from CN-TW and find following problem about this addon: The spell "mage ward" is not work in CN-TW whlie other spells work well. So I tried to modify the lua in order to make this work, but I find it led to error when...
File: Shieldmonitor11-21-10
Originally posted by Nyoghta The...
Posted By: frenchie
Originally posted by Nyoghta The tooltips of mana shield, mage ward and ice barrier (and I assume other shields for other classes) now show the actual strength of the shield, including spell power and the glyph effect, so adding the spellpower bonus yields the wrong amount. The strength could be taken directly from the tooltip at e...
File: Shieldmonitor11-18-10
Originally posted by nonameform I...
Posted By: frenchie
Originally posted by nonameform I use it only on my priest, so it was Power Word: Shield. I have noticed that both while taking melee and magic damage. It was the only shield buff I had on me when I noticed that problem (happens to me all the time, so even if I had another shield at some point, I solo old content, so no other shiel...
File: Shieldmonitor11-17-10
Originally posted by nonameform H...
Posted By: frenchie
Originally posted by nonameform Have the same issue as Kinoko does. Every time shield takes damage, it goes back to 100%, which doesn't really help. Since I got used to the monitor from the moment it was released pre-WotLK, it's a bit annoying that it stopped doing what I expect it to do. Any help would be appreciated. It wo...
File: Shieldmonitor10-25-10
Originally posted by KurenaiXIII...
Posted By: frenchie
Originally posted by KurenaiXIII Hi Frenchie, love the addon--very very useful! Are there any plans to allow ShieldMonitor to monitor more than one shield at a time? Say if I have Mage Ward and Ice Barrier up at the same time, for whatever reason, or if I have a Word of Glory overheal and a priest tosses PW:S on me. The addo...
File: Shieldmonitor10-20-10
Re: Newer absorb spells
Posted By: frenchie
Originally posted by Tatltael I wonder if anyone would be able to figure out how to add in the newer absorb spells to this addon? Hi Tatitael, It depends how Blizz show the information in the combat log. If they send the 'SPELL_AURA_APPLIED' log entry (and particularly if they send the strength of the shield in that even...
File: Shieldmonitor10-19-10
Hehe , no worries, I've made simila...
Posted By: frenchie
Hehe , no worries, I've made similar mistakes myself before now. I appreciate people taking the time to test and report errors.
File: Shieldmonitor10-19-10
Thanks zasy99, however the error...
Posted By: frenchie
Thanks zasy99, however the errors you've posted say that you are running 1.7.3? I've doublechecked that I did upate the version number for the release, so could you please try re-installing your copy?
File: Shieldmonitor10-18-10
Originally posted by Zhiva Maybe...
Posted By: frenchie
Originally posted by Zhiva Maybe you could take this information from combat log? Ah excellent, Blizz added it to the combat log too. That's much the easiest way to grab the number. Now if only they could be persuaded to do it for other shields besides the priest ones. I expect this info was added because Disc priests kept c...
File: Shieldmonitor10-17-10
Bah.. it seems it's only Power Word...
Posted By: frenchie
Bah.. it seems it's only Power Word:Shield that have the amount it will absorb in the buff tooltip. Still I suppose something is better than nothing.
File: Shieldmonitor10-17-10
Hmm, the buff tooltip didn't use to...
Posted By: frenchie
Hmm, the buff tooltip didn't use to say exactly many points of damage a shield would absorb, so this looks like a very useful change by Blizz I will investigate recoding the addon to pick up the value from the buff tooltip rather than the spell tooltip since this looks like it will give the exact value and may well work for buffs...
File: Shieldmonitor10-17-10
Arrrghhhhh!!! Thanks zasy99 yo...
Posted By: frenchie
Arrrghhhhh!!! Thanks zasy99 your post has solved the mystery. It's Blizz's damn 'beginner tooltips' that they've introduced. As you can see from the debug line that shows it, the beginner version does not include the amount the shield absorbs. I'll have to investigate if there's a way to get the proper tooltip via LUA, if...
File: Shieldmonitor10-16-10
Hi Hope, thanks for the report....
Posted By: frenchie
Hi Hope, thanks for the report. At the moment this has got me a bit baffled. Does it happen on every cast of PW:S or only sometimes? I have a little level 40 priest that casts it ok.
File: Shieldmonitor10-16-10
Ok, just uploaded 1.7.3 which hopef...
Posted By: frenchie
Ok, just uploaded 1.7.3 which hopefully will get rid of most if not all LUA error messages If you do get an error, the info which people have posted from things like Buggrabber is very helpful. Also you can help by switching on Shieldmonitor's own debug messages by typing '/sm dbg' (it's a toggle, typing it again switches off...
File: Shieldmonitor10-15-10
Thanks Xylan and etnoxic for your b...
Posted By: frenchie
Thanks Xylan and etnoxic for your bug reports I'll look into them. etnoxic, I do have a mage but she's only level 70 so obviously quite a bit of stuff is different. Mage Ward works fine on her without any other shields being cast and I'm not seeing any lag, so I'm a bit stuck, but I'll see what I can work out.
File: Shieldmonitor10-15-10
The 'nameTalent' bug with PW:S is b...
Posted By: frenchie
The 'nameTalent' bug with PW:S is because the addon is checking for priest talents which modify the shield that no longer exist. I'll release an update later today with a fix for this and also including grimmer's submitted changes for the new mage shield. I expect there will be other problems lurking with things like changed co...
File: Shieldmonitor10-14-10
Originally posted by etnoxic If p...
Posted By: frenchie
Originally posted by etnoxic If possible could you also fix it so we could move the shield anchor again? It doesn't respond to left or right click, so we can't unlock it or move it at all. Ok, have just uploaded a fix for mouse button clicks on the window. (damn you and all your API changes Blizz!! )
File: Shieldmonitor10-14-10
Originally posted by Dree3 So I n...
Posted By: frenchie
Originally posted by Dree3 So I notice Shieldmonitor vanished in 4.0. The addon still loads, and I can access the options through /sm options, but when I shield myself with Ice Barrier, the graphic itself is just gone. Is there any way to fix this? Thank you I've made a fix for a small change in the WoW API that stopped th...
File: Shieldmonitor11-06-09
Originally posted by affix Okay,...
Posted By: frenchie
Originally posted by affix Okay, thanks again for your hard work. One more question, sorry for taking up so much of your time: It seems that since I changed the priority systems around, Frost Ward no longer has the 'only absorbs frost damage' flag on it - is this something I can fix? If you just changed the slot= bit then t...