Search FAQ Search FAQ
Search Word(s):
Matching Options:
Search in:

How do I install an AddOn?
To manually install your mods:

1. Download your chosen addon

2. Extract the files to a folder on your desktop.

3. Open your WoW folder.

If using a PC, the typical default install path is:

C:\Program Files\World of Warcraft

If using a Macintosh, the typical default install path is:

Macintosh Main HD (or whatever you renamed it to, if you did)/Applications/World of Warcraft

4. In the WoW folder, create a new folder called Interface (if it doesn’t already exist)

5. Open that folder, create another one inside it, called AddOns (again, if it doesn’t already exist)

6. Open the AddOns folder

7. Copy the files from the folder on your desktop into the AddOns folder

8. Your final path should look like:

PC:

C:\Program Files\World of Warcraft\Interface\AddOns\< ModAFolderName >\< files >
C:\Program Files\World of Warcraft\Interface\AddOns\< ModBFolderName >\< files >
C:\Program Files\World of Warcraft\Interface\AddOns\< ModCFolderName >\< files >

Mac:

Macintosh HD/Applications/World of Warcraft/Interface/Addons/< ModAFolderName >/< files >
Macintosh HD/Applications/World of Warcraft/Interface/Addons/< ModBFolderName >/< files >
Macintosh HD/Applications/World of Warcraft/Interface/Addons/ < ModCFolderNaem >/< files >

(where < ModAFolder > < .B. > < .C. > are the names of the actual folders that the mods create)

9. Log into game. At the character select screen, there should be an "AddOns" button in the lower left corner. Click on that. If any of the mods in the list that pops up say "out of date" or some such, choose the "Load Outdated AddOns" option.

10. Log the rest of the way into game, you should be up and running now. :)


Where should my files be saved? (Having trouble)

The should be saved in a single level folder. One of the most common reason that UI's wont load is that there is a sub-folder inside the Custom UI Folder

Here are two pictures one showing the wrong way, and one showing the correct way. Click on the images to see the larger image

               WRONG WAY                                                            CORRECT WAY
                   
Click images to enlarge


Still having trouble! What now?

1. Is there any chance that you have 2 WoW directories?

ie: C:\Program Files\World of Warcraft\Blah blah blah and C:\World of Warcraft\Blah blah blah, or anything like that?

If so, that may be the problem. Try putting your ui files in the other one.

2. Did you make sure that the files aren't in a sub-folder within your custom folder? See the graphical interpretation above.

You can post questions on installing troubles in the Interface/Script Help . Please read through or use the search feature first. Most of the time your questions have been answered already.

Be sure to read this thread first before posting your help request.

Include this information in your post:

When asking for help in trouble shooting a problem you are having with a skin/mod please include this information in your post.

1. What is the name of the mod, provide a link to where its located on our site. If its your own home made dont worry about it.

2. What steps did you take to install the mod? Post your complete install path. If you don't give us your complete install path, all we can do is guess as to what the problem may be.

3. Be as descriptive as you can. Just posting you cant get xyz mod to work will result in no responce to your help request. The more information you can provide the faster some one will respond.