WoWInterface

WoWInterface (http://www.wowinterface.com/forums/index.php)
-   PTR UI Bugs (http://www.wowinterface.com/forums/forumdisplay.php?f=176)
-   -   EditBox cursor issue in 7.3 (http://www.wowinterface.com/forums/showthread.php?t=55696)

Gello 08-30-17 06:11 PM

EditBox cursor issue in 7.3
 
If you create several dozen lines of text in a multi-line EditBox (MacroFrameText is a convenient example, add 1 2 3 4 5 6 7 8 9 0 broken into 10 lines and copy and paste it a few times), and then you try editing text near the end, the cursor is positioned away from where the insertion point is.

Can anyone corroborate that this is or is not happening with them?

Fizzlemizz 08-30-17 06:50 PM

This indeed does happen. Tested using TinyPad. Once you go below the first scroll point it starts happening.

If you have a couple of scroll pages and scroll all the way to the end, the scroll bar starts jumping up and down.

Jarod24 08-31-17 03:51 AM

I've seen the same issue in my addon (IfThen) too.

The editbox works just like normal tho and I have no idea how to fix it...

anyone got suggestions?

spiralofhope 09-01-17 05:52 PM

Confirmed
 
This is happening to many others, and I've seen it in three addons so far.

For the morbidly curious, this was my adventure:

https://github.com/spiralofhope/_DevPad.GUI/issues/1

Gello 09-27-17 07:50 PM

It's not fixed as of 7.3.2 PTR build 25135 that went up tonight.

I hope they can squash this before 7.3.2 goes live.

Gello 10-10-17 06:25 PM

This appears fixed as of tonight's PTR build (25255). Tested with an effective scale of 0.65 and 1.15 and cursor is behaving once again.

Thanks for fixing this Blizzard!


All times are GMT -6. The time now is 05:32 PM.

vBulletin © 2018, Jelsoft Enterprises Ltd
© 2004 - 2017 MMOUI