WoWInterface

WoWInterface (http://www.wowinterface.com/forums/index.php)
-   nUI: Bug Reports (http://www.wowinterface.com/forums/forumdisplay.php?f=90)
-   -   No Players (http://www.wowinterface.com/forums/showthread.php?t=39810)

megabit21 04-26-11 06:57 PM

No Players
 
1 Attachment(s)
I'm not able to see any players when joined into a group, and the button to change from player to group to raid is just red.

spiel2001 04-26-11 07:21 PM

You've got a problem with your installation... something is breaking at load time and it's probably one of your plugins that you use with nUI

I would suggest you start by turning off everything except nUI itself (including all plugins) then start enabling mods one at a time until it breaks again.... then we'll know which mod is causing the issue.

Zyler 04-27-11 04:39 PM

Same issue
 
My looks identical to the first post but I only have one plugin which is the healbot plugin and it is turned off but I am still unable to get any graphics in that area. Also none of the buff bars are showing on the left and right of my screen.

Xrystal 04-27-11 04:45 PM

The secret will lie in that buggrabber error list. As you can see from that screenshot it is recording errors again. This signifies something in the region of 50 or more errors from one addon or another. Those errors will help identify the cause.

That said, I have the latest nUI and all but a couple of my plugins running and have no problems.

1. Make sure you are using the latest nUI version on its own with no other addons at all and see what happens and go from there.

2. Just in case it is a configuration error somewhere rename your wtf folder and run wow again. It will reset everything to the default. What does nUI look like now.

If after step 1 it isn't working but after step 2 it is then it is something in your settings messed up. I would suggest that it might be in your best interest to re do your settings anyway due to it being a major patch and some addons may have had to do some major changes to reflect that. It is something I tend to do, especially if I get problems like this.

Zyler 04-27-11 05:04 PM

Still not there
 
I did both steps and neither one did the trick.

I am still missing the player frames and buffs.

Zyler 04-27-11 05:14 PM

Still not there
 
I did both steps and neither one did the trick.

I am still missing the player frames and buffs.

update:


I deleted the add on and reinstalled it and if fixed the issue.

Xrystal 04-27-11 05:27 PM

Hmm, perhaps a corrupted download maybe.

Glad it resolved your problem anyway.

Rucker403 04-29-11 02:34 PM

I had been having this exact same problem - no players (me or anyone else) in the unit frames boxes since 5.07.18 came out.

I tried re-downloading and re-installing the addon. I poked around in the LUA file. Nothing. I updated all my other addons and turned them all off (and on). I tried a clean WTF file. Nothing.

What finally did it for me was to *delete* the NUI file in my WOW/Interface/Addons file. What I had been doing was copying and pasting the new (.19) file over top of the old one (.16), and evidently it was leaving a file that you had meant to be deleted.

FYI for any other copy-n-pasters out there.

Carry on with a great addon. Nothing to see here ...

Wulfemeister 04-29-11 10:46 PM

I too am having the same issues. I removed all the addons and just had nUI running. I deleted the nUI folder instead of overwriting, renamed the WTF folder and nothing. Same issues. No player frames.

Here's the interesting part. I've kept the previous versions of nUI+ going back several versions. I removed nUI 5.07.19 plus since that did not work. I then installed nUI 5.07.18 plus...same thing. I went to version nUI 5.07.16 plus and the player frames were there!

This issue seems to lie in verion 5.07.18 plus and up. Please advise.

Wulfe

spiel2001 04-30-11 08:04 AM

Can you please enable script error reporting in the interface options or install a bug reporting mod like BugSack and let me know what errors are being recorded? There almost has to be an error of some kind being thrown here

Wulfemeister 04-30-11 09:31 AM

I would love to help but am not sure how to enable script error reporting. I see there is a /nui debug command, and am not sure if this is the correct one or not? If so, what level should I set, and where does it place the log data for me to upload?

spiel2001 04-30-11 09:35 AM

To enable error reporting...
  • press "Escape" to open the WoW menu
  • click "Interface"
  • click "Help"
  • make sure "Display Lua Errors" is checked
  • clock "Okay"
  • click "Return to Game"
  • type '/nui rl' and press Enter
See if any errors get reported when it reloads. If they do, just take a screen shot and post it here using the paperclip icon in the message editor or by scrolling down the message editor page to the "Manage Attachments" button.

Thanks

Wulfemeister 04-30-11 10:08 AM

Alrighty! I have disabled all other mods, just the nUI ones, and this is the message I get:

Message: Interface\AddOns\nUI\Units\nUI_Unit.lua:310: attempt to call field 'applyAnchor' (a nil value)
Time: 04/30/11 12:04:01
Count: 1
Stack: Interface\AddOns\nUI\Units\nUI_Unit.lua:310: in function <Interface\AddOns\nUI\Units\nUI_Unit.lua:199>
Interface\AddOns\nUI\Units\nUI_Unit.lua:727: in function `applySkin'
Interface\AddOns\nUI\Units\nUI_Unit.lua:791: in function `createUnit'
Interface\AddOns\nUI\Units\nUI_UnitPanel.lua:616: in function `applySkin'
Interface\AddOns\nUI\Main\nUI.lua:264: in function <Interface\AddOns\nUI\Main\nUI.lua:137>

Locals: unit = nUI_SoloUnit_Pet {
changeScale = <function> defined @Interface\AddOns\nUI\Units\nUI_Unit.lua:536
Elements = <table> {
}
active = true
scale = 1
setUnitID = <function> defined @Interface\AddOns\nUI\Units\nUI_Unit.lua:764
newUnitInfo = <function> defined @Interface\AddOns\nUI\Units\nUI_Unit.lua:454
unit = "pet"
refreshSkin = <function> defined @Interface\AddOns\nUI\Units\nUI_Unit.lua:737
applySkin = <function> defined @Interface\AddOns\nUI\Units\nUI_Unit.lua:714
configText = <function> defined @Interface\AddOns\nUI\Units\nUI_UnitFrame.lua:357
skin = <table> {
}
0 = <userdata>
background = nUI_SoloUnit_Pet_Background {
}
enabled = true
applyAnchor = <function> defined @Interface\AddOns\nUI\Units\nUI_Unit.lua:582
applyOptions = <function> defined @Interface\AddOns\nUI\Units\nUI_Unit.lua:623
parent = nUI_UnitPanel_Player {
}
options = <table> {
}
click_cast = true
clickable = false
skinName = "nUI_SoloUnit_PetSkin"
setVisibility = <function> defined @Interface\AddOns\nUI\Units\nUI_Unit.lua:749
width = 124.44444784861
Faders = <table> {
}
popup = nUI_SoloUnit_Pet_Popup {
}
cachedSetUnitID = <function> defined @Interface\AddOns\nUI\Units\nUI_UnitFrame.lua:606
applyScale = <function> defined @Interface\AddOns\nUI\Units\nUI_Unit.lua:502
height = 157.06667740802
applyFrameFader = <function> defined @Interface\AddOns\nUI\Units\nUI_Unit.lua:553
setEnabled = <function> defined @Interface\AddOns\nUI\Units\nUI_Unit.lua:469
Labels = <table> {
}
}
skin = <table> {
height = 310
desc = "nUI Solo Player Mode: Player Pet's unit skin"
elements = <table> {
}
width = 210
}
(for index) = 5
(for limit) = 23
(for step) = 1
i = 5
(*temporary) = nil
(*temporary) = <table> {
relative_to = "$parent_RaidGroup"
yOfs = 0
xOfs = 0
relative_pt = "CENTER"
anchor_pt = "CENTER"
}
(*temporary) = "attempt to call field 'applyAnchor' (a nil value)"
skin_elements = <table> {
Portrait = <table> {
}
Label = <table> {
}
Class = <table> {
}
Happiness = <table> {
}
Resting = <table> {
}
Aura = <table> {
}
Status = <table> {
}
Level = <table> {
}
RaidTarget = <table> {
}
Power = <table> {
}
Frame = <table> {
}
Feedback = <table> {
}
ReadyCheck = <table> {
}
Health = <table> {
}
Role = <table> {
}
PvP = <table> {
}
Casting = <table> {
}
RaidGroup = <table> {
}
Combat = <table> {
}
}
update_elements = <table> {
}
update = <table> {
type = "Combat"
options = <table> {
}
anchor = <table> {
}
frame = nUI_SoloUnit_Pet_Combat {
}
}
CreateElement = <function> defined @Interface\AddOns\nUI\Units\nUI_Unit.lua:146

spiel2001 04-30-11 11:16 AM

1 Attachment(s)
Okay... if you would, please save the attached file in the [ Interface > AddOns > nUI > Units ] folder and then reload nUI and tell me what frame it says does not have an applyAnchor method (it will print in the chat frame)

thanks.

.

Wulfemeister 04-30-11 12:39 PM

1 Attachment(s)
Well, it says unknown frame. I've included a screenshot of the nUI info from the chat frame.

spiel2001 04-30-11 01:27 PM

Okay... I think I know what the problem is.

Wulfemeister 05-02-11 06:46 PM

Anything I can do to assist with troubleshooting?

Wulfemeister 06-28-11 10:28 PM

Well, I downloaded nUI 5.07.20 plus and the player frames are not there. Along with that, I have no buff bar. As I stated in the earlier post, they work in nUI 5.07.16 plus and previous versions, but nothing after. Any thoughts?

Wulde

spiel2001 06-28-11 10:46 PM

Ummmmmmmmmmmmmm....

I *thought* this was fixed.

:-/

Wulfemeister 06-29-11 04:45 PM

No, not really...sorry. I still had the issue with the previous version. You stated you thought you knew what the problem was, in the thread...but that was it. I've been using 5.07.16 plus ever since.

Wulfe


All times are GMT -6. The time now is 02:07 PM.

vBulletin © 2014, Jelsoft Enterprises Ltd
©2012 ZAM Network LLC