WoWInterface

WoWInterface (http://www.wowinterface.com/forums/index.php)
-   Carbonite Archive (http://www.wowinterface.com/forums/forumdisplay.php?f=158)
-   -   Patch for COMBAT_LOG_EVENT_UNFILTERED error messages (http://www.wowinterface.com/forums/showthread.php?t=40644)

CyberZombie 06-28-11 06:42 PM

Patch for WoW 4.2 error messages
 
There are 2 new parameters for the COMBAT_LOG_EVENT_UNFILTERED event added in 4.2. The changes I made correct them. Note: I am sure that the Carbonite folks will be making use of the additional parameters as they fall in line with other parameters they are using. This is ONLY A TEMPORARY FIX. Buyer beware.

This patch is for the release version 4.11 of Carbonite in the file Carbonite.lua.

The lines to patch are 2675, 9672, and 9679-9682.

Thanks to Karquile for his idea to use search if line numbers don't match:
Quote:

Originally Posted by Karquile (Post 240212)
I did the same. I think the difference is that I use Win32Pad for my text editor, and it assigns numbers to the wraparounds of those ultralong data lines in the 5000's.

Anyone who can't find the patch area in Carbonite 4.11, regardless of the editor they use, should search for
...
which only occurs once in the whole lua file. The patch starts there.


Line 2675 or search for the following:
Code:

local sNa,sFl
Original:
Code:

local sNa,sFl,dId,dNa,dFl=select(5,...)
Patched:
Code:

local sNa,sFl,sRFl,dId,dNa,dFl,dRFl=select(5,...)

Line 9672 or search for the following:
Code:

local time,cEv
Original:
Code:

local time,cEv,_hideCaster,sId,sNa,sFl,dId,dNa,dFl,a1,a2,a3,a4=select(1,...)
Patched:
Code:

local time,cEv,_hideCaster,sId,sNa,sFl,sRFl,dId,dNa,dFl,dRFl,a1,a2,a3,a4=select(1,...)

Lines 9679-9682 or search for the following:
Code:

local i=10
Original:
Code:

local i=10
if pre~="SWING" then
spI,spN,spS=select(10,...)
i=13

Patched:
Code:

local i=12
if pre~="SWING" then
spI,spN,spS=select(12,...)
i=15


Vis 06-28-11 06:55 PM

Just tested your fix CyberZombie and all errors are gone from Carb. Nicely done.



Quote:

There are 2 lines that involve a comma-separated list of variables. In both cases you want to insert another variable after these.

Note: These variables involve the letter 'l', not the number '1'. After the variable dFl add the variable dRFl. After the variable sFl add the variable sRFl. You want to do this on lines 2675 and 9672.

CyberZombie 06-28-11 07:15 PM

Heh. First mob I attacked surfaced another Carbonite error. Looking into it.

Gendou 06-28-11 07:25 PM

Quote:

Originally Posted by CyberZombie (Post 240197)
Heh. First mob I attacked surfaced another Carbonite error. Looking into it.

Looking forward to any further fixes you come up with.

CyberZombie 06-28-11 07:26 PM

It helps to look at the whole function. Simple fixes:

Line 9679: Set i=12 (was i=10)
Line 9681: Set select(12,...) (was select(10,...))
Line 9682: Set i=15 (was i=13)

Editing my original post with this information.

Lyoo 06-28-11 07:47 PM

maybe im looking at something different but when I look at those lines those things you say to change are not there for me

Karquile 06-28-11 07:55 PM

I don't know why this would be, but in my copy of Carbonite 4.11 the lines you are talking about seem to be down at 15636-15639.

jeffy162 06-28-11 07:59 PM

Quote:

Originally Posted by CyberZombie (Post 240200)
It helps to look at the whole function. Simple fixes:

Line 9679: Set i=12 (was i=10)
Line 9681: Set select(12,...) (was select(10,...))
Line 9682: Set i=15 (was i=13)

Editing my original post with this information.

This may sound like an odd question, but....

Do I add the "Set" in front of the line? The rest of the line is there, but there is no "Set" in it. Sorry, I really don't understand Lua.

Perhaps if it doesn't belong in the changed lines, it would be better to phrase it: "Change line 9675 from i=10 to i=12 ." Or something along those lines.

CyberZombie 06-28-11 08:06 PM

Quote:

Originally Posted by Karquile (Post 240206)
I don't know why this would be, but in my copy of Carbonite 4.11 the lines you are talking about seem to be down at 15636-15639.

I downloaded 4.11 again, and the lines are as I specified. Perhaps you're still using the beta?

Quote:

Originally Posted by jeffy162 (Post 240207)
This may sound like an odd question, but....

Do I add the "Set" in front of the line? The rest of the line is there, but there is no "Set" in it. Sorry, I really don't understand Lua.

No. The lines look like (starting at 9679):

Code:

local i=12
if pre~="SWING" then
spI,spN,spS=select(12,...)
i=15

Editing the original post to include the source lines in question.

Vis 06-28-11 08:07 PM

Mine does not have "Set" in it either. All I changed were the numbers themselves.


The line number differences are usually due to people using different Editors. For instance using Notepad may mark something as line 10, but TextPad would mark it as line 12.

As long as the text matches you should be ok.

jeffy162 06-28-11 08:20 PM

I was still getting some errors from Carbonite after editing the Carbonite.lua, but was also getting errors (a lot) from !ClassColors, PhanxChat and Parrot. I disabled those and Carbonites errors went away also.

PS: That "Set" is an instruction. It doesn't go into the line. DOH!!

PPS: Maybe if I read the new comments after testing something, I wouldn't look quite so ignorant. Nah, probably not. :o

EDIT: Where are my manners? Thank you, CyberZombie, for finding the cause of, and taking the time to post the fix for, the errors. END EDIT

Karquile 06-28-11 08:21 PM

Quote:

Originally Posted by CyberZombie (Post 240209)
I downloaded 4.11 again, and the lines are as I specified. Perhaps you're still using the beta?

I did the same. I think the difference is that I use Win32Pad for my text editor, and it assigns numbers to the wraparounds of those ultralong data lines in the 5000's.

Anyone who can't find the patch area in Carbonite 4.11, regardless of the editor they use, should search for
Code:

local i=10
which only occurs once in the whole lua file. The patch starts there.

CyberZombie 06-28-11 08:34 PM

Quote:

Originally Posted by Karquile (Post 240212)
I did the same. I think the difference is that I use Win32Pad for my text editor, and it assigns numbers to the wraparounds of those ultralong data lines in the 5000's.

Anyone who can't find the patch area in Carbonite 4.11, regardless of the editor they use, should search for
Code:

local i=10
which only occurs once in the whole lua file. The patch starts there.

Mind if I quote you in the original post?

Karquile 06-28-11 08:44 PM

Quote:

Originally Posted by CyberZombie (Post 240213)
Mind if I quote you in the original post?

be my guest :D

Lyoo 06-28-11 08:49 PM

I still get errors as soon as I log in

CyberZombie 06-28-11 09:38 PM

Quote:

Originally Posted by Lyoo (Post 240216)
I still get errors as soon as I log in

Did you make the changes using the search to find the lines that Karquile posted?

Quote:

Originally Posted by Karquile (Post 240212)
I did the same. I think the difference is that I use Win32Pad for my text editor, and it assigns numbers to the wraparounds of those ultralong data lines in the 5000's.

Anyone who can't find the patch area in Carbonite 4.11, regardless of the editor they use, should search for
Code:

local i=10
which only occurs once in the whole lua file. The patch starts there.

I've been running error-free (as far as all the addons I use are concerned - Carbonite included) for 2 hours...

JemBijoux 06-28-11 09:53 PM

Thanks
 
Thanks for this. I can confirm that this patch worked for me as well.

I really love this add on. Almost depend on it really, so I appreciate the work of anyone involved with ensuring it's up to date / operational. :D

Palladia 06-28-11 11:33 PM

I have 4.11 and I made the changes you posted (copied and pasted) but not only do I still get errors, but the Carbonite map doesn't load at all.

Here are the first 3 of 6 errors:

1x Carbonite-4.11\Carbonite.lua:19532: attempt to perform arithmetic on local 'na2' (a nil value)
Carbonite-4.11\Carbonite.lua:22951: in function `Ini'
Carbonite-4.11\Carbonite.lua:19656: in function `h'
Carbonite-4.11\Carbonite.lua:352: in function `NXOnEvent'
<string>:"*:OnEvent":1: in function <[string "*:OnEvent"]:1>

--

1x _NPCScan.Overlay-4.2.0.1\Modules\Carbonite.lua:21: attempt to index global 'NxMap1' (a nil value)

1x Carbonite-4.11\Carbonite.lua:19905: attempt to index local 'map' (a nil value)
Carbonite-4.11\Carbonite.lua:25691: in function `RCL'
Carbonite-4.11\Carbonite.lua:3508: in function `h'
Carbonite-4.11\Carbonite.lua:352: in function `NXOnEvent'
<string>:"*:OnEvent":1: in function <[string "*:OnEvent"]:1>

I tried re-installing 4.11 and redoing the edits posted here from scratch. I got the same result though I only got 3 errors instead of 6. But even though I get Carbonite errors, I don't get Carbonite itself. No map, no quest watch. I do get the Carbonite minimap button, but clicking it generates another error:

1x Carbonite-4.11\Carbonite.lua:11828: attempt to index local 'map' (a nil value)
Carbonite-4.11\Carbonite.lua:24162: in function `NXOnClick'
<string>:"*:OnClick":1: in function <[string "*:OnClick"]:1>

tarix 06-29-11 01:59 AM

CyberZombie, cheers for this. Your changes work great! :banana:

Verttex 06-29-11 02:57 AM

Added to the WoWI archive.
Please post here if bugs alert or something else.

Thanks
-Verttex


All times are GMT -6. The time now is 09:17 AM.

vBulletin © 2014, Jelsoft Enterprises Ltd
©2012 ZAM Network LLC