WoWInterface

WoWInterface (http://www.wowinterface.com/forums/index.php)
-   nUI: Technical Support (http://www.wowinterface.com/forums/forumdisplay.php?f=92)
-   -   Unable to mouse-over self-and-friendly debuffs. (http://www.wowinterface.com/forums/showthread.php?t=40720)

MisterVeziel 07-03-11 09:21 PM

Unable to mouse-over self-and-friendly debuffs.
 
This is an issue I've always had with nUI. Before, during Wrath, it wasn't much of a problem since I already knew what most of the debuffs were.

My issue: I cannot see what debuffs are affecting myself or friendly targets. The boss debuffs work just fine, but the icons that show up on the outsides of the HP/Resource bars do not tell me anything about what the debuffs are or what they do.

tinyu 07-03-11 09:33 PM

this is a issue with nUI5, it probably wont get fixed as spiel is investing a but load of time (he better be :P), in nUI6.

Temporarily you could give nUI: Aura Buttons a try.

MisterVeziel 07-03-11 09:50 PM

Aura Buttons didn't seem to help. It changed my buff icons (as was intended, I assume), but my debuffs are still by my HP/Resource bars and are still not showing up.

EDIT: Also, thank you for the quick reply.

Akestrasz 07-14-11 04:49 AM

have the same problem (using latest nui+5 release version, waiting for a nui+6 release and not alpha)

on my HUD bars i see the icon of a debuff but cant get the tooltip when i mouseover it
in the same effect, on the HUD target bar, i see the icon of the buff of my target, but cant get the tooltip on mouseover

found this post about it:
http://www.wowinterface.com/forums/s...d.php?p=220663
but didnt work when I replaced the file nUI_UnitAura.lua
or i didnt understand how to do it!!

What can i do apart of just waiting nui+6?

Thanks a lot <3

spiel2001 07-14-11 05:16 AM

Use a plain text editor to open [ Interface > AddOns > nUI > Layouts > Default > HUDLayouts > {hud mode} > nUI_HUDSkin_{hud mode}_{unit id}.lua ] where {hud mode} is the HUD mode you use (PlayerTarget, HealthPower, etc.) and {unit id} is the unit you want the mouseover to work for {Player, Target, etc.)

Locate the ["Aura"] section that for the "harm" auras and change "clickable = false" to "clickable = true" and save the file then do a '/nui rl' -- you should be all set.

Note that because auras are now protected frames, I cannot show/hide them, I can only make them transparent. That means that even when the aura is not visible, it is still on the screen and therefore interacting with your mouse. That will mean you cannot click in the field of play anywhere an aura is positioned... which is why the mouseover tooltips are current disabled by default. However, as long as that doesn't bother you, it will work.

Akestrasz 07-15-11 02:49 AM

GREAT!!! thats what I was looking for!
and yes i dont botter that i cant click on this so little field of play :)

Thank you a lot I love this UI, just perfect


All times are GMT -6. The time now is 12:55 AM.

vBulletin © 2014, Jelsoft Enterprises Ltd
©2012 ZAM Network LLC