WoWInterface

WoWInterface (http://www.wowinterface.com/forums/index.php)
-   OpenRDX: Bug/Error Reports (http://www.wowinterface.com/forums/forumdisplay.php?f=105)
-   -   WoW 64 bit client error (http://www.wowinterface.com/forums/showthread.php?t=42586)

Alianka 02-10-12 10:20 AM

WoW 64 bit client error
 
1 Attachment(s)
Hi,

since i installed 64 bit client for WoW, i get this following error every time i log in. It happens regardless if its clean install meaning with WoWRDX UI or with my UI and regardless if i have any other addon loaded or not. The only result of this error i get is that it quiete often, when switching UI states, does not repaint frames and do not want to repaint, but more often it just refuse to log saying its already logged and switched. And i tried and failed to make a sure way to reproduce it. It happens often when ExtraActionBar and with PlayerPowerBarAlt is needed. Switching back to 32 bit client solves everything, but i just happened to have win 7 64 bit ultimate, so want to use the whole power my PC provides .)

Quote:

Interface\AddOns\RDX\DesktopMgr\Obj_Desktop.lua:268: attempt to index local 'sp' (a nil value)

Stack trace:
-----------
Interface\AddOns\RDX\DesktopMgr\Obj_Desktop.lua:313: in function <Interface\AddOns\RDX\DesktopMgr\Obj_Desktop.lua:287>
Interface\AddOns\RDX\DesktopMgr\Obj_Desktop.lua:320: in function <Interface\AddOns\RDX\DesktopMgr\Obj_Desktop.lua:317>
Interface\AddOns\RDX\DesktopMgr\Obj_Desktop.lua:328: in function `LayoutDesktop'
Interface\AddOns\RDX\DesktopMgr\Obj_Desktop.lua:878: in function `oi'
Interface\AddOns\RDX\ObjectMgr\ObjectDB.lua:223: in function <Interface\AddOns\RDX\ObjectMgr\ObjectDB.lua:213>
(tail call): ?
Interface\AddOns\RDX\DesktopMgr\Obj_Desktop.lua:1056: in function <Interface\AddOns\RDX\DesktopMgr\Obj_Desktop.lua:1027>
Interface\AddOns\RDX\DesktopMgr\Obj_Desktop.lua:1079: in function `SecuredChangeDesktop'
Interface\AddOns\RDX\DesktopMgr\Obj_DUI.lua:413: in function <Interface\AddOns\RDX\DesktopMgr\Obj_DUI.lua:408>
Interface\AddOns\RDX\DesktopMgr\Obj_DUI.lua:421: in function `SecuredChangeState'
Interface\AddOns\RDX\DesktopMgr\Obj_DUI.lua:383: in function <Interface\AddOns\RDX\DesktopMgr\Obj_DUI.lua:363>
Interface\AddOns\RDX\DesktopMgr\Obj_DUI.lua:533: in function `hsig'
Interface\AddOns\VFL\Core\DispatchTable.lua:119: in function `Dispatch'
Interface\AddOns\RDX\Init.lua:76: in function `hsig'
Interface\AddOns\VFL\Core\DispatchTable.lua:119: in function <Interface\AddOns\VFL\Core\DispatchTable.lua:117>

Any ides why this strange behavior ?

Regards
Alianka

EDIT: scrnshot added that shows the errors when i switch UI states

sigg 02-10-12 11:50 AM

Yes I know.

It is a bug in the GIT code, remove the line 268 of the file Obj_Desktop.
the stupid print function VFL.print(sp.l);

Alianka 02-10-12 03:02 PM

Thank you my saviour


All times are GMT -6. The time now is 04:48 AM.

vBulletin © 2014, Jelsoft Enterprises Ltd
©2012 ZAM Network LLC